20:02:39 <ttx> #startmeeting tc
20:02:41 <openstack> Meeting started Tue Aug 19 20:02:39 2014 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:45 <openstack> The meeting name has been set to 'tc'
20:02:47 <ttx> The agenda for today:
20:02:55 <ttx> #link https://wiki.openstack.org/wiki/Governance/TechnicalCommittee
20:03:06 <ttx> #topic Manila for incubation (part 2)
20:03:15 <ttx> We have two changes up for review on that:
20:03:20 <ttx> * Propose Shared File Systems program: (https://review.openstack.org/111149)
20:03:25 <ttx> * Propose Manila for incubation (https://review.openstack.org/113583)
20:03:34 <ttx> Last week we had the first part of this discussion
20:03:42 <ttx> Several points were raised, which I'll try to summarize
20:03:55 <ttx> 1. The Cinder relationship (code was originally copied as a template, but now evolved on its own, common code is being osloified, Manila can pull architectural improvements directly from Nova)
20:04:15 <ttx> 2. Community size/width with most commits coming from same person(s) and same company
20:04:28 <ttx> 3. The driver/vendor aspect (avoid another Neutron with no first-party driver really viable, getting swamped by driver requests, relationship with glusterfs)
20:04:43 <ttx> 4. User interest (is it something people want)
20:04:58 <ttx> I think all the discussion last week falls into on of those 4 points
20:05:07 <ttx> Shout if you think I missed something
20:05:11 <bswartz> good summary
20:05:15 <ttx> I don't think any of those was seen as a blocker to incubation though.
20:05:32 <ttx> The main concern was more our ability to handle more projects in incubation, but that's external to Manila itself
20:06:00 <bswartz> I think all of those above points were responded to, but if anyone wants elaboration let me know
20:06:05 <russellb> and our conversation about that mainly ended up focusing on how to ensure higher quality
20:06:10 <russellb> and not so much about # of projects
20:06:19 <ttx> Those 4 points were mostly things to carefully watch for DURING incubation
20:06:38 <dhellmann> Right
20:06:42 <ttx> russellb: yes
20:06:52 <annegentle> right
20:07:27 <ttx> Also much more concerns in graduating a project to integrated, compared to accepting another project in incubation
20:07:36 <russellb> yes, agree
20:07:53 <annegentle> right also
20:08:07 <dhellmann> Yep
20:08:10 * ttx looks at the state of those reviews
20:08:11 <markmc> nice summary
20:08:26 <russellb> i was waiting on the meeting before voting
20:08:27 <markmc> devananda has a -1 based on process AFAICT
20:08:35 <ttx> We have a -1 from deva on the program thing, but I still think separate changes is the right way to propose this
20:08:35 <jeblair> russellb: same here
20:08:36 <russellb> i think ttx responded to deva
20:08:37 <markmc> that approving the program without the project doesn't make sense
20:08:43 <russellb> of course, he's not around to see the response
20:08:59 <ttx> russellb: jebalir has the power to reverse it though
20:09:04 <russellb> ah yes
20:09:05 <ttx> jeblair: even
20:09:44 <ttx> so unless we have other questions to throw, I suppose we need to wait for votes to be cast on those proposals
20:10:17 <ttx> I'll approve if that reaches 7 YES, and if it doesn't reach such bar during the week, we'll discuss it again next week to try to see what blocks it
20:10:19 <annegentle> #link https://review.openstack.org/#/c/111149/
20:10:50 <ttx> Comments on that before we switch to next topic ?
20:10:59 <markmcclain> we've pointed out the lack of community… would it be reasonable to know if there is a plan to help grow it?
20:11:12 <bswartz> are you going to hold votes on both reviews this week?
20:11:13 * russellb +1d both of them fwiw
20:11:15 <ttx> markmcclain: sure that's reasonable
20:11:18 <bswartz> or just the program?
20:11:24 <ttx> bswartz: both
20:11:27 <annegentle> bswartz: my sense was that your community was waiting for incubation?
20:11:34 <bswartz> ty
20:11:41 <ttx> markmcclain: I think the general idea is that the incubation status should result in a surge in contributions
20:11:53 <ttx> markmcclain: as we've seen with barbican, which is the next topic
20:12:06 <russellb> i guess we should clarify the incubation expectations
20:12:12 <bswartz> annegentle: yes there are several developers who will be able to dedicate more time once they can tell their managers it's a real project
20:12:13 <russellb> but it's basically the 4 concerns you brought up at the beginning, i think
20:12:29 <dhellmann> That won't be automatic though. Is there a plan to onboard new contribs?
20:12:56 <markmcclain> ttx: right with barbican there were identified companies that said they'd step in if incubated
20:12:59 <bswartz> I'm not sure why incubation matters so much to those managers but it seems to be important
20:13:01 <ttx> dhellmann: on the other hand, if they fail to attract enough people they can be de-incubated alright :)
20:13:07 <dhellmann> True
20:13:24 <jeblair> yeah, it's not the first time we've heard that
20:13:26 <russellb> yep, not graduating is certainly a possible outcome, and that's OK
20:13:34 <dhellmann> Seems like a plan is a plus, and a lack may not be a blocker
20:13:41 <markmcclain> bswartz: labeling is definitely critical for resource allocation
20:13:49 <russellb> i think it's an obvious value add ot openstack, nothing is competing with it, we should give it a shot to grow
20:14:00 <ttx> russellb: ++
20:14:08 <dhellmann> Agree
20:14:09 <vishy> o/ (sorry i’m late, reading scrollback)
20:14:12 <markmcclain> russellb: +1
20:14:19 <jeblair> but yeah, i agree, best to maximize chance of success by being prepared to recruit and onboard once/if you get the label
20:14:24 <bswartz> vishy: just +1 my review :p
20:14:28 * ttx gives vishy 2 min to read scrollback before moving on to next topic
20:14:49 <vishy> go ahead
20:14:50 <vishy> :)
20:14:56 <annegentle> two whole minutes? :)
20:14:56 <ttx> #topic Graduation review: Barbican (part 1)
20:15:10 <ttx> I live in a separate timespace continuum
20:15:22 <ttx> So.. At every end of cycle we look at currently-incubated projects, discuss progress
20:15:31 <ttx> and see if any are ready to be made a part of the next OpenStack integrated release development cycle
20:15:48 <ttx> Today we start this end-of-Juno-cycle process by looking into Barbican, which started incubation back in March
20:16:06 <ttx> jraim: o/
20:16:10 <jraim> I'm here
20:16:15 <ttx> On the contributor diversity side, there was undeniable progress in Juno, which is great to see
20:16:31 <jraim> yep, we're very happy with the folks that have been contributing
20:16:31 <ttx> jraim: what would be your assessment of the current state of Barbican in incubation?
20:16:49 <redrobot> #link https://wiki.openstack.org/wiki/Barbican/Integration
20:16:59 <jraim> ^^ We put a quick wiki page on our status for integration
20:17:22 <ttx> Looking at http://lists.openstack.org/pipermail/openstack-dev/2014-August/043360.html my gut feeling is that there are also pretty critical features still being worked on at this point
20:17:35 <russellb> what integration work has been done?
20:17:49 <russellb> completed, i should say
20:17:58 <ttx> the first "integrated" cycle is busy enough already so that should probably be considered once the key features are off the ground
20:18:10 <jraim> russellb: some of that is on the wiki (status wise anyway)
20:18:29 * jaypipes rushes into meeting...
20:18:30 <jraim> ttx: We have mostly focused on technical work, especially with the onboarding of a lot of new contribs
20:18:42 <russellb> jraim: my reading was that no integrations are completed?
20:18:56 <jraim> We have done some work on translating documenation over, but I wouldn't say that was complete yet
20:19:08 <ttx> russellb: (status=MET) means completed
20:19:24 <russellb> this one is STATUS=???
20:19:26 <ttx> russellb: or do you mean integration with some project?
20:19:31 <russellb> integraiton with some projects, yes
20:19:32 <russellb> sorry
20:19:34 <ttx> oh right ignore me
20:19:50 <ttx> It would also not be bad to have at least one integrated project being able to make use of Barbican, so that we check basic use case / collaboration / interoperability
20:19:50 <russellb> i think for this to graduate, i would expect integration with nova to be completed, for example
20:20:05 <russellb> right, i'm trying to see if there is at least one ...
20:20:06 <annegentle> jraim: do you have user docs anywhere already?
20:20:11 <jraim> the main integrations are with neutron, nova and cinder
20:20:12 <ttx> as you would be expected to complete most of them during the first integrated cycle
20:20:17 <russellb> jraim: are any merged?
20:20:41 <jraim> russellb: not really. there are reviews out for all three, btu I would classify them as WIP
20:20:44 <russellb> I don't think it makes sense to graduate without integration completed with at least one other integrated project in this case
20:20:57 <ttx> russellb: I would be on the same line
20:21:11 <jraim> annegentle: yes, they are our tree....redrobot is digging up the link
20:21:13 <ttx> jraim: Back in June there was a discussion on a barebones CA for easier testing -- was there progress on that ?
20:21:13 <jeblair> it sounds like things are heading in a really good direction, but probably need more time
20:21:19 <russellb> ok so in that case, i think i'd say my feeling is "keep up the really great work, let's talk again next cycle"
20:21:29 <ttx> jeblair: yes, I feel like integrating now would do more harm than good
20:21:30 <redrobot> annegentle we've been working on user docs in the barbican tree
20:21:33 <redrobot> #link http://git.openstack.org/cgit/openstack/barbican/tree/docs
20:21:37 <jraim> ttx: RedHat has contributed dogtag code, which is a pure software CA that can be used for that
20:21:39 <ttx> it generally feels a bit early for tackling integration in the next cycle
20:21:48 <jraim> but we are struggling with 3rd party testing, especially around physical devices
20:22:08 <russellb> but i'd like to reiterate that i think you guys are doing a great job
20:22:18 <russellb> very happy about the progress you've made
20:22:37 <jeblair> jraim: is the dogtag stuff running?
20:22:46 <russellb> jraim: i tihnk every project trying to do 3rd party testing is struggling in some way with it
20:22:50 <jraim> russellb: I wouldn't disagree with you assessment. I'm happy with where we are going, but most of the work this cycle has been technical and we haven't gotten a lot of work on the integrations done
20:22:55 <ttx> yeah, frankly back when we incubated you I thought there would be 0% chance we would discuss integration now
20:22:56 <dhellmann> Are those technical issues?
20:23:02 <markmcclain> russellb: same here really happy with their progress not sure graduation time is now
20:23:03 <jraim> jeblair: the patches are merged, we are working through the testing issues
20:23:05 <annegentle> jraim: I talked to Constanze at lunch (one of the writers) and basically the core-docs resources go towards core docs first... but I think that install docs and end user (CLI, Dashboard) docs are expected
20:23:07 <ttx> but it just seems to not be that far
20:23:21 <russellb> yeah, coming along nicely
20:23:33 * dhellmann is experiencing lag
20:23:33 <ttx> From a release management perspective, we did handle juno-2 but the jobs were not really there yet, so it's still a bit fresh
20:23:37 <jraim> annegentle: agreed. We have more docs work to do.
20:23:40 <jeblair> jraim: okay.  i think having really good first-party testing of the all-software path is critical; let me know if you need help
20:23:44 <ttx> It's just all a bit too fresh
20:24:01 <jraim> jeblair: will do. We're looking at setting up turbohipster and the like to enable 3rd party test runs
20:24:06 <ttx> jraim: Would you like to go through list of integration requirements to make sure we are on the same page on them ?
20:24:26 * jaypipes sees no reason to rush graduation, or even the vote on it.
20:24:28 <jraim> We did have one question around horizon
20:24:40 <ttx> i would like to insist that the list is not the complete set of arguments the TC can use, it's more like the minimal, consensual stuff that all TC members agree are a base for integration
20:24:45 <russellb> in the case horizon integration makes sense, yes i think it shold be done before graduation
20:24:48 <russellb> IMO
20:24:53 <jraim> What needs to be completed for integration? and do we write that code or does someone else?
20:24:57 <jeblair> jraim: yep i understand that device testing will be important to you; just want to make sure you know that can't be at the expense of the first-party software device path :)
20:25:06 <jraim> jeblair: agreed
20:25:20 <russellb> jraim: ideally you, or in some sort of collaboration with horizon folks
20:25:29 <ttx> jraim: we had both cases
20:25:35 <jraim> russellb: great. I'll go get some front-end time for that work then
20:25:35 <russellb> not necessarily you personally, but the projcet somehow bringing forward the resources would be ideal
20:26:02 <jraim> russellb: we'll go see what we can do. I think an initial integration won't be horribly complex
20:26:22 <russellb> cool
20:26:23 <jraim> Other question we had: for the answer questions requirements, is that ask.openstack or launchpad or both?
20:26:41 <jeblair> jraim: i think just ask.o.o at this point
20:26:43 <russellb> ask.o.o generally preferred over launchpad answers these days
20:26:48 <ttx> jraim: I would also recommend completing integration with one project, to serve as a key example of good integration / collaboration with established projects
20:26:51 <jraim> okay, good to know
20:26:52 <russellb> launchpad answers was shut down for a lot of projects
20:27:02 <russellb> jraim: i'd say openstack ML as well
20:27:02 <jeblair> i think we stopped enabling lp?  we may need to turn off lp answers for barbican if it isn't already
20:27:11 <jraim> ttx: we are working hard with neutron and the john-hopkins folks are working on nova/cinder so we should be pretty far along on those fronts
20:27:23 <annegentle> jraim: ask.o.org
20:27:40 <ttx> heh, neutron is not the best guinea pig, they have a long backlog of things
20:27:43 <markmcclain> jraim: the neutron integration is not likely to land in juno
20:27:54 <markmcclain> ttx: true
20:28:01 <jraim> markmcclain: true. We want to get the work done, but juno seems like a stretch as this point
20:28:03 <annegentle> jraim: and yes, turn off LP answers
20:28:12 <jraim> annegentle: will do
20:28:15 <ttx> if you have the choice, pick a slightly less busy project :)
20:28:42 <russellb> of course they're all busy :)
20:28:47 <russellb> varying levels of busy
20:28:48 <ttx> jraim: any other question on the integration requirements?
20:28:56 <jraim> nope, that's all we had
20:29:02 <russellb> thanks!
20:29:04 <jraim> thanks for the help as always
20:29:05 <ttx> OK, so let's try to summarize
20:29:12 <annegentle> jraim: thanks for all the integration work so far
20:29:14 * dhellmann reaches hotel and signs off for a few min
20:29:56 * russellb is also in a hotel.
20:30:01 <ttx> #info the TC is pleased with the progress Barbican has made during this first cycle in incubation, feels like it's still a bit fresh and early to consider graduation at this point
20:30:12 <jraim> agreed from our side
20:30:15 <russellb> ++
20:30:20 <ttx> #info Integration with at least oen project should be completed before graduation
20:30:40 <ttx> #info continue the good job on getting a more diverse community
20:30:41 * jeblair agrees with ttx while not in a hotel
20:30:48 <russellb> heh
20:30:57 <ttx> doies that summarize it well?
20:30:58 * markmcclain agrees and is in a hotel
20:31:01 <jraim> Yep
20:31:26 <mikal> Sounds good to me from my house
20:31:31 <ttx> jraim: thanks for coming, and keep up the good work!
20:31:41 <jraim> ttx: thanks again all
20:31:55 <ttx> #topic New nominee for User committee
20:32:10 <ttx> I would like to actively engage with people to see if they would be interested, but to do that I need names. Any suggestion?
20:32:43 <annegentle> Jon Proulx, Joe Topjian
20:32:55 <annegentle> ttx: I have contact info I can send you
20:33:06 <russellb> Nate from NSA
20:33:08 <annegentle> Sean Winn
20:33:08 <ttx> I suggested Guillaume Aubuchon but haven't checked if he would have the time
20:33:15 <annegentle> Beth Cohen
20:33:48 <annegentle> oh and I haven't checked in with any of these names I'm mentioning, but I'd definitely nominate them
20:33:53 <russellb> a large enterprise user of some kind
20:33:54 <ttx> Could you all send me names / contact info? I'll reach to them to check if they would be up to it, and we'll select the final nominee in a future meeting
20:34:01 <annegentle> sure
20:34:07 <ttx> Please send names before the end of week
20:34:54 <annegentle> #action send ttx names/contact info for user committee nominees by Fri 8/22
20:34:56 <ttx> #action ttx to reach to nominees to check if they would be up for the User Committe job first thing Monday morning
20:35:25 <annegentle> I guess that action should have said "all" -- how do I fix it with meetbot?
20:35:38 <russellb> you can #undo, but ttx has already done something after you
20:35:38 <ttx> action is assigned to "send"
20:35:42 <annegentle> ok
20:35:45 <ttx> I guess that works
20:35:47 <annegentle> ah well
20:35:47 <annegentle> :)
20:35:48 <ttx> #topic Other governance changes
20:35:55 <ttx> * Rename marconi to zaqar (https://review.openstack.org/114770)
20:36:06 * russellb proposes a ban on name changes
20:36:11 <jeblair> this is a thing that has happened ^
20:36:13 <annegentle> pronounced "zah-caar"
20:36:22 <jeblair> russellb: i second that :)
20:36:25 <annegentle> for those who talk about things aloud
20:36:25 <ttx> I think mikal's remark is valid, but jeblair just submitted on behalf of the zaqar crew
20:36:27 <mikal> Did they give in to my demands?
20:36:39 <ttx> mikal: jebalir proposed the change
20:36:44 <ttx> dammit jeblair did
20:37:00 <jeblair> hrm
20:37:02 <ttx> jeblair: why is my keyboard mangling your name
20:37:13 <jeblair> well, the governance change is because now the governance repo points to the wrong project names :)
20:37:25 <mikal> I think even the text from that linked email would be sufficient
20:37:43 <mikal> Just some sort of easy to find historical record
20:38:09 <ttx> I guess that commit message can be expanded, yes.
20:38:29 <ttx> Anyway, this is a housekeeping change
20:38:41 <jeblair> updated.  now everyone gets to vote again
20:38:43 <mikal> Hey, I'll update the commit message if Jim doesn't want to
20:39:05 <ttx> jeblair: I'll approve it post-meeting if nobody objects (housekeeping change)
20:39:22 <ttx> post-meeting = as soon as I come back from urgent dental care tomorrow morning
20:39:29 <ttx> * Update kite repo and add python-kiteclient (https://review.openstack.org/114772)
20:39:49 <ttx> Same here, will approve unless someone posts a -1 there
20:39:56 <ttx> * Add repository glance.store to glance (https://review.openstack.org/107585)
20:40:11 <ttx> This one is blocked by Glance PTL virtual -1, and markwash is not back from vacation yet
20:40:17 <ttx> (that I know of)
20:40:22 * dhellmann returns
20:40:41 <ttx> dhellmann: just in time for some interesting open discussion
20:40:42 <jeblair> er
20:40:45 <annegentle> stop talking about dhellmann he's back!
20:40:47 <jeblair> it's already in openstack/
20:41:06 <jeblair> assuming that we correctly waiting for the ptl approval when creating that repo
20:41:15 <jeblair> i would assert that the ptl has already agreed that it's in the program
20:41:20 <dhellmann> annegentle: ha!
20:41:23 * jeblair double checks that
20:41:27 <ttx> jeblair: he posted a -1 on that review though
20:41:37 <ttx> "-1 for just a few days
20:41:38 <ttx> At the mini summit, we were at a bit of a loss to remember the benefits that outweigh the extra integration costs.
20:41:38 <ttx> We're regrouping to discuss this issue this week and to re-evaluate."
20:41:58 <ttx> I don't feel we should bypass thatone
20:42:12 <ttx> #topic Open discussion
20:42:14 <jeblair> ugh
20:42:25 <ttx> So I have a few things
20:42:31 <ttx> zehicle_at_dell would like to propose a DefCore/TC call to give feedback on the Designated Sections strawman.
20:42:33 <jeblair> we (mordred) apparently did _not_ wait for the glance ptl before approving the repo creation
20:42:42 <ttx> That would happen sometimes later in the week or early next week.
20:42:43 <jeblair> so that was an error on infra's part, sorry
20:42:52 <ttx> He explicitely mentioned it would be a call, not an IRC meeting
20:42:59 <jeblair> if he rejects it, we'll move it out of openstack/
20:43:04 <ttx> So watch for announcements on the list(s)
20:43:16 <russellb> boo for non-IRC, but fine :)
20:43:32 <dhellmann> we need to have a transcription service for those calls
20:43:48 <ttx> dhellmann: i can probably make one up.
20:44:01 <dhellmann> ttx: not *quite* what I was looking for :-)
20:44:04 <russellb> you can make up a transcription service?
20:44:23 <russellb> it's been long enough since the last TC blog post
20:44:27 <annegentle> I type fast :)
20:44:29 <russellb> anyone want to take a stab at writing one?
20:44:45 <jeblair> do we have a schedule for that?
20:44:47 <ttx> I guess we should wait until the final decision on Manila
20:44:51 <annegentle> russellb: I can, by when?
20:45:01 <russellb> no schedule, been playing by ear so far
20:45:04 <ttx> so that we actually announce something else than barbican continuing incubation
20:45:11 <russellb> the first few were every 2-3 weeks
20:45:16 <russellb> yeah, maybe after next time
20:45:20 <ttx> Since we have a bit of time there was a topic I wanted to discuss
20:45:23 <russellb> just want to make sure we keep it up
20:45:35 <annegentle> ok
20:45:37 <ttx> Should we have dedicated TC members follow integrated/incubated projects ?
20:45:40 <russellb> annegentle: much appreciated
20:46:00 <ttx> That is, rather than expect we can follow everythign everywhere, try to specialize and follow SOME projects we don't have a direct stake in ?
20:46:06 <markmcclain> how about a blog post of focusing on quality?
20:46:11 <russellb> ttx: I like the idea in general
20:46:22 <ttx> I feel like that would be very useful for incubated projects in particular
20:46:26 <russellb> i think we assume too much that every project is looked after at the detail needed
20:46:43 <annegentle> markmcclain: and the discussion on the future of the integrated release
20:46:44 <markmcclain> russellb: +1
20:46:49 <dhellmann> isn't that part of what the ptl should be handling, though?
20:46:50 <ttx> To be current on Barbican for this meeting, I read ML posts, blogposts, asked questions around...
20:47:10 <annegentle> dhellmann: honestly I think PTLs could use support here from each other and from the TC
20:47:19 <annegentle> even if it's just a Q&A Hangout
20:47:19 <ttx> dhellmann: the idea is that the TC would rely on a particular member to flag issues with projects
20:47:44 <russellb> though we need to be careful with it ... don't want to create another "position"
20:47:53 <russellb> where X is the "TC overlord" of Y
20:47:58 <dhellmann> right, or "subcommittees" or whatever
20:48:03 <ttx> I agree it's tricky, we don't want to be blind and rely on a single person either
20:48:21 <russellb> I think our regular check-ins with projects are good, at least
20:48:25 <dhellmann> ttx: I can see the benefit, I just thought we already had someone to do that, but I guess we don't want to delegate our evaluation to the project
20:48:26 <bswartz> +1 for PTL support group
20:48:31 <ttx> it just feels like a lot of work to watch all projects and know enough about them for every discussion
20:48:40 <bswartz> although I don't get the hate mail that most PTLs do yet
20:48:46 <russellb> ttx: are you thinking specifc to incubation?
20:48:50 <russellb> or more generally?
20:48:51 <mikal> bswartz: I can send you some if you feel left out
20:48:56 <bswartz> lol
20:48:56 <dhellmann> annegentle: I'd be up for some sort of "office hours" thing periodically
20:49:17 <annegentle> "I'm Anne G. and I'm an OpenStack PTL"
20:49:20 <ttx> russellb: I think it's more useful for incubation, since it's easier to overlook those projects
20:49:30 * russellb nods
20:49:38 <dhellmann> annegentle: from 3 tenants to 12 steps?
20:49:41 <russellb> ttx: and maybe for integrated projects, a once per cycle status check is enough?
20:50:05 <annegentle> "It has been 3 days since my last hate mail"
20:50:24 <ttx> russellb: but I also like that some members (devananda) took the time to deep dive into some projects flaws to get us the info we needed
20:50:37 * markmcclain wants to trade inboxes with annegentle
20:50:44 <russellb> ttx: incubated though right?
20:50:53 <russellb> ttx: totally agree this is something worth adding to our incubation process
20:50:54 <annegentle> markmcclain: oh I can't even. Don't have enough. Ugh.
20:51:29 <ttx> I feel like we are supposed to follow all of them, and in practice we only follow a few, which creates dark areas that nobody looks into
20:51:51 <annegentle> ttx: so you're wanting to assure coverage
20:52:00 <russellb> yeah that makes sense
20:52:02 <ttx> russellb: although if we want to scale the number of integarted projects, we won't be able to be current on all of them all the time
20:52:24 <russellb> i generally feel like an integrated project should be able to stand on its own and do well without supervision :)
20:52:28 <vishy> i agree I don’t really look deeply enough into the projects
20:52:34 <ttx> So maybe we can start with assigning "TC mentors" to Kilo incubated projects
20:52:39 <russellb> and a once-per-cycle "chat with the TC about status" should be OK
20:52:47 <russellb> but for incubation, absolutely
20:52:49 <vishy> but i think it is more important pre incubation and integration
20:52:59 <russellb> vishy: yeah i've thought about that too
20:53:04 <russellb> when we go to evaluate a project for incubation
20:53:07 <vishy> as in have a couple of members deep dive with the project for a week
20:53:17 <russellb> not always clear who/if there has been a deep dive ...
20:53:18 <ttx> I've been doing mentoring on the release integration side, but I'll be the first to admit I don't follow their progress very closely
20:53:19 <jogo> russellb: I think that is being overly optimistic
20:53:39 <jogo> russellb: (integrated standing on there own)
20:53:40 <russellb> jogo: i did say "should"
20:53:55 <russellb> saying what i think we should be able to expect.
20:54:02 <ttx> I usually try to catch up when we reach the end-of-cycle graduation review
20:54:24 <ttx> OK, I'll suggest it again when we start the Kilo TC session
20:54:47 <ttx> #action ttx to propose to Kilo TC members to have a TC mentor for each Kilo incubated project to follow their progress more closely
20:54:52 <russellb> +1
20:55:19 <annegentle> nice
20:55:26 <ttx> You might want to stay for the next meeting, we'll brainstorm around potential improvements to deisgn summits to try to make them more useful
20:55:41 <ttx> based on midcycle feedback
20:55:53 <ttx> Anything else, anyone?
20:56:21 <ttx> Do we have someone volunteering to draft a TC article for when we'll have the votes in for Manila?
20:56:40 <russellb> ttx: annegentle
20:56:46 <annegentle> yep
20:57:13 <russellb> annegentle: ping if you'd like another set of eyes on the draft
20:57:18 <ttx> #action annegentle will write the next TC  blogpost, waiting for final decision on Manila first
20:57:21 <russellb> annegentle: do you have an openstack blog account?
20:57:27 <annegentle> russellb: awesome thanks.
20:57:32 <ttx> annegentle: I think you already have a openstack.org blog account
20:57:36 <annegentle> russellb: used to, they don't really exist any more?
20:57:42 <russellb> they dont?
20:57:48 <annegentle> unless I'm retro vintage?
20:57:49 <russellb> i've been using a wordpress account to post
20:57:52 <ttx> annegentle: if not we can get taht clarified
20:57:56 <annegentle> ok
20:58:02 <russellb> stefano hooked me up
20:58:35 <annegentle> ok
20:59:16 <ttx> Oh, and please have a look at the meeting backlog, I think we can fit all discussions before September 16 deadline
21:00:00 <ttx> jeblair: the wiki is asking me to long in for the 3rd time today. Did we change anything on our side?
21:00:14 <ttx> log in
21:00:38 <ttx> #endmeeting