20:02:18 <ttx> #startmeeting tc
20:02:19 <openstack> Meeting started Tue Feb  4 20:02:18 2014 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:24 <openstack> The meeting name has been set to 'tc'
20:02:28 <ttx> Our agenda for today:
20:02:41 <ttx> #link https://wiki.openstack.org/wiki/Governance/TechnicalCommittee
20:02:57 <ttx> #topic Defcore sub-committee questions about Projects vs Programs
20:03:03 <ttx> zehicle: hi!
20:03:11 <zehicle_at_dell> hey
20:03:18 <ttx> zehicle: could you summarize what those questions or concerns are ?
20:03:22 <zehicle_at_dell> #topic programs
20:03:35 <zehicle_at_dell> yes
20:03:37 <vishy> o/
20:04:11 <zehicle_at_dell> discussion is about basically about order/membership between programs and projects
20:04:26 <zehicle_at_dell> and there's a follow-on about how programs are authorized
20:04:37 <ttx> OK, I think there is confusion around the program concept.
20:04:45 <ttx> As far as "core" in concerned, the board should really only be looking at projects imho.
20:04:51 <ttx> My basic definition would be:
20:04:53 <zehicle_at_dell> my understanding of OpenStack Programs is that they are meta constructs for OpenStack that abstract large areas of function
20:04:59 <ttx> Projects are code repositories ("openstack/nova")
20:04:59 <zehicle_at_dell> e.g.: compute, network, storage, etc
20:05:11 <ttx> Programs are actually *teams* working on a number of those code repostories, aligned with a mission statement ("Infrastructure")
20:05:14 <zehicle_at_dell> they also help protect OpenStack from name collisions
20:05:26 <ttx> I think all the confusion stems from sometimes reusing the openstack functional name (i.e. "Compute") as the program name...
20:05:27 <zehicle_at_dell> as such, a program would contain >0 projects
20:05:39 <ttx> ...while one of the projects below them (nova) is also using that functional name (= "OpenStack Compute")
20:06:16 <zehicle_at_dell> ttx, my understading is the OpenStack Compute _is_ the program name
20:06:33 <ttx> the program name is "compute"
20:06:48 <annegentle> For docs, we have a list for conventional use https://wiki.openstack.org/wiki/Documentation/Conventions#Service_and_project_names
20:06:50 <ttx> I guess we could rename some of the programs if that helped reducing the confusion
20:07:08 <ttx> zehicle: basically, the team working on nova and python-novaclient is the compute team
20:07:22 <jeblair> #link http://git.openstack.org/cgit/openstack/governance/tree/reference/programs.yaml
20:07:22 <zehicle_at_dell> what about glance?
20:07:22 <ttx> the progral just reflects the structure of the dev teams
20:07:39 <zehicle_at_dell> hold on
20:07:42 <zehicle_at_dell> I see the wiki
20:07:43 <ttx> the team working on glance and python-glanceclient is the image service team
20:08:24 <zehicle_at_dell> so, are you suggesting that every project eventually becomes a program?
20:08:31 <ttx> zehicle: no
20:08:46 <ttx> zehicle: really, it's reusing the same name that creates the confusion
20:09:01 <zehicle_at_dell> I don't think this matches how we're talking about OpenStack to users - jbryce said that he's focused on "capabliities" whichi are also described as compute, network, etc
20:09:16 <ttx> zehicle: we couldn't be having this discussion if the team working on nova and python-novaclient was called the Albator team
20:09:25 <ttx> s/couldn't/wouldn't/
20:09:27 <vishy> i think it makes sense to just consider a program to be a grouping of projects
20:09:38 <vishy> i.e. a program is a set containing 0..n projects
20:09:40 <ttx> vishy: right
20:09:49 <zehicle_at_dell> that's where I was going
20:10:11 <ttx> zehicle: but from the core / board perspective I think you should be looking at projects
20:10:20 <jeblair> as long as the group can contain 0 projects
20:10:31 <zehicle_at_dell> ttx, no sure
20:10:43 <ttx> zehicle: programs are just a way to reflect the dev teams organization
20:10:44 <vishy> ttx: as far as I can tell they are ignoring projects completely and going with capabilities
20:10:49 <zehicle_at_dell> the board has been working to use capabilities/tests to define core
20:10:52 <markmc> zehicle, yes jbryce should be talking about capabilities, more than the groups implementing those
20:10:57 <ttx> and structure reflects how we work, rather than the other way around
20:10:57 <vishy> s/they/we (i suppose) :)
20:10:59 <zehicle_at_dell> but there's still a question about use of the OpenStack trademark
20:11:22 <ttx> zehicle: in program names ?
20:11:24 <zehicle_at_dell> there's a question about how a project can use the OpenStack trademark
20:11:33 <ttx> zehicle: or in project names
20:11:33 <zehicle_at_dell> since we get into challenges w/ OpenStack Neutron, etc
20:11:41 <ttx> agreed
20:11:48 <zehicle_at_dell> Program Names are 1) generic and 2) can hold a trademark
20:11:54 <markmc> zehicle, yes there is that trademark question and the TC is keen to see the board resolve it
20:11:58 <zehicle_at_dell> so, OpenStack Compute should be protectable
20:12:20 <ttx> zehicle: the program name is "compute", not "openstack compute", though*
20:12:23 <zehicle_at_dell> if we agree that Nova is a member of Compute, then we've have a clear way to describe the project
20:12:38 <zehicle_at_dell> OpenStack Compute Project Nova
20:13:01 <markmc> "OpenStack Compute" is another name for the project
20:13:02 <ttx> zehicle: hmmm... not sure about that
20:13:03 <markmc> not the program
20:13:20 <zehicle_at_dell> not according to what vishy was saying
20:13:27 <ttx> "Compute" program has openstack/nova proiject, also known as "OpenStack Compute"
20:13:34 <zehicle_at_dell> Nova is a member of Compute
20:13:43 <zehicle_at_dell> but compute could have other memembers
20:13:44 <markmc> Nova is a member of the compute program
20:13:57 <markmc> and the Nova project is also known as OpenStack Compute
20:14:02 <zehicle_at_dell> what is the objection to the Capital C?
20:14:03 <markmc> the compute program could have other projects
20:14:05 <annegentle> Compute needs images to give capabilities though
20:14:13 <markmc> whose official names may be OpenStack Foobar
20:14:18 <zehicle_at_dell> why is compute better/different than Compute
20:14:23 <jeblair> indeed the compute program also holds the gantt and python-novaclient projects
20:14:38 <ttx> zehicle: "compute" avoids using the trademark altogether
20:14:49 <zehicle_at_dell> I've been told that Compute also includes glance
20:15:03 <zehicle_at_dell> not sure that avoiding the trademark is needed/helpful
20:15:11 <markmc> the compute program doesn't include glance
20:15:14 <ttx> Glance is developed by a separate team, so Glance is in a separate program
20:15:16 <zehicle_at_dell> since we specifically want to be able to say "OpenStack Foo"
20:15:21 <zehicle_at_dell> so we have to deal w/ trademark
20:15:22 <markmc> and OpenStack Compute is not another name for the glance project
20:15:37 <zehicle_at_dell> I think we're back to the issue
20:15:41 <zehicle_at_dell> I see glance as a project
20:15:45 <zehicle_at_dell> that is a member of a program
20:15:46 <markmc> it is
20:15:50 <markmc> indeed
20:15:57 <zehicle_at_dell> it's not the only member of a program,
20:16:05 <annegentle> and the program is not "Images" it's "Compute"
20:16:06 <zehicle_at_dell> why should it be the only member?
20:16:24 <ttx> annegentle: ?
20:16:28 * annegentle attempts to complete zehicle_at_dell's thoughts
20:16:29 <markmc> zehicle_at_dell, it's the only member right now
20:16:41 <markwash> well, python-glanceclient sort of
20:16:42 <jeblair> glance and python-glanceclient are the two members of the Image Service program
20:16:44 <zehicle_at_dell> I am _not_ recommending any membership at this point, just using them as examples.  that's a different discussion
20:16:48 <ttx> markmc: well, not counting python-glanceclient
20:16:54 <zehicle_at_dell> markmc, we agree on that on
20:16:57 <markmc> ttx, yeah
20:17:04 <zehicle_at_dell> but I'm not sure which programs we have
20:17:07 <annegentle> @link http://git.openstack.org/cgit/openstack/governance/tree/reference/programs.yaml
20:17:11 <annegentle> er
20:17:12 <annegentle> #link http://git.openstack.org/cgit/openstack/governance/tree/reference/programs.yaml
20:17:16 <markmc> ^^ that's our list of programs
20:17:17 <zehicle_at_dell> sorry, I know which are posted
20:17:24 <annegentle> zehicle_at_dell: that just reflects current reality
20:17:24 <markmc> IOW, our list of teams
20:17:47 * zehicle_at_dell gets broom
20:18:06 <ttx> zehicle: I'm starting to think we should have used DIFFERENT nati_ueno mes for the teams, to avoid confusion
20:18:17 <ttx> names, not nati_ueno, stupid tab completion
20:18:26 <zehicle_at_dell> perhaps
20:18:33 <ttx> zehicle: note: we still can
20:18:37 <ttx> zehicle: easy
20:18:54 <zehicle_at_dell> I'm not sure that we need for projects to take on generic names
20:19:02 <ttx> zehicle: would calling it the keystone team work better ?
20:19:04 <zehicle_at_dell> maybe, but I think it's different
20:19:17 <annegentle> zehicle_at_dell: honestly for docs and a user perspective we have to call it something meaningful not code-named
20:19:18 <ttx> rather than the identity team ?
20:19:24 <dhellmann> zehicle_at_dell: the project is the thing we release, and that's the place where the trademark is important, right?
20:19:33 <ttx> dhellmann: +1
20:19:39 <markmc> zehicle_at_dell, 20 minutes in, I really don't know what the DefCore related issue you're getting at here is
20:19:48 <markmc> zehicle_at_dell, maybe start again from that angle?
20:19:50 <zehicle_at_dell> ah, circle is complete dhellmann
20:19:57 <joshuamckenty> markmc: I believe that was the reason we suggested a F@F
20:19:57 <dhellmann> all of the rest of this is just organizing people, and i'm not sure why that matters so much outside of the people being organized
20:19:59 <joshuamckenty> f@f
20:20:03 <jeblair> annegentle: programs aren't really for consumption by docs or users though...  really only openstack developers see them
20:20:42 <zehicle_at_dell> TC asked the Board to approve then name change of Ceilometer to become a core prgram  named OpenStack Telemetry
20:20:57 <dhellmann> core project, right?
20:21:03 <zehicle_at_dell> sigh
20:21:04 <ttx> core project.
20:21:08 <joshuamckenty> there aren't core projects, anymore
20:21:11 <zehicle_at_dell> we are not making projects core
20:21:12 <joshuamckenty> just core capabilities
20:21:22 * zehicle_at_dell echos joshuamckenty
20:21:22 <ttx> joshuamckenty: nor core programs, right ?
20:21:27 <joshuamckenty> right
20:21:35 <joshuamckenty> just integrated releases
20:21:43 <markmc> the TC wanted the Board to allow the Ceilometer project call itself "OpenStack Telemetry"
20:21:44 <joshuamckenty> there are three specific uses of the trademark
20:21:45 <dhellmann> can we make sure we're all using the words with the same meantings before we decide we don't need to use the words?
20:21:48 <zehicle_at_dell> I think that we could consider programs as core if we handle the membership issue
20:21:53 <joshuamckenty> that we were trying to protect in the bylaws
20:21:58 <markmc> which, based on our interpretation of the bylaws required board approval
20:22:08 <joshuamckenty> 1. Use of the mark by the community of developers to refer to the product of their efforts
20:22:08 <markmc> we don't care whether that means making the project "core" or not
20:22:11 <jgriffith> dhellmann: great idea :)
20:22:15 <markmc> we just think it should be allowed use that name
20:22:16 <dhellmann> we don't want core programs, because programs have multiple projects and not all of the projects in a given program are going to be core
20:22:16 <ttx> zehicle: I think we shouldn't consider programs as core. They reflect how the team self-organize
20:22:22 <joshuamckenty> 2. Use of the mark of vendors to indicate compliance with some definition of "core"
20:22:36 <dhellmann> the tests should look at capabilities provided by projects and should not think about programs at all
20:22:38 <vishy> joshuamckenty, zehicle_at_dell: that is a cool approach, but on the other hand branding the projects as OpenStack definitely has some value
20:22:44 <zehicle_at_dell> dhellmann, that's a big jump
20:22:59 <vishy> so perhaps any project that implements some of said capabilites can use OpenStack in its name?
20:23:01 <joshuamckenty> vishy: I'm just describing what's already been approved by the board
20:23:08 <zehicle_at_dell> vishy, yes.  it has value AND it's the only stick that we really have
20:23:09 <dhellmann> zehicle_at_dell: when we say "program" we do not mean "computer program" we mean "team of developers"
20:23:13 <dhellmann> so why is that a big jump?
20:23:17 <zehicle_at_dell> so we need to maintain some goverannce on it
20:23:26 <markmc> joshuamckenty, zehicle_at_dell, the creation of programs (i.e. "teams") is purely a technical governance issue
20:23:36 <joshuamckenty> markmc: not if they use the mark
20:23:43 <zehicle_at_dell> dhellmann, perhaps we sould say Program (not program)
20:23:44 <vishy> markmc: but they don't
20:23:48 <joshuamckenty> if you want to call them StackStack Program <x>
20:23:49 <markmc> joshuamckenty, we're not asking for programs to use the mark
20:23:50 <vishy> joshuamckenty: ^^
20:23:53 <joshuamckenty> then there's no issue
20:23:54 <dhellmann> zehicle_at_dell: I'm not sure case matters. :-)
20:23:59 <ttx> zehicle: definitely agree -- that's why programs should stay out of it... since programs are a reflection of our ever-changing team organization, and not of "openstack" capabilities
20:24:00 <zehicle_at_dell> dhellmann, it's big because you're assuming that integrated = program member
20:24:05 <vishy> the mark is for projects imo
20:24:12 <dhellmann> zehicle_at_dell: yes, that is a requirement from the TC
20:24:20 <dhellmann> there has to be a team backing a project for us to integrate it
20:24:34 <markmc> joshuamckenty, we've created the telemetry program and then *later* asking the board to allow the ceilometer project to use the OpenStack Telemetry name
20:24:39 <zehicle_at_dell> vishy, that creates problems because we have to protect all the uses (which means ALL the projects)
20:24:49 <joshuamckenty> markmc: you've got the order backwards, though
20:25:04 <vishy> zehicle_at_dell: well that is the whole reason for having rules
20:25:06 <jbryce> joshuamckenty: what was the 3rd use?
20:25:08 <joshuamckenty> because the "OpenStack Telemetry" program implies that the board has agreed that telemetry capabilities will be part of core
20:25:10 <vishy> i'm not saying every project gets one by default
20:25:15 <joshuamckenty> which it hasn't
20:25:18 <markmc> joshuamckenty, no I don't
20:25:18 <zehicle_at_dell> My understanding (no JD degree) is that we have an issue w/ brand protection if every project could eventually use _OpenStack_
20:25:26 <vishy> but there has to be a way for a project to be called OpenStack X
20:25:28 <markmc> joshuamckenty, I've got the order exactly correct :)
20:25:36 <vishy> if for no other reason then that's the way it works today
20:25:37 <zehicle_at_dell> we'd have to vet every project name just in case it got inclubated
20:25:49 <joshuamckenty> vishy: that's not a reason
20:25:54 <dhellmann> joshuamckenty: it sounds like you think the board should be setting the technical direction, in terms of features, which is not a responsibility I understood the board to have.
20:25:56 <vishy> joshuamckenty: actually it is
20:26:18 <zehicle_at_dell> vishy, I think we'd get to a point where program membership is an additional gate beyond integrated
20:26:23 <ttx> zehicle: if the telemetry program was called the doctorwho program, would we be having that discussion ?
20:26:24 <vishy> joshuamckenty: you can't go back and uncall things OpenStack Compute
20:26:26 <vishy> it is all over the internet
20:26:28 <joshuamckenty> dhellmann: it is precisely the responsibility vested into it by by the bylaws
20:26:30 <dhellmann> zehicle_at_dell: we can change the names at incubation time if there is a conflict -- that's part of the incubation process, right?
20:26:37 <zehicle_at_dell> ttx, yes
20:26:54 <ttx> even if ceilometer still asked to be called OpenStack telemetry ?
20:26:56 <vishy> zehicle_at_dell: why make it more complicated then the board must approve using OpenStack in the name of the project?
20:27:01 <joshuamckenty> vishy: true, but that doesn't mean we need a process that allows additional cases
20:27:10 <vishy> joshuamckenty: agreed
20:27:14 <dhellmann> joshuamckenty: that's now how I read 4.1
20:27:25 <vishy> but involving programs etc. just makes it more complicated
20:27:43 <vishy> when it could be simply stating integrated projects do not get automatic access to the trademark
20:27:48 <zehicle_at_dell> vishy, I don't remember the board ever doing that except the predefined ones in the by-laws
20:27:49 <joshuamckenty> dhellmann: we can argue over the language if you want, but I can speak to the intent of the drafting committee
20:27:51 <vishy> it must be approved by the board
20:27:51 <ttx> programs are and should stay a reflection of how our teams self-organize
20:27:58 <dhellmann> joshuamckenty: later, then
20:28:02 <ttx> because we can't mandate how teams self-organize
20:28:05 <mikal> I see programs as irrelevant to this discussing, they're just internal team structure. Defcore only cares about released software, i.e. projects.
20:28:18 <dhellmann> mikal: +1
20:28:18 <ttx> mikal: agreed
20:28:22 <joshuamckenty> DefCore cares about use of the mark that's confusing
20:28:30 <joshuamckenty> and the equation of project to program
20:28:32 <dhellmann> are the programs using the mark?
20:28:33 <ttx> mikal: the confusion is because swe used the same names (the functional description)
20:28:36 <mikal> So can we ban the word "program" from this conversation to reduce confusion?
20:28:36 <markmc> but programs aren't using the mark
20:28:36 <zehicle_at_dell> mikal, so how does that match to vishy comment that programs have >0 projects
20:28:41 <vishy> does anyone else feel like there actually isn't any debate here, and we just need to state what is actually true
20:28:51 <vishy> that projects can only use the mark if approved by the board
20:28:53 <ttx> joshuamckenty: the programs are NOT using the openstack trademark though
20:28:55 <vishy> and programs cannot use it
20:28:56 <mikal> zehicle_at_dell: every program has at least one project
20:29:05 <markmc> vishy, yes
20:29:09 <mikal> (That I can recall)
20:29:11 <ttx> joshuamckenty: but just the functional description.
20:29:15 <joshuamckenty> great
20:29:16 <vishy> simple problem, simple answer
20:29:19 <jeblair> mikal: some programs have 0 projects
20:29:20 <joshuamckenty> well, okay
20:29:21 <zehicle_at_dell> mikal, can you give me an excample of a program w/ >1 project?
20:29:24 <dhellmann> mikal: we have discussed some programs that won't have their own project (UX)
20:29:29 <joshuamckenty> then we just need to make it more clear in community documentation
20:29:29 <ttx> i.e. "compute program", not "openstack compute program"
20:29:31 <zehicle_at_dell> jeblair, which ones?
20:29:36 <mikal> Oh true
20:29:36 <vishy> zehicle_at_dell: nova, gantt, python-novaclient
20:29:44 <joshuamckenty> that the existence of a program does not indicate that the projects inside it will become part of openstack
20:29:49 <markmc> joshuamckenty, pointers to where it's not clear are welcome
20:29:53 <ttx> joshuamckenty: oh, definitely nOT
20:29:54 <vishy> joshuamckenty: correct
20:29:54 <mikal> zehicle_at_dell: we've given you an example several times: the compute program has nova, gantt and python-novaclient
20:30:06 <jeblair> oh, it looks like "Release cycle management" did grow a project, but it started without one
20:30:09 <annegentle> joshuamckenty: by doing what?
20:30:18 <ttx> joshuamckenty: the "release managemnt" program, for example, will NEVER EVER have an openstack name attached to one of its projects
20:30:22 <vishy> i think we are actually all agreeing we just need to make clear statements about what exists becasue it is confusing
20:30:27 <jeblair> and we have positively discussed that we would be happy to add a ux program with 0 projects (but the team for that hasn't formed yet)
20:30:50 <mikal> I think we're on a tangent again
20:30:53 <joshuamckenty> https://wiki.openstack.org/wiki/Programs
20:31:06 <mikal> What I am getting from this is that the board wants to be the only one who can assign the openstack amrk to things
20:31:10 <joshuamckenty> This line is particularly confusing: "The Technical Committee has a mandate to review programs that wish to be included as official OpenStack programs."
20:31:19 <mikal> So we need to be careful to not call something "OpenStack Foo" until the board has been consulted, yes?
20:31:20 <joshuamckenty> mikal: there is a specific mandate for the community to use the mark
20:31:26 <joshuamckenty> but not to refer to componets
20:31:28 <ttx> joshuamckenty: agreed, we need to clarify that
20:31:29 <markmc> joshuamckenty, sounds accurate to me
20:31:30 <joshuamckenty> but just the community itself
20:31:38 <markmc> they're still official programs
20:31:43 <zehicle_at_dell> so, we have an unending list of programs?
20:31:46 <vishy> joshuamckenty: I agree that page is a bit confusing from a mark perspective
20:31:48 <markmc> even if we don't use the mark with them
20:31:52 <joshuamckenty> they're programs of OpenStack, but not "OpenStack programs"
20:31:57 <joshuamckenty> :)
20:31:58 <vishy> so lets edit it to clarify
20:32:02 <ttx> joshuamckenty: I'll take that
20:32:13 <ttx> "official programs of OpenStack"
20:32:17 <markmc> "official programs of OpenStack"
20:32:19 <ttx> or even
20:32:21 <markmc> right :)
20:32:27 <joshuamckenty> awesome
20:32:28 <ttx> "TC-recognized prograls of OpenStack"
20:32:32 <ttx> programs
20:32:35 <zehicle_at_dell> how did the offiical programs become official?  was there a TC vote?
20:32:43 <vishy> zehicle_at_dell: yes
20:32:43 <joshuamckenty> Yes
20:32:44 <markmc> yes
20:32:56 <joshuamckenty> there was a mailing list process for existing ones to submit, IIRC
20:33:40 * ttx edited the wiki
20:33:47 <mikal> So I still don't understand the ask from the board here
20:33:53 <markmc> joshuamckenty, resolved in under 30 minutes with no need for a f2f :)
20:33:55 <mikal> Is it just that you want us to stop using the openstack name?
20:34:05 <markmc> mikal, that programs don't use the mark
20:34:11 <ttx> mikal: in a confusing way yes
20:34:11 <joshuamckenty> just stop calling them "OpenStack Telemetry", yes
20:34:11 <joshuamckenty> it creates confusion
20:34:13 <mikal> That's it?
20:34:19 <markmc> but that does bring us back to *projects* using the name
20:34:31 <ttx> joshuamckenty: in retrospect, we should have called those programs by the codename
20:34:38 <ttx> i.e. the nova program
20:34:39 <annegentle> from an official documentation perspective, then the second change request is for the documentation conventions to stop using OpenStack Telemetry, right?
20:34:44 <zehicle_at_dell> I think the gap is larger than I thought
20:34:48 <ttx> and avoid confusion with the trademark altogether
20:34:48 <markmc> the TC would still like Ceilometer project to be able to use the OpenStack Telemetry name
20:34:57 <mikal> What if we just always have "team" at the end of program names... "Compute Team", "UX Team", etc etc
20:35:30 <markmc> and the TC doesn't mean by that request that Ceilometer should be a required part of OpenStack clouds
20:35:32 <jeblair> mikal: i like that because it helps us continue to use the generic name which i think has value
20:35:36 <ttx> mikal: blame mordred for suggesting "program" instead of "team"
20:35:40 <zehicle_at_dell> what happens if there's another project that wants to use the same program name?
20:35:44 <joshuamckenty> that way a project that has capabilities in core can be called "OpenStack Compute
20:35:44 <joshuamckenty> without overlap on the program
20:35:44 <joshuamckenty> Awesome, can we cover one other defcore issue?
20:35:48 <zehicle_at_dell> for example another approach to orchtestration?
20:35:54 <jeblair> ttx: if we have to use 'nova', ok, but i think it's good that 'compute program' doesn't mean 'just nova'.
20:35:54 <mikal> markmc: yes, that's my second question from this
20:35:55 <ttx> joshuamckenty: quick yes
20:35:58 <zehicle_at_dell> would Orchestration has two projects?
20:36:08 <dhellmann> zehicle_at_dell: we would ask them to collaborate with the existing team and possibly create another project
20:36:13 <mikal> markmc: ceilometer can only be "openstack telemetry" if the board picks a capability it provides to be in the core set?
20:36:15 <joshuamckenty> markmc: we're trying to have those two things mean the same thing
20:36:15 <sparkycollier> So would it be fair to say that "The integrated release of OpenStack includes Telemetry in the Havana version" ?
20:36:18 <ttx> zehicle: if the same team works on it yes
20:36:19 <markmc> #link https://review.openstack.org/#/c/55375/2/resolutions/20131106-ceilometer-and-heat-official-names
20:36:28 <joshuamckenty> wherever possible
20:36:29 <joshuamckenty> e.g., OpenStack <foo> means that some foo capabilities are part of core
20:36:43 <joshuamckenty> mikal: yes
20:36:50 <ttx> joshuamckenty: what's the second issue ?
20:36:51 <joshuamckenty> that's the current theory
20:36:56 <joshuamckenty> designated sections
20:37:00 <mikal> So we can never call something "OpenStack X" until after a capability is blessed?
20:37:15 <joshuamckenty> we need the PTLs to decide what code sections are designated sections
20:37:16 <ttx> mikal: the board decides how the trademark is used
20:37:27 <jeblair> markmc: has the board taken that up yet?
20:37:30 <mikal> In that case, can't we just say to the board "bless this name, this project provides the following capabiities we would like to have considered for the core set"?
20:37:44 <markmc> jeblair, no, it's gotten all mixed up in this defcore stuff
20:37:46 <mikal> ttx: I get that, I'm trying to work out how we interact over it though
20:37:47 <dhellmann> joshuamckenty: what is "designated sections"?
20:37:51 <zehicle_at_dell> what does same team mean?  if there are two projects, would they be the same team?
20:38:03 <joshuamckenty> zehicle_at_dell: team == program
20:38:21 <mikal> zehicle_at_dell: yes. A team can work on more than one project at a time. I thought we'd covered that.
20:38:22 <joshuamckenty> https://wiki.openstack.org/wiki/Governance/CoreDefinition
20:38:24 <ttx> zehicle: if they share the same core reviewers, then they are the same team
20:38:26 <joshuamckenty> dhellmann: ==^
20:38:42 <joshuamckenty> section 4
20:38:51 <joshuamckenty> as a hypothetical example,
20:38:56 <lifeless> back
20:38:57 <joshuamckenty> since I'm not supposed to use the term "plugin",
20:38:58 <zehicle_at_dell> I don't think you're leaving room for parallel efforts
20:38:59 <lifeless> sorry about that
20:39:21 <joshuamckenty> nova might make the "conductor" a designated section
20:39:24 <dhellmann> joshuamckenty: are you seriously asking for line numbers within specific files?
20:39:31 <zehicle_at_dell> if we're saying team == program because they are commonly managed
20:39:38 <joshuamckenty> no, module names or some such is probably fine
20:39:42 <mikal> joshuamckenty: how does a section differ from a capability?
20:39:47 <markmc> zehicle_at_dell, I think you're on to another topic altogether, unrelated to DefCore
20:40:00 <joshuamckenty> capabilities don't have to be implemented with the same code unless that code is a designated section
20:40:06 <markmc> zehicle_at_dell, i.e. "how the TC should run its technical meritocracy"
20:40:09 <joshuamckenty> e.g., neutron plugins
20:40:09 <mikal> Wait what?
20:40:10 <dhellmann> joshuamckenty: tying core branding to code organization is going to make a mess when we refactor something
20:40:14 <joshuamckenty> and floating ip support
20:40:27 <zehicle_at_dell> markmc, asking questions to resolve word choices
20:40:31 <mikal> You want us to list the blocks of code that implement floating IP support?
20:40:36 <joshuamckenty> no
20:40:38 <joshuamckenty> the reverse
20:40:39 <vishy> zehicle_at_dell: parallel efforts as part of the integrated release is a poor choice imo, but this is a tangent
20:40:48 <mikal> You want us to list the blocks of code which don'
20:40:49 <joshuamckenty> the blocks of code that vendors MUST INCLUDE to use the mark
20:40:53 <mikal> t implement floating IP support?
20:40:56 <zehicle_at_dell> but it does seem to me that I should be able to ask questions about it without that push back
20:41:09 <vishy> mikal: they want a list of modules that must be included to still call the thing e.g. nova
20:41:15 <mikal> joshuamckenty: that's a lot more granular than my original expectation
20:41:16 <jeblair> all of them
20:41:21 <jgriffith> jeblair: +1
20:41:23 <joshuamckenty> jeblair: nope
20:41:27 <mikal> joshuamckenty: I was expecting "all of nova except the hypervisor drivers"
20:41:28 <joshuamckenty> because some of them are hypervisor specific
20:41:30 <vishy> to prevent people from rewriting the whole thing and still calling it OpenStack
20:41:35 <joshuamckenty> mikal: exactly!
20:41:39 <joshuamckenty> each project gets to designate
20:41:44 <mikal> joshuamckenty: no, the hypervisor specific stuff is behind a clear line in the code
20:41:46 <joshuamckenty> neutron will be less, probably
20:41:47 <ttx> joshuamckenty: makes sense to me
20:41:48 <markmc> zehicle_at_dell, we're trying to avoid tangents, is all
20:41:49 <zehicle_at_dell> we left it to the TC to make recommendations about how to handle it
20:42:02 <vishy> joshuamckenty: curious why this is left up to the PTLs
20:42:05 <jgriffith> joshuamckenty: so "cinder-create, delete, ...."
20:42:05 <joshuamckenty> glance is likely 100% as well
20:42:11 <markwash> well
20:42:12 <zehicle_at_dell> markmc, I don't think we resolved the issues that started this
20:42:12 <jgriffith> joshuamckenty: literally call out all of the API calls?
20:42:12 <joshuamckenty> vishy: who would you suggest instead?
20:42:19 <vishy> joshuamckenty: doubtful there are driver backends for glance
20:42:21 <joshuamckenty> jgriffith: not api calls, code modules
20:42:21 <zehicle_at_dell> and now we're way off
20:42:25 <jgriffith> Because modules doesn't make any sense
20:42:33 <joshuamckenty> jgriffith: why not?
20:42:36 <vishy> joshuamckenty: tc would be another choice
20:42:37 <annegentle> vishy: joshuamckenty: this does sound more product manager type questions than tech leads
20:42:37 <joshuamckenty> cinder has drivers
20:42:46 <jeblair> i think this topic is very interesting but probably merits a clear/detailed proposal for us to review
20:42:48 <vishy> jgriffith: loosely, which part of the code
20:42:49 <joshuamckenty> drivers probably aren't designated sections
20:42:54 <dhellmann> joshuamckenty: this list is going to need to be updated for each release, is that going to be OK?
20:42:58 <joshuamckenty> yup
20:43:00 <zehicle_at_dell> jeblair, +1
20:43:04 <joshuamckenty> we have to rerun defcore every release, too
20:43:12 <ttx> zehicle: joshuamckenty was apparently satisfied by our changes to the use of the openstack trademark in program names
20:43:12 <mikal> I am scared of the board somehow being involved in our ability to refactor code
20:43:15 <jgriffith> vishy: joshuamckenty modules includes things like cinder.volume.utils
20:43:21 <jgriffith> rpc modules
20:43:23 <jgriffith> logging modules
20:43:23 <ttx> zehicle: which is why we moved on to second issue
20:43:24 <jgriffith> etc etc
20:43:26 <joshuamckenty> mikal: that's why we're not in charge of the designated sections
20:43:38 <zehicle_at_dell> ttx, so we're exiting that part w/o resolution. ok
20:43:46 <vishy> jgriffith: the idea is (currently) the ptl decides which sections of the code are required to use the mark
20:43:46 * dhellmann wonders if this means oslo libraries are going to start being considered as part of core
20:43:48 <joshuamckenty> jgriffith: I was using modules in the generic "Code Complete" sense, not the python sense
20:43:53 <mikal> joshuamckenty: ok, but a code reviewer would still need to block a refactor to seek some form of management approval
20:43:58 <jeblair> mikal: well, they can't be and won't be so don't worry.  :)
20:44:03 <joshuamckenty> mikal: why?
20:44:09 <zehicle_at_dell> missed the #topic modules definition in core
20:44:09 <jgriffith> vishy: I get it... easy enough
20:44:10 <joshuamckenty> that management approval is from the PTL
20:44:10 <ttx> zehicle: resolution was: do not call programs "OpenStack X" anymore
20:44:19 <mikal> joshuamckenty: because it might change what is in the defnitiion and what isn't
20:44:27 <vishy> joshuamckenty: that makes sense... i.e. must use the API code, must use the RPC code
20:44:28 <joshuamckenty> zehicle_at_dell: designated sections
20:44:34 <mikal> joshuamckenty: let's say you list all the capabilities of nova in core, _except_ floating IPs
20:44:37 <vishy> without getting to the level of every python module/file included
20:44:43 * zehicle_at_dell corrected
20:44:47 <mikal> joshuamckenty: how do we then define what bits of the common nova code aren't for floating IPs?
20:44:52 <annegentle> ttx: I'd still like an agreement logged about https://wiki.openstack.org/wiki/Documentation/Conventions#Service_and_project_names
20:44:53 <joshuamckenty> mikal: you don't have to
20:44:58 <mikal> joshuamckenty: and what happens when I refactor that code and break the defined list as a side effect
20:45:00 <ttx> zehicle: I though joshuamckenty was echoing the same concern you were - and so if he was happy with that resolution you were, too
20:45:04 <zehicle_at_dell> ttx, that does not resolve issue.  just side steps naming
20:45:04 <joshuamckenty> mikal: if you put it in the designated section, that's your business
20:45:24 <markmc> ok, look
20:45:26 <joshuamckenty> zehicle_at_dell: the naming issue is separate from the "parallel efforts" issue
20:45:31 <markmc> if zehicle_at_dell doesn't agree the issue is resolved
20:45:34 <markmc> let's stop the other thing
20:45:35 <joshuamckenty> but I don't want to try and deal with parallel efforts over IRC
20:45:42 <ttx> zehicle: then I don't get your issue. Expressing it on ML first would have helped explaining it
20:45:49 <markmc> zehicle_at_dell, re-state how we're "side-stepping naming" ?
20:46:05 <jeblair> annegentle: only the board-approved projects can use openstack names
20:46:16 * mikal pauses on the designated sections thing to let the naming debate restart
20:46:21 <jeblair> annegentle: so it is premature to call ceilometer "OpenStack Telemetry"
20:46:26 <ttx> OK, back to first issue
20:46:38 <jeblair> annegentle: same for heat
20:46:41 <joshuamckenty> parallel effort issue is the following:
20:46:42 <ttx> joshuamckenty: are your concerns answered now, or is it just sidesteps ?
20:46:53 * zehicle_at_dell suggests that I review commends based on updated information and discussion and start thread on list
20:47:05 <ttx> zehicle: that would help
20:47:05 <annegentle> jeblair: ttx: do we need a review patch to reverse the resolution in our governance repo?
20:47:20 <ttx> zehicle: with limited shared context, ML usualluy works better to explain one's point
20:47:25 <jeblair> annegentle: the resolution was that we ask the board to consider allowing it; they have not done so yet
20:47:47 <jeblair> annegentle: we can not decide that ourselves (and we did not try, we only asked)
20:47:47 <ttx> zehicle: otherwise we'll talk past each other for 15 more minutes
20:47:52 <zehicle_at_dell> I was trying to get a thread but wanted to get more input before it launched - sorry that wasted some time.  I think this discussion will help influence the thread
20:48:08 <ttx> zehicle: consider it a good bootstrap ;)
20:48:21 <ttx> so... back to issue #2 ?
20:48:28 <zehicle_at_dell> +1
20:48:30 <joshuamckenty> so was there a suggestion to have the TC own the designated sections instead of the PTLs?
20:48:32 <markmc> restate #2?
20:48:35 <ttx> TC vs. PTL to designate critical code sections
20:48:36 <markmc> ttx, just to be clear
20:48:45 <vishy> please no thread
20:48:52 <jeblair> ttx, markmc: back me up here on https://wiki.openstack.org/wiki/Documentation/Conventions#Service_and_project_names -- i think it's important because it appears to be an actual use of the mark outside of what we agreed
20:49:09 <jeblair> and annegentle rightly wants clarity there
20:49:22 <annegentle> yes please
20:49:28 <jbryce> i'm confused on this too
20:49:30 <annegentle> and in a logged manner so I can point the doc team to it
20:49:34 <markmc> jeblair, sorry, I agree with what you said - we do not yet know that Ceilometer and Heat cannot yet be called OpenStack Telemetry and OpenStack Orchestration
20:49:45 <ttx> jeblair: the board is currently changing the rules for trademark usage. So obviously the doc needs to be updated to reflect that, if necessary
20:49:58 <jbryce> Section 4.1 - "The Core OpenStack Project means the software modules which are part of an integrated release and for which an OpenStack trademark may be used. The other modules which are part of the OpenStack Project, but not the Core OpenStack Project may not be identified using the OpenStack trademark except when distributed with the Core OpenStack Project."
20:49:58 <lifeless> markmc: *blink* double negative?
20:50:00 <vishy> ttx, zehicle_at_dell: imo, this issue is resolved, and any further discussion on the ML is just extra beauracracy that wastes everyones time
20:50:07 <annegentle> ttx: and the stable/havana branch changed?
20:50:15 <markmc> lifeless, sorry
20:50:17 <ttx> vishy: if zehicle still has concerns, he can raise a thread
20:50:21 <jbryce> ceilometer and heat are "other modules" (second sentence) distributed with the Core OpenStack Project
20:50:28 <ttx> vishy: don't feel forced to participate to it :)
20:50:29 <markmc> jeblair, sorry, I agree with what you said - we do not yet know that Ceilometer and Heat may be called OpenStack Telemetry and OpenStack Orchestration
20:50:34 <annegentle> jbryce: appreciated
20:50:36 <vishy> ttx: ok I will ignore it then :)
20:50:55 <zehicle_at_dell> vishy, you can ignore if you'd like.  perhaps some 1x1 will be useful
20:51:10 <markmc> jeblair, I'm using that language because I think you could interpret the bylaws like jbryce and say we could use those names
20:51:11 <zehicle_at_dell> vishy, can bring you up on DefCore too
20:51:20 <vishy> zehicle_at_dell: sure no problem there
20:51:33 <markmc> jeblair, but I'm being cautious - i.e. I don't think there's consensus on the interpretation
20:51:43 <vishy> zehicle_at_dell: but really there is way to much pointless discussion around these topics. Most of the questions are simple
20:51:51 <ttx> So. On that second topic. I'd propose the PTLs propose sections and the TC approves them
20:52:07 <vishy> and we can talk about them forever
20:52:07 <vishy> ttx: +1
20:52:07 <joshuamckenty> vishy: that's an unnecessary ad-hominem attack
20:52:12 <sparkycollier> I read it as "you can talk about Telemetry in the context of OpenStack because it's part of the integrated release"
20:52:15 <mikal> ttx: with the understanding that the default proposal is "anything outside the drivers" I'm ok with that
20:52:39 <joshuamckenty> mikal: the default state for DefCore is 0%, unless we hear otherwise :)
20:52:41 <vishy> joshuamckenty: ?
20:53:01 <vishy> joshuamckenty: we just went through 20 minutes of agreeing and being unwilling to state what the agreement was
20:53:06 <joshuamckenty> vishy: "You should stop talking about this because it's simple and this discussion is pointless"
20:53:15 <ttx> joshuamckenty: so the TC will take the ball on that section definition thing
20:53:18 <mikal> joshuamckenty: I think that's almost exactly backwards for the projects which use the trademark
20:53:24 <vishy> joshuamckenty: if there is disagreement i'm all for discussion
20:53:27 <joshuamckenty> mikal: how so?
20:53:31 <vishy> joshuamckenty: but afaict ther is no disagreement
20:53:53 <vishy> someone just needs to say "this is the agreement" and we can all ratify it
20:53:54 <joshuamckenty> vishy: there is clear disagreement on a complex issue. We just agreed on the easy part
20:53:57 <ttx> joshuamckenty: any deadline for proposing initial sets ?
20:53:58 <jeblair> ttx: i missed the last board meeting; is this whole process documented somewhere?  as the tc do we know clearly what the board is asking us to do?
20:54:00 <mikal> If you let nova use the openstack mark, for example, then the default assumption should be that 100% of its code is covered by defcore
20:54:07 <ttx> jeblair: no, it's all new
20:54:21 <joshuamckenty> mikal: no, 0%
20:54:23 <mikal> We should then _exclude_ bits we think are ok for vendors to hack on
20:54:25 <joshuamckenty> well, unknown
20:54:30 <mikal> joshuamckenty: I get that's what you're saying
20:54:32 <dhellmann> jeblair: yeah, I'd like to have a clearer understanding of the form this recommendation should take
20:54:35 <mikal> joshuamckenty: I'm disagreeing with you
20:54:41 <jeblair> joshuamckenty: is there something, somewhere i can read about what you're asking us to do other than what you've said in this meeting?
20:54:41 <joshuamckenty> okay, I'm not defending a position
20:54:43 <zehicle_at_dell> we're confusing the project using the mark and a commercial business using the mark
20:54:44 <joshuamckenty> just asking for one
20:54:45 <dhellmann> because mikal's statement seems like the right sort of level of detail
20:54:51 <joshuamckenty> jeblair: there's the link I posted earlier
20:54:57 <joshuamckenty> https://wiki.openstack.org/wiki/Governance/CoreDefinition
20:55:00 <zehicle_at_dell> but they are related topics
20:55:13 <mikal> joshuamckenty: we should be defining areas for vendors to compete in
20:55:24 <joshuamckenty> YES! That's the point of the designated sections
20:55:33 <joshuamckenty> some projects will be 100% competitive, some may be 0%
20:55:43 <mikal> joshuamckenty: yes, but the default should be to say no to vendor patches
20:55:49 <joshuamckenty> 0% is likely not good for the users, 100% is bad for the developers
20:55:51 <mikal> joshuamckenty: and then designate sandboxes they can play with
20:56:03 <sparkycollier> Defcore is about the commercial use AFAIK as stated in teh first sentence of the wiki "The following list represents the "guiding principles" used by the Foundation Board to determine how commercial implementations of OpenStack can be granted use of the trademark"
20:56:04 <mikal> 10)% is great for developers who understand open source
20:56:04 <joshuamckenty> 0% makes interop very hard
20:56:09 <mikal> 100% even
20:56:21 <mikal> And I'm not sure I care about vendors who want to ship crazy private drivers
20:56:26 <lifeless> mikal: what about e.g. keystone
20:56:33 <lifeless> mikal: which started as a replacement project
20:56:36 <joshuamckenty> sparkycollier: which is why "projects and programs" isn't directly in DefCore's purview
20:56:38 <mikal> If the driver isn't good enough to land in our git repos, why should we encourage it?
20:56:41 <joshuamckenty> but it *is* problematic
20:56:50 <joshuamckenty> mikal: ask Rackspace
20:57:06 <ttx> OK. We'll continue that discussion on openstack-dev
20:57:07 <mikal> joshuamckenty: pardon?
20:57:13 <joshuamckenty> Rackspace would lose the use of the mark depending on how the designated sections code goes
20:57:16 <dhellmann> mikal: I think what joshuamckenty means is that even if the code is in our repo, it may not be required to be used at runtime
20:57:31 <vishy> mikal: -1
20:57:32 <joshuamckenty> because they don't run many openstack things
20:57:44 <ttx> #action ttx to raise thread on defining critical sections in projects, TC vs. PTL
20:57:44 <joshuamckenty> that was true for HP up until relatively recently
20:57:53 <joshuamckenty> and still true today for Dreamhost cloud b/c of the ceph usage
20:58:05 <mikal> Sure, and this is what we're trying to fix
20:58:11 <joshuamckenty> ditto for, I believe, almost every vendor
20:58:12 <ttx> #action zehicle to raise thread with unaddressed concerns about programs, if any
20:58:14 <mikal> So let's not build a system which perpetuates the fail
20:58:16 <joshuamckenty> Nebula and Piston, certainly
20:58:30 <joshuamckenty> mikal: be very careful how you define "fail"
20:58:33 <joshuamckenty> fail for devs, or for users?
20:58:38 <joshuamckenty> or for vendors?
20:58:38 <markwash> so we want to make a mark that no one uses?
20:58:43 <ttx> mikal: we need to wrap up. Josh asked for a position, we'll define it
20:58:48 <joshuamckenty> thanks
20:58:49 <annegentle> ttx: did you have an action to edit the OpenStack Program wiki page?
20:58:53 <mikal> joshuamckenty: for users and devs. I thought the goal here was to encourage interop?
20:58:59 <ttx> annegentle: I multiplexed and did it
20:59:03 <annegentle> ttx: nice
20:59:13 <joshuamckenty> mikal: but not at the total expense of the commercial ecosystem
20:59:17 <joshuamckenty> ttx: and https://wiki.openstack.org/wiki/Documentation/Conventions#Service_and_project_names ?
20:59:22 * vishy looks forward to the ml discussion on point #2
20:59:24 <annegentle> #action annegentle to edit https://wiki.openstack.org/wiki/Documentation/Conventions#Service_and_project_names
20:59:24 <ttx> Looks like Barbican will be considered next week
20:59:34 <joshuamckenty> thanks everyone for the time
20:59:44 <vishy> thanks for jumping in joshuamckenty zehicle_at_dell
20:59:46 <ttx> joshuamckenty: you're welcome
20:59:55 * zehicle_at_dell thanks everyone!  until next time
21:00:02 <lifeless> ciao
21:00:04 <ttx> #topic Minor governance changes
21:00:12 <ttx> Add a requirement for deprecating duplicated code (https://review.openstack.org/#/c/70389/)
21:00:39 <ttx> I think that one needs a few more iterations on Gerrit
21:01:04 <ttx> I'll approve it once it reaches the approval threshold though, so vote -1 if you want to block it
21:01:20 <ttx> and... no time for open discussion
21:01:38 <ttx> #endmeeting