17:00:05 <gema> #startmeeting tailgate
17:00:09 <openstack> Meeting started Thu Oct  1 17:00:05 2015 UTC and is due to finish in 60 minutes.  The chair is gema. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:13 <openstack> The meeting name has been set to 'tailgate'
17:00:18 <gema> #topic rollcall
17:00:29 <gema> anyone around?
17:01:01 <spyderdyne> tailgate
17:01:07 <jasonsb_> hi
17:01:15 <spyderdyne> :)
17:01:21 <gema> hi y'all :D
17:01:33 <gema> let's give a few mins in case someone else joins
17:01:45 <gema> unless you are in a hurry?
17:01:54 <spyderdyne> no hurry
17:02:04 <spyderdyne> i'm hourly
17:02:05 <spyderdyne> :)
17:02:20 <gema> lol
17:02:22 <jasonsb_> i'm hourly too
17:02:23 <jasonsb_> work one hour
17:02:26 <jasonsb_> take rest day off
17:02:29 <gema> haha
17:02:39 <jasonsb_> opps, thats logged
17:02:47 <gema> jasonsb_: we all took it as joke
17:02:47 <jasonsb_> now they know
17:02:51 <gema> :P
17:03:26 <gema> jose-idar: around?
17:04:20 <gema> ok, we are going to get going
17:04:27 <gema> #topic Last week's actions
17:04:37 <gema> jasonb to figure out the mechanics of getting endpoints and gurumeditationreport and maybe create a simple script that does this
17:04:43 <gema> jasonsb_: did you get to it this week?
17:04:46 <jasonsb_> nope
17:04:56 <gema> #action jasonb to figure out the mechanics of getting endpoints and gurumeditationreport and maybe create a simple script that does this
17:05:09 <gema> ok, I am going to carry over malini and jose-idar's
17:05:20 <gema> #ACTION malini to try to write a test with tempest-lib that spins a VM and destroys is, as a POC
17:05:23 <gema> #ACTION jose-idar to start a spec for component tests for nova (user side, no admin), so we can all contribute cases and maybe implement them at some point , but at least start to get organised
17:05:42 <gema> and three mine that are not directly related to tokyo
17:05:46 <gema> #ACTION gema to continue with the strategy doc
17:05:46 <gema> #ACTION gema to write a blog post about refstack-client running
17:05:46 <gema> #ACTION gema to send out the defcore details on actionable gaps
17:05:58 <gema> #topic ODS Talk
17:06:08 <gema> #link https://etherpad.openstack.org/p/tailgaters-tokyo-summit-talk
17:06:34 <gema> jasonsb_: I see you've added some stuff
17:06:39 <jasonsb_> i have
17:06:51 <jasonsb_> still working out what I can add to the conversation
17:06:55 <gema> ok
17:07:02 <gema> I think talking in person will help
17:07:15 <gema> as long as we have a few slides that we can use in the event they call us suddenly
17:07:24 <gema> I haven't added our part
17:07:28 <gema> spyderdyne: ?
17:07:36 <jasonsb_> do you have a google doc for your piece?
17:07:43 <gema> nope, not either
17:07:43 <jasonsb_> i think you had mentioned goog doc
17:07:47 <jasonsb_> ok np
17:07:49 <spyderdyne> yes?
17:07:52 <spyderdyne> sry
17:07:54 <gema> I wanted to create a google doc presentation
17:08:06 <gema> spyderdyne: you still need to add content to the presentation, right?
17:08:44 <spyderdyne> i can add some stuff
17:08:52 <spyderdyne> it looks like i wont be able to attend now
17:08:57 <spyderdyne> but i am here for support
17:09:00 <spyderdyne> whatever you need
17:09:29 <gema> ok, so you are in teh same situation as clee
17:09:34 <jasonsb_> you can't go?
17:09:35 <jasonsb_> :(
17:09:36 <spyderdyne> i am
17:09:38 <gema> I spoke to him and he won't be in tokyo
17:09:47 <spyderdyne> i thought i was going but they told me no at the last minute
17:09:50 <gema> I wonder what happens in these cases
17:10:08 <spyderdyne> if i can provide any assistance i will be happy to
17:10:08 <gema> spyderdyne: I am still expecting someone to tell me not to go x)
17:10:13 <spyderdyne> but i wont be on site to present
17:10:14 <gema> spyderdyne: I mean it can happen
17:10:37 <jasonsb_> i was looking forward to strategizing in person
17:10:50 <spyderdyne> yeah, it would be much better
17:10:57 <gema> spyderdyne: will you be in the next one?
17:10:58 <spyderdyne> we could still run a webex tho
17:11:01 <gema> I think it is austin
17:11:03 <spyderdyne> i will be at the next one
17:11:13 <gema> coolio, I don't know about that one yet, we'll see
17:11:28 <gema> anyway, I think we need to decide what to do bearing in mind two of our speakers won't be present
17:11:38 <gema> spyderdyne: have you informed the openstack people?
17:12:58 <gema> as in , telling them you won't be tehre in response to their email
17:13:06 <gema> asking for phone number and stuff
17:15:10 <spyderdyne> i havent registered, is that adequate?
17:15:26 <spyderdyne> i can respond if you think i should
17:15:33 <gema> if you didn't answer to the email they sent stating that they wanted you to confirm assistance, I guess you are good
17:15:48 <gema> but I think we should ask them , if we are two speakers down, can we still be called?
17:16:23 <spyderdyne> im sure you can be called until you tell them you cant present
17:16:44 <gema> ok
17:16:48 <spyderdyne> i wish we knew how many alternates were called last summit
17:17:15 <gema> indeed
17:17:18 <gema> jasonsb_: thoughts?
17:17:51 <gema> ok, in any case, I would like that you and clee give us input in the overall presentation and also in the common areas
17:18:21 <gema> so that we are all in sync in the message
17:18:45 <jasonsb_> opps
17:18:48 <jasonsb_> snoozing
17:19:15 <jasonsb_> we can reach out to the contacts
17:19:21 <jasonsb_> and get their guidance
17:19:34 <jasonsb_> if we have quorum we are fine
17:19:37 <gema> coolio
17:19:42 <jasonsb_> but i'm not sure if we have?
17:19:54 <gema> what is quorum, agreement?
17:20:01 <jasonsb_> enough speakers
17:20:02 <gema> soo far we have 3 out of however many we were
17:20:07 <jasonsb_> or speaker proxies
17:20:07 <gema> speakers more
17:20:09 <gema> 5
17:20:38 <gema> yeah, if someone from cisco and dreamhost were there to represent you two in case we have to present, that'd be also an option
17:20:42 <jasonsb_> if one of us can give sppyderdynes piece then maybe its fine?
17:20:47 <gema> or that
17:20:56 <spyderdyne> sure
17:21:01 <jasonsb_> somebody from cisco/dreamhost is better
17:21:33 <gema> jasonsb_: even better, we could all present each other's stuff
17:21:42 <gema> that means we have understood what the others are doing
17:21:48 <gema> and we can talk about each other's work
17:21:54 <gema> but that'll require a bit more preparation
17:22:09 <spyderdyne> im asking around to see if i can find a proxy
17:22:29 <gema> spyderdyne: ok, you can let us know, I will ask clee for the same
17:22:36 <gema> and see if we get a proxy for each
17:23:12 <gema> the rest of actions we had were about the presentation
17:23:19 <jasonsb_> did spyderdyne get a repo?
17:24:31 <gema> no idea
17:24:36 <gema> we can talk about his project now
17:24:52 <gema> let me summarize what is left of the actions for the presentation
17:25:04 <spyderdyne> i just added some stuff
17:25:16 <gema> #action gema to talk to clee and see if he can get someone from dreamhost present in tokyo in case we have to present
17:25:18 <spyderdyne> i didnt get a repo
17:25:27 <spyderdyne> just have a web server for now
17:25:33 <spyderdyne> still working on it
17:25:50 <gema> #action all, to continue working on the presentation
17:25:53 <spyderdyne> #Cisco Systems- Openstack Mythos Project (Scale Testing)  - Odin (Rally Wrapper)  - Medusa (Instance and Network Testing)  - Janus (Cleanup Scripting)  - Mania (Sanity Testing)
17:26:35 <gema> spyderdyne: you said you wanted to share something or show us something
17:26:38 <gema> right?
17:26:50 <spyderdyne> i need to complete my docs
17:26:52 <gema> do you want us to have a webex or a hangout next week?
17:27:03 <gema> and we can talk about the talk and about your project
17:27:06 <spyderdyne> then i can work with whoever is able to present
17:27:14 <gema> spyderdyne: ok
17:27:21 <spyderdyne> will try to find someone from my org, if not can work with one of you
17:27:24 <jasonsb_> i think we should make a stackforge
17:27:31 <gema> jasonsb_: what's wrong with github?
17:27:34 <jasonsb_> because spyerdyne
17:27:36 <spyderdyne> i could work with a stackforge
17:27:42 <spyderdyne> or git
17:27:47 <spyderdyne> git preferred
17:28:01 <spyderdyne> lots of folks are abandoning stackforge
17:28:06 <gema> yep, if you put it on github we can always move it to the official project when we have it
17:28:07 <jasonsb_> or straight to openstack
17:28:12 <jasonsb_> ok sure
17:28:13 <gema> jasonsb_: can we commit to openstack?
17:28:21 <spyderdyne> rackspace moved to ansible, at&t is just using chef to bootstrap puppet/mirantis now
17:28:21 <jasonsb_> i think straight to openstack then
17:29:02 <spyderdyne> can someone figure out how to get a space for me?
17:29:13 <gema> a space for you where?
17:29:16 <gema> openstack?
17:29:18 <jasonsb_> i think make a launchpad
17:29:20 <spyderdyne> wherever
17:29:25 <jasonsb_> #link http://docs.openstack.org/infra/manual/creators.html
17:29:26 <jasonsb_> old though
17:29:29 <spyderdyne> launchpad is fine
17:29:36 <spyderdyne> to get started
17:29:38 <gema> then put it in launchpad
17:29:43 <gema> I can make us a team
17:29:44 <spyderdyne> we just need some place to put stuff
17:29:48 <spyderdyne> ok
17:29:57 <jasonsb_> Note: All projects should use the openstack/ namespace regardless of whether they are or intend to become official OpenStack projects.
17:30:04 <jasonsb_> sounds pretty inclusive
17:30:20 <spyderdyne> how do we get a spot in there?
17:30:43 <gema> https://launchpad.net/~openstack-tailgate
17:30:52 <gema> so, gimme a few lp ids
17:30:57 <gema> and I will add you
17:31:13 <gema> we can then create projects and make this team the maintainer
17:31:19 <gema> or just have a few branches on the team itself
17:31:37 <gema> spyderdyne: do you have a launchpad id?
17:31:50 <spyderdyne> i do
17:31:59 <spyderdyne> pretty sure its spyderdyne
17:32:01 <spyderdyne> verifying
17:32:02 <jasonsb_> https://launchpad.net/~jason-bishop
17:32:27 <spyderdyne> https://launchpad.net/~spyderdyne
17:32:35 <gema> ok, I added you
17:32:39 <gema> I have left it open
17:32:43 <gema> so anyone can join, I think
17:32:52 <spyderdyne> good deal
17:32:58 <gema> if it gets out of hand, we can always moderate it
17:33:01 <gema> I will make you two admins
17:33:05 <gema> because I can xD
17:33:13 <spyderdyne> i see the memebership
17:33:37 <gema> that way we share admin tasks if there is ever any
17:33:48 * beisner sneaks in and joins lp
17:33:49 <beisner> o/
17:33:54 <gema> beisner: !
17:34:00 <jasonsb_> wheee
17:34:03 <beisner> ./!\
17:34:09 <beisner> who is this  guy
17:34:11 <spyderdyne> I'm a real boy now!
17:34:13 <spyderdyne> lol
17:34:16 <gema> x)
17:34:40 <jasonsb_> spyderdyne, if you up for it, if we could post your code in repo
17:34:46 <jasonsb_> i think that would be really nice
17:35:08 <spyderdyne> will do
17:35:18 <gema> spyderdyne: excellent, thanks
17:35:28 <spyderdyne> i have lots of making things friendly to do now :)
17:35:48 <gema> #action everyone to join the launchpad team that we created to host code: https://launchpad.net/~openstack-tailgate
17:35:55 <gema> #link https://launchpad.net/~openstack-tailgate
17:35:57 <spyderdyne> and maybe 20 copies of the apache license to paste
17:36:32 <gema> ok, so what do we do next week
17:36:38 <gema> irc meeting or video?
17:36:57 <spyderdyne> lets webex
17:37:04 <spyderdyne> or gchat
17:37:08 <gema> spyderdyne: ok
17:37:18 <gema> spyderdyne: I will send a link to a hangout to the mailing
17:37:21 <spyderdyne> ok
17:37:26 <gema> I doubt we'll reach critical mass anyway
17:37:39 <spyderdyne> probably not
17:38:01 <gema> #link https://plus.google.com/hangouts/_/canonical.com/openstack-tailgate
17:38:06 <gema> there you go, our meeting room
17:38:08 <gema> :)
17:38:53 <gema> oh, maybe I will need to create a public one
17:38:57 <gema> nevermind, will do that
17:39:10 <gema> #action gema to create a public hangout for next week's meeting
17:39:48 <jasonsb> gema before i forget,  when do you arrive?
17:40:01 <gema> jasonsb: monday morning
17:40:24 <jasonsb> nice
17:40:28 <gema> you?
17:40:44 <jasonsb> 3pm
17:41:00 <gema> yeah, I will probably be shopping by that time
17:41:03 <gema> I arrive at 9:30
17:41:05 <gema> am
17:41:55 <beisner> i think i arrive sun mid-afternoon
17:42:07 <gema> beisner: well done
17:42:14 <gema> you'll have time to see stuff :)
17:42:45 <jasonsb> wish i was going to be there earlier now
17:42:51 <jasonsb> i'll be there all fri tho
17:42:59 <gema> yep, me too
17:43:05 <gema> but we'll have work to do on friday
17:43:07 <gema> I hope :D
17:43:34 <jasonsb> there is also defcore
17:43:45 <gema> yes
17:43:53 <gema> jasonsb: did you make it to their meeting yesterday?
17:43:59 <jasonsb> sorry, didn't mean to hijack your convo
17:44:09 <jasonsb> i was there
17:44:16 <jasonsb> but only last half
17:44:21 <gema> #topic defcore
17:44:28 <gema> ok, and what did you get from it?
17:44:59 <jasonsb> generally the state of the api's
17:45:21 <jasonsb> even glance v1 vs v2 is a problem
17:45:27 <jasonsb> there is alot of work to do
17:45:56 <jasonsb> i think rally is still on v1
17:46:42 <gema> yeah, there are compatiblity conversations ongoing, but that is good
17:46:48 <jasonsb> this is good
17:46:55 <gema> people have to have a good reason to move to a newer api
17:46:57 <jasonsb> but for interop, there is a long way to go
17:47:03 <gema> jasonsb: yes
17:47:04 <jasonsb> (this is fine)
17:47:48 <gema> yes
17:47:53 <gema> ok, fair enough
17:48:04 <gema> is there anything else you want to discuss?
17:48:11 <jasonsb> i don't have whole defcore convo in my head yet
17:48:15 <jasonsb> still picking up
17:48:19 <gema> jasonsb: it takes time
17:48:36 <gema> plus, I don't think any single person except for Chris maybe, has it
17:49:04 <gema> ok, calling it a day then
17:49:12 <gema> #endmeeting