17:00:15 <gema> #startmeeting tailgate
17:00:16 <openstack> Meeting started Thu Aug 13 17:00:15 2015 UTC and is due to finish in 60 minutes.  The chair is gema. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:20 <openstack> The meeting name has been set to 'tailgate'
17:00:25 <gema> #topic rollcall
17:00:47 <gema> o/
17:04:17 <malini> o.
17:04:20 <malini> o/
17:04:24 <gema> malini: \o/
17:04:32 <gema> malini: I thought I was going to have to cancel :D
17:04:38 <malini> heyy gema :)
17:05:04 <gema> how was your week?
17:05:14 <malini> it was good :)
17:05:22 <malini> house back in shape now?
17:05:32 <gema> nope, they delayed till next week
17:05:38 <malini> :/
17:05:39 <gema> they confirmed they are starting monday :D
17:05:48 <malini> hope you are not living in a tent
17:05:54 <gema> nah, it's not that bad
17:05:57 <gema> next week maybe ;)
17:06:02 <malini> :)
17:06:17 <gema> jose-idar: you around?
17:06:39 <gema> alright, let's get started then
17:06:45 <gema> and review our stuff
17:06:58 <gema> #topic Last week's actions
17:07:09 <gema> we'll carry over all the non present people actions to next week
17:07:24 <malini> you'll have to carry over the present one as well :/
17:07:40 <gema> #action spyderdyne to give more updates on HA testing
17:07:44 <gema> ok, don't worry :)
17:07:56 <gema> #action jasonb to initiate the review of the questionaire on the ML and handle review comments, review due to end early Sept (in case people are on holidays)
17:08:11 <gema> #action jasonb to figure out the mechanics of getting endpoints and gurumeditationreport and maybe create a simple script that does this
17:08:21 <gema> #action malini to try to write a test with tempest-lib that spins a VM and destroys is, as a POC
17:08:32 <gema> #action jose-idar to start a spec for component tests for nova (user side, no admin), so we can all contribute cases and maybe implement them at some point , but at least start to get organised
17:08:33 <malini> I havent started on tht yet..
17:08:40 <malini> hope to get to that by next week
17:08:45 <gema> alright, sounds good
17:09:00 <gema> #action gema to continue with the strategy doc
17:09:05 <gema> this one keeps going too
17:09:19 <gema> #action gema to check what parts of keystone are accesible without admin on ubuntu's distro
17:09:22 <gema> so does this one
17:09:43 * gema gema to talk to matthew about stable tempest kilo and report back
17:09:56 <gema> I have decided this one is not necessary anymore, after having a go at refstack tests
17:10:05 <malini> cool..one less :)
17:10:14 <gema> they are aiming at having a set of tests that can be run on the different releases
17:10:17 <gema> in a stable manner
17:10:36 * gema gema to submit a few test runs of refstack and get familiar with it
17:10:56 <gema> I did this one yesterday, did set up a cloud and configured it for tempest, came up with a tempest.conf
17:11:07 <gema> and used refstack-client to run a bunch of tests
17:11:15 <malini> did you set up a real cloud or devstack?
17:11:30 <gema> a real cloud, but virtualised
17:11:41 <gema> we stand up test clouds on a cloud we have for testing
17:11:43 <malini> tht is reallly eneat!
17:11:47 <malini> neat
17:11:51 <gema> it's openstack on openstack but with juju
17:12:08 <gema> and I run the tests on the overcloud
17:12:13 <gema> undercloud is kilo
17:12:17 <gema> overcloud was icehouse
17:12:25 <gema> it went well, I managed to get it to run and pass most of the tests, except for some exceptions that were listed on the "flagged tests" list
17:12:29 <malini> tht is really cool
17:12:36 <malini> how hard was it?
17:12:42 <gema> it took me a couple of hours
17:12:49 <malini> tht is not at all bad
17:12:51 <gema> to figure out what I was doing wrong with refstack client
17:12:51 <jasonsb> thats not bad
17:12:58 <gema> running the tests was 10 mins
17:12:58 <malini> jasonsb: o/
17:13:07 <gema> jasonsb: o/
17:13:17 <jasonsb> :)
17:13:24 <gema> however you need a working tempest.conf file for the cloud under test and the basic initial set up (default users, networks, images available), having that ready, running with refstack-client is very easy (just follow README instructions).
17:14:09 <gema> we can talk more about refstack now or later on a separate topic
17:14:12 <gema> whatever you guys prefer
17:14:14 <malini> do they have the tests in https://github.com/stackforge/refstack as well?
17:14:25 <malini> or is it pulled from tempest repo?
17:14:38 <gema> malini: no, the tests are from the tempest repo, however they have lists that have to use to run
17:14:48 <malini> sorry..I am hijacking
17:15:18 <gema> #link https://github.com/openstack/defcore
17:15:25 <gema> if you look at the folder 2015.05
17:15:28 <gema> I run that one
17:15:39 <gema> once you get your failures you look at the flagged list
17:15:51 <malini> the names somehow remind me of perf evals :/
17:16:03 <gema> maybe
17:16:26 <gema> I can prepare a blog post about how I did the run
17:16:30 <gema> if you guys think that may be useful
17:16:36 <jasonsb> +1
17:16:38 <gema> I have a new blog to talk about what we are doing ready to go :)
17:16:41 <malini> tht will be cool
17:16:56 <gema> #action gema to write a blog post about refstack-client running experience
17:17:03 <malini> I was just getting irritated abt the lack of good test blogs :D
17:17:12 <gema> mine is empty for now
17:17:19 <malini> not tht I am inclined to do anything abt it ;)
17:17:23 <gema> never felt inspired to write and when I did, I kept taking it down xD
17:17:41 <gema> #link http://www.thetestingcorner.com/
17:17:43 <jasonsb> a blog is a nice dipping-the-toe in
17:17:46 <gema> coming soon ^ ;)
17:17:47 <jasonsb> i'll do one too
17:17:57 <gema> yeah, and we can link each others
17:17:58 <spyderdyne> hola
17:18:02 <gema> spyderdyne: hello
17:18:22 <spyderdyne> i alologize for dropping off the face of the earth
17:18:26 <jasonsb> i think i'll do one on network testing ala spyderdyne
17:18:37 <malini> spyderdyne: no worries..rockets do tht to you
17:18:38 <gema> spyderdyne: don't worry
17:18:42 <spyderdyne> lol
17:19:17 <spyderdyne> i have somethign cool i have been working on if anyone is interested
17:19:23 <gema> spyderdyne: go for it
17:19:30 <spyderdyne> Odin, a bash loader for Rally test plans
17:19:41 <gema> a tool?
17:19:47 <spyderdyne> just some scripting
17:19:56 <spyderdyne> pretty useful though
17:20:03 <gema> share the link
17:20:05 <spyderdyne> i will write it up and share a link
17:20:25 <gema> #action spyderdyne to write up and share link about Odin, the bash loader for rally test plans
17:20:29 <malini> Rally test plans == json templates they use?
17:20:41 <spyderdyne> accepted
17:20:52 <spyderdyne> all my plans are json
17:21:01 <spyderdyne> easy to convert though
17:21:09 <gema> spyderdyne: do you have a blog?
17:21:16 <spyderdyne> i do
17:21:18 <malini> gema is all bloggy today :)
17:21:22 <gema> malini: lol, yep
17:21:26 <spyderdyne> spyderdyne.com
17:21:32 <spyderdyne> i dont use it much tho
17:21:43 <spyderdyne> i can write it up on there and share if you like
17:21:49 <gema> that'd be nice
17:21:53 <spyderdyne> ok
17:21:55 <gema> #link http://spyderdyne.com/
17:21:57 <spyderdyne> will let you know
17:22:05 <gema> thanks, send an email to the mailing or so
17:22:27 <gema> ok, where were we
17:22:36 <gema> spyderdyne: wanna talk about HA, whilst at it?
17:22:53 <spyderdyne> our ha testing has failed to launch
17:23:15 <gema> ok, we keep the action to talk about it in the future, then?
17:23:22 <spyderdyne> we have some issues with the test plans
17:23:37 <gema> can we help with that?
17:23:41 <spyderdyne> go ahead and drop the action and I will provide it when its available.
17:23:51 <gema> ok, will drop it next week
17:23:54 <spyderdyne> it turned out not to be as easy as we thought it would be though
17:23:58 <gema> I have already added it to this week's
17:23:58 <spyderdyne> thanks
17:24:07 <gema> spyderdyne: HA is never easy
17:24:19 <spyderdyne> HA, ha, hah!
17:24:21 <gema> spyderdyne: however, we have a way to deploy HA in one go with juju that it may be useful for you
17:24:24 <jasonsb> you can keep the topic i think
17:24:28 <jasonsb> i'm working on it too
17:24:39 <jasonsb> so we should visit it soemtime
17:24:42 <gema> with the new version of juju that has leader election and the new charms, you can deploy openstack HA unattended
17:24:48 <spyderdyne> would that we were using juju
17:24:52 <spyderdyne> ;)
17:25:00 <jasonsb> juju is nice
17:25:23 <gema> :)
17:25:25 <gema> ok
17:25:54 <spyderdyne> we moved to RHEL for bug fix support so we are in the middle of a jump between operating systems and have our hands full at the moment
17:25:58 <gema> I don't remember what actions I haven't covered x)
17:26:21 <gema> spyderdyne: ah, ok
17:26:26 <gema> fair enough
17:26:34 <gema> #action gema to send out the defcore details on actionable gaps
17:26:45 <gema> I am still working on understanding the scope for this one
17:26:55 <gema> I attended their meeting yesterday but I have that as a topic
17:27:32 <gema> and reading the previous week's meeting and check whether glance required admin are both done
17:27:42 <gema> I think that's it for actions
17:27:47 <gema> unless I am forgetting something?
17:28:15 <gema> alright, moving on
17:28:21 <gema> #topic defcore
17:28:30 <gema> Mid cycle feedback:
17:28:38 <gema> #link http://superuser.openstack.org/articles/openstack-continues-to-strenghten-its-commitment-to-interoperability
17:28:46 <gema> #link http://robhirschfeld.com/2015/08/11/defcore-update-slowly-taming-the-interop-hydra/
17:28:54 <gema> Yesterday's meeting:
17:29:01 <gema> #link http://eavesdrop.openstack.org/meetings/defcore/2015/defcore.2015-08-12-14.59.html
17:29:10 <gema> The meeting was good, they are working on more capabilities.
17:29:35 <gema> tbh I am not very clear on what constitutes a capability , I stilll have to read further about it, but they seem to be api calls (don't quote me on this though)
17:29:49 <gema> I found the fact that they are entertaining the idea of vendors providing details of the cloud they are running interesting and somewhat concerning:
17:29:57 <gema> #link https://review.openstack.org/#/c/207209/6/doc/source/process/2015B.rst
17:30:45 <gema> if you guys are interested, there was a lively discussion in yesterday's meeting about this
17:30:48 <gema> you can read it
17:31:14 <jasonsb> i tried to join
17:31:16 <gema> I sent my results this morning to their interop meeting and got an email back saying my support request would be dealt with
17:31:23 <jasonsb> but couldn't figure out when
17:31:32 <gema> jasonsb: ok, I can ping you next week if you want
17:31:36 <jasonsb> please
17:31:41 <gema> ok
17:31:45 <jasonsb> i haz tiny brain
17:31:48 <gema> lol
17:32:01 <gema> that's all I have on defcore
17:32:04 <gema> questions?
17:32:41 <gema> ok, moving on
17:32:45 <gema> #topic AOB
17:32:52 <gema> (any other business?)
17:33:10 <gema> oh, jasonsb , I forgot
17:33:19 <gema> did you get my email with the thoughts on the review?
17:33:22 <gema> and the links and all?
17:33:34 <gema> I sent it to your gmail account, I believe
17:33:50 <gema> (questionaire review)
17:33:56 <jasonsb> opps!
17:34:01 <jasonsb> i missed it i'm sorry
17:34:05 <jasonsb> looking now
17:34:15 <gema> if you don't have it I can send it again
17:34:20 <gema> maybe I ended up in the spam folder
17:34:43 <jasonsb> i have it i'm just lame and missed it
17:34:48 <gema> jasonsb: lol, ok
17:34:58 <gema> jasonsb: do you still want to keep that action?
17:34:58 <jasonsb> very nice
17:35:02 <jasonsb> yes
17:35:05 <gema> cool
17:35:23 <gema> the other question I had, do you guys think the weekly meetings are good or do you want to fall back to every two weeks?
17:35:58 <gema> or shall we alternate times on consecutive weeks?
17:35:58 <jasonsb> i'm fine as-is
17:36:20 <gema> ok
17:36:28 <malini> me too
17:36:30 <gema> me too, but wanted to hear if someone wanted to go back
17:36:38 <gema> there is a lot of people that don't show up
17:36:44 <gema> shall we ask on the mailing the reason?
17:36:49 <gema> if this is a conflict time for them
17:36:51 <gema> or so?
17:36:55 <malini> maybe the interest is waning?
17:37:14 <gema> maybe
17:37:20 <gema> I still think it's worth it
17:37:22 <jose-idar> sry, just got here.
17:37:30 <gema> jose-idar: welcome sir
17:37:44 <gema> malini: see? jose-idar clearly had a conflict :D
17:37:53 <jose-idar> indeed!
17:38:12 <gema> jose-idar: did you have a chance to start your spec?
17:38:31 <jose-idar> so, just an update, I'm talking with daryl walleck.  He's working with defcore to clarify what it is the tempest tests actually do
17:38:54 <jose-idar> I'd like to piggyback on that work, and make the request something along the lines of:
17:38:57 <gema> jose-idar: what do you mean what they do?
17:39:22 <jose-idar> making the steps tests actually take explicit
17:39:56 <jose-idar> Right now defcore is driven by what the tests actually do, which is bad since what they do and what they are assumed to be doing sometimes doesn't match.
17:40:09 <gema> yep
17:40:20 <gema> but I thought what they are doing is identifying capabilities
17:40:24 <gema> and then choosing tests
17:40:29 <jose-idar> So, I think I want the spec to read something like "Decide what steps define feature X, and make a test that actually does that"
17:40:29 <gema> to validate those capabilities
17:41:08 <jose-idar> which is fine, but no one has really gone through and audited the tests from top to bottom
17:41:21 <gema> I have done a few
17:41:35 <gema> they were poor :)
17:41:38 <jose-idar> a big one is whether or not authenticating is a 'necessary step' for doing something like creating a server.
17:41:39 <gema> as in, simple
17:41:44 <jose-idar> yeah
17:42:26 <jose-idar> So, i'm still writing that, with all that stuff in mind.
17:42:35 <gema> jose-idar: ok, sounds great
17:42:39 <jose-idar> i've had precious little time to work on it, should be better this week
17:42:41 <gema> so what do you want me to call the action?
17:42:49 <jose-idar> I gues leave it the same?
17:42:54 <gema> ok, done :D
17:43:03 <gema> jose-idar: where are you writing that?
17:43:08 <gema> in a doc locally?
17:43:16 <gema> I am wondering if we shouldn't start a project
17:43:40 <gema> or does what you are doing fit nicely into defcore?
17:45:28 <jose-idar> gema: good question!  I was just keeping it local.
17:45:37 <gema> I think we are going to add a topic to our meeting about how we want to contribute "stuff"
17:45:39 <jose-idar> Do ya'll have a preference?
17:46:09 <gema> we can discuss that next week, you can put it on an etherpad if you want to share it, but etherpads are not really the right place to do reviews and stuff
17:46:31 <gema> google doc is what I was using foor the test doc, but it is also not the right place
17:46:35 <jose-idar> that's fine.  I'll modify it to follow the defcore spec 'style' and put it up there.
17:46:47 <gema> jose-idar: sounds good
17:46:57 <jose-idar> coolbeans
17:47:03 <gema> if it fits nicely there and it is only about what defcore are doing, it belongs there indeed
17:47:25 <gema> #action next chair to discuss location of our contributions and whether we should create a project in github
17:47:45 <gema> malini: going back to your concern about interest fading
17:47:50 <gema> I also have it
17:48:12 <gema> but there are a few of us that keep pushing, so I think it is worth it, what do you guys think?
17:48:20 <malini> +1
17:48:24 <jasonsb> +1
17:48:29 <gema> +1
17:48:37 <jasonsb> i hope to spend more time starting now
17:48:45 <jasonsb> got behind on work stuff a little bit recently
17:48:47 <malini> Right now, even a sounding board is good :)
17:48:57 <gema> :)
17:49:02 <gema> alright, we are good then, rock solid here
17:49:06 <gema> let's keep it up
17:49:14 <jasonsb> it will come to you gema
17:49:23 <jasonsb> you'll see
17:49:28 <gema> hehe
17:49:38 <gema> so any volunteers for next week's chairing?
17:50:12 <gema> ok, I think I can do it, will let you guys know if not and we can reorganise
17:50:20 <gema> (on the mailing)
17:50:31 <jasonsb> snds fine
17:50:50 <gema> anything else in the last 10 mins?
17:51:21 <gema> ok, thank you all for coming, as usual!
17:51:28 <gema> #endmeeting