17:01:15 <malini2> #startmeeting tailgate
17:01:16 <openstack> Meeting started Thu Jul 16 17:01:15 2015 UTC and is due to finish in 60 minutes.  The chair is malini2. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:19 <openstack> The meeting name has been set to 'tailgate'
17:01:24 <malini2> #topic rollcall
17:01:28 <malini2> so who is around?
17:01:29 <clee> o/
17:01:30 <malini2> o/
17:01:36 <jasonsb> me
17:01:36 <gema> 0/
17:01:47 <spyderdyne> here
17:02:06 * malini2 waits for tht last person
17:02:21 <malini2> 3…2..1…
17:02:29 <malini2> lets get started
17:02:36 <malini2> #topic Action items from last week
17:02:49 <malini2> spyderdyne composing a spec to present to rally on topic of
17:02:49 <malini2> rally cleanup
17:03:09 <malini2> spyderdyne: any updates on tht?
17:03:13 <gema> malini2: where is last week's log?
17:03:21 <malini2> good point gema
17:03:24 <malini2> #link http://eavesdrop.openstack.org/meetings/tailgate/2015/tailgate.2015-07-09-17.01.txt
17:03:37 <gema> ta!
17:04:17 <malini2> spyderdyne: want me to carry tht over to next week?
17:04:33 <spyderdyne> still wip
17:04:41 <malini2> ok..will carry tht over
17:04:45 <spyderdyne> thx
17:04:55 <malini2> #action: spyderdyne composing a spec to present to rally on topic of rally cleanup
17:05:06 <malini2> next one is..
17:05:12 <malini2> spyderdyne check back to see if any updates/info for HA testing discussion
17:05:14 <spyderdyne> on HA testing, I have a number of HA test plans and am working with another internal group to execute them over the next week or so
17:05:26 <spyderdyne> we have started work on it
17:05:38 <malini2> cool..anything we can help you guys with?
17:05:41 <spyderdyne> will definitely have results/feedback next weke
17:05:48 <jasonsb> oh neat
17:05:56 <spyderdyne> i have also starte don the google survey form
17:06:05 <spyderdyne> will send links out in a few minutes
17:06:09 <malini2> #action: spyderdyne to give more updates on HA testing
17:06:20 <spyderdyne> roger roger
17:06:30 <jasonsb> spyderdyne: i would be happy to test drive if you want
17:06:33 <malini2> next one…
17:06:38 <malini2> gema to submit a few test runs of refstack and get familiar with it
17:06:55 <gema> malini2: haven't made progress in any of the two I have
17:06:55 <malini2> the friendly folks here gave u some work while you were away gema ;)
17:07:05 <malini2> will carry tht over
17:07:07 <gema> malini2: nah, it's carried over froom the previous :D
17:07:20 <malini2> #action gema to submit a few test runs of refstack and get familiar with it
17:07:31 <malini2> #action gema to talk to matthew about stable tempest kilo and report back
17:07:35 <gema> malini2: thanks
17:07:52 <spyderdyne> jasonsb: feel free to take it. i will give you what I have so far
17:08:13 <gema> test drive what, I am a bit lost
17:08:16 <jasonsb> spyderdyne: snds gd
17:08:23 <malini2> #action spyderdyne, jasonsb to send out the google survey link on per project testing strategies
17:08:25 <jasonsb> gema: test drive the goog form
17:08:31 <gema> jasonsb: ahh, ok
17:08:47 * malini2 malini open topic of actioning tailgate members to circulate test strategy goog doc within respective company
17:08:56 <malini2> will carry tht over till we have the survey
17:09:07 <malini2> tht's all we had
17:09:21 <malini2> on a positive note - we did submit our talks - yayyyy
17:09:22 <jasonsb> there are two that we didn't get to
17:09:37 <jasonsb> clee to ping about the redhat tempest.conf
17:09:49 <clee> jasonsb: I actually got a reply from dkranz and linked it here :)
17:09:51 <jasonsb> and the config mining part of the inspector
17:09:54 <spyderdyne> https://docs.google.com/forms/d/1fbY5MpMgnQmYT1l2KSjfUkKFqO_xnvgWWeTW4tt93ro/viewform?usp=send_form
17:10:01 <jasonsb> clee: indeed :)
17:10:08 <clee> I've been looking into it a little bit but haven't had more than an hour or so to dedicate to it yet
17:10:12 <jasonsb> clee: give a link for the bot to save?
17:10:20 <malini2> #link https://docs.google.com/forms/d/1fbY5MpMgnQmYT1l2KSjfUkKFqO_xnvgWWeTW4tt93ro/viewform
17:10:41 <clee> https://github.com/redhat-openstack/tempest/blob/kilo/tools/config_tempest.py
17:10:52 <clee> along with an unmerged patch he linked: https://review.openstack.org/#/c/133245/
17:10:56 <gema> #link https://github.com/redhat-openstack/tempest/blob/kilo/tools/config_tempest.py
17:11:08 <gema> #link https://review.openstack.org/#/c/133245/
17:11:10 <jasonsb> #link https://github.com/redhat-openstack/tempest/blob/kilo/tools/config_tempest.py
17:11:17 <gema> jasonsb: done!
17:11:30 <jasonsb> your too fast for me
17:11:43 <jasonsb> malini2: did the talks get submitted ok?
17:11:52 <malini2> jasonsb: yes
17:11:54 <jasonsb> malini2: beisner said there was some question about speaker profile
17:12:02 <jasonsb> excellent
17:12:02 <malini2> I missed tht
17:12:16 <malini2> jasonsb: the talk from my profile got submitted ok
17:12:35 <malini2> But in the event we get accepted, we shud still be able to +/- speakers
17:12:40 <jasonsb> we should be ok then since speaker list was same for both iirc
17:12:45 <beisner> yep there was a glitch in the matrix, not actually an issue with our proposal
17:13:20 <malini2> I wouldn't worry too much abt tht
17:13:46 <jasonsb> we should all contribute to gema doc i think still
17:13:46 <jasonsb> #link test strategy doc: https://docs.google.com/document/d/19N4lZJ5mYkQbkXrtBGntf7C1bWvwt1RKoSU8NerAphQ/edit#
17:13:49 <malini2> I see 2/3 topics addressed above - do we want to start tackling them one by one?
17:14:01 <gema> spyderdyne: I have some comments on the questionaire
17:14:08 <gema> wanna talk about it outside the meeting?
17:14:09 <malini2> me too..
17:14:14 <gema> shall we discuss then?
17:14:17 <malini2> #topic: questionnaire
17:14:23 <gema> malini2: you rock :)
17:14:35 <malini2> thanks gema - dont hear tht often :D
17:14:41 <gema> malini2: you go first :D
17:15:04 <malini2> IMO instead of pointing to specific tools tempest/rally/ OOO - we shud leave them open ended
17:15:30 <spyderdyne> ok. fire away
17:15:32 <malini2> Most of us have separate testing solutions & tht's what we are trying to find out -rt?
17:15:53 <gema> that's also my question, what are we trying to get out of this form
17:15:53 <spyderdyne> yes
17:16:20 <spyderdyne> tools used, how used, a little bit about their architecture to quantify their responses
17:16:25 <malini2> I was thinking something along the lines of - how do you test nova? how do you test swift etc.
17:16:44 <spyderdyne> i just threw something together real quick so feel free to hack and slash to your heart's desire
17:17:09 <gema> nah, I wasn't here last week, so I really missed the rationale for the questionnaire
17:17:51 <spyderdyne> not a problem
17:18:19 <malini2> gema: we moved to the questionnaire format to collect as much info as we can, instead of spending weeks on talks from each company
17:18:19 <spyderdyne> shoudl add a generic question like : what openstack components do you deploy and how do you test each one?
17:18:30 <gema> imo there are many different concepts mixed, like how many physical nodes you maintain (which for an integrator is kind of a weird question.. you mean in different clouds or in the same?) and you have questions about test suites but without asking about what they are trying to test
17:18:38 <spyderdyne> or we can add a question for each item as well
17:18:42 <spyderdyne> i have no preference
17:18:53 <gema> malini2: info needs to be actionable and comparable
17:18:56 <spyderdyne> we might get better data by separating them
17:19:16 <malini2> I am thinking of how someone from Rackspace will answer this
17:19:32 <gema> malini2: yep, I am thinking the same about canonical
17:19:35 <malini2> We have separate teams testing each of the components & no one person will have answer to all of these
17:19:45 <malini2> Guess its the same for all of us?
17:19:58 <gema> I could probably ask around and answer all, and so could beisner
17:19:59 <spyderdyne> Do you deploy components fm the Openstack Swift project?  If so which components do you use and how do oyu test/validate them?
17:20:24 <gema> but we have different clouds for different purposes, for instance and test in different ways for different reasons
17:20:43 <malini2> spyderdyne: +1
17:21:19 <spyderdyne> i can just run down the projects list and then add a question about projects that arent listed here
17:22:20 <malini2> should we just brain dump on an etherpad ?
17:22:34 <malini2> then spyderdyne can use that to consolidate into a questionnaire?
17:22:44 <gema> go for it, I cannot really contribute until I  understand what we are trying to gather and why
17:22:59 <malini2> ok -lets solve that first
17:23:22 <malini2> 'we test in different ways for different reasons'
17:23:40 <malini2> but do have the same problems -rt?
17:23:51 <malini2> we*
17:23:53 <gema> right
17:23:58 <gema> to some extent, yes
17:24:12 <jasonsb> i think just make the form specific to a openstack project
17:24:14 <malini2> Right now one of the gray areas is how each of us are testing
17:24:24 <jasonsb> and then have place to list tools
17:24:28 <gema> we've discussed that on several occasions
17:24:37 <malini2> hmm..I mean testing openstack when I use the generic word 'testing' - atleast in this channel
17:24:40 <malini2> sorry
17:24:48 <gema> yep
17:25:34 <gema> I mean, keep sharing what we have already discussed is not going to get us further, we have all this information in the log from the conversation we had in Vancouver, iirc
17:25:36 <spyderdyne> reload the form and check the last questions
17:25:50 <malini2> gema: our intent is to collect info on how each of us are testing openstack, what commonalities do we have, what common gaps do we have, what we can borrow from somebody else & what we can tackle together
17:26:14 <gema> malini2: is all this information going to be public?
17:26:21 <malini2> gema: yes
17:26:31 <jasonsb> we should make a etherpad to collect the things we want in the form and link it here
17:26:35 <malini2> All of us are going to have some proprietary stuff
17:26:45 <gema> it's not that
17:27:16 <malini2> gema: can u clarify?
17:27:32 <gema> let's say I am wary about gathering all this information instead of focussing on where the gaps are in openstack and tackling those
17:27:52 <gema> which is what really matters and trickles down to our own orgs very clearly
17:28:15 <malini2> the gaps clearly affect all of us
17:28:29 <spyderdyne> i thought the intent was to gather information about the tools that people are using to test/validate openstack components to find common threads
17:28:35 <malini2> But what if somebody os already working on some internal stuff tht aims to plug some of those holes?
17:28:44 <gema> malini2: exactly, what if that happens?
17:28:45 <malini2> like what spyderdyne is doing on HA ?
17:28:53 <jasonsb> spyderdyne: +1.  if everybody is testing it, its a candidate for tailgate
17:28:55 <gema> then that person either volunteers that information because they can or not
17:29:17 <spyderdyne> i guess it depends on what our goal is here
17:29:23 <gema> malini2: yep, he shared it, and we will share what we are doing with mojo specs in juju and we can share many things
17:29:30 <gema> but that doesn't get openstack to a better place
17:29:45 <gema> the things that we can contribute upstream that are not covered yet do
17:30:04 <malini2> gema: tht gets us to a place where rackspace thinks that canonical stuff is cool & would like to work on taking tht further
17:30:05 <gema> spyderdyne: keep going
17:30:09 <jasonsb> gema: but thats easy.  most are not covered
17:30:17 <gema> jasonsb: exactly
17:30:34 <gema> jasonsb: so let's get cracking instead of keeping gathering info that we are not acting on
17:31:04 <malini2> why wud we want to act on stuff, which somebody might have already solved?
17:31:04 <jasonsb> gema: as i see it, if everybdoy is testing some aspect of nova then there is a gap
17:31:13 <jasonsb> gema: and we should promote that to priority in tailgate
17:31:22 <malini2> jasonsb: +1
17:31:31 <gema> malini2: we look at the gaps and share: I am tackling this, anything has this solved? no? cool, I will do it
17:31:39 <malini2> if we put all those together, we probably will have something better than what we have today
17:31:46 <spyderdyne> what we can give openstack is a package of tools that someone can just pull and run that covers as many use cases as possible
17:32:09 <gema> spyderdyne: do you think we can build that out of all our different ways of running tests?
17:32:11 <spyderdyne> instead of haivng to reinvent the wheel every time someone deploys a cloud
17:33:00 <spyderdyne> i think we can use the form responses to identify common accepted testing methodologies and identify best practices
17:33:01 <malini2> If we can use the same code to build a cloud, we can atleast share some stuff to test it
17:33:29 <gema> ok, if you guys are convinced this is the way forward, let's do it and I will do my best to answer the questions, I however don't think I will be processing any info that comes out of it
17:33:33 <gema> :D
17:33:53 <gema> I rather focus on the stuff that defcore are doing where they have a very defined set of tests and gaps
17:34:00 <gema> where it is easy to start contributing
17:34:07 <spyderdyne> ideally someone shoudl be able to git checkout tailgate, input access credentials, and fire a battery against the components they have deployed
17:34:31 <gema> spyderdyne: yep, that's one of our goals
17:34:35 <jasonsb> spyderdyne: +1
17:34:45 <jasonsb> i like the UX focus
17:34:53 <malini2> this should not be mutually exclusive to contributing to defcore
17:35:01 <jasonsb> friendly to operators i should think would be welcome
17:35:09 <spyderdyne> i dont think we shoudl give preference or have any bias as to what tools to use, but rather identify the things that meet the requirements and provide them in a way that makes sense
17:35:24 <gema> malini2: agreed, just wanted to voice my concern
17:35:39 <gema> malini2: not going to stop you guys from gathering the info and will contribute all I can with our practices
17:35:40 <malini2> gema: I am glad we are having this conversation
17:35:51 <malini2> sounds like an existential question :)
17:35:57 <gema> malini2: it is
17:36:05 <jasonsb> this reminds me.  i would like to be in the defcore meetings
17:36:10 <jasonsb> when are they?
17:36:12 <gema> jasonsb: yesterday
17:36:17 <spyderdyne> some of the data we collect will have no relevance, but collecting it is free and we may find a use for it right?
17:36:18 <gema> at 3UTC
17:36:22 <jasonsb> is it same time every week?
17:36:27 <gema> jasonsb: since yesterday, yes
17:36:35 <gema> jasonsb: they changed to same time every week
17:36:43 <jasonsb> gema: thnx
17:36:45 <gema> np
17:37:00 <gema> jasonsb: they are going to be having a midcycle in austin in two weeks, so maybe that week there will be no meeting
17:37:03 <gema> we'll see
17:37:17 <malini2> coming back to questionnaire
17:37:18 <jasonsb> gema: i would propose that if we have good data, we might bring something to the table for defcore
17:37:31 <jasonsb> gema: IE: unidentified gaps
17:37:38 <malini2> gema: do you have concerns that this is a distraction?
17:37:43 <gema> malini2: absolutely
17:37:48 <gema> malini2: I think we are procrastinating
17:38:03 <malini2> gema: what would be your ideal scenario?
17:38:07 <gema> in a very technical way
17:38:11 <malini2> start contributing to defcore?
17:38:25 <gema> and continue the efforts of the inspector gadget
17:38:36 <gema> see how it correlates with the stuff that redhat shared with us
17:38:50 <gema> I had a quick look the other day and they can sort of generate an automated tempest conf
17:39:06 <gema> so maybe contribute there and get it to where we want it to be
17:39:09 <gema> and start adding tests
17:39:22 <gema> I can add the ones I have seen missing
17:39:24 <gema> you can add yours
17:39:32 <gema> we can share what we are adding with each other
17:39:34 <jasonsb> i vote we do both tracks
17:39:35 <gema> and make it grow
17:39:44 <malini2> jasonsb: me too
17:39:53 <gema> coolio, let's do it
17:40:03 <jasonsb> gema is right, we should get our hands dirty
17:40:27 <jasonsb> the process of working on defcore itself will vet our approach to the other
17:40:40 <gema> vet?
17:40:47 <malini2> Agreed - but I also want us to use stuff which might be already out there, instead of building new
17:41:16 <gema> malini2: nobody is sitting on tests that they are not sharing and if somebody is, this questionaire is not going to change that
17:41:28 <gema> let's share branches if you guys want
17:41:38 <gema> but many of our tests are going to be dependant on our tools
17:41:57 <malini2> its not about ppl not wanting to share - & the questionnaire wont change attitudes
17:42:16 <jasonsb> gema: i dont mind if it is dependent on your tools
17:42:17 <malini2> It is just gathering info on what is available which somebody else can collaborate & take furthere
17:42:29 <gema> malini2: ok, let's do that
17:42:47 <jasonsb> as i see it, i'm going to be spending my time on testing no matter what.  i would prefer to do it in tailgate and in the community
17:43:16 <gema> yep, me too
17:43:19 <malini2> lets do the questionnaire etherpad brain dump outside the meeting & move on
17:43:24 <gema> ack
17:43:27 <gema> sorry for derailing
17:43:39 <malini2> gema: no -it was a good discussion
17:43:43 <jasonsb> gema: so in conclusion
17:43:46 <malini2> Thanks for starting that
17:43:56 <jasonsb> we have tactical (defcore) and strategic (community)
17:44:21 <malini2> lets meet outside this meeting on the etherpad - like we did for the talk submission
17:44:30 <gema> malini2: ok
17:44:36 <gema> malini2: link for the etherpad?
17:44:43 <malini2> spyderdyne: can you drive the scheduling/logistics?
17:45:22 <malini2> it might just be hopping on to g+ when most folks are around
17:46:08 <malini2> #link https://etherpad.openstack.org/p/questionnaire-test-approaches
17:46:13 <malini2> moving on..
17:46:29 <malini2> I am very curious to hear from gema on specific actionable stuff we can do bow
17:46:31 <malini2> now*
17:46:48 <malini2> any votes for that?
17:47:17 <malini2> beep beep
17:47:24 <malini2> BEEP BEEEP
17:47:27 <gema> I already said the two things I think to be front runners
17:47:54 <gema> one is continue the inspector gadget effort (which stopped after a week, I think), the other is to start adding tests to defcore
17:48:01 <gema> and submitting them to tempest
17:48:19 <gema> and if we do complete those two before tokyo
17:48:26 <gema> I bet we will have everybody's attention :)
17:48:34 <malini2> gema: do you have a link to the gaps identified by defcore?
17:48:47 <gema> I have a link to the tests they have now
17:48:54 <spyderdyne> we had previously mentioned an interst in developing an inspector detector/inspector gadget project for determining what components are available in a particular build
17:48:57 <gema> I just cannot find for the live of me the link in our etherpad
17:49:02 <spyderdyne> are we still trying to do that?
17:49:02 <gema> life
17:49:09 <spyderdyne> if so who can work on that?
17:49:18 <malini2> spyderdyne: clee was doing some of tht
17:49:23 <gema> spyderdyne: yep, that's the one I was talking about , the link that clee shared from redhat
17:49:29 <gema> does something similar to taht
17:49:30 <gema> that
17:49:30 <spyderdyne> ok
17:49:42 <jasonsb> i'm working on config stuff
17:49:43 <gema> (generates tempest based on some cloud)
17:49:50 <spyderdyne> good stuff
17:49:53 <jasonsb> but i don't have it done yet
17:50:03 <gema> jasonsb: have a look at the redhat project and try it, plz
17:50:06 <spyderdyne> what sort of scheduling/logistics needs to be sorted out?
17:50:10 <gema> you may be pleasantly surprised
17:50:17 <spyderdyne> you have a link?
17:50:18 <jasonsb> gema: will do
17:50:28 <gema> spyderdyne: earlier in the log
17:50:31 <gema> it will appear on the summary
17:50:33 <spyderdyne> thx
17:50:41 <malini2> spyderdyne: do a brain dump on etherpad, then get together on g+ to chat & finalize the questionnaire
17:51:11 <malini2> spyderdyne: braindump will come from everybody (A)
17:51:51 <malini2> gema: if you can get us the link to the current tests vs desired, some of us can start adding some of tht
17:52:03 <gema> malini2: desired needs to be determined
17:52:10 <gema> they have what they have and then a list of capabilities
17:52:26 <gema> I will write an email on this subject tomorrow
17:52:30 <gema> so we are all on the same page
17:52:32 <malini2> sounds good
17:52:33 <gema> action?
17:52:42 <malini2> u r getting tht now :)
17:53:04 <malini2> #action: gema to send out the defcore details on actionable gaps
17:53:26 <gema> and guys, don't forget all the info here:
17:53:35 <gema> #link https://etherpad.openstack.org/p/testing2.0
17:53:35 <malini2> #action: spyderdyne to finalize the questionnaire details with everybody
17:53:42 <gema> whenever we analyze the questionaire
17:53:54 <malini2> gema: good point
17:54:06 <malini2> we have 5 min left
17:54:23 <malini2> anybody has something they wud like to discuss?
17:54:28 <gema> chair for next week?
17:54:54 <malini2> any volunteers?
17:55:05 <jasonsb> gema :)
17:55:08 <gema> haha
17:55:11 <gema> o/
17:55:12 <gema> ok
17:55:21 <malini2> #action: gema to chair next meeting
17:55:30 <spyderdyne> :)
17:55:44 <malini2> Anything else or we can chat abt weather for 5 min ;)
17:56:06 <gema> do you know when we will have results for the talks?
17:56:16 <malini2> some time in Sep
17:56:23 <jasonsb> would like to say thank you to malini gema and beisner for the talk submissions
17:56:23 <gema> oh, that's late
17:56:49 <gema> you are welcome jasonsb, exciting times
17:57:00 <beisner> happy to, yes it is exciting
17:57:07 <malini2> yes - I am really glad we found us all :D
17:57:33 <beisner> yeah we'll basically have 6wks from acceptance to delivery if those proposals make it ;-)
17:57:33 <malini2> sounds like we are out of topics now
17:57:54 <jasonsb> i wonder if we can backchannel on our chances of getting approved
17:58:03 <malini2> send candies?
17:58:06 <jasonsb> heh
17:58:15 <beisner> lol
17:58:18 <gema> jasonsb: start contributing to defcore
17:58:21 <gema> :)
17:58:27 <gema> test cases are candy in this case :D
17:58:38 <jasonsb> indeed
17:58:49 <jasonsb> double indeed
17:59:01 <malini2> the talk should not be our main motivator
17:59:13 <gema> agreed
17:59:14 <malini2> Ultimately its what makes our lives easier :)
17:59:37 <malini2> with tht, I am calling it done
17:59:42 <malini2> thank you all !!!
17:59:48 <malini2> #endmeeting