04:31:00 <gongysh> #startmeeting tacker
04:31:01 <openstack> Meeting started Wed Jun 21 04:31:00 2017 UTC and is due to finish in 60 minutes.  The chair is gongysh. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:31:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:31:04 <openstack> The meeting name has been set to 'tacker'
04:31:12 <gongysh> #topic roll call
04:31:22 <dkushwaha> o/
04:31:25 <tbh> o/
04:31:29 <Liuqing> o/
04:31:31 <tung_doan> o/
04:31:34 <gongysh> dkushwaha, tbh weclome
04:31:45 <gongysh> Liuqing, welcome to join us.
04:31:58 <gongysh> tung_doan, nice to see you.
04:32:04 <Liuqing> gongysh, thanks
04:32:18 <YanXing_an> o/
04:32:35 <gongysh> YanXing_an, welcome our patch producer.
04:33:00 <YanXing_an> gongysh, haha:)
04:33:17 <tung_doan> gongysh: me too.. get stuck in a hard project :)
04:33:31 <gongysh> chinamobile is ranking 2nd at http://stackalytics.com/?metric=commits&module=tacker
04:33:41 <gongysh> YanXing_an, thanks
04:34:00 <Liuqing> cool
04:34:30 * gongysh is wondering where sridar_ram is.
04:34:36 <YanXing_an> gongysh, we will work hard to be 1st :)
04:35:03 <gongysh> YanXing_an, glad to see that.
04:35:46 <gongysh> if you can keep that, I will consider to give over PTL role.
04:35:56 <gongysh> to give -> giving
04:36:10 <gongysh> :)
04:36:32 <gongysh> ok, 5 mins passed. we will start without sridar_ram.
04:36:51 <gongysh> #topic release
04:37:02 <gongysh> http://lists.openstack.org/pipermail/openstack-dev/2017-June/118151.html
04:37:31 <gongysh> thanks sridar_ram, who reminds me the release email.
04:38:10 <gongysh> if you guys see this email, we can feel the time is running low.
04:38:31 <gongysh> so please keep up reviewing activity and coding.
04:39:30 <gongysh> #topic bp
04:39:49 <gongysh> tung_doan, do you think your bp can be finished at this short time?
04:40:29 <tung_doan> gongysh: sure, I thibk both vnffg-autoscaling and vnffg-autohealing can do
04:41:12 <gongysh> tung_doan,  ok. but you bp spec update is kind of slow.
04:41:28 <gongysh> so keep up, and you can code side by sie.
04:41:36 <tung_doan> gongysh: I had some code locally. will push it in parallel
04:41:36 <gongysh> sie -> side.
04:42:04 <tung_doan> gongysh: I got stuck in some urgent works until last week
04:42:38 <gongysh> tung_doan, fine, make each patch testable,  if it does not break CI, we can trust manual test first.
04:43:04 <gongysh> but FT is favorable and must be made up sometime.
04:43:04 <tung_doan> gongysh: got it. thanks
04:43:28 <gongysh> dkushwaha, you NS with vnffg status?
04:43:52 <dkushwaha> gongysh: no any update in last week
04:44:09 <gongysh> have you implemented it in your mind, then?
04:44:49 <dkushwaha> gongysh: will update spec by tomorrow.
04:45:10 <gongysh> dkushwaha, if you have no time for it, we can leave it to next cycle.
04:45:29 <gongysh> dkushwaha, you can help to review other bps and patches.
04:46:07 <dkushwaha> gongysh: i will try to finish it, but yes, i will give 100% in review and other
04:46:28 <gongysh> dkushwaha, thanks.
04:46:33 <gongysh> #topic coding
04:46:58 <gongysh> first code patch is the blueprint refactor-vim-monitor patches.
04:47:28 <gongysh> these are from Liuqing, who is from 99cloud too. I have invited him to do contribution.
04:47:31 <gongysh> Liuqing, thanks.
04:47:50 <Liuqing> :-)
04:47:55 <tung_doan> Liuqing: welcome
04:48:12 <dkushwaha> Liuqing: welcome
04:48:28 <gongysh> dkushwaha, to verify the patches are working as expected. I have tested it.
04:48:28 <gongysh> https://docs.google.com/document/d/14xiggy3kkEXR435CDaTuYVUz8p8XHqK9Gc9VfvRXvL0/edit
04:48:37 <gongysh> you can see it.
04:48:42 <Liuqing> tung_doan, dkushwaha , thanks
04:48:43 <YanXing_an> Liuqing, welcome, nice job.
04:48:58 <gongysh> if you have no time to do testing, you can trust it.
04:49:20 <dkushwaha> gongysh: yup sure. i checked it.
04:49:44 <dkushwaha> gongysh: i will merge the patch
04:49:47 <gongysh> dkushwaha, thanks
04:50:14 <Liuqing> dkushwaha, thanks
04:50:34 <dkushwaha> gongysh: done
04:50:56 <gongysh> Liuqing, next after https://review.openstack.org/#/c/475594/5, please add a patch to write devref doc and a function test.
04:51:31 <gongysh> and also I will help you to start the monitor policy BP code.
04:51:33 <Liuqing> sure, and in next patch i will add doc and test
04:52:35 <gongysh> with blueprint refactor-vim-monitor is framework, we have good foundation.
04:52:47 <tbh> I have to drop, travelling to office
04:52:48 <gongysh> with blueprint refactor-vim-monitor's framework
04:52:58 <gongysh> tbh, see you.
04:53:11 <gongysh> tbh, storage patch, if you have time.
04:53:46 <gongysh> next code patch is from YanXing_an
04:53:50 <Liuqing> yep, gongysh and thanks
04:54:20 <gongysh> Liuqing welcome
04:54:22 <gongysh> https://review.openstack.org/#/c/465080/
04:54:37 <gongysh> YanXing_an, I thing you have the solution for the CI failure.
04:54:46 <gongysh> thing -> think
04:55:18 <YanXing_an> yes, I have known the reason of failure, will update the patch
04:55:36 <gongysh> YanXing_an, good to know it.
04:56:44 <gongysh> more things I want to say is the kolla installation of tacker MANO system.
04:58:04 <gongysh> I want use kolla way to do tacker installation. devstack is too weak for non tacker developer to install tacker.
04:58:58 <gongysh> second stuff is the doc -> user guide.
04:59:31 <gongysh> YanXing_an, if you want to rank 1st, the user guide is the place to produce patch.
04:59:36 <tung_doan> gongysh: nice to see that
04:59:58 <gongysh> we can write it in tacker repo first, and then move to openstack document team.
05:00:58 <gongysh> #topic open discussion
05:01:09 <gongysh> do you guys want to say something?
05:01:39 <dkushwaha> gongysh: any updates from OPNFV summit
05:01:48 <dkushwaha> ?
05:02:00 <gongysh> triant is not here. he is there, I am not.
05:02:12 <Liuqing> wiil we Angularize tacker-horizon dashboard?
05:02:16 <dkushwaha> gongysh: oh
05:02:26 <tung_doan> dkushwaha: gongysh: yeah.. i also want to know
05:03:15 <gongysh> Liuqing,  I want the visual digram for VNFD, VNFFGD
05:03:52 <dkushwaha> tung_doan yup, i think there should be many input points from opnfv summit
05:04:07 <dkushwaha> for Tacker
05:04:24 <Liuqing> gongysh, we can use d3 to draw the digram
05:04:28 <gongysh> Liuqing, if you are interested in it, that is great.
05:04:35 <tung_doan> YanXing_an: thanks for caring my patch: https://review.openstack.org/#/c/462690/ . I already emailed to Heat Translator team. Good news is that they may release Heat Translator 0.8.1 this week
05:05:49 <gongysh> tung_doan, have it on my plate.
05:06:01 <tung_doan> dkushwaha: agree
05:06:02 <gongysh> once the CI is happy, I will do the reviewing.
05:06:47 <tung_doan> gongysh: great! thanks
05:06:59 <gongysh> tung_doan, dkushwaha , it seems triant is still touring tiananmen square and Great Wall.
05:07:09 <tung_doan> gongysh: hahaha
05:07:14 <dkushwaha> gongysh: hahahaha
05:07:35 <gongysh> and Forbidden city is large too. he has asked me for those sites.
05:07:52 <dkushwaha> gongysh: i also love to visit Great wall some day :)
05:08:02 <gongysh> dkushwaha, welcome anytime.
05:08:05 <Liuqing> gongysh: hahahaha
05:08:30 <gongysh> dkushwaha, you can install a WeChat client on your phone so that can chat me anytime.
05:09:01 <dkushwaha> gongysh: sure, will try it
05:09:28 <gongysh> my wechat number is my telephone number.
05:09:51 <Liuqing> dkushwaha, welcome
05:10:07 <dkushwaha> gongysh: and what is your telephone number ?
05:10:16 <gongysh> 18618199879
05:10:25 <dkushwaha> gongysh: thanks
05:11:03 <gongysh> YanXing_an, don't forget your state transition diagram.
05:11:11 <gongysh> we need it.
05:12:07 <gongysh> to narrate  what action is ok at each state.
05:12:47 <gongysh> dkushwaha, https://bugs.launchpad.net/tacker/+bug/1697818
05:12:48 <openstack> Launchpad bug 1697818 in tacker "We can create vims with same name in same tenant." [Critical,New] - Assigned to Yan Xing'an (yanxingan)
05:12:57 <YanXing_an> gongysh, ok
05:12:58 <gongysh> what do you think of this bug?
05:13:37 <gongysh> dkushwaha, after you update the unique index to include deleted_at, we can have the duplicated name for not deleted resources.
05:14:40 <dkushwaha> gongysh: it should not be occurred, i will check it
05:15:17 <gongysh> dkushwaha, thanks.
05:15:33 <Liuqing> gongysh, duplicated name is not nice for end user, and we can raise a duplicatedNameException.
05:15:58 <gongysh> #action dkushwaha  to check 1697818
05:16:38 <gongysh> Liuqing, yes, we have constrain it via mysql unique index.
05:16:48 <gongysh> constrain -> constrained
05:16:59 <Liuqing> gongysh, ok
05:17:47 <gongysh> if you guys have no more thing to talk, we can end meeting earlier.
05:18:20 <gongysh> one more news, YanXing_an and me have got a topic to talk about tacker at openstack china days
05:18:58 <gongysh> the day is at July 24th.
05:19:31 <gongysh> ok
05:19:36 <gongysh> thanks everyone.
05:19:47 <gongysh> have a good night or day.
05:19:58 <gongysh> #endmeeting