05:30:08 <gongysh> #startmeeting tacker
05:30:09 <openstack> Meeting started Wed May 17 05:30:08 2017 UTC and is due to finish in 60 minutes.  The chair is gongysh. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:30:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
05:30:12 <openstack> The meeting name has been set to 'tacker'
05:30:17 <gongysh> helo guys
05:30:46 <gongysh> #topci roll call
05:31:21 <gongysh> hi dkushwaha
05:31:23 <dkushwaha> o/
05:31:29 <dkushwaha> gongysh, hi
05:31:44 <sridhar_ram> o/
05:31:47 <gongysh> any other guys here for tacker meeting?
05:31:53 <Kanagaraj> o/
05:32:30 <YanXing_an> o/
05:32:38 <janki> o/
05:32:39 <trinaths> o/
05:33:07 <gongysh> ok, 7
05:33:28 <gongysh> #topic summit info
05:33:45 <gongysh> https://www.openstack.org/videos/search?search=tacker
05:34:08 <gongysh> last week, I am on the summit. delivered the tacker on boarding forum
05:34:20 <gongysh> there are about 10 people in the room.
05:34:48 <gongysh> two of them came from korean as students.
05:35:07 <trinaths> ok
05:35:13 <gongysh> they talked about the vnffg's way to select vnf according to member vnfd.
05:35:53 <sridhar_ram> any etherpad used to document ? any operators attended ?
05:36:08 <gongysh> currently, we are selecting vnf randomly, they are thinking about an algorithm according to some metrics.
05:36:28 <sridhar_ram> cool
05:36:28 <gongysh> sridhar_ram, no, it is just an onboarding forum.
05:36:40 <sridhar_ram> gongysh: okay
05:36:43 <gongysh> I presented a ppt and show the system.
05:36:44 <trinaths> gongysh: what is the basic idea they are thinking to .. algorithmic approach ?
05:37:16 <gongysh> trinaths, for example, the cpu-utils of vnf.
05:37:34 <gongysh> vnffg to select the least loaden vnf to do the chaining.
05:37:51 <trinaths> gongysh: then what is the use of dynamic scaling ?
05:38:12 <gongysh> trinaths, that is different case.
05:38:30 <trinaths> ok
05:38:31 <gongysh> other two sessions related to tacker is one from china mobile
05:38:52 <gongysh> china mobile is doing the vnf stuff
05:38:59 <sridhar_ram> china mobile using tacker is a wonderful news !!
05:39:15 <gongysh> sridhar_ram, they are evaluating tacker.
05:39:24 <trinaths> we have china-mobile guys in tacker team too
05:39:31 <dkushwaha> gongysh, can you share the ppt?
05:39:45 <gongysh> if the evaluation comes to a good result, they will devote more resources.
05:40:11 <sridhar_ram> we sure can prioritize any asks from them ..
05:40:16 <gongysh> so we tacker team have to oil up  our progress
05:40:39 <sridhar_ram> which the other session on tacker ? I can only see the chinamobile one
05:40:56 <trinaths> +1
05:40:58 <gongysh> sridhar_ram, I think vnf, vnf configure is the big part for the china mobile.
05:41:03 <gongysh> other is from senlin team.
05:41:11 <gongysh> scaling.
05:41:20 <sridhar_ram> i see .. do you have a link?
05:41:28 <gongysh> there is a patch hanging there.
05:41:35 <gongysh> sridhar_ram, https://www.openstack.org/videos/search?search=tacker
05:42:15 <gongysh> so this is the part for summit briefing.
05:42:31 <gongysh> dkushwaha, I will upload it and share the url to team.
05:42:46 <dkushwaha> gongysh, thanks
05:43:05 <gongysh> one more information from community is the project management.
05:43:49 <gongysh> I think community is thinking about the way of managing the projects that are not active.
05:44:02 <trinaths> oh!
05:44:10 <gongysh> they will come up a way to remove inactive projects.
05:44:17 <trinaths> we are active !
05:44:28 <gongysh> so please make our project active
05:44:46 <gongysh> that leads to our activity stats topic.
05:44:57 <gongysh> #topic project activity stats
05:45:14 <gongysh> #link http://stackalytics.com/?metric=marks&module=tacker-group
05:45:33 <gongysh> trinaths, thanks for the review effort.
05:45:51 <trinaths> happy to help tacker
05:46:15 <gongysh> our review comes to about 40 across the openstack projects
05:46:28 <gongysh> but commit data lacks behind.
05:47:07 <gongysh> about review I have a proposal.
05:47:18 <gongysh> I want to say:
05:48:58 <gongysh> core member can merge feature code,  (not the refactor code.)  once there is a +2 and have tested and there is no -1 after 7 days.
05:49:00 <trinaths> where to find this '40' count across openstack projects? how we move the project forward
05:49:44 <trinaths> gongysh: good idea. its it a self merge ?
05:50:07 <gongysh> not self merge.
05:50:11 <trinaths> ok
05:50:44 <gongysh> currently, there are many complaints to say openstack patches get merged too slow.
05:51:02 <sridhar_ram> in essence, you are proposing one +2 rule instead of two +2s ?
05:51:03 <gongysh> some projects even quit the big tent due to the long process.
05:51:14 <gongysh> sridhar_ram, right.
05:51:58 <gongysh> but +2 and the test.
05:52:16 <sridhar_ram> given where we are in the project .. i think it is a reasonable move.. i support
05:52:30 <sridhar_ram> .. but self merge is absolute NO
05:52:34 <gongysh> and wait one week in case other cores find problem.
05:53:00 <gongysh> sridhar_ram, the patch must not from core himself.
05:53:12 <gongysh> must not be from core himself.
05:53:17 <gongysh> include co-author.
05:53:39 <gongysh> dkushwaha, Kanagaraj , any opinions?
05:53:51 <trinaths> gongysh: there it requires commitment between the author and reviewer.
05:54:00 <dkushwaha> gongysh, IMO it is a nice approach, if it tested and pending for more than a week
05:54:45 <gongysh> Kanagaraj, your idea?
05:56:19 <gongysh> #agreed core can merge codes after one +2 with passed test and pending for more than 7 days.
05:56:24 <Kanagaraj> gongysh: self merge may not be the case. otherwise fine. good to go
05:56:43 <gongysh> #topic features and bp
05:57:12 <gongysh> from me, there is the vim monitoring bp
05:57:22 <gongysh> I got comments from sridhar_ram
05:57:30 <gongysh> and update it.
05:57:40 <gongysh> sridhar_ram, thanks for the comments.
05:58:28 <gongysh> http://docs-draft.openstack.org/20/459520/9/check/gate-tacker-specs-docs-ubuntu-xenial/53098d4//doc/build/html/specs/pike/mistral_vim_monitor.html
05:58:36 <sridhar_ram> gongysh: sure .. i would encourage other cores to review this spec .. it proposes two significant additions - tacker-conductor component and gRPC
05:58:39 <gongysh> this is the rendered spec doc.
05:58:58 <gongysh> sridhar_ram, I have removed the gRPC
05:59:15 <gongysh> to speed up the approval process.
05:59:34 <gongysh> but tacker-conductor, we have to add it.
05:59:35 <sridhar_ram> gongysh: ah, i haven't checked the latest version .. so, sticking with oslo.messaging ?
05:59:49 <gongysh> sridhar_ram, yes.
06:00:02 <trinaths> tacker-conductor == nova-conductor ?
06:00:10 <sridhar_ram> gongysh: good idea
06:00:45 <gongysh> since mistral is part of our system, which probably introduced the rabbitmq, we can use it.
06:00:56 <sridhar_ram> make sense
06:01:28 <gongysh> so please review the new spec version.
06:01:58 <gongysh> I will later write other spec for our vnf monitor policy.
06:02:28 <gongysh> if someone wants to implement the vim monitor spec, welcomed.
06:03:09 <dkushwaha> gongysh, I can join.
06:03:11 <gongysh> pike-2 is on june 5.
06:03:14 <gongysh> https://launchpad.net/tacker/+milestone/pike-2
06:03:33 <gongysh> dkushwaha, you are on ns bp.
06:04:09 <gongysh> for the official release plan. before that day, we have to merge all the bp specs in the pike cycle.
06:04:38 <dkushwaha> gongysh, yup. Working on that.
06:04:38 <gongysh> pike-3 is the deadline for code freeze.
06:05:08 <gongysh> dkushwaha, it is your turn to talk about NS bp
06:05:30 <dkushwaha> In vnffg-ns bp, I got comment from gongysh.
06:06:06 <trinaths> gongysh: is this bug a valid one ? https://bugs.launchpad.net/tacker/+bug/1577354
06:06:07 <openstack> Launchpad bug 1577354 in tacker "No output when tacker vnf-list, vnfd-list is empty" [Low,Triaged] - Assigned to Trinath Somanchi (trinath-somanchi-m)
06:06:27 <dkushwaha> I am referring https://github.com/openstack/tacker/blob/master/samples/tosca-templates/vnffgd/tosca-vnffgd-sample.yaml for this
06:07:05 <gongysh> dkushwaha, so?
06:07:38 <gongysh> trinaths, we will talk about bug later.
06:07:46 <dkushwaha> Currently looking for the way to expose CP as per Tim comment in https://review.openstack.org/#/c/448109/3/specs/pike/vnffg-ns.rst@153
06:08:37 <dkushwaha> I am planing to update the spec by today
06:08:41 <gongysh> dkushwaha, ok
06:08:42 <gongysh> thanks
06:09:15 <gongysh> dkushwaha, make it tight. ping me if need my comments.
06:09:44 <dkushwaha> gongysh, sure, I will gear up now
06:09:58 <gongysh> barbican spec is merged,  YanXing_an  is working on patch at bug smash days in china.
06:10:23 <YanXing_an> yes. I will rapidly response to the review comments these days.
06:10:58 <gongysh> so since it is an event,  our core members should help this bug fix race.
06:11:11 <YanXing_an> Please help to review it. https://review.openstack.org/#/c/465080/
06:11:26 <gongysh> YanXing_an, remove the WIP if ready for review.
06:11:50 <YanXing_an> gongysh, ok
06:11:58 <gongysh> tung_doan, hi
06:12:00 <tung_doan> YanXing_an: Do we need Barbican client in local conf. file?
06:12:18 <tung_doan> gongysh: Hi all :)
06:12:41 <gongysh> #topic bugs
06:13:00 <gongysh> trinaths, do you have any bugs to talk about?
06:13:05 <trinaths> https://bugs.launchpad.net/tacker/+bug/1577354
06:13:06 <openstack> Launchpad bug 1577354 in tacker "No output when tacker vnf-list, vnfd-list is empty" [Low,Triaged] - Assigned to Trinath Somanchi (trinath-somanchi-m)
06:13:36 <gongysh> tung_doan, the E2E service?
06:13:38 <trinaths> nova client give an empty table putput,  other projects give an empty putput
06:13:48 <YanXing_an> tung_doan: we need barbicanclient installed
06:14:24 <tung_doan> gongysh: After finish my bug lists i will move forward to this bp
06:14:48 <tung_doan> gongysh: https://review.openstack.org/#/c/462690/
06:15:03 <gongysh> tung_doan, we are trying to finish spec before June 5.
06:15:04 <tung_doan> that 's serious bug i think
06:15:18 <tung_doan> gongysh: got it
06:15:50 <gongysh> tung_doan,  462690, then fix it.
06:16:41 <tung_doan> YanXing_an: in that case, we need to update dependency in https://review.openstack.org/#/q/project:openstack-infra/project-config
06:17:15 <gongysh> we also need someone to track senlin scale patch
06:17:16 <gongysh> https://review.openstack.org/#/c/449471/
06:17:28 <tung_doan> YanXing_an: similar to Gongysh's patch https://review.openstack.org/#/c/385472/
06:18:25 <gongysh> #topic meeting time rescheduling
06:18:36 <trinaths> gongysh: my bug ?
06:18:54 <dkushwaha> gongysh, i have to discuss one more bug
06:19:12 <gongysh> I want to make tacker meeting one hour earlier so that USA team member can join us.
06:19:50 <gongysh> or make them feel better or work better on the meeting.
06:19:51 <tung_doan> gongysh: totally agree
06:20:06 <dkushwaha> gongysh, +1
06:20:17 <sridhar_ram> +100
06:20:27 <dkushwaha> sridhar_ram, :D
06:20:33 <trinaths> +1
06:20:37 <janki> +1
06:20:58 <gongysh> YanXing_an,  it means we have to have the meeting with our launch box.
06:21:17 <trinaths> gongysh: you can have yummy meetings
06:21:30 <sridhar_ram> gongysh: thanks for proposing this .. it helps a LOT
06:21:41 <gongysh> #agreed make the tacker meeting one hour earlier.
06:22:02 <gongysh> sridhar_ram, I have to look if there is a time lot on this channel.
06:22:08 <gongysh> or other meeting channel.
06:22:13 <sridhar_ram> sure
06:22:19 <YanXing_an> gongysh, ok. we need have launch more earlier and faster
06:22:37 <gongysh> sridhar_ram,  what is the process to change the meeting time?
06:22:58 <sridhar_ram> you need a patchset to irc-meetings repo
06:23:11 <sridhar_ram> will send a link
06:23:16 <gongysh> sridhar_ram,  ok. thanks
06:23:28 <gongysh> #topic open discuss
06:23:35 <gongysh> dkushwaha,  your one more bug please.
06:23:39 <dkushwaha> gongysh, sridhar_ram In the current code, anyone can delete a VNF even it is the part of an active NS, it needs to be fixed. I will log a bug for this. Currently I was working on it and want to know your opinion  for the right approach to fix it.
06:24:06 <gongysh> VNF event?
06:24:32 <dkushwaha> gongysh, "vnf"
06:24:33 <sridhar_ram> gongysh: see https://review.openstack.org/#/c/406390/ for meeting time change
06:24:37 <trinaths> bug: https://bugs.launchpad.net/tacker/+bug/1577354
06:24:39 <openstack> Launchpad bug 1577354 in tacker "No output when tacker vnf-list, vnfd-list is empty" [Low,Triaged] - Assigned to Trinath Somanchi (trinath-somanchi-m)
06:24:41 <gongysh> just make the EVENT delete as admin priviledge on tacker's policy.json.
06:25:13 <gongysh> trinaths,  no need to change it. 1577354
06:25:17 <YanXing_an> if a vnf is used by NS or vnffg, it should not be deleted?
06:25:44 <dkushwaha> YanXing_an, right
06:25:44 <sridhar_ram> it is not about privilege .. but NS still owns that VNF and it shdn't be deleteed underneath
06:25:47 <tung_doan> dkushwaha: I met this issue. I think VNFs should be locked when NS are still active
06:25:48 <gongysh> YanXing_an, right, we should check the logic when we remove a vnf.
06:25:59 <trinaths> gongysh: thank you, I will close this bug.
06:27:19 <gongysh> dkushwaha, I mistook 'delete a VNF even' as 'delete a VNF event'
06:27:25 <dkushwaha> gongysh, sridhar_ram should we add ns_id column in vnf table ?
06:27:34 <Kanagaraj> YanXing_an: you may want to enable the casecade delete mode in db schema and i believe vnf can't be deleted until its reference entities get deleted
06:27:36 <sridhar_ram> dkushwaha: no
06:27:46 <YanXing_an> in vnffg/ns db, vnf id/name is saved in json text
06:28:43 <dkushwaha> sridhar_ram, gongysh tung_doan any suggestion on this ?
06:28:44 <sridhar_ram> dkushwaha: we are better off with an func call across plugin boundary
06:28:44 <tung_doan> sridhar_ram: sridhar_ram: I really hope to have ns_id column in vnf table
06:28:54 <gongysh> dkushwaha,  please talk it at bug page
06:29:15 <tung_doan> sridhar_ram: just imagine how we heal vnfs inside NSs
06:29:16 <sridhar_ram> tung_doan: it will break modularity .. let's avoid
06:29:16 <gongysh> tung_doan, what about vnf refered by the vnffg
06:29:23 <dkushwaha> gongysh, sure, I will raise a bug for this
06:29:51 <gongysh> sridhar_ram, we have to fix it in this or that way.
06:29:52 <sridhar_ram> VNFM / vnf shouldn't know it is participating in a NS ..
06:29:56 <tung_doan> sridhar_ram: if ping failed, we need to know which ns VNFs point to
06:30:02 <gongysh> #endmeeting