05:30:10 <gongysh> #startmeeting tacker
05:30:11 <openstack> Meeting started Wed Mar 22 05:30:10 2017 UTC and is due to finish in 60 minutes.  The chair is gongysh. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:30:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
05:30:14 <openstack> The meeting name has been set to 'tacker'
05:30:22 <gongysh> helo guys
05:30:32 <gongysh> #topic roll up
05:30:49 <gongysh> who are here to join tacker meeting?
05:30:53 <YanXing_an> o/
05:30:55 <tbh> o/
05:31:29 <Zhou_Zhihong> o/
05:31:35 <JimmyYe2528> o/
05:31:35 <diga> o/
05:31:40 <dkushwaha> o/
05:31:44 <gongysh> hi Zhou_Zhihong
05:31:50 <tung_doan_> o/
05:31:53 <Zhou_Zhihong> hi
05:32:15 <gongysh> is sridhar_ram here?
05:32:17 <sridhar_ram> o/
05:32:24 * gongysh is missing sridhar_ram
05:32:40 <tung_doan_> hi sridhar_ram
05:32:57 <sridhar_ram> hi everyone.. missed last week, glad to be back
05:32:58 <gongysh> yes, we have many of you at the meeting.
05:33:12 <gongysh> sridhar_ram, welcome back to meeting.
05:33:14 <YanXing_an> sridhar_ram, missing you
05:33:33 <trinaths> o/
05:33:44 <gongysh> hi, trinaths , welcome
05:34:04 <gongysh> trinaths is doing great job at tacker client unit mock replacement.
05:34:14 <gongysh> trinaths, thanks.
05:34:29 <gongysh> let move to next topic
05:34:30 <trinaths> gongysh: thank you. but been struck..
05:34:36 <sridhar_ram> trinaths: great ... familiar face, welcome!
05:34:56 <trinaths> sridhar_ram: hi, thank you.
05:34:57 <gongysh> #topic project activity stats
05:35:19 <gongysh> #link http://stackalytics.com/?metric=marks&module=tacker
05:35:47 <gongysh> hi guys, in particular core reviewers, please look at out project's review, commit data.
05:36:01 <gongysh> we are improving, but still lag behind.
05:37:06 <gongysh> many of openstack project are in dormant status.
05:37:34 <gongysh> the projects which ranking after 100 ...
05:37:44 <gongysh> we can imagine their status.
05:37:54 <trinaths> gongysh: what are the suggestions for improvement?
05:38:14 <gongysh> so we have to keep up with our efforts.
05:38:44 <gongysh> trinaths, be active is the only way.
05:38:55 <dkushwaha> gongysh, I will improve my review
05:39:12 <gongysh> dkushwaha, thanks.
05:39:12 <trinaths> gongysh: ok.
05:39:38 <gongysh> #topic features or BPs
05:40:01 <gongysh> the first topic is still task rescheduling
05:40:18 <gongysh> today I got  reviews from sridhar_ram and dkushwaha
05:40:50 <diga> gongysh: that's the reason I was saying, handover module wise responsibilities of reviews each member like we do for features, if we have less member of core people
05:41:26 <gongysh> one comment I want to say is: long live task is done by the framework, and  I want shot one let them go to  mistral.
05:41:37 <sridhar_ram> gongysh: i saw ur response for long-running vs one shot ..
05:41:58 <sridhar_ram> gongysh: ... can mistral support long running tasks ?
05:42:18 <gongysh> sridhar_ram,  I don't think so.
05:42:21 * sridhar_ram wondering whether we can punt the scale problem to mistral
05:42:36 <dkushwaha> sridhar_ram, gongysh no
05:43:01 <sridhar_ram> dkushwaha: okay..
05:43:14 <gongysh> dkushwaha, you are saying mistral does not support long live task, right?
05:43:21 <sridhar_ram> i think it will be confusing to have two different wasnt to write "tasks" in tacker
05:43:36 <sridhar_ram> s/wasnt/ways/
05:43:50 <dkushwaha> gongysh, right. We need to give a time limit in mistral
05:44:11 <sridhar_ram> dkushwaha: time limit is okay, but can we do a task in a loop ?
05:44:27 <gongysh> So since mistral will become part of tacker system, we will make more use of mistral.
05:44:59 <dkushwaha> sridhar_ram, I will check it, but IMO it looks not possible
05:45:11 <sridhar_ram> dkushwaha: gongysh: https://wiki.openstack.org/wiki/Mistral/Long_Running_Business_Process
05:45:11 <gongysh> such as start vnf, scaling vnf, update vnf, etc, these all can be put into mistral.
05:45:42 <sridhar_ram> we use heat stack for many of these operations ..
05:46:13 <sridhar_ram> ... it will be good to have clear demarcation .. which method to use for which tasks
05:46:29 <sridhar_ram> .. it will avoid confusion .. for all of us
05:47:29 <gongysh> TOSCA workflow system in future will be mistral dependent.
05:47:30 <sridhar_ram> dkushwaha: gongysh: better to ask Mistral PTL (Renat)
05:47:54 <sridhar_ram> gongysh: +1
05:48:16 <gongysh> #action ask mistral PTL renat for our long-live task support.
05:48:58 <gongysh> sridhar_ram, you are always able to come up with different ideas.
05:49:20 <sridhar_ram> gongysh:  didn't mean to slow down ur efforts ;-)
05:50:01 <gongysh> sridhar_ram, ideas are always important too. :)
05:50:28 <sridhar_ram> gongysh: mistral has some good practical deployments .. particularly in StackStorm product.. used in NetFlix ..
05:50:44 <gongysh> sridhar_ram, I will ask mistral PTL if mistral is ok for long live task we need.
05:50:44 <gongysh> thanks
05:50:50 <gongysh> next topic
05:50:54 <sridhar_ram> sure
05:51:14 <gongysh> #topic vim credential barbican solution
05:51:44 <gongysh> YanXing_an, could you please update?
05:52:23 <YanXing_an> I am working on the barbican spec, trying write some draft code, will update the spec before next meeting.
05:52:32 * gongysh is waiting for YanXing_an to wake up
05:53:17 <gongysh> YanXing_an, please come up with spec first. sridhar_ram will probably change your mind. :)
05:53:28 <sridhar_ram> LOL
05:53:40 <sridhar_ram> already working on it ;-)
05:53:51 <YanXing_an> https://review.openstack.org/#/c/445543/, it's still in WIP
05:54:30 <sridhar_ram> sripriya was the lead dev for fernet key ... missing her insights
05:54:36 * gongysh has a sip of coffee
05:55:30 <gongysh> sridhar_ram,  sripriya is enjoy her coffee somewhere. we cannot find her for a long time.
05:55:44 <gongysh> enjoy -> enjoying
05:56:02 <gongysh> YanXing_an, ok we are waiting for your spec.
05:56:19 <YanXing_an> sridhar_ram: if barbican is used, the fernet is not necessary? IMO
05:56:51 <gongysh> So we will have barbican, mistral, keystone being our parts of tacker system then.
05:57:00 <sridhar_ram> YanXing_an: we shouldn't need it .. we need move away from file (disk) based credential store for scalable tacker
05:57:27 <sridhar_ram> YanXing_an: with barbican, we will move to API based which is good
05:57:57 <gongysh> next topic
05:58:14 <gongysh> #topic NS with vnffg
05:58:30 <gongysh> dkushwaha,  would you like to elaborate it?
05:58:37 <dkushwaha> gongysh, I have WIP initial spec for vnffg-ns https://review.openstack.org/#/c/448109/
05:59:09 <dkushwaha> gongysh, and I am working on it
05:59:37 <gongysh> dkushwaha, the nice assii diagram, I don't have the patience to draw it even with that tool.
05:59:41 <sridhar_ram> dkushwaha: trozet is intererested to co-author .. please include him in the spec and implementation
06:00:13 <dkushwaha> sridhar_ram, it will be great help if trozet can join
06:00:29 <trinaths> in vnffg, its only with ODL ?
06:00:31 <gongysh> dkushwaha, yesterday, I have tested the networking-sfc with ovs driver.
06:00:40 <sridhar_ram> dkushwaha: he has capacity this cycle to co-author
06:00:52 <dkushwaha> sridhar_ram, yes sure, I will add him.
06:01:06 <gongysh> it works for asymmetric vnffg.
06:01:24 <gongysh> but for the symmetric, there is still a bug.
06:01:52 <gongysh> trinaths, networking-sfc can work with ODL
06:02:21 <sridhar_ram> gongysh: you mean, networking-sfc now support symmetric but it is buggy ?
06:02:32 <gongysh> in vnffg, our current solution is to integrate with networking-sfc.
06:02:46 <gongysh> networking-sfc will use ovs or odl driver.
06:02:51 <gongysh> sridhar_ram, right.
06:02:59 <sridhar_ram> gongysh:  okay
06:03:15 <trinaths> gongysh: ok
06:03:23 <gongysh> sridhar_ram, https://bugs.launchpad.net/networking-sfc/+bug/1674588
06:03:23 <openstack> Launchpad bug 1674588 in networking-sfc "Can not to find the back group is set with symmetric chain" [Undecided,New]
06:03:43 <tbh> dkushwaha, if trozet is not available, I would like to join the efforts in vnffg
06:03:48 <gongysh> sridhar_ram, it is a concern, networking-sfc is not an active project.
06:03:52 <sridhar_ram> gongysh: heads up, even if this bug is fixed.. there might be issues in tacker sfc driver side ..
06:04:02 <sridhar_ram> .. for symmetric
06:04:20 <gongysh> if we depend on it, we have to risk.
06:04:34 <sridhar_ram> gongysh: really ? i haven't looked at their stats  .. i thought lfourie and cathy are active
06:05:05 <gongysh> sridhar_ram, yes, that will be a small fix.
06:05:07 <sridhar_ram> gongysh: we shd flag it to neutron PTL (kevin) .. *if* we get slow response
06:05:10 <dkushwaha> tbh, sure, I will confirm it with trozet again
06:05:53 <sridhar_ram> i might meet armando and some sfc folks in the upcoming ONS summit
06:06:03 <gongysh> tbh, you can start with vnffg, to fix the symmetric bug.
06:06:46 <sridhar_ram> dkushwaha: i agree with gongysh, that diagram in the spec is super cool
06:06:51 <gongysh> tbh, I mean even with networking-sfc fixed that bug https://bugs.launchpad.net/networking-sfc/+bug/1674588
06:06:51 <openstack> Launchpad bug 1674588 in networking-sfc "Can not to find the back group is set with symmetric chain" [Undecided,New]
06:07:00 <gongysh> tbh, tacker needs a small fix too
06:07:11 <dkushwaha> sridhar_ram, gongysh Thanks :)
06:08:08 <gongysh> next I want to talk about is
06:08:13 <tbh> gongysh, I will work on those
06:08:29 <gongysh> #topic bp persistent-block-storage
06:08:44 <gongysh> #link https://blueprints.launchpad.net/tacker/+spec/persistent-block-storage
06:09:27 <gongysh> even though I have come up with a block-mapping solution, I think we need a tosca solution.
06:09:53 <gongysh> YanXing_an has said the china mobil guy will take it.
06:09:56 <YanXing_an> Zhou_Zhihong wants to help with it
06:10:03 <Zhou_Zhihong> gongysh,I'll try to work on it
06:10:05 <gongysh> Zhou_Zhihong, hi
06:10:18 <gongysh> Zhou_Zhihong, welcome on board.
06:10:28 <sridhar_ram> Zhou_Zhihong: welcome to tacker!
06:10:34 <gongysh> please write a spec and let sridhar_ram to review.
06:10:46 <gongysh> sridhar_ram is expert on tosca.
06:11:16 <Zhou_Zhihong> I'm newer to tacker and need time to fimiliar with the feature
06:11:38 <sridhar_ram> can't claim being a expert, but will sure can help on the TOSCA side.. to come of up appropriate storage attributes
06:11:59 <gongysh> with this, we will have floatingip ( in review), address pair, (merged), block-image ( to be drafted)
06:12:06 <Zhou_Zhihong> OK,thanks sridhar_ram first
06:12:51 <gongysh> ok, we are expecting Zhou_Zhihong 's spec.
06:12:57 <gongysh> let's move to
06:13:14 <gongysh> #topic bugs or REFs
06:13:35 <gongysh> first bug is vnfc image position
06:14:08 <gongysh> https://bugs.launchpad.net/tacker/+bug/1673012
06:14:08 <openstack> Launchpad bug 1673012 in tacker "Place vnfc image" [Medium,In progress] - Assigned to yong sheng gong (gongysh)
06:14:44 <gongysh> I have skipped the vnfc functional test since it breaks our CI now and then.
06:15:03 <gongysh> it is the github limit. I think
06:15:12 <sridhar_ram> make sense.. not too surprised by github throttling
06:15:36 <gongysh> so I plan to put the image to https://tarballs.openstack.org/tacker/
06:15:49 <gongysh> this is the way kolla team is doing.
06:15:54 <sridhar_ram> i tried the vnfc image script.. it worked fine, though it took quite some time generate the file
06:16:03 <gongysh> we will need a few more CI job to do it.
06:16:27 <sridhar_ram> gongysh: are you planning to generate fedora vnfc image on every CI job run ?
06:16:51 <gongysh> so if we have this job running, and want to update the image, we will just need to update one of file in our devstac/vnfc
06:17:38 <gongysh> sridhar_ram you got it.
06:17:53 <gongysh> we will let the image updating job to be intelligent.
06:18:44 <gongysh> sridhar_ram, have I made clear?
06:18:55 <sridhar_ram> on my baremetal server, it took 8 mins for the script to spit out a qcow2 image
06:19:54 <sridhar_ram> gongysh: if i understand you correctly, you will conditionally update this file in the tarballs location ? on what condition you would run this script ?
06:21:13 <gongysh> sridhar_ram,  Ci job has a precondition, for example the files under a particular dir
06:21:43 <sridhar_ram> gongysh: okay, will wait for you related PS .. conditional update, if possible, is a fine approach
06:21:52 <gongysh> nine mins to go
06:22:06 <gongysh> next bug
06:22:14 <gongysh> vnffg functional test.
06:22:31 <gongysh> JimmyYe2528 uploaded a patch 5 days ago.
06:22:36 <gongysh> but it is WIP.
06:22:44 <JimmyYe2528> today, i will update it
06:22:48 <gongysh> so please keep on updating it.
06:23:05 <JimmyYe2528> got it
06:23:44 <gongysh> vnffg is a pearl of our tacker.
06:23:51 <gongysh> we need to make it work.
06:24:16 <gongysh> next bugs https://review.openstack.org/#/q/status:open+project:openstack/tacker+branch:feature/falcon-api-framework
06:24:31 <gongysh> API branch's CI is broken
06:25:03 <gongysh> so make an eye on these review so that API work can go right.
06:25:23 <gongysh> #topic open discussion
06:25:44 <gongysh> I want leave some time for every one.
06:25:53 <gongysh> so what do you guys have in mind?
06:26:18 <trinaths> gongysh: you are talking leave ?
06:26:19 <YanXing_an> https://review.openstack.org/#/c/447773/, need some reviews
06:26:28 <dkushwaha> trinaths, ;)
06:27:13 <trinaths> gongysh: how to check this pagination ?
06:27:17 <dkushwaha> YanXing_an, SURE
06:27:20 <gongysh> trinaths,  how should I say?
06:27:40 <trinaths> gongysh: i'm confused :(
06:27:43 <dkushwaha> YanXing_an, sure
06:27:49 <gongysh> trinaths, you can generate a dozen vnfd
06:28:07 <trinaths> gongysh: okay.
06:28:14 <gongysh> and to test the pagination feature of API.
06:28:15 <sridhar_ram> trinaths: put vnfd-create in a loop
06:28:15 <YanXing_an> dkushwaha, thanks
06:28:33 <trinaths> sridhar_ram: ok got it
06:29:04 <trinaths> gongysh: since othe project client are aligning to osc, tackerclient do the same ?
06:29:14 <gongysh> trinaths, will.
06:29:22 <gongysh> trinaths, if you want to take it, you can start.
06:29:51 <gongysh> one minute.
06:30:02 <trinaths> gongysh: okay. I will start that work. integrating tackerclient to osc.
06:30:10 <gongysh> #endmeeting