16:02:27 <s3wong> #startmeeting tacker
16:02:28 <openstack> Meeting started Thu Jun 11 16:02:27 2015 UTC and is due to finish in 60 minutes.  The chair is s3wong. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:31 <openstack> The meeting name has been set to 'tacker'
16:03:17 <s3wong> #link agenda  https://wiki.openstack.org/wiki/Meetings/Tacker#Meeting_June_11.2C_2015
16:03:30 <s3wong> #topic announcements
16:03:42 <s3wong> sridhar_ram: hello
16:03:43 <sridhar_ram> ho
16:04:13 <s3wong> the only announcement I have is that the tacker horizon patch is approved, and now we have a horizon repo
16:04:16 <changzhi> sridhar_ram:hi
16:04:23 <sridhar_ram> changzhi: hi
16:04:35 <sridhar_ram> s3wong: that's the one I had to announce as well!
16:04:46 <vishwana_> hi
16:04:54 <s3wong> sridhar_ram: go ahead and add links (to review and the repo)
16:05:04 <s3wong> vishwana_: hello
16:05:06 <sridhar_ram> s3wong: sure
16:05:30 <sridhar_ram> #link https://github.com/stackforge/tacker-horizon
16:05:49 <sridhar_ram> Follow the README for installation steps
16:06:14 <s3wong> any patches on Tacker horizon from now on can go through the regular gerrit process against tacker-horizon
16:06:22 <sridhar_ram> this repo just carries the delta / dashboard required for tacker
16:06:55 <s3wong> sridhar_ram: great job!
16:07:01 <sridhar_ram> s3wong: thanks!
16:07:20 <s3wong> Any other announcement?
16:07:32 <sridhar_ram> the contribution came from vishwana_ .. so thanks goes to him as well!
16:07:39 <sridhar_ram> s3wong: nothing else
16:07:44 <s3wong> vishwana_: thanks!
16:07:53 <s3wong> OK, moving on
16:07:56 <vishwana_> Glad to contribute
16:08:15 <vishwana_> sridhar_ram, appreciate the recognition
16:08:27 <s3wong> #topic Liberty topics (spill over from last week's meeting)
16:08:51 <s3wong> We penciled in Murano discussion for this week
16:09:19 <s3wong> dgollub: is there any news on contacting some Murano folks to join us?
16:09:32 <s3wong> (for discussion, not contributing)
16:09:47 <dgollub> s3wong: sorry no - I contacted intially the wrong guy. I try to get some contact for next week
16:10:02 <s3wong> dgollub: that is fine
16:10:09 <dgollub> just keep it as action item for me
16:10:10 <melisha> I can take Murano
16:10:43 <dgollub> melisha: do you have some inside about there TOSCA translator/interpreter plan?
16:11:23 <s3wong> #action dgollub to work with Murano team and investigate viability of using Murano for Tacker VNF catalog
16:11:28 <Puri_> Hi from Rakesh comcast
16:11:32 <s3wong> dgollub: Thanks!
16:11:40 <melisha> Not yet. S we are also interested in Tacker b Murano but more with Heat catalog
16:11:48 <sridhar_ram> Puri_: hi
16:11:54 <s3wong> Puri_: welcome! We would love to have user feedback!
16:12:16 <sridhar_ram> regarding Murano and TOSCA here the recent discussion #link http://lists.openstack.org/pipermail/openstack-dev/2015-June/066185.html
16:12:52 <sridhar_ram> perhaps melisha: dgollub: should followup with the folks in this thread as well
16:13:21 <s3wong> sridhar_ram: yes, I notice that Vahid from IBM is very active to contribute to Murano TOSCA effort
16:13:32 <sridhar_ram> BTW I've some updates to share on Heat-Translator's TOSCA support
16:13:56 <s3wong> sridhar_ram: you want to do that later? on the status update front?
16:14:04 <sridhar_ram> sure, can wait
16:14:14 <s3wong> sridhar_ram: thanks
16:14:18 <s3wong> Moving on
16:14:32 <s3wong> the next carryover is HA
16:15:00 <s3wong> when we were at the summit, folks from Stratus Technologies were interested to contribute
16:15:23 <s3wong> but I haven't seen them (or did I miss anyone) on meeting
16:15:53 <s3wong> given most of us have immediate tasks in hand, I would suggest we should postpone the HA discussion / design later in the cycle
16:16:06 <s3wong> is that OK with everyone?
16:16:28 <dgollub> I agree. I can ping Arraon from Stratus so they can contribute some ideas/requirments/usecases/code ..
16:16:41 <s3wong> dgollub: cool, Thanks!
16:16:42 <Masato> I think OK to postpone for a while
16:17:03 <s3wong> Masato: agreed
16:17:14 <sridhar_ram> s3wong: Sounds good. though we do have a simple 'network reachablility' based health check
16:17:29 <s3wong> Will take that off agenda until we have cycle to revisit later on in the cycle
16:17:29 <sridhar_ram> so new folks trying out tacker .. please check it out
16:18:11 <s3wong> sridhar_ram: true, we have self-healing logic --- though it is tough to exactly call it HA :-)
16:18:20 <s3wong> Moving on
16:18:37 <sridhar_ram> s3wong: true :)
16:18:38 <s3wong> #topic Additional Liberty Topics
16:19:01 <s3wong> we added some items in the etherpad also: https://etherpad.openstack.org/p/liberty-tacker
16:19:36 <s3wong> most of them are items that we skipped during the demo cycle
16:20:08 <s3wong> the devstack patch should be refined (local.conf without yamahata 's company IP addresses, for example)
16:20:18 <s3wong> and check into Tacker repo
16:20:42 <sridhar_ram> s3wong: devstack now supports plugin in the actual repo
16:21:00 <s3wong> sridhar_ram: Oh, OK... need to see how that works then
16:21:24 <sridhar_ram> s3wong: IMO .. this is an urgent tasks to ease of installation of Tacker
16:21:40 <s3wong> sridhar_ram: +1
16:21:41 <bobh_> sridhar_ram: I agree
16:21:57 <s3wong> sridhar_ram: I guess it is either you or me, want to take that?
16:22:20 <sridhar_ram> yes, in fact other items like cleaning up tacker.conf can wait
16:22:32 <s3wong> sridhar_ram: OK
16:23:04 <sridhar_ram> s3wong: is this something you can take up ?
16:23:05 <s3wong> #action sridhar_ram to work on devstack plugin for Tacker
16:23:20 <s3wong> sridhar_ram: Oh, I though your "yes" means you are :-)
16:23:26 <s3wong> #undo
16:23:27 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x9a198d0>
16:23:29 <sripriya> sridhar_ram: is this the devstack-tacker branch from yamahata's github?
16:23:44 <sridhar_ram> s3wong: I beat you to it ;-)
16:23:47 <s3wong> sripriya: there is
16:23:55 <s3wong> sridhar_ram: OK, I will look into it
16:24:11 <s3wong> #action s3wong to look into devstack plugin for Tacker
16:24:14 <sridhar_ram> s3wong: thanks!
16:25:04 <s3wong> sridhar_ram: yeah, I think having everyone looking into yamahata's local.conf and see how to modify it is a bit much for users :-)
16:25:08 <s3wong> Moving on
16:25:23 <s3wong> C! test / Tempest
16:25:24 <sridhar_ram> what we need is #link http://docs.openstack.org/developer/devstack/plugins.html
16:25:31 <sridhar_ram> externally hosted plugins
16:25:44 <s3wong> sridhar_ram: OK --- will take a look
16:26:12 <s3wong> before we move to functional test, scenario test, and tempest, we need to first tackle the unit test part
16:26:33 <s3wong> I start to play around with our tox.ini, which really only does pep8
16:26:59 <s3wong> I will add py27 as well --- but of course, I need to write some unit test to test this
16:27:08 <dgollub> did run_tests.sh worked at any time?
16:27:47 <s3wong> dgollub: I think it runs, but just pep8 for now
16:28:42 <s3wong> as run_tests.sh usually runs what tests you enable and set up testenv accordingly
16:28:57 <dgollub> on the current master branch it's failing quite early for me. But I guess we can take this later on #tacker
16:29:18 <s3wong> dgollub: OK --- I haven't tried it actually, so good to know
16:29:32 <s3wong> Moving on
16:29:57 <s3wong> auto-scaling with Heat/monitoring/LBaaS
16:30:02 <sridhar_ram> s3wong: we need to talk about CI ?
16:30:17 <s3wong> sridhar_ram: OK
16:30:39 <s3wong> sridhar_ram: at its basic form, CI runs the repo's unit tests
16:30:45 <sridhar_ram> s3wong: it will be nice to have a some simple scenarios covered
16:31:14 <sridhar_ram> s3wong: no, I'm talking about invoking actual tacker scenarios on a PS
16:31:17 <s3wong> sridhar_ram: so my take is we need to have our unit tests working before Jenkins can be a meaningful gate
16:31:55 <sridhar_ram> s3wong: we need both..perhaps we can work on these in parallel
16:32:36 <s3wong> sridhar_ram: I do agree the meaningful test should be more functional tests
16:33:09 <s3wong> sridhar_ram: do you want to take on developing some functional tests?
16:33:30 <sridhar_ram> s3wong: yeah, I can take that up..
16:33:50 <s3wong> I am still on hook for preliminary unit tests
16:34:00 <sridhar_ram> s3wong: sure, we definitely need those
16:34:16 <sridhar_ram> I'll look into some basic functional tests
16:34:24 <s3wong> #action sridhar_ram to look into developing preliminary functional tests
16:34:39 <sridhar_ram> which we can hook to a CI to get basic sanity going for our patchsets
16:35:01 <sridhar_ram> it is better to establish these practices and frameworks early in the cycle :)
16:35:28 <s3wong> sridhar_ram: agreed. Especially given how much we depend on other projects, we need to make sure any development in Heat /Nova / Neutron would not break Tacker
16:35:44 <sridhar_ram> s3wong: true
16:35:54 <s3wong> sridhar_ram: and that would be the most immediate items you will tackle (among the tasks on your plate)?
16:36:38 <sridhar_ram> s3wong: yes.. I can go some background work on TOSCA .. but mostly discussions & emails
16:36:46 <sridhar_ram> *do
16:36:48 <s3wong> sridhar_ram: sounds good
16:37:19 <s3wong> For the auto-scaling stuff, it is very low priority for now. I will do some preliminary investigation when I have time, but nothing urgent
16:37:48 <s3wong> #topic Liberty tasks status update
16:38:13 <s3wong> item #1: tacker.conf
16:38:21 <sripriya> I'm working on refacotring the tacker.conf and identified few sections that can be removed
16:38:28 <s3wong> sridhar_ram, sripriya, bobh_: any update?
16:38:32 <sripriya> will be sending a patchset soon
16:38:39 <s3wong> sripriya: OK. Thanks!
16:39:52 <s3wong> it is a bit of a mess right now
16:40:03 <s3wong> it looks like neutron.conf :-)
16:40:19 <sridhar_ram> it is neutron.conf ;-)
16:40:34 <sripriya> yes, many neutron sections such as quotas, agent scheduler extension and neutron specific options will be removed in first take
16:40:35 <s3wong> haproxy driver for LBaaS :-)
16:40:55 <sridhar_ram> I'd suggest to go after some low hanging items towards cleanup...
16:41:25 <sripriya> sridhar_ram: sure
16:41:49 <s3wong> sripriya: thanks for the update
16:42:05 <s3wong> item #2: TOSCA - Heat tranlator
16:42:13 <s3wong> sridhar_ram: update?
16:42:32 <sridhar_ram> I tried out heat's tosca translator..
16:42:51 <sridhar_ram> tacker currently uses a particular spec of TOSCA ..
16:43:05 <sridhar_ram> TOSCA Simple Profile for Network Function Virtualization
16:43:12 <sridhar_ram> #link https://www.oasis-open.org/committees/download.php/55662/tosca-nfv-v1.0-wd01-rev04.doc
16:43:32 <sridhar_ram> however the heat-translator doesn't seem to support this schema ..
16:44:00 <s3wong> sridhar_ram: is that something we can patch to heat-translator?
16:44:01 <sridhar_ram> instead it supports a general schema that is doesn't have the node-types of NFV
16:44:42 <sridhar_ram> yes, I think we should reach out / collaborate with heat-translator team to bring in this support
16:45:00 <sridhar_ram> bobh_: do you more info in this area ?
16:45:03 <s3wong> sridhar_ram: +1
16:45:31 <dgollub> this schema seems to be fairly new. Was the first release of that simplified one in May this year?
16:45:37 <bobh_> sridhar_ram: We have done some work internally with NFV and TOSCA - I can take a look at what it would take to add it to heat-translator
16:45:58 <sridhar_ram> bobh_: great, thanks!
16:46:02 <s3wong> bobh_: cool, adding you to this item then :-)
16:46:09 <dgollub> the stock TOSCA things looks pretty diffrent IIRC
16:46:46 <sridhar_ram> dgollub: this schema was available even earlier...might have been revised in May
16:47:09 <sridhar_ram> dgollub: agree, stock TOSCA is too general ..
16:47:13 <dgollub> oh I see
16:47:14 <s3wong> dgollub: the document says May 2015, so fairly new
16:47:40 <sridhar_ram> given they have already spec'd out NFV / VNF stuff we should converge on that
16:47:56 <dgollub> makes sense
16:48:09 <sridhar_ram> bobh_: perhaps we can start a thread in the ML on this ?
16:48:24 <bobh_> sridhar_ram: Sounds like a good idea
16:48:44 <s3wong> sridhar_ram: this is a working draft --- how often do they update?
16:49:22 <sridhar_ram> s3wong: I don't know much on the cadence of OASIS spec policy
16:49:46 <sridhar_ram> perhaps we can get to meet some folks (from IBM) in the f2f mtg in VMware
16:49:53 <s3wong> but I do agree we need something to start out with --- and this is a "standard" doc, so start with that is reasonable
16:50:04 <s3wong> sridhar_ram: yes, we can ask them next Monday
16:50:34 <s3wong> the editor (Shitao Li) is only on the invite list for that meeting
16:50:38 <s3wong> Moving on
16:50:53 <s3wong> item #3: monitoring framework
16:51:06 <s3wong> bobh_, prashantD_: any updates?
16:51:14 <prashantD_> s3wong : on that...I have filed a BP under launchpad. We don't have enough information to start writing spec
16:51:24 <prashantD_> bobh_ : feel free update and add more info to BP
16:51:38 <prashantD_> As bobh_ pointed out I am looking into MONaas and also Ceiliometer.
16:52:14 <s3wong> prashantD_: sure, you and bobh_ will come up with the design ... and I didn't expect that to be done in a week :-)
16:52:17 <bobh_> prashantD_: I am also looking at Monasca - I think we should probably start there before inventing new things
16:52:49 <prashantD_> bobh_ : sure, When you have time wanted to discuss few things offline maybe
16:53:14 <bobh_> prashantD_: Sounds good
16:53:34 <sridhar_ram> we need a spec in tacker-specs repo to review
16:53:52 <s3wong> prashantD_, bobh_: would be interesting to see how ceilometer and monasca work together
16:53:56 <sridhar_ram> launchpad is just a pointer to the gerritt review
16:54:05 <s3wong> sridhar_ram: yes, but they haven't spec out yet :-)
16:54:23 <bobh_> sridhar_ram: I want to understand monasca a little better before starting a spec
16:54:36 <sridhar_ram> bobh_: sure
16:54:38 <bobh_> s3wong: Me too :-)
16:54:53 <sridhar_ram> this definitely needs more ground work
16:55:10 <sridhar_ram> looks we lost s3wong:
16:55:44 <dgollub> should we do the next topic?
16:55:52 <sridhar_ram> I think we are done w/ the status updates
16:56:00 <sridhar_ram> #topic Open Discussion
16:56:22 <dgollub> jfyi, I did the telco working group usecase for VNF bringup .. which might be relevant to the config-driver work: https://review.openstack.org/#/c/190080/
16:56:27 <dgollub> #link https://review.openstack.org/#/c/190080/
16:56:30 <Puri_> 0
16:56:47 <sridhar_ram> dgollub: sure, will review
16:57:06 <s3wong> sorry guys
16:57:08 <s3wong> I was dropped for a moment
16:57:09 <sridhar_ram> I believe Sripriya was also looking at config drive
16:57:19 <sridhar_ram> s3wong: np, we moved on !
16:57:25 <sripriya> yes, heat support for config-drive
16:57:30 <s3wong> sridhar_ram: good :-)
16:57:49 <s3wong> any other updates?
16:57:50 <sridhar_ram> time check .. 3 more mins!
16:57:56 <s3wong> #topic Open DIscussion
16:58:02 <sripriya> quick overview, this is possible and we will able to load configuration using config-drive
16:58:12 <dgollub> perfect
16:58:19 <s3wong> sripriya: great!
16:58:23 <sripriya> using user-data tag
16:58:33 <dgollub> would this be also configurable - per VNF?
16:58:40 <sripriya> yup
16:58:52 <sridhar_ram> Puri_: we would like to understand potential usage pattern of tacker
16:58:54 <bobh_> we use file injection in heat templates to do vnf-specific confguration today
16:59:26 <bobh_> personality tag in heat template
16:59:41 <sridhar_ram> Puri_: it will be great if you share your thoughts in the etherpad #link https://etherpad.openstack.org/p/liberty-tacker
16:59:47 <dgollub> bobh_: then I would be interested if you get share your feedback on: https://review.openstack.org/#/c/190080/
16:59:58 <bobh_> dgollub: Will do
17:00:06 <dgollub> thanks!
17:00:16 <s3wong> OK time's up
17:00:20 <s3wong> Thanks everyone!
17:00:25 <s3wong> #endmeeting