07:00:10 <mahatic> #startmeeting swift
07:00:11 <openstack> Meeting started Wed May 31 07:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is mahatic. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:15 <openstack> The meeting name has been set to 'swift'
07:00:33 <mahatic> who is here for Swift alternate meeting?
07:00:42 <mattoliverau> o/
07:00:43 <cschwede_> Yay, Swift time :) Hello everyone!
07:00:45 <m_kazuhiro> o/
07:00:46 <mathiasb> good morning
07:00:52 * notmyname here, although disagrees with "alternate" ;-)
07:01:01 <mahatic> :D
07:01:15 <mahatic> Did I see acoles too?
07:01:15 <notmyname> thanks, mahatic, for leading this meeting
07:01:24 <acoles> I'm here!
07:01:24 <mattoliverau> So weird to have it at this time, but also great :)
07:01:35 <kota_> hello
07:01:36 <mahatic> notmyname: of course np!
07:01:42 <mahatic> hello everyone!
07:01:43 <zhongjun> hi
07:01:47 <mahatic> great to see you all
07:01:56 <mahatic> let's get started
07:02:12 <mahatic> #topic Rotating Chair
07:02:42 <mahatic> So, it'd be really great and helpful if we could have rotating Chairs
07:02:54 <acoles> I have one :)
07:03:00 * mattoliverau imagines mahatic on a swivel chair leading the meeting
07:03:55 <mahatic> Part of the reason is, currently I'm not 100% on Swift and also involved in other projects at my work
07:04:09 <mahatic> all those jokes, note the capitalization of C ;)
07:04:10 <mattoliverau> mahatic: ok, but so far your doing great :)
07:04:19 <mattoliverau> Fair enough.
07:04:19 <cschwede_> maybe rotate alphabetically? so it's (nearly) clear who's next and who has been the last one (eg acoles, cschwede, kota, mahatic, mathiasb, mattoliverau, and so on...)
07:04:47 <mahatic> getting back, it'd make sense we have different Chairs especially to avoid times when one of is not caught up enough on what's going on
07:05:02 <acoles> cschwede_: I see what you did to me there ;)
07:05:16 <mahatic> cschwede_: sounds great to me
07:05:20 <mahatic> acoles: ;)
07:05:34 <cschwede_> acoles: pure coincidence :)
07:05:40 <mattoliverau> So long as it's written somewhere (on the ajenda/wiki) cause I'll forget :)
07:05:44 <mattoliverau> But sure
07:05:51 <acoles> mahatic: ok with me
07:06:07 <mahatic> Is everyone else ok with having Chairs, in the alphabetical order?
07:06:14 <mahatic> acoles: great, thanks
07:06:19 <cschwede_> let's do that!
07:06:21 <kota_> +1
07:06:28 <mattoliverau> +1
07:06:34 <m_kazuhiro> +1
07:06:46 <acoles> I think I saw that rledisez may be attending, so add him to list?
07:06:55 <mattoliverau> Yup ;)
07:07:03 <mahatic> yes sure
07:07:13 <cschwede_> yeah, my list is surely not complete...
07:07:22 <acoles> And clayg *promised* he'd be here!!
07:07:28 <mahatic> seems a lot of us agree on that. Nice!
07:07:37 <notmyname> he specifically said he wouldn't be here, today in the office :-)
07:07:41 <mahatic> yes, clayg: where are you?! ;)
07:08:08 <mathiasb> i'm not sure i'm ever caught up enough on what's going on, but if that's not a strict requirement then sure, +1 :)
07:08:08 <mahatic> thank you everyone for agreeing on being a Chair!
07:08:38 <mahatic> mathiasb: oh well, you *can* get caught up if you aren't already, no? ;)
07:08:49 <mattoliverau> mathiasb, it's should be just leading and going through what's on the ajenda
07:09:22 <mahatic> +1 also preparing the agenda as well
07:09:25 <mattoliverau> And getting us back into line when we get too off track ;)
07:09:34 <acoles> mathiasb: everyone - i think it's important that the Chair does not fee they need to know everything that is going on - I see the role as facilitating
07:09:45 <acoles> s/fee/feel/
07:10:02 <mattoliverau> Yeah, let's all try and help with the ajenda
07:10:04 <mahatic> I agree
07:10:36 <mattoliverau> Start with some common topics, then people can add if they need/want to discuss
07:10:59 <notmyname> I would be very happy to assist anyone with that
07:11:19 <notmyname> and am available to do so at whatever time is convenient for you
07:11:28 <mahatic> I was just about to say that - you can coordinate with notmyname in any case :)
07:11:38 <mattoliverau> notmyname: thanks!
07:12:07 <mahatic> any more questions/thoughts on this?
07:12:18 <notmyname> so for practical todos, acoles will chair the next meeting on June 14?
07:12:30 <mattoliverau> Kk
07:13:08 <mahatic> Yup
07:13:31 <mahatic> notmyname: should this be a hashtag todo you mean?
07:14:17 <notmyname> yes, it can be, but that's not what I meant by the statement/question
07:14:27 <mahatic> okay
07:14:34 <mahatic> I'll probably just note it in the wiki
07:14:46 <mahatic> next up
07:14:49 <notmyname> #agreed chairs for 0700 meeting will rotate
07:14:59 <notmyname> #agreed acoles will chair june 14
07:15:12 <notmyname> done :-)
07:15:20 <mahatic> thanks! :)
07:15:26 <mahatic> #topic Priority review patches that didn't have a turnaround in over a month
07:15:55 <mahatic> so as the title suggests, I noted a few of those patches
07:16:00 <mahatic> s/noted/noticed
07:16:10 <kota_> notmyname: perhaps the hashtag commands are only for the chiar?
07:16:16 <kota_> chair
07:16:35 <notmyname> kota_: dunno
07:16:48 <mahatic> #agreed chairs for 0700 meeting will rotate
07:17:07 <mahatic> hmm that didn't prompt anything
07:17:14 <kota_> hmm...
07:17:19 <mahatic> getting back - https://review.openstack.org/#/c/289664/
07:17:49 <patchbot> oh hi!
07:18:04 <notmyname> https://review.openstack.org/#/c/289664/
07:18:05 <patchbot> patch 289664 - swift - Make eventlet.tpool's thread count configurable in...
07:18:14 <kota_> #link https://review.openstack.org/#/c/289664/
07:18:14 <patchbot> patch 289664 - swift - Make eventlet.tpool's thread count configurable in...
07:18:15 <mahatic> that one is Sam's patch and Clay seems to have left a -1. There hasn't been any activity in more than a month
07:18:23 <mahatic> thank you kota_ notmyname
07:19:06 <mattoliverau> Oh I had problems, getting it to work when testing this
07:19:21 <mattoliverau> Been meaning to retry
07:19:37 <mahatic> oh okay
07:19:41 <mahatic> I'm not sure if Sam is still intending to work on it?
07:20:06 <mahatic> notmyname: would you know?
07:20:14 <notmyname> he's not, in the short term
07:20:47 <notmyname> or rather, that's not what he's currently working on day-to-day
07:20:59 <mahatic> well, since it's in the priority reviews, maybe anyone else who has bandwidth and interest could pick it up
07:21:05 <mattoliverau> Maybe it shouldn't be a priority review, it's cool, so stay a patch
07:21:15 <notmyname> there's more info in the bug report https://bugs.launchpad.net/swift/+bug/1554233
07:21:16 <openstack> Launchpad bug 1554233 in OpenStack Object Storage (swift) "Servers-per-port can consume excessive OS threads" [Medium,In progress] - Assigned to Samuel Merritt (torgomatic)
07:21:39 <notmyname> mattoliverau: a bug doesn't get less-bad when someone is unavailable to work on a patch ;-)
07:21:48 <notmyname> just means the rest of us have to step up :-)
07:21:51 <mattoliverau> Lol true
07:21:58 <mahatic> lol
07:21:59 <cschwede_> yeah, clayg's comments seem to be rather easy to include, maybe someone wants to step in on this patch?
07:22:19 <mahatic> maybe Clay! ;)
07:22:32 <acoles> notmyname: right, but it would be helpful in such a case to know that the patch needs someone to take it on. otherwise it just clutters the priority review list but is in fact going nowhere
07:22:37 <cschwede_> i assume Sam would be ok if someone takes over as long as the author tag is kept
07:22:38 <mahatic> on a serious note, maybe someone who already has context - that's what I meant
07:23:15 <notmyname> yes, acoles and mahatic. that is very true
07:23:21 <acoles> So do we need a "priority reviews in need of an owner" list?
07:23:35 <cschwede_> Prashanth liked the patch, maybe he has some interest in this. I'll ping him
07:23:48 <notmyname> is he still around?
07:24:33 <mattoliverau> I'm not sure how great or long my promises can last in my current situation. But I can loop round on it seeing as I was testing it in the past.
07:24:56 <mahatic> acoles: looks like it. at least if we have bugs/patches that are a priority but doesn't have an owner, having a list would help and bring some visibility
07:24:57 <notmyname> I think what we need on this patch is for someone to spend a bit of time to understand it, especially since it may need to be taken over from torgomatic
07:25:23 <notmyname> ...and it sounds like mattoliverau can take a stab at that?
07:25:40 <mattoliverau> Yup
07:26:00 <notmyname> great, thanks
07:26:11 <mahatic> and a fallback would be Prashanth if he's interested?
07:26:15 <notmyname> mattoliverau: and even working in clay's comment and pushing another patch set would be good
07:26:28 <notmyname> mahatic: if he's still working on swift...
07:26:35 <mattoliverau> Kk
07:26:51 <mahatic> oic okay
07:27:05 <mahatic> thanks mattoliverau!
07:27:34 <mahatic> the other patch is
07:27:34 <mahatic> https://review.openstack.org/#/c/371150/
07:27:35 <patchbot> patch 371150 - swift - Return 404 on a GET if tombstone is newer
07:28:33 <mahatic> this one has also been for quite sometime with no activity. Could check with tdasilva if he's still planning on continuing with that work
07:28:39 <notmyname> this one looks like it's been a conversation between timburke and tdasilva
07:28:58 <notmyname> yes, this one needs to be brought up in the 2100 meeting later today
07:29:14 <cschwede_> looks like a useful improvement
07:30:07 <mahatic> yeah, I'm sure it'd be useful. It's tagged as medium priority
07:30:28 <mahatic> okay, we have one more and Romain is the author. But he doesn't seem to be around
07:30:36 <rledisez> hi everybody :)
07:30:45 <mahatic> rledisez: oh hi! :)
07:30:55 <mahatic> welcome
07:31:06 <notmyname> https://review.openstack.org/#/c/456921/ has everyone here right now :-)
07:31:07 <patchbot> patch 456921 - swift - Fix SSYNC failing to replicate unexpired object
07:31:24 <mahatic> mattoliverau left a comment and acoles seems to have addressed it
07:31:30 <mahatic> mattoliverau: did you get a chance to look over it?
07:31:37 <mattoliverau> rledisez: o/
07:31:39 <mahatic> notmyname: yes, thanks! :)
07:32:09 <mattoliverau> Not yet, been distracted
07:32:23 <rledisez> mattoliverau: i think alister answered your concerns about commit/verify
07:32:29 <rledisez> *acoles
07:32:50 <mattoliverau> Kk, will take a look, sorry everyone
07:32:59 <acoles> mattoliverau: yeah, it is a little subtle but the verify flag is distinct from commit
07:33:01 <notmyname> mattoliverau: no worries. you've been upended recently
07:33:38 <notmyname> mattoliverau: what would be best here (for you)? take it from rledisez an acoles that it's resolves? wait for you to respond in gerrit?
07:34:00 <notmyname> get another person involved in the review?
07:34:49 <acoles> notmyname: clayg spent some time on this - IIRC I ripped off a probe test he started in the follow up, so he may be able to jump in
07:34:53 <mattoliverau> I'll take a quick look tomorrow
07:35:05 <mattoliverau> But if need be don't wait for me
07:35:35 <mattoliverau> But I do trust them :)
07:36:26 <notmyname> ah, ok. https://review.openstack.org/#/c/460073/ is the follow-up
07:36:27 <patchbot> patch 460073 - swift - Add probe test for ssync of unexpired metadata to ...
07:36:36 <notmyname> acoles: maybe that should be merged in?
07:37:03 <notmyname> mattoliverau: ok, if you take a look tomorrow, that would be great. but if not, that's ok, but just let us know :-)
07:37:23 <mahatic> ok, that sounds good
07:38:25 <mahatic> thanks everyone for figuring it out :)
07:38:31 <mahatic> next up is
07:38:35 <mahatic> #topic Drop translation that's causing bugs
07:38:39 <mattoliverau> I will, I'll leave a comment if I have issues or fail to test on my limited resources
07:39:03 <acoles> notmyname: +1 (squash the probe test) it's 'only' another 58 lines to review
07:39:23 <notmyname> :-)
07:39:32 <mahatic> so we have a couple of bugs on this (maybe more around)
07:39:35 <mahatic> https://bugs.launchpad.net/swift/+bug/1648082
07:39:36 <openstack> Launchpad bug 1648082 in OpenStack Object Storage (swift) "Yet UnicodeDecodeError: 'ascii' codec can't decode byte..." [Undecided,New]
07:39:41 <mahatic> https://bugs.launchpad.net/swift/+bug/1580678
07:39:42 <openstack> Launchpad bug 1580678 in OpenStack Object Storage (swift) "UnicodeDecodeError when rebalancing a ring" [Medium,In progress] - Assigned to Christian Schwede (cschwede)
07:40:41 <mahatic> on the latter, clayg commented that openstack had a resolution to drop off log message translations
07:40:51 <cschwede_> +1!
07:40:59 <mahatic> and here is what info I could find on that - https://wiki.openstack.org/wiki/LoggingStandards#Log_Translation
07:41:28 <mahatic> but it doesn't quite say the same. If anyone could point to a better source, that'd be great
07:41:55 <mahatic> or if I'm missing some ML announcement on this, please correct me
07:41:56 <cschwede_> if you ever google a translated log message, your chance is pretty low to find something useful...
07:42:13 <notmyname> here
07:42:14 <notmyname> https://docs.openstack.org/developer/oslo.i18n/guidelines.html#log-translation
07:42:33 <notmyname> " Starting with the Pike series, OpenStack no longer supports log translation. It is not necessary to add translation instructions to new code, and the instructions can be removed from old code. Refer to the email thread understanding log domain change on the openstack-dev mailing list for more details."
07:42:35 <mahatic> awesome, thanks notmyname
07:42:39 <notmyname> http://lists.openstack.org/pipermail/openstack-dev/2017-March/thread.html#113365
07:42:45 <cschwede_> IMO that's not helpful for operators, and AFAICT many don't run this in a translated language therefore (true for other software as well)
07:43:07 <cschwede_> so we're getting rid of this?
07:43:17 <mahatic> yup!
07:43:21 <notmyname> cschwede_: if you're saying that translated logs aren't helpful I completely agree
07:43:22 <cschwede_> could be a nice low-hanging-fruit
07:43:33 <cschwede_> notmyname: that's what i wanted to say! :)
07:43:38 <notmyname> (I acknowledge that the logs [and everything else] are in my native language, though)
07:44:32 <notmyname> so from the links above it seems very clear that we can remove translations from log messages
07:44:50 <notmyname> cschwede_: does that help make progess on these open bugs (you'd been working on at least one)
07:45:13 <notmyname> ?
07:45:21 <mahatic> https://review.openstack.org/#/c/339360/1
07:45:22 <patchbot> patch 339360 - swift - Make verbose unicode test output working
07:45:25 <cschwede_> notmyname: i need to look again into that patch & bug, but sounds so
07:45:29 <mahatic> Is that one related?
07:47:03 <mahatic> okay cschwede_ to look at it
07:47:29 <mahatic> thanks
07:47:59 <mahatic> #topic open discussion
07:48:56 <mahatic> I think that's all we have on the agenda today. Anyone has other topics to bring up?
07:49:02 <notmyname> o/
07:49:03 <acoles> might be worth linking to this https://review.openstack.org/#/c/446762/ when removing translations from our code
07:49:03 <patchbot> patch 446762 - oslo.i18n - add notes about skipping log translation setup (MERGED)
07:49:09 <notmyname> or rather, as question
07:49:25 <cschwede_> we also need to prepare the birthday party for patch 337297
07:49:26 <patchbot> https://review.openstack.org/#/c/337297/ - swift - Add support to increase object ring partition power
07:49:33 <mahatic> yay!
07:49:36 <cschwede_> it's getting one year in a few weeks!
07:49:37 <acoles> cschwede_: :/
07:50:01 <mahatic> oops, I thought you had linked to the merged composite ring patch
07:50:08 <mattoliverau> cschwede_ congrats :)
07:50:28 <kota_> mahatic: no, it's increase part power
07:50:35 <mattoliverau> We should def get it in. It's awesome
07:50:37 <mahatic> yeah, I see that :)
07:51:09 <mahatic> it had a +2 from Pete on a last patchset
07:51:22 <cschwede_> yes; i had to rebase it again because of a merge conflict
07:51:49 <kota_> cschwede_: sorry, I know my global ec + composite ring had big conflicts with that
07:51:58 <kota_> and thanks for working to update
07:52:17 <notmyname> kota_: now that global ec patches have landed, does that mean you could look at composite rings?
07:52:17 <mattoliverau> Had timburke finished looking? I noticed he was going back and forth for a while on it
07:52:18 <cschwede_> kota_: no worries!
07:52:53 <acoles> notmyname: do you mean part power increase ^^ ?
07:52:57 <kota_> notmyname: yeah, i could look at *the increase part power*
07:53:12 <cschwede_> mattoliverau: maybe - he updated the patch a while ago and fixed a few things
07:53:12 <kota_> that's fair
07:53:26 <notmyname> yes, I mean part power increase :-)
07:53:41 <mahatic> :)
07:54:30 <mahatic> I think we have another 5 mins
07:54:32 <acoles> kota_: thanks!
07:54:39 <mahatic> notmyname: you had something to ask?
07:54:53 <notmyname> it kinda got covered
07:55:15 <mahatic> okay
07:55:20 <acoles> more positive news ... we have in last few weeks landed composite ring support and per-policy affinity config which are both pieces of work that Kota started a long time ago :)
07:56:02 <mattoliverau> \o/
07:56:04 <rledisez> as it's open discussion, I have two patches related to cname_lookup/domain_remap that got +2 from tim, waiting for a an other reviewer from +1 workflow :)
07:56:07 <kota_> yey, thanks acoles for helping it's done!
07:56:08 <mahatic> congrats kota_ ! and of course everyone else who helped get it merged
07:56:09 <rledisez> one is bugfix: https://review.openstack.org/#/c/435771/
07:56:09 <patchbot> patch 435771 - swift - Rewrite redirection in cname_lookup & domain_remap
07:56:25 <rledisez> and other a new feature: https://review.openstack.org/#/c/435768/
07:56:25 <patchbot> patch 435768 - swift - Allow to configure the nameservers in cname_lookup
07:57:05 <rledisez> if anybody got some times to have a look, that would be awesome :)
07:57:37 <mattoliverau> Will try :)
07:58:00 <rledisez> thx mattoliverau
07:58:08 <acoles> rledisez: I have them starred, will try to get round to them soon
07:58:11 <notmyname> mattoliverau: you've already promised to loot at at least 2 others!
07:58:22 <notmyname> s/loot/look/
07:58:25 <mattoliverau> That's why I said I'll try ;)
07:58:27 <mahatic> I could try and look at one of those
07:58:36 <notmyname> mahatic: thanks
07:58:44 <rledisez> thx mahatic
07:59:08 <mahatic> okay, if that's all we have - let's conclude
07:59:25 <mahatic> thanks so much for coming, it was a great first start to a new TZ meeting :)
07:59:34 <acoles> mahatic: well done!
07:59:39 <mattoliverau> Nice work mahatic!
07:59:39 <rledisez> thx mahatic for chairing
07:59:48 <kota_> thanks mahatic!
08:00:03 <notmyname> mahatic: thanks for chairing and leading the whole group to set this up!
08:00:21 <mahatic> thank you too for making it a great start!
08:00:29 <mahatic> notmyname: thanks for your help!
08:00:39 <mahatic> #endmeeting