21:00:48 <notmyname> #startmeeting swift
21:00:49 <openstack> Meeting started Wed May 18 21:00:48 2016 UTC and is due to finish in 60 minutes.  The chair is notmyname. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:53 <openstack> The meeting name has been set to 'swift'
21:00:55 <notmyname> who's here for the swift meeting?
21:00:57 <mattoliverau> o/
21:00:59 * onovy 
21:01:00 <jrichli> o/
21:01:03 <pdardeau> o/
21:01:04 <kota_> o/
21:01:06 <hurricanerix> \o/\
21:01:07 <hosanai> o/
21:01:15 <bkeller`> o/
21:02:18 <notmyname> agenda this week is
21:02:19 <notmyname> #link https://wiki.openstack.org/wiki/Meetings/Swift
21:02:26 <acoles> hi
21:02:37 <joeljwright> evening
21:03:00 <ntata|> o/
21:03:04 <cutforth> o/
21:03:52 <torgomatic> .
21:04:01 <notmyname> ok, we can get started I think
21:04:16 <notmyname> not a ton on the agenda this week
21:04:23 <notmyname> #topic crypto update
21:04:30 <notmyname> #link https://trello.com/b/63l5zQhq/swift-encryption
21:04:41 <notmyname> acoles: jrichli: what's going on this week with crypto?
21:05:17 <acoles> well, the todo list has been going down and there's a bunch of patches waiting review
21:05:25 <acoles> the top 3 are on priotity reviews page
21:05:46 <acoles> including one that needs no crypto knowledge to review, patch 316924
21:05:46 <patchbot> acoles: https://review.openstack.org/#/c/316924/ - swift (feature/crypto) - crypto - make some probe tests compatible with crypto
21:06:00 <mmotiani> \o/
21:06:14 <notmyname> great
21:06:42 <acoles> we now have copy middleware and therefore func tests pass and we have crypto in pipeline for jenkins functional test jobs on feature/crypto :)
21:06:56 <jrichli> woohoo!
21:07:27 <notmyname> cool
21:07:27 <acoles> and if that patch 316924 lands then we have a good story on probe tests
21:07:28 <patchbot> acoles: https://review.openstack.org/#/c/316924/ - swift (feature/crypto) - crypto - make some probe tests compatible with crypto
21:08:32 <acoles> jrichli has been collatingsome questions for "crypto experts" to validate our final choices over how we handle key and iv, ready for final review
21:08:57 <notmyname> good. jrichli when/how is that happening?
21:09:20 <jrichli> the strategy involves both etherpad and the doc in review
21:09:32 <jrichli> and some email and pings on IRC
21:10:03 <jrichli> i wasn't planning on a meeting yet - got to get everyone on same page on what we are doing now first, i guess
21:10:05 <jrichli> we
21:10:18 <jrichli> we'll decide from then if a meeting needs to happen.  prob will
21:10:31 <notmyname> ok
21:11:04 <acoles> notmyname: so although we are closer to being ready for final review, in that tasks are being addressed at a good rate, we have a review backlog to get through on feature/crypto before I can start to prepare for a feature/crypto-review branch
21:11:11 <notmyname> looking at the TODO list on the trello page, the only one that looks tricky is the PUT is really post-as-copy
21:11:34 <notmyname> acoles: ok. you're reading my mind. I was going to ask that :-)
21:11:35 <acoles> notmyname: ah,  i wanted to raise that for opinions here
21:12:22 <acoles> currently a post-as-copy will cause a previously unencrypted object body to get encrypted (as it is copied), which differs from a fast-post
21:12:56 <notmyname> right. makes sense
21:13:29 <acoles> we think we know how to prevent that (more code!) but question is do we care? on one hand I feel it is inconsistent wrt fast post, on other hand clients cannot tell, its an internal anomaly
21:14:19 <acoles> and I could even buy an argument that if something is unencrypted and we get chance to encrypt it then we should!
21:14:20 <notmyname> what's the end result? a POST may or may not be (re-)encrypted?
21:14:34 <notmyname> but otherwise everything works?
21:15:16 <acoles> an already encrypted object will always remain encrypted after a POST, an unencrypted object will become encrypted by post-as-copy
21:15:32 <jrichli> but not fast-post
21:15:32 <torgomatic> doesn't matter to me... you copy A to B, GET B, and A's contents come back
21:15:42 <torgomatic> what's not to like?
21:15:48 <notmyname> and unencrypted object with fast-post will have encrypted metadata and listing info?
21:15:50 <acoles> otherwise it all works, and client cannot tell
21:16:10 <jrichli> notmyname: yes
21:16:13 <acoles> notmyname: just encrypted metadata, thelisting etag does not change on a fast-post
21:16:19 <notmyname> ok
21:16:22 <notmyname> my gut reaction is that I'm completely fine with crypto only ever working with fast-post. so yeah, sounds like a non-issue to me. it Just Works
21:16:24 <jrichli> ok, partly right ;-)
21:17:15 <acoles> I am obviously biased towards not writing more code.
21:17:27 <mattoliverau> lol
21:17:28 <notmyname> I mean that I would be fine if you told me that crypto is broken with post-as-copy. so I'm definitely ok with it working with both fast-post and post-as-copy, evne if they have slightly different internal effects
21:17:49 <notmyname> yes! definitely write less code :-)
21:18:02 <acoles> ok. any contrary opinions?
21:18:04 <jrichli> since we are going in that direction anyway, i will also bring up the fact that it has been expressed that those that really want to ensure all data is encrypted will no be starting with pre-existing unencrypted objs
21:18:53 <jrichli> so, just more reason not to write more code!
21:19:11 <notmyname> acoles: I don't hear any
21:19:24 <mattoliverau> If you've turned on encrypted you want things encrytpted.. if you have objects taht aren't if they start being encrypted even partially then that's what you want.. so I think its ok
21:19:25 <acoles> notmyname: that's helpful, that was probably one of the bigger/trickier remaining todo's.
21:19:47 <notmyname> #agreed crypto doesn't need to detect if a PUT is from a POST-as-COPY
21:19:48 <jrichli> and now its the easiest!
21:20:01 <acoles> notmyname: coding todo's that is, we have lots of reviewing todo's ;)
21:20:10 <notmyname> :-)
21:20:32 <notmyname> ok, so the top 3 reviewing todos are the ones on the priority reviews page?
21:20:35 <jrichli> i know!  i keep adding to my list to review throughout the day - the stack is not shrinking
21:20:38 <notmyname> #link https://wiki.openstack.org/wiki/Swift/PriorityReviews
21:21:46 <acoles> notmyname: yes, and i know I have mentioned it before but I'd really appreciate feedback on patch 316924 (probe test changes) because if the approach I have there is not acceptable then I need to think really hard
21:21:46 <patchbot> acoles: https://review.openstack.org/#/c/316924/ - swift (feature/crypto) - crypto - make some probe tests compatible with crypto
21:22:20 <jrichli> acoles: added to the top of my stack
21:22:28 <acoles> and thinking is even harder than coding!
21:22:36 <joeljwright> :)
21:22:55 <timburke> acoles: the approach seems sane to me. i should actually run the probe tests for that one...
21:23:02 <notmyname> acoles: jrichli: thanks for the update
21:23:08 <notmyname> now speaking of priority reviews...
21:23:16 <notmyname> #topic review the reviews
21:23:26 <notmyname> looking at https://wiki.openstack.org/wiki/Swift/PriorityReviews
21:23:37 <notmyname> last week we had some busted probetests
21:23:45 <notmyname> I think those are all ok now, right?
21:24:19 <jrichli> those problems were fixed, but i have had more lately - but it might just be me
21:24:20 <acoles> I reviewed something to fix a probe test today, testing expirer
21:24:36 <kota_> ah, yeah, that's my fault.
21:24:52 <acoles> patch 318167
21:24:52 <patchbot> acoles: https://review.openstack.org/#/c/318167/ - swift (feature/crypto) - crypto - test varying proxy pipeline configs
21:25:03 <acoles> no not that! sorry
21:25:32 <kota_> patch 315918
21:25:32 <patchbot> kota_: https://review.openstack.org/#/c/315918/ - swift - Fix probe failure and small things
21:25:40 <acoles> yes, that ^^
21:25:47 <notmyname> got it
21:25:59 <notmyname> I'll make sure that's on the priority reviews page, too
21:26:13 <jrichli> i saw that one, and i ran with those changes to see if my issues were fixed.  seems like i still had issues, but i will test that again and leave comments.
21:26:21 <notmyname> makes me think we should reexamine getting the probetests running in the gate
21:26:25 <notmyname> jrichli: thanks
21:26:44 <acoles> jrichli: i think it could be racey as it is now
21:26:58 <notmyname> patch 238799 has some comments and has a merge conflict
21:26:58 <patchbot> notmyname: https://review.openstack.org/#/c/238799/ - swift - Change schedule priority of daemon/server in config
21:27:07 <notmyname> onovy: is it something peter will be able to look at again?
21:27:12 <notmyname> peterlisak: ^
21:28:34 <notmyname> ok, I'm going to assume "no" then
21:29:17 <notmyname> we might need to bug someone to take that over. mattoliverau were your review comments something that would be reasonable to write and push over the current version?
21:30:06 <mattoliverau> yeah
21:30:24 <notmyname> mattoliverau: ok. might be good to do that in order to move it forward
21:30:58 <notmyname> I'll also add patch 317475 to the priority page. looks like a rather ugly bug
21:30:58 <patchbot> notmyname: https://review.openstack.org/#/c/317475/ - swift - Send correct size in POST async update for EC object
21:31:03 <notmyname> acoles: thanks for picking that one up
21:31:18 <mattoliverau> notmyname: let me take a look at it again. If no one else will I'll rebase and push up a new patchset and we can take it from there.
21:31:19 <acoles> notmyname: i caused it :/
21:31:42 <notmyname> acoles: but importantly you're solving it :-)
21:32:14 <notmyname> container sync and crypto stuff on the priority reviews page i'll leave as-is
21:33:06 <notmyname> somewhat related to the priority reviews page (and as a small status update from me)...
21:33:21 <notmyname> if you haven't seen it already, I added a new section to http://not.mn/swift/swift_community_dashboard.html
21:34:00 <notmyname> the "needs follow-up" is a list of patches that has had reviews but doesn't have any reviews on the current patch set
21:34:42 <notmyname> ie stuff where the patch owner has been doing stuff but is likely waiting on reviews
21:35:12 <notmyname> and although not published in a web page or irc bot yet, I've also built on that to build some personalized lists
21:35:25 <notmyname> (I talked about this some in bristol)
21:35:59 <jrichli> nice
21:36:14 <notmyname> so eg stuff that you own that has a negative review or stuff that youv'e starred but haven't reviewed
21:36:41 <notmyname> and I'll be working on some more complicated things like stuff you've previously negatively reviewed but has a new patch set
21:36:54 <notmyname> all sorted by the community stars. etc etc
21:36:58 <notmyname> still WIP :-)
21:37:24 <mattoliverau> cool
21:37:31 <notmyname> #topic next release
21:37:42 <notmyname> I'd like to have a release *before* we land crypto
21:38:00 <notmyname> or rather, not wait until crypto lands to do a release
21:38:24 <notmyname> AFAICT patch 317475 is the biggest thing not landed that should
21:38:25 <patchbot> notmyname: https://review.openstack.org/#/c/317475/ - swift - Send correct size in POST async update for EC object
21:38:37 <notmyname> but if there's other stuff, please let me know
21:39:31 <notmyname> does that sound reasonable? any reason to rush one out now or wait until crypto lands?
21:40:38 <notmyname> nobody is very chatty today ;-)
21:41:03 <mattoliverau> sounds reasonable. Sorry -ETOOEARLY :P
21:41:17 <mattoliverau> was just looking at open patches
21:41:19 <jrichli> +1
21:41:19 <kota_> hehe, nothing special to push for it :)
21:41:29 <notmyname> :-)
21:41:32 <notmyname> ok, a couple of miscellaneous things before talking about the state of golang
21:41:38 <notmyname> #topic misc stuff
21:41:58 <notmyname> yesterday was swift's "birthday". six years in production
21:42:08 <kota_> congrats!
21:42:21 <mattoliverau> \o/
21:43:06 <m_kazuhiro> congrats!!
21:43:10 <notmyname> it's pretty cool, I think. and the fact it's still a thing that people are using and taking into account is a huge testament to the people who are writing and reviewing the code. thanks for your work
21:43:53 <notmyname> has anyone tried putting swift on 16.04 yet? I've been putting together a new SAIO on 16.04
21:44:19 <notmyname> for me, it's working pretty well so far. just a couple of weird new things that I need to transcribe into the SAIO docs, but nothing major
21:44:42 <mattoliverau> I haven't yet.
21:45:10 <notmyname> well I was still on precise so I figured after 4 years it was a good time to upgrade :-)
21:45:32 <notmyname> quick note about the hackathon
21:45:41 <mattoliverau> I tried an openstack-ansible AIO on 16:04 and had some issues, but they I think is me and nothing to do with Swift. :)
21:46:12 <notmyname> basic info is july 11-14 in san antonio. rackspace is sponsoring and hurricanerix is doing all the logistics coordination
21:46:12 <mattoliverau> s/they/that/
21:46:35 <mattoliverau> thanks hurricanerix!
21:46:43 <notmyname> like normal, we'll have an eventbrite page set up for registrations and likely some sort of cap on how many
21:46:43 <hurricanerix> mattoliverau np
21:46:48 <kota_> \o/
21:46:50 <notmyname> I'm working with hurricanerix to get all those details
21:47:05 <mattoliverau> hmm, that sounds like I'll be flying home on my birthday.. that's exciting :P
21:47:07 <notmyname> thanks hurricanerix :-)
21:47:18 <notmyname> mattoliverau: maybe you'll have 2 if you time it right?
21:47:19 <joeljwright> good luck hurricanerix!
21:47:33 <mattoliverau> notmyname: wrong way. there is a chance I'd miss it :P
21:47:38 <notmyname> lol
21:47:43 <hurricanerix> thanks, jrichli gave me her checklist, which is making this much easier.
21:47:55 <acoles> mattoliverau: do that every year and stay forever young
21:47:58 <jrichli> yw
21:48:09 <notmyname> I'll pass out more info on the hackathon as we have it
21:48:20 <mattoliverau> lol, yeah if your birthday day doesn't actually happen, do I get to stay younger?
21:48:27 <notmyname> of course!
21:48:29 <notmyname> #topic what's up with the whole golang conversation?
21:48:51 <hurricanerix> and if anybody has any questions or requests, feel free to pm/email me
21:48:52 <notmyname> so there's been a *huge* mailing list thread and several rather intense IRC meeting discussions
21:49:36 <notmyname> nothing is "decided" per-se, but many of the cross-project teams are working on figuring the details of what supporting golang means
21:50:15 <notmyname> eg we've got to figure out how we identify dependencies and have some sort of reproducable builds. and how to run golang tests in the -infra environment. and how to find and build docstring-style docs
21:50:19 <notmyname> stuff like that
21:50:23 <notmyname> so those are going well, I think
21:50:40 <notmyname> the TC meeting this week, however, was...interesting
21:51:28 <notmyname> basically it very quickly got steered from "do we support golang" to "what *is* openstack and is it ok to actually have a dataplane service project in openstack or not"
21:52:01 <mattoliverau> wow
21:52:02 <notmyname> there will likely be another (very long) email thread about this question in the near future
21:52:08 <notmyname> mattoliverau: yeah. wow
21:52:37 <redbo> I still say we were here first, and they should be the ones to leave.
21:52:41 <notmyname> lol
21:52:44 <nadeem> ha ha
21:52:44 <joeljwright> hahaaha
21:52:48 <mattoliverau> redbo: rofl
21:52:52 <notmyname> I actually don't htink anyone is going to leave :-)
21:53:04 <notmyname> so, because there's a whole lot of different things being said, I wanted to be available to answer any questions you have about it, if you've been paying attention
21:53:30 <nadeem> but reading through tc meeting logs...it seems like some guys want Swift to leave openstack
21:54:20 <bkeller`> i think it's more of they want the front-end of swift to stay, but the back-end (which we'd be porting to go) should be its own separate service
21:54:21 <notmyname> nadeem: I'm not sure that's the case. I do think there's some misconceptions and a perception that "swift is different"
21:54:49 <notmyname> bkeller`: and that's the misconception, I think. where the (rather arbitrary) line between front-end and back-end is
21:54:52 <nadeem> yep true
21:55:16 <notmyname> so that's part of what I'm trying to work with a few people on the TC and in defcore about
21:56:08 <notmyname> as of now, with the current defcore standard, you can run swift on top of some other system and still pass defcore. however, that doesn't mean swift is an object storage provisioning service
21:56:11 <nadeem> notmyname: I would say you did a good job on all of this.
21:56:21 <notmyname> nadeem: thanks. still trying to figure out most of it as I go :-)
21:57:04 <notmyname> if anyone does have concerns, please feel free to ask me publicly or privately. concerns with either what other people are saying or with what i'm saying
21:57:10 <redbo> Does that mean all the other projects would have to spin off their default backends?  Like keystone's mysql backend and cinder's lvm backend?
21:57:50 <notmyname> redbo: actually i think the extreme conclusion is that swift would become like mysql or lvm (a service that is used but not part of openstakc)
21:58:09 <notmyname> now, I don't htink that will actually happen, but it is the logical conclusion of one answer
21:58:32 <notmyname> redbo: at least, that's how ttx presented it in the TC meeting
21:59:19 <notmyname> personally, I'm not sure why this conversation needs to be had or needs to be had at this particular time. I'm not sure of the actual problem that's being solved or the issue that's actually broken
21:59:52 <notmyname> there are about zero people who have actually approached me to talk about these things, although i have had several people relay these things to me anonymously
22:00:23 <notmyname> so in general, stuff is happening. we;ll see where it goes. I'm not particularly worried about swift's place in openstack in the future
22:00:34 <notmyname> and I'd be happy to talk with you if you want to go over it more
22:00:58 <mattoliverau> sorry I'm dumbfounded with the craziness.
22:01:10 <notmyname> heh. me too, sometimes :-)
22:01:17 <notmyname> looks like we're over time
22:01:25 <mattoliverau> notmyname: thanks as always for being the voice and taking the swift fight
22:01:38 <jrichli> +2
22:01:40 <pdardeau> notmyname: maybe we can have group therapy at hackathon ;)
22:01:41 <joeljwright> notmyname: I'll second that - thanks
22:01:43 <notmyname> thank you for your participation and work on swift. 6 years now!
22:01:48 <notmyname> pdardeau: lol
22:01:48 <redbo> Yeah
22:01:54 <redbo> I've been working on it for 7 years :(
22:02:00 <notmyname> I appreciate your support :-)
22:02:05 <notmyname> redbo: 6.5 for me :-)
22:02:13 <notmyname> #endmeeting