18:07:33 <SotK> #startmeeting storyboard
18:07:34 <openstack> Meeting started Thu Feb 11 18:07:33 2021 UTC and is due to finish in 60 minutes.  The chair is SotK. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:07:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:07:38 <openstack> The meeting name has been set to 'storyboard'
18:07:44 <SotK> #link https://wiki.openstack.org/wiki/Meetings/StoryBoard#Agenda_for_next_meeting Agenda
18:08:22 <SotK> #topic AngularJS EOL solutions
18:08:54 <SotK> last meeting we decided that we're going to use Vue to create a replacement webclient
18:09:04 <SotK> I think we wanted to think about next steps today?
18:11:01 <diablo_rojo> Yes
18:11:03 <diablo_rojo> that is correct
18:11:37 <diablo_rojo> I have started to look over basic vue tutorials but I obviously have a lot of work to do to catch up.
18:11:55 <diablo_rojo> I wonder how much of your POC we can use for realsies?
18:13:29 <SotK> hopefully a reasonable chunk at least, or we can try to use it as a base and just iterate further on it
18:13:45 <SotK> it currently lives here: https://gitlab.com/SotK/sb-vue
18:13:57 <SotK> #link https://gitlab.com/SotK/sb-vue Vue prototype
18:14:27 * diablo_rojo closes Othello wiki article and opens link SotK provided
18:14:33 <SotK> :D
18:15:05 <SotK> if we want to go for an "iterate on it" approach then I think the first step is moving it to opendev.org rather than my personal gitlab
18:15:14 <SotK> namespace
18:16:33 <diablo_rojo> I think that sounds good.
18:17:11 <diablo_rojo> Do we want to like.. Make a new repo in opendev and then do renames?
18:17:17 <diablo_rojo> Or how would that work exactly?
18:18:03 <SotK> we can just add a project in the opendev config and then push that repo in when it gets created I assume
18:18:20 <SotK> though I should probably add a license first :D
18:20:39 <diablo_rojo> Yeah that might be a good idea lol
18:20:53 <diablo_rojo> Okay well I can look into getting the opendev repo added.
18:22:17 <diablo_rojo> You can make that an action item
18:22:22 <diablo_rojo> hold me accountable lol
18:22:25 <fungi> what do we want it called?
18:22:36 <fungi> storyboard-vue?
18:22:43 <fungi> storyboard-webclient-ng?
18:23:07 <fungi> or should it be a feature branch of storybaord-webclient?
18:25:42 <SotK> a new repo feels cleanest to me if we're iterating on the current prototype, there'll be minimal to no code reuse probably
18:26:39 <SotK> maybe storyboard-vue-client or similar
18:26:47 <SotK> though I can see value in reusing the existing repo
18:27:48 <diablo_rojo> I feel like storyboard-vue-client is good
18:30:59 <fungi> i'm cool with whatever you prefer
18:33:43 <SotK> lets make storyboard-vue-client then I think
18:34:43 <fungi> wfm
18:36:07 <SotK> #action diablo_rojo will make a storyboard-vue-client repo for us to push the existing prototype for further iteration
18:38:33 <SotK> I guess another next step is I'll make some stories in storyboard once we have a project
18:42:18 <SotK> then I guess next week we can do some thinking about what to work on on that side of things
18:42:45 <SotK> do either of you have other next steps ideas?
18:43:51 <fungi> not really, but diablo_rojo, give me a heads up when the new project creation change is up so i can review it asap
18:44:49 <fungi> we'll also want to adjust the container image building/publication jobs in the opendev/storyboard repo to add a container for it, i guess
18:45:14 * diablo_rojo is back from signing for a package
18:45:15 <diablo_rojo> sorry!
18:45:20 * diablo_rojo catches up
18:45:39 <diablo_rojo> fungi, I will make sure to add you as a reviewer :)
18:46:05 <diablo_rojo> SotK, I guess you need to get a license on that while I am working on the repo?
18:46:25 <SotK> yeah, I'll push something later
18:47:40 <diablo_rojo> Cool. Then I think we are good to go.
18:48:36 <SotK> I agree
18:48:39 <SotK> #topic Open Discussion
18:49:02 <SotK> anything else people want to discuss?
18:49:05 <diablo_rojo> I've got nothing.
18:49:18 <diablo_rojo> Well, I have many todos, but not much to discuss lol
18:50:01 <SotK> in that case
18:50:05 <SotK> #endmeeting