15:01:15 <Zara> #startmeeting storyboard
15:01:16 <openstack> Meeting started Wed Nov  9 15:01:15 2016 UTC and is due to finish in 60 minutes.  The chair is Zara. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:20 <openstack> The meeting name has been set to 'storyboard'
15:01:35 <Zara> #topic Announcements
15:01:45 <Zara> I don't believe we have any, although I was on holiday last week
15:01:52 <SotK> o/
15:01:58 <Zara> hi there
15:01:59 <SotK> (I don't think we have any either)
15:02:01 <Zara> okay
15:02:06 <Zara> #topic Urgent Items
15:02:19 <Zara> None noted
15:02:25 <Zara> #topic In-Progress Work
15:02:46 <Zara> Agenda lists me as updating webclient components, though currently i'm working through my massive review backlog
15:03:16 <Zara> it occurs to me now that perhaps we should have announced boartty just now. I feel like jeblair should pick when to announce, though :)
15:03:28 * SotK feels like that too
15:04:00 <SotK> I did a bunch of search stuff, which is probably part of Zara's backlog
15:04:04 <Zara> yep :)
15:04:15 <Zara> the goal is to be able to save search queries, right?
15:04:35 <Zara> actually, that was in my backlog, but I believe you're reworking one of those patches
15:04:43 <Zara> *at least one
15:04:47 <SotK> indeed
15:04:55 <SotK> (to the latter point)
15:05:05 <Zara> okay, cool, wanted to check I was right not to have it flagged as something I needed to get to
15:05:15 <SotK> s/save/bookmark/, but yeah
15:05:49 <SotK> it'd be nice to be able to save queries you want to quickly go to or save them to your dashboard or something, btu that is fuuuuture
15:06:08 <persia> Do we expect the format to also be sensibly concise to facilitate sharing (e.g by pasting a URI to IRC)?
15:06:23 <Zara> (oh, yeah, I meant link a query for others or save it somewhere on your own computer, not save within storyboard)
15:06:51 <SotK> persia: that depends how long is too long
15:06:55 <Zara> (once you're saving within sb, it feels like a worklist is more appropriate anyway, though I might be ignoring a case)
15:07:27 <persia> SotK: At least: fits within freenode's maximum line limits.  Ideally, shorter than LP URLs.
15:08:05 <SotK> do you have a LP URL example handy?
15:08:15 * persia gets one
15:08:37 <persia> https://bugs.launchpad.net/nova?field.searchtext=scheduling&search=Search&field.status:list=NEW&field.status:list=INCOM
15:09:16 <persia> Obviously, more complex queries with more criteria are longer, etc.
15:09:23 <clarkb> its irc that limits and its to 512 bytes including the PRVMSG prefix and destination details
15:09:38 <clarkb> so longer channel names means shorter messages
15:09:46 <persia> clarkb: So 400-450 is a sensible maximum?
15:10:14 <clarkb> that should be plenty conservative
15:10:54 <SotK> I can't see them being longer than 400 characters, but I'll keep it in mind... they probably will be similar in length to the LP ones sadly (perhaps shorter by virtue of shorter parameter names)
15:11:07 <SotK> maybe storyboard needs a url shortening method :D
15:11:47 <Zara> aw, you mean we can't just use shadyurl? :D
15:13:44 <persia> LP ones used to be much longer, so my expectations when I got that URL were much worse than it was in practice.  SImilar length to that seems reasonable (and likely to be compatible with current team practices)
15:14:29 <persia> The key is really to make sure that there aren't empty parameters for all the queries that aren't currently being performed, or similar.
15:15:08 <Zara> sounds like folks generally agree on this
15:15:31 <Zara> other in progress work I have listed... removing the incubated oslo code
15:15:42 <Zara> dhellman has been doing that for us, thanks, dhellman! :D
15:16:14 <Zara> I'm steadily working through the patches; https://review.openstack.org/#/c/394570/ is the next waiting one
15:17:05 <Zara> I think after that, there's one more for storyboard, and one for python-storyboardclient
15:17:09 <persia> The nice thing about those is that they are fairly obvious :)
15:17:20 <Zara> yep
15:18:21 <Zara> I believe the other thing I have outstanding in my review backlog is the review for adding teams to private stories
15:19:24 <Zara> oh, and I need to poke betherly about those headings in the less/sass patch
15:19:29 <Zara> well now i'm just talking to myself
15:19:48 <Zara> we ready to move on to discussion? any other in-progress work anyone wants to mention?
15:21:01 <Zara> #topic Discussion
15:21:25 <Zara> So, here I have noted 'summit recap'
15:23:31 <Zara> plan is to continue to follow the task-tracking spec: https://review.openstack.org/#/c/314185/2/specs/task-tracker.rst for migration , updating assignees
15:23:50 <Zara> oops, linked old version
15:24:13 <Zara> https://review.openstack.org/#/c/314185/5/specs/task-tracker.rst
15:25:07 <Zara> there'll probably be more on this in coming weeks; people are pretty busy right now and distracted with the end of the world
15:25:14 <SotK> there were some things we thought may be blockery on the etherpad from our session I think?
15:25:37 <Zara> ah yeah, opinions differed on how blockery
15:25:55 <SotK> do you have a link for it handy?
15:26:00 * SotK doesn't
15:26:11 <Zara> nope, but just found it again
15:26:13 <Zara> #link https://etherpad.openstack.org/p/ocata-infra-community-task-tracking
15:26:23 <SotK> thanks :)
15:28:31 <Zara> so I think we can look forward to more cross-project discussion to arrive at a list
15:29:23 <Zara> anyone have anything to add on that?
15:29:58 <SotK> I don't think so
15:30:10 * SotK is also looking forward to discussions
15:31:22 <Zara> :) okay, open discussion time!
15:31:26 <Zara> #topic Open Discussion
15:31:34 <Zara> I forgot to put this on the agenda...
15:32:06 <Zara> SotK and I are hoping to move this meeting to a slot between 19:00UTC and 21:00UTC
15:32:18 <Zara> at a glance, 19:00UTC Weds loooooks like it's free
15:32:27 <SotK> if free that sounds great
15:33:08 <Zara> I did ctrl+f on the meetings page
15:33:18 <Zara> it wasn't the most rigorous survey
15:33:39 <Zara> I would like to keep the same day and channel if possible; easier to remember if it just moves a few hours
15:33:48 <persia> 1900UTC Wednesday is good for me, although I don't always attend, so I'm not sure whether that should affect a decision.
15:35:39 <Zara> well, we're the ones here right now, so based on that, roll on 19:00UTC (well, I'll ask in #infra about it, anyway)
15:38:33 <fungi> seems fine to me
15:39:17 <fungi> though i mostly just tend to pop in when someone prods me, i keep meaning to lurk more actively and consistently
15:40:11 <SotK> Zara: would you like to propose the patch to the schedule or shall I?
15:40:57 <Zara> fungi: heh, np, I still appreciate being able to ping when necessary! :)
15:41:25 <Zara> SotK: if you can remember where it lives, feel free, otherwise I'll find it later.
15:43:51 <Zara> that sounds straightforward, anyway, yay :) my ctrl+f suggested we could probably find another suitable slot without too much trouble if that doesn't work
15:44:26 <persia> IT may be useful to use #agreed and #action at this point for the minutes :)
15:44:45 <Zara> ah yeah, thanks (I kept forgetting #link before, too
15:45:07 <Zara> #agreed StoryBoard meeting to shift to 19:00UTC in #openstack-meeting, weekly on Wednesdays
15:45:34 <Zara> #action Zara or SotK to update the meetings schedule to reflect StoryBoard meeting move
15:46:04 <Zara> normally 'x or y' actions are a bad idea, but I think we'll be fine
15:47:19 <persia> In case anyone is hunting, it's in openstack-infra/irc-meetings @ meetings/storyboard-meeting.yaml
15:47:23 <Zara> ah, thanks
15:47:54 <SotK> #link https://review.openstack.org/395678
15:47:57 <Zara> hopefully we can change it for next week's meeting (in which case, I'll send a mail out
15:48:00 <Zara> )
15:49:46 <Zara> okay, any more discussion points?
15:52:50 * Zara assumes not
15:52:53 <Zara> meeting ends in 5
15:52:53 <Zara> 4
15:52:54 <Zara> 3
15:52:55 <Zara> 2
15:52:55 <Zara> 1
15:52:58 <Zara> END!
15:53:03 <Zara> #endmeeting