15:02:10 <Zara> #startmeeting storyboard
15:02:10 <openstack> Meeting started Wed Jan  6 15:02:10 2016 UTC and is due to finish in 60 minutes.  The chair is Zara. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:13 <openstack> The meeting name has been set to 'storyboard'
15:02:34 <Zara> # Announcements
15:03:05 <Zara> Not much to announce... this is our first meeting after the holidays!
15:03:17 <betherly> sure :) hope yours was good!
15:03:27 <betherly> happy new year!
15:03:33 <Zara> it was, you too! so yeah, we're around again if people have questions etc.
15:03:53 <Zara> # Urgent Items
15:04:18 <Zara> Nothing critical, though we have several things in review. Will come back to them
15:04:27 <Zara> since I've already written a bunch of notes on current work...
15:04:43 <Zara> # In Progress Work
15:05:19 <Zara> ookay, lots here! as I mentioned, SotK is ill this week, so hard to give all the details, but I can link to the patches!
15:05:38 <betherly> great ok :)
15:05:44 <Zara> # info several worklists and boards patches awaiting review
15:06:04 <Zara> misc patches here (I also need to get to them, sorry!):
15:06:04 <Zara> #link https://review.openstack.org/#/c/263761/
15:06:04 <Zara> #link https://review.openstack.org/#/c/263728/
15:06:05 <Zara> #link https://review.openstack.org/#/c/263717/
15:06:14 <Zara> they're various tweaks for UX for making new worklists and boards,
15:06:15 <Zara> should make things more usable.
15:06:36 <Zara> SotK's other work in progress as listed in agenda is email notifications-- this is exciting!
15:06:56 <Zara> we got a lot done right before the holidays so it might not have been recorded very well...
15:07:11 <Zara> anyway, patches currently in review:
15:07:13 <betherly> what is the status on notifications at the moment?
15:07:26 <Zara> #link https://review.openstack.org/#/c/263304/
15:07:26 <betherly> or is that worth waiting for SotK to be back to ask?
15:07:27 <Zara> #link https://review.openstack.org/#/c/241665/
15:07:33 <Zara> I have a wall of text on that
15:07:36 <Zara> !
15:07:55 <Zara> though I think there will be plenty of gaps that SotK can fill in
15:08:14 <betherly> awesome thanks!
15:08:17 <Zara> wall of text incoming!
15:08:17 <Zara> to recap about the second patch: we're holding off merging the
15:08:17 <Zara> button for choosing to subscribe to email notifications, because
15:08:17 <Zara> 1) openstack infra is a big storyboard user, and doesn't have
15:08:17 <Zara> those notifications enabled in puppet yet (see first patch!), so
15:08:20 <Zara> it could mislead users into thinking the feature is active.
15:08:22 <Zara> 2) currently there's just one button to turn emails on/off.
15:08:25 <Zara> we don't yet have templates for all things that can be updated
15:08:27 <Zara> via user preferences, and we don't want to mislead users into
15:08:30 <Zara> thinking they'll get notifications for those things before that is
15:08:32 <Zara> the case. so either we want a bunch of checkboxes for all active
15:08:35 <Zara> possible notifications, or we want one box (and notifications will
15:08:37 <Zara> just overlap with user preferences).
15:08:44 <Zara> didn't want to type all that in realtime, hopefully explains those patches at least
15:08:53 <Zara> things are moving forwards
15:09:57 <Zara> need to update roadmap in line with that, given that's listed as my current work on the agenda... in practise this week I've been reviewing and working on a misc patch, so I should get back to the roadmap after the meeting
15:10:30 <Zara> #action Zara to update roadmap after meeting
15:10:53 <SotK> Yeah, I plan to throw together some more templates and get the plugin configured in storyboard.o.o soon, then we can merge the patch that adds the preference option
15:11:01 <Zara> #info notifications are making steady progress!
15:11:08 <Zara> a zombie appears!
15:11:26 <SotK> sure feels that way :)
15:11:34 <Zara> :( hope you feel better soon
15:11:41 <Zara> also hope you didn't catch my cold
15:13:31 <Zara> there are various misc patches from both SotK and myself at
15:13:31 <Zara> #link https://review.openstack.org/#/q/project:+openstack-infra/storyboard+status:open
15:13:31 <betherly> get well soon SotK
15:13:34 <Zara> #link https://review.openstack.org/#/q/project:+openstack-infra/storyboard-webclient+status:open
15:15:40 <Zara> btw, I wonder if it's worth it for me to look at doing some of the templates this afternoon? I'd assumed it was a pretty quick job and by the time I'd worked it out you'd've done it, since you'd already started, but if you're ill I could make a start. might just end up duplicating effort, though.
15:16:02 <SotK> sounds like a good idea to me :)
15:16:08 <Zara> okay, will take a look
15:16:13 <SotK> thanks
15:16:25 <Zara> #action Zara will also look at making some email templates
15:16:40 <Zara> haha, don't thank me until I manage to make some, lol
15:17:12 <Zara> I think that's all the in-progress stuff...
15:17:21 <Zara> no discussion topics listed, so...
15:17:32 <Zara> #Open discussion
15:17:39 <Zara> anyone have anything they want to discuss?
15:19:04 <betherly> just to say I'll be around more for reviewing and submitting code in the next couple of weeks once the ironic plugin starts going upstream
15:19:29 <SotK> \o/
15:19:36 <betherly> once I'm more proactively involved directly I'm sure I'll have more questions and comments moving forward :)
15:19:37 <SotK> it'll be good to have you around :)
15:19:54 <betherly> Ye I'm really excited to work with you both
15:20:04 <Zara> yay! :) if there's anything we can do to help with the ironic plugin, let us know
15:20:55 <Zara> and I'm excited to work with you, too!
15:21:32 <betherly> thanks so much :)
15:22:00 <SotK> me too!
15:22:54 <Zara> ~storyboard is gonna be the very best, that no one ever was~
15:23:15 <Zara> any more things?
15:23:33 <SotK> _o_
15:24:20 <Zara> okay, go back to sleep! or whatever it is you do when you're ill. :P
15:24:40 <Zara> meeting ends in 5...
15:24:47 * SotK disappears again
15:24:50 <Zara> \o/
15:24:52 <Zara> 4...
15:25:01 <Zara> 3...
15:25:06 <Zara> 2...
15:25:10 <Zara> 1...
15:25:15 <Zara> #endmeeting