16:01:11 <ttx> #startmeeting storyboard
16:01:12 <openstack> Meeting started Mon Mar  2 16:01:11 2015 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:16 <openstack> The meeting name has been set to 'storyboard'
16:01:16 <ttx> o/
16:01:17 <SergeyLukjanov> o/
16:01:31 <ttx> who is around for the storyboard meeting?
16:01:43 <yolanda> o/
16:01:44 <jeblair> hi
16:02:00 <ttx> I'll be your host today since krotscheck can't make it
16:02:05 <ttx> expect less fun
16:02:28 <ttx> Agenda:
16:02:36 <ttx> #link https://wiki.openstack.org/wiki/StoryBoard#Meeting
16:02:46 <ttx> #topic Actions from last week
16:02:57 <ttx> "krotscheck: Put GSoC proposals on the wiki."
16:03:08 <ttx> Does anyone know if that was completed ?
16:03:11 * ttx digs the wiki
16:04:14 <ttx> Hmm, I see Michael listed as mentor on https://wiki.openstack.org/wiki/GSoC2015
16:04:26 <ttx> but no idea posted yet
16:04:56 <ttx> I'll update it at the end of the meeting with the suggestions we'll have confirmed from the roadmap analysis
16:05:19 <ttx> #topic Urgent items
16:05:27 <ttx> None were posted to the meeting agenda
16:05:54 <jeblair> i have a last minute one
16:06:07 <ttx> We still have a failure on the js-draft preventing easy review of webclient stuff
16:06:22 <ttx> but krotscheck said it was a bit tricky
16:06:38 <jeblair> apparently the lack of support for timeline paging is causing problems for folks
16:07:12 <ttx> jeblair: what kind of problems ?
16:07:23 <ttx> If they come from Launchpad they can't find it worse
16:07:33 <jeblair> ttx: apparently you can't see beyond X entries when looking at a story
16:07:46 <ttx> jeblair: ah. hm.
16:08:00 <jeblair> i don't know the value of X, but it is low
16:08:11 <jeblair> so if there are more than X timeline events or comments, you can't see them
16:08:40 <jeblair> the server side api implements paging, and so only returns X, but the client side does not, so it only ever retrieves X (it does not know to do another query)
16:08:40 <ttx> jeblair: could we set an arbitrary large number there ?
16:09:16 <jeblair> i proposed 159515 which removes server side paging, krotscheck would like to add client side paging.  perhaps in the mean time we could just set a very high value for the paging value
16:09:34 <jeblair> ttx: yeah, i think that would be fine
16:09:37 <ttx> jeblair: that sounds an appropriate workaround
16:09:41 <jeblair> mostly, i just want to un-break for now
16:09:44 <ttx> right
16:10:00 <jeblair> (and hopefully in the future, not get ahead of ourselves again :)
16:10:02 <NikitaKonovalov> o/ sorry late
16:10:16 <ttx> anyone feels like proposing a quickfix for this ?
16:10:23 <jeblair> i'm not sure if we can do that with local config or if it needs a code change
16:10:36 * ttx looks at 159515
16:11:28 <ttx> set it to CONF.page_size_maximum instead of default
16:12:09 <ttx> "if limit is None: limit = CONF.page_size_maximum" in storyboard/api/v1/timeline.py ?
16:12:22 <jeblair> would it be better to set page_size_default in our config to, eg, 1000?
16:13:06 <ttx> jeblair: that's another way, I just have less idea how far it spreads. What is it set to ?
16:13:12 <ttx> (I mean, currently ?)
16:13:57 <jeblair> ttx: it's commented out, so is the code default:
16:13:57 <jeblair> # page_size_default = 20
16:14:03 <NikitaKonovalov> jeblair: or may be ingonre page size at server-side, and apply paging on client only
16:14:04 <jeblair> so maybe 20?
16:14:29 <NikitaKonovalov> I mean for timeline events only
16:14:51 <jeblair> NikitaKonovalov: i would like to avoid paging altogether, but krotscheck says that server side paging is important for performance for stories with many events.
16:15:02 <jeblair> NikitaKonovalov: so the client can load something and display it quickly
16:15:20 <NikitaKonovalov> jeblair: makes sense
16:15:29 <ttx> jeblair: set page_size_default = 100 as a temporary workaround?
16:15:40 <ttx> assuming people complain they can't see the 21st comment
16:15:53 <NikitaKonovalov> ttx: sounds like a good workaround
16:16:12 <jeblair> ttx: seems reasonable to me; so does the code change (but would need a nice big FIXME because it almost looks correct)
16:16:15 <ttx> and file a story to remember to fix it properly
16:16:53 <ttx> jeblair: your call
16:17:35 <jeblair> ttx: i think the config change will require some puppet work (i don't think that can actually be specified at the moment)
16:17:39 <jeblair> the code change will be easier
16:17:45 <ttx> #action jeblair to propose workaround for the "can't see a lot of comments" issue (due to lack of clientside timeline paging)
16:17:58 <jeblair> i'll take a look :)
16:18:08 <ttx> jeblair: it's actually closer to the issue, so I think I prefer the FIXME
16:18:20 <jeblair> ttx: makes sense
16:18:32 <ttx> jeblair: anything else ?
16:18:38 <jeblair> ttx: nak
16:18:53 <ttx> #info We still have a failure on the js-draft preventing easy review of webclient stuff
16:19:02 <ttx> #topic User feedback
16:19:13 <ttx> I think the previous one was almost user feedback
16:19:24 <jeblair> urgent user feedback? :)
16:19:25 <ttx> last-minute additions to taht category ?
16:20:00 <ttx> I'll count that as "no"
16:20:02 <ttx> #topic Roadmap status review
16:20:24 <NikitaKonovalov> Ive got some user feedback
16:20:26 <ttx> I was preparing this meeting and decided to go and update the roiadmap to get a clearer picture of where we stand
16:20:32 <ttx> #undo
16:20:33 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x8622850>
16:20:37 <ttx> NikitaKonovalov: please submit
16:21:12 <NikitaKonovalov> So the issue a user found is that when a page with a story loads it has a lot of placeholders instead of real values
16:21:28 <ttx> like "undefined" etc ?
16:21:38 <NikitaKonovalov> so it would be great not to render an empty template to the user
16:21:41 <NikitaKonovalov> ttx: exactly
16:22:03 <ttx> NikitaKonovalov: yes, I observe that too -- I suspect the slower your connection to storyboard.o.o the most obvious it is
16:22:04 <NikitaKonovalov> instead there should be some loading gif or something else
16:22:16 <NikitaKonovalov> to hide the page until it is fully populated
16:22:21 <ttx> I tend to agree with that user of yours
16:22:47 <NikitaKonovalov> ttx: yes the web client does a LOT of requests which may be slow
16:22:48 <ttx> or some greyed out page until it's fully loaded
16:23:09 <NikitaKonovalov> ttx: yes like horizon does
16:23:26 <ttx> greyed out with pseudo progress bullets until it's fully loaded
16:23:45 <NikitaKonovalov> I'll file a story for that
16:24:02 <ttx> what do others in more privileged parts of the world think ?
16:24:12 <ttx> is it a problem there too ?
16:25:09 <jeblair> ttx: i notice it too
16:25:16 <jeblair> ttx: (though more distressing is when it never loads)
16:25:44 <ttx> jeblair: ok
16:25:56 <ttx> NikitaKonovalov: yes, file story, and link it here when done
16:26:03 * ttx moves on in the mean time
16:26:17 <NikitaKonovalov> here it is https://storyboard.openstack.org/#!/story/2000183
16:26:28 <ttx> #info progressive page load with undefined values until it's loaded does not provide such a great UX
16:26:38 <ttx> #link https://storyboard.openstack.org/#!/story/2000183
16:26:49 <ttx> OK, moving on
16:27:03 <ttx> #topic Roadmap status review
16:27:08 <ttx> So as I said...
16:27:21 <ttx> I was preparing this meeting and decided to go and update the roadmap to get a clearer picture of where we stand
16:27:37 <ttx> I need your collective hepl to make it relevant and current though
16:27:40 <ttx> #link https://wiki.openstack.org/wiki/StoryBoard/Roadmap
16:27:49 <ttx> So.. top to bottom there
16:28:05 <ttx> Tags - have a spec, API done, webclient todo
16:28:15 <ttx> NikitaKonovalov: will you be going to work on the webclient side too ?
16:28:46 <ttx> (don't update the page right now, I'll keep a lock on it to update it myself)
16:29:04 <ttx> (since wikis are so great at losing concurrent changes)
16:29:09 <NikitaKonovalov> ttx: I think yes
16:29:21 <ttx> NikitaKonovalov: ok great
16:29:29 <ttx> PythonSDK -- how far along are you ?
16:29:30 <NikitaKonovalov> after the db issues are settled
16:29:47 <ttx> I considered no spec was needed except "expose all API"
16:29:49 <NikitaKonovalov> SDK now coveres 90% of API calls
16:30:08 <NikitaKonovalov> some changes from aripinen are on review to cover the rest
16:30:08 <ttx> Should we consider it complete as far as the roadmap goes ?
16:30:19 <NikitaKonovalov> ttx: it's almost complete
16:30:35 <ttx> NikitaKonovalov: it will always catch up anyway
16:30:42 <NikitaKonovalov> agree
16:31:26 <ttx> NikitaKonovalov: is the difference currently on recent APIs or old ones ?
16:31:43 <ttx> i.e. can we consider it's complete-except-very-recent-API-obviously
16:31:59 <NikitaKonovalov> ttx: only recent things like milstones and new token endpoints
16:32:10 <NikitaKonovalov> are missing
16:32:12 <ttx> OK, I'll mark the feature "complete" then
16:32:29 <ttx> API support for issuing long-lasting Auth Tokens
16:32:37 <ttx> I don't think there is a spec, do we need one ?
16:32:39 <NikitaKonovalov> that one is complete
16:32:46 <ttx> OK
16:32:49 <NikitaKonovalov> krotscheck and yolanda did that
16:33:02 * ttx updates
16:33:48 <ttx> looks better now
16:33:58 <ttx> "Branches & Milestones"
16:34:13 <ttx> we have a spec, and I think API side is done now
16:34:23 <NikitaKonovalov> api is done
16:34:29 <NikitaKonovalov> sdk is partially done
16:34:36 <NikitaKonovalov> web client is not started
16:34:47 <ttx> NikitaKonovalov: should I add a "SDK" column in that page ?
16:35:02 <NikitaKonovalov> ttx: I think so
16:35:12 <ttx> I don't want to duplicate too much of storyboard on that page :)
16:35:34 <ttx> but until we have task lists it's difficult to do tracking
16:35:57 <ttx> NikitaKonovalov: ok, I'll add one, just comment on SDK status and I'll add it after meeting
16:36:03 <ttx> "Story Types phase 1"
16:36:20 <ttx> So this is the first part of the implementation of the story type spec
16:36:55 <jeblair> ttx: task lists?
16:36:58 <ttx> I don't thin kwe have anyone working on that yet
16:37:20 <jeblair> ttx: (nm, let's wait until open discussion)
16:37:38 <ttx> Scream if you think the status there is wrong
16:37:45 <ttx> "Task Ordering" is next
16:38:01 <ttx> It is in italic, meaning it's a proposed GSoC/internship topic
16:38:11 <NikitaKonovalov> I agree on the rest of the statuses
16:38:17 <ttx> which is why I don't spec it, I think the student should work on spec too
16:38:44 <ttx> Also scream if I blatantly miss somethign or if you disagree with the priority order
16:38:49 <jeblair> can that really wait for gsoc?
16:39:02 <jeblair> i mean, if it's the _next_ item in feature tracking...
16:39:03 <NikitaKonovalov> we are missing pagination
16:39:25 <ttx> jeblair: yolanda has a potential intern that would be sooner
16:39:58 <ttx> Base Task lists (sprint planning)
16:40:28 <yolanda> yep, i'll be pinging pholland again about her this week
16:40:34 <ttx> So that is the equivalent of the "planning" use of the milestone in LP. The ability to target a series of tasks to a given event/milestone/sprint
16:41:01 <ttx> We have a wiki page describing this, I'll turn it into a spedc
16:41:01 <jeblair> (ah, this is what you said was missing earlier)
16:41:08 <ttx> yes
16:41:53 <ttx> jeblair: compared to Launchpad which uses milestones both before (for planning) and after milestone (for reporting), in StoryBoard we separate the two
16:42:03 <ttx> since one is subjective and the other is objective
16:42:12 <ttx> and going from one to another at milestone time is kind of wrong
16:42:33 <ttx> based on 7 years of doing that
16:42:39 <jeblair> ++
16:42:48 <ttx> so task lists is the answer
16:43:00 <ttx> task lists may *also* be the answer to express complex priorities
16:43:07 <NikitaKonovalov> ttx: here is the spec for pagination and search https://review.openstack.org/#/c/139638/ This one should be added somwhere
16:43:11 <ttx> but that's 1.3 material
16:43:35 <ttx> jeblair: would you put pagination/search in 1.2.1 or 1.2.3 ?
16:43:56 <ttx> The difference being, 1.2.3 stuff that didn't get done may be deferred to 1.3.2
16:44:21 <ttx> it's "very nice to have" stuff
16:44:37 <ttx> (so you might also want to move email to 1.2.1)
16:44:42 <jeblair> ttx: i don't want pagination at all :(
16:44:49 <ttx> haha
16:45:07 <ttx> jeblair: I want infinite scrolling, personally
16:46:09 <ttx> Looks like we spotted a contgention point that may deserve its own debate
16:46:16 <jeblair> ttx: really quickly, my guess is that should be 1.2.3.
16:46:26 <ttx> ok, will add
16:46:27 <NikitaKonovalov> than at least marker-based pagination should be available in UI
16:46:47 <ttx> "Import blueprints in progress from Launchpad" is obviosuly needed in 1.2.2 too
16:47:17 <ttx> NikitaKonovalov: I'll put it in 1.2.3 and schedule a discussion about it at a future meeting
16:47:24 <NikitaKonovalov> ttx: ok
16:47:44 <ttx> the stuff in 1.2.3 is "urgent polish"
16:48:10 <ttx> "not so-urgent polish" should move to 1.4 (and the other way around)
16:48:45 <NikitaKonovalov> one more missing thing: ACLs
16:48:48 <ttx> I think CLI interface and Rich text comments and IRC bots make good intern/GSoC topics
16:49:06 <ttx> NikitaKonovalov: it's down to 1.3
16:49:13 <ttx> "Story Types phase 2 (vulnerabilities), ACLs"
16:49:23 <NikitaKonovalov> oh, didn't notice that
16:49:29 <ttx> Unless you mean something else with ACLs ?
16:50:44 <ttx> OK, I'll update the roadmap asap to match all your comments
16:50:54 <ttx> That should help people decide "what do work on next"
16:50:58 <ttx> to*
16:51:12 <ttx> #topic In progress work
16:51:27 <ttx> Anyone with an update on that ?
16:52:01 <NikitaKonovalov> I helped aripinen to create a spec on what to do with foreign keys
16:52:13 <NikitaKonovalov> that one is collecting review right now
16:52:31 <NikitaKonovalov> And I'm still working on db session management
16:52:37 <NikitaKonovalov> that's my update
16:52:45 <ttx> NikitaKonovalov: thx! anyone else ?
16:53:49 * ttx switches to Open discussion, if you ahev other updates just shout
16:53:56 <ttx> #topic Open discussion
16:54:04 <ttx> Anything else, anyone ?
16:54:21 <NikitaKonovalov> nothing from me
16:56:53 <ttx> NikitaKonovalov: added SDK status at https://wiki.openstack.org/wiki/StoryBoard/Roadmap
16:57:03 <ttx> Let me know of any incorrect state there
16:57:15 <NikitaKonovalov> ok, I'll check
16:57:27 <ttx> NikitaKonovalov: would you consider "CLI" to be part of PythonSDK ?
16:57:28 <reed> since you mentioned tasks for interns, please add a note on wiki/Mentors page so we have a reminder
16:57:42 <ttx> reed: yes, I'll copy stuff there
16:57:48 <reed> sweet
16:57:49 <NikitaKonovalov> ttx: let's keep it separate for now
16:58:47 <ttx> OK, last minute comments ?
16:59:38 <jeblair> ++separate
17:00:10 <ttx> ok, all set
17:00:13 <ttx> #endmeeting