#openstack-meeting: state-management-goodness

Meeting started by harlowja at 20:00:44 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/StateManagement#Agenda_for_next_meeting (harlowja, 20:02:50)

  1. summary (harlowja, 20:05:43)
    1. https://wiki.openstack.org/wiki/StructuredStateManagement is sorta my entry point into this (harlowja, 20:14:30)
    2. https://wiki.openstack.org/wiki/StructuredWorkflowPrimitives (adrian_otto, 20:15:26)
    3. AGREED: attempt at developing taskflow in cinder to start (harlowja, 20:31:37)
    4. AGREED: have core 'sponsors' from other projects that want to use said taskflow library (starting in cinder) be involved from the start in design (and even code if they have time) (harlowja, 20:36:20)
    5. ACTION: harlowja send email to ML to get other interested core people involved (harlowja, 20:38:22)
    6. ttp://docs.openstack.org/developer/nova/devref/vmstates.html (harlowja, 20:42:01)
    7. http://docs.openstack.org/developer/nova/devref/vmstates.html (harlowja, 20:42:06)

  2. cinder-primitives (harlowja, 20:42:26)
    1. https://wiki.openstack.org/wiki/StructuredWorkflowPrimitives (harlowja, 20:43:35)
    2. https://wiki.openstack.org/wiki/StructuredWorkflows (harlowja, 20:46:04)
    3. ACTION: jgriffith hemna document a possible taskflow,workflow to take, then reconvine via ML (or email or IRC) about how library (which is slightly in progress) may have to be adjusted to accomdate (harlowja, 20:47:39)
    4. ACTION: cinder team to provide cinder workflow data (jgriffith, 20:47:39)

  3. open-dicussion (harlowja, 20:50:39)


Meeting ended at 20:59:51 UTC (full logs).

Action items

  1. harlowja send email to ML to get other interested core people involved
  2. jgriffith hemna document a possible taskflow,workflow to take, then reconvine via ML (or email or IRC) about how library (which is slightly in progress) may have to be adjusted to accomdate
  3. cinder team to provide cinder workflow data


Action items, by person

  1. harlowja
    1. harlowja send email to ML to get other interested core people involved
  2. hemna
    1. jgriffith hemna document a possible taskflow,workflow to take, then reconvine via ML (or email or IRC) about how library (which is slightly in progress) may have to be adjusted to accomdate
  3. jgriffith
    1. jgriffith hemna document a possible taskflow,workflow to take, then reconvine via ML (or email or IRC) about how library (which is slightly in progress) may have to be adjusted to accomdate


People present (lines said)

  1. harlowja (123)
  2. adrian_otto (47)
  3. jgriffith (36)
  4. maoy (27)
  5. hemna (22)
  6. changbl (8)
  7. openstack (3)
  8. jlucci (2)
  9. esheffield (1)
  10. sandywalsh (1)
  11. glikson (1)
  12. anniec (1)
  13. alaski (1)


Generated by MeetBot 0.1.4.