20:00:43 <harlowja> #startmeeting state-management
20:00:44 <openstack> Meeting started Thu Jan 30 20:00:43 2014 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:48 <openstack> The meeting name has been set to 'state_management'
20:01:14 <harlowja> hi folks!
20:01:39 <akarpinska1> hi
20:01:49 <haruka_> hi
20:02:07 <iv_m> hi hi
20:02:09 <harlowja> hi hi
20:02:37 <harlowja> #link https://wiki.openstack.org/wiki/Meetings/StateManagement#Agenda_for_next_meeting
20:02:45 <harlowja> #topic last-action-items
20:03:18 <harlowja> #link http://eavesdrop.openstack.org/meetings/openstack_state_management/2014/openstack_state_management.2014-01-23-19.59.html
20:03:43 <iv_m> oh my
20:03:48 <harlowja> soooo zookeeper should now be running on the testing slaves, due to https://review.openstack.org/#/c/70022/
20:04:04 <harlowja> i'm doing some verification to see if it really is, supposedly is :-P
20:04:19 <harlowja> if not i'll bug infra to see what its doing
20:04:39 <harlowja> #link https://review.openstack.org/#/c/70017/ will use this
20:05:00 <harlowja> although marco here stated we should use an ENV variable to know if zookeper should be used instead of probing localhost
20:05:07 <harlowja> that seems to make sense...
20:05:30 <harlowja> some env variable set by jenkins in the test environemtn to know whats avaialble
20:05:48 <changbl> hi guys
20:05:53 <harlowja> hi changbl
20:06:04 <harlowja> just was discussing my action item about zookeeper
20:06:20 <changbl> harlowja, i am reading the logs
20:06:22 <harlowja> retried test thats supposed to find it last night, it didn't seem to run, so gonna investigate more
20:06:23 <changbl> move one
20:06:25 <changbl> move on
20:06:25 <harlowja> k
20:06:51 <harlowja> also other one i had was venv conf changes, that all got resolved after a little bumps around which ones we were using
20:06:52 * iv_m totally forgout about our action item, moves to next week
20:06:52 <iv_m> #action iv_m akarpinska1 wiki writeup on reversion strategies
20:06:58 <harlowja> iv_m woot :)
20:07:21 <harlowja> i think https://bugs.launchpad.net/taskflow/+bug/1273850 is still happening, but shouldn't be hard to fix
20:07:38 <harlowja> if anyone wants to figure that one out, much appreciated :)
20:07:44 <harlowja> iv_m i think put some comments up on that also
20:07:48 <akarpinska1> I think, I'll finish the last part of reversion strategies soon and then will write some examples and wiki
20:08:00 <harlowja> akarpinska1 great, that will help a bunch (for me especially)
20:08:03 <iv_m> akarpinska1: cool
20:08:06 <harlowja> akarpinska1 are u doing ok :-/
20:08:13 <harlowja> ukraine ??
20:08:15 <harlowja> :(
20:09:06 <akarpinska1> but my cinder patch has been merged today. I want to put a new one to review and then return to taskflow, maybe next week
20:09:24 <harlowja> akarpinska1 ++++++
20:09:26 <harlowja> awesome!!!
20:09:27 <akarpinska1> I'm fine, everything ok in Kharkov
20:09:28 <harlowja> finnally
20:10:22 <harlowja> akarpinska1 good, phew, hopefully ukraine calms down (but who knows)
20:11:04 <harlowja> hmmm, and i had one other action item, not sure what 'harlowja writeup little wiki with a similar explanation as checkpoint/reversion/controller strategies' was about, lol
20:11:13 <harlowja> so i'll look into what the heck i was supposed to do :-P
20:11:36 <harlowja> #action harlowja look into what u were supposed to do
20:11:38 <harlowja> ha
20:12:02 <harlowja> #topic 0.2 release timeframe/timeline/features
20:12:09 <harlowja> sooo this is an interesting one
20:13:19 <harlowja> so let me just list what i know about for 0.2
20:13:33 <harlowja> 1. reverting/retry strategy work
20:13:52 <harlowja> 2. zookeeper work (jobboard + logbook backend)
20:14:08 <harlowja> 3. kombu engine
20:14:29 <harlowja> those are the big 3 that are currently being reviewed and i think are nearly all ready to go
20:14:42 <harlowja> + other bugs (like the storage locking one)
20:15:00 <harlowja> what do people think is a good timeline to get all those reviews in and done?
20:15:01 <harlowja> next week?
20:15:16 <harlowja> *just needs some focused review time imho
20:15:21 <changbl> 2  is fine with me for next week
20:15:27 <akarpinska1> maybe 2-3 weeks, to test it well and write docs
20:15:53 <iv_m> i don't think we'll manage to do it next week, 2-3 weeks look more reasonable to me
20:16:03 <iv_m> but i'll try nevertheless;)
20:16:31 <harlowja> ok, iv_m  that seems fine :)
20:17:14 <harlowja> akarpinska1 sounds great, the doc part i think will be the real great addition, to make sure people understand the concept  :)
20:17:45 <harlowja> cause i know i'm a little confused by #1  :)
20:17:51 <harlowja> more docs the better
20:18:19 <harlowja> changbl u ok with doing those zookeeper reviews when u get time, seem manageable?
20:18:24 <changbl> yes, harlowja
20:18:27 <harlowja> great
20:18:29 <akarpinska1> maybe it became more clear with example
20:18:39 <harlowja> akarpinska1 i think that will help :)
20:19:22 <harlowja> ok, lets aim for 2 weeks and see what it gets us, probably when we release we (or me) can write up little ML post that says new features and new additions...
20:19:36 <harlowja> let people know and all that
20:19:56 <haruka_> :)
20:20:00 <harlowja> #action iv_m akarpinska1 changbl harlowja  try to make 0.2 happen  in 2 weeks :)
20:20:08 <changbl> yes, sir:)
20:20:10 <harlowja> haha
20:20:15 <harlowja> thx u sir
20:20:24 <iv_m> ++)
20:20:42 <harlowja> k, cool, so next bigger topic
20:20:49 <harlowja> #topic oslo-joining-part-3
20:20:57 <harlowja> or is it part 4, i'm not sure, lol
20:21:34 <harlowja> so i think everyone is aware of this kind of question, to join oslo or not
20:21:46 <iv_m> ok, to sum up, when we join to oslo
20:21:46 <iv_m> - we get cool repo url
20:21:46 <iv_m> - there will be few organizational changes
20:21:46 <iv_m> - we get more visibility in community
20:21:46 <iv_m> - everything else stays pretty much the same
20:21:48 <iv_m> am i missing something?
20:21:57 <harlowja> afaik yes
20:22:08 <harlowja> and we help guide the oslo community into what this means
20:22:13 <harlowja> since it appears not to be well known really
20:22:27 <harlowja> *ie help establish the ground-rules
20:22:58 <harlowja> so not missing anything else i think iv_m (except the uncertainty part)
20:24:07 <harlowja> so maybe we can have a vote, i think most core people are here, does that seem ok?
20:24:33 <changbl> yes
20:24:38 <harlowja> #startvote Should we join oslo and see what happens? Yes, No, Maybe
20:24:40 <openstack> Begin voting on: Should we join oslo and see what happens? Valid vote options are Yes, No, Maybe.
20:24:41 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
20:24:57 <harlowja> #vote yes
20:24:59 <changbl> #vote yes
20:25:07 <iv_m> #vote Yes
20:25:19 <haruka_> #vote yes
20:25:22 <akarpinska1> #vote maybe
20:25:33 <iv_m> at least out of curiosity
20:25:41 <harlowja> *feel free to vote as u want, no pressure
20:25:59 <harlowja> i will not penalize anyone for voting in there own way :)
20:26:12 <changbl> :)
20:26:48 <harlowja> ok, anyone else around that wants to vote?
20:27:06 * harlowja waits a few just incase
20:27:12 <iv_m> harlowja: final countdown?
20:27:22 <harlowja> #showvote
20:27:23 <openstack> Maybe (1): akarpinska1
20:27:23 <akarpinska1> I'm not too familiar with oslo and I can't make a decision :(
20:27:24 <openstack> Yes (4): iv_m, harlowja, haruka_, changbl
20:27:49 <harlowja> akarpinska1 sure, and thats fine to
20:27:56 <harlowja> 5
20:28:00 <harlowja> 4
20:28:03 <harlowja> 3
20:28:06 <harlowja> 2
20:28:06 <harlowja> 1
20:28:13 <harlowja> beep
20:28:14 <harlowja> #endvote
20:28:15 <openstack> Voted on "Should we join oslo and see what happens?" Results are
20:28:16 <openstack> Maybe (1): akarpinska1
20:28:17 <openstack> Yes (4): iv_m, harlowja, haruka_, changbl
20:28:39 <harlowja> ok, so i'll start talking with dhellmann about what the next steps are
20:28:49 <iv_m> #link https://wiki.openstack.org/wiki/Oslo
20:28:53 <harlowja> *likely infra changes (don't want to overload them either)
20:28:56 <iv_m> #link https://etherpad.openstack.org/p/oslo-taskflow
20:29:00 <akarpinska1> thanks
20:29:00 <iv_m> akarpinska1: ^^
20:29:39 <akarpinska1> I worked only with oslo.messaging and I don't like it :(
20:29:46 <harlowja> understandable
20:29:59 <harlowja> we just have to make sure we don't become like that :)
20:30:05 <harlowja> aka, we control our own destiny still
20:30:08 <iv_m> so, oslo will have at least one library we like
20:30:10 <iv_m> lol
20:30:14 <harlowja> pbr
20:30:16 <harlowja> hacking :-P
20:30:22 <harlowja> and taskflow
20:30:24 <harlowja> woot
20:30:31 <harlowja> maybe oslo.messaging someday
20:31:37 <iv_m> i was just kidding of course
20:31:37 <harlowja> #action harlowja work with dhellmann to figure out next steps, and unless something drastically is bad, move forward here with oslo and see what happens
20:32:14 <changbl> +1 harlowja
20:32:36 <harlowja> cool, hopefully everything turns out ok, if something seems wrong, i'll let u all know
20:32:52 <harlowja> *hopes nothing seems wrong*
20:33:54 <harlowja> #topic reviews-feedback-more-reviews
20:34:12 <harlowja> so any reviews that need discussion, or integration reviews that need discussion (or just in general any review)
20:34:22 <harlowja> i have one at least, https://review.openstack.org/#/c/69507/
20:34:36 <harlowja> iv_m did u investigate the lock-less solution, would be interested in hearing that
20:34:57 <harlowja> *others feel free to bring up any reviews u have also
20:35:21 <harlowja> congrats to akarpinska1 for another cinder integration review done :)
20:35:23 <haruka_> not gerrit is OK?
20:35:52 <changbl> +1 akarpinska1
20:35:52 <harlowja> haruka_ ?
20:36:04 <haruka_> I commented at etherpad a little bit.Would you read it later? https://etherpad.openstack.org/p/cinder-taskflow-persistence
20:36:13 <harlowja> ah, great haruka_ will look at
20:36:24 <haruka_> thank you.
20:37:45 <harlowja> haruka_ initial feedback, i think cinder can just create a table for taskflow, and use it, taskflow isn't connected to oslo.db, but instead has a SQLAlchemyBackend that can be configured to use whatever cinder table they want (or its own db)
20:38:20 <harlowja> its also possible that we can extend SQLAlchemyBackend to take in a pre-existing 'engine' that oslo.db would provide
20:38:37 <haruka_> oh yes. good.
20:39:22 <harlowja> taskflow not depending on oslo.db was intentionally (oslo.db isn't a pypi library yet, the incubator version depends on oslo.confg which doesn't behave with libraries so well imho)
20:39:48 <harlowja> i am seeing progrress in that area @ https://review.openstack.org/#/c/68684/
20:39:55 <harlowja> *making oslo.db better, more library like
20:40:24 <harlowja> *no globals and such, thinks that are totally not appropriate for a library
20:40:29 <harlowja> *things that
20:40:46 <haruka_> hmh . thank sfor your feedback. I think so too.
20:40:55 <harlowja> np, i'll add some more on the etherpad
20:41:01 <harlowja> *some more ideas*
20:41:37 <harlowja> any other reviews that people need looking at (etherpads welcome to), if not thats fine to :)
20:41:40 <iv_m> harlowja: i guess smth should be done to move https://blueprints.launchpad.net/nova/+spec/glance-snapshot-tasks forward, also i'm not sure what(
20:41:53 <harlowja> ah
20:41:59 <harlowja> that one
20:42:00 <harlowja> hmmm
20:42:53 <harlowja> do u know if alex is working on that at all iv_m ?
20:43:12 <harlowja> last thing i heard was the nova folks wanted a little more of a blueprint with the ideas/design/api adjustments
20:43:45 <harlowja> *especially in regard to the virt drivers
20:44:39 <harlowja> an idea, if alex can get some of that done, then i can help with him writeup ML email or talk with nova folks about it
20:44:46 <harlowja> see if we can get something to happen there
20:45:31 <harlowja> and we need to get a nova-core to make sure they understand it i think
20:45:34 <iv_m> k, we'll se what we can do, writing some docs is our next step
20:45:35 <harlowja> *understand the intention
20:46:24 <harlowja> daniel berrange seems like he understands it, and i think he's nova-core so if we have some docs we can start discussion with him and see what to do
20:46:33 <harlowja> iv_m sound ok?
20:46:51 <iv_m> yup
20:47:05 <harlowja> cool
20:47:11 <harlowja> thx for brining that up
20:47:13 <harlowja> *bringing
20:48:01 * harlowja knows its not so easy to make such integration changes (takes alot of persistence)
20:48:47 <harlowja> just think of it like fighting a dragon or something
20:50:02 <harlowja> alright
20:50:26 <harlowja> so any need for new use-cases topic??
20:50:38 <harlowja> guess can just open-discuss for 10 mins
20:50:50 <harlowja> #topic open-discuss
20:50:57 <harlowja> so i had a question for folks
20:51:05 <harlowja> summit, design, speaker sessions?
20:51:11 <harlowja> should we/me try to do another one??
20:51:20 <harlowja> taskflow new-hotness session or something
20:51:25 <iv_m> of course we should
20:51:34 <harlowja> what should we talk about :)
20:51:38 <harlowja> we/me
20:51:39 <harlowja> lol
20:52:10 <harlowja> maybe just something to think about
20:52:27 <harlowja> i can do another talk about taskflow session if i have to :-P
20:52:46 <harlowja> #link v
20:52:48 <harlowja> oops
20:52:50 <harlowja> #link http://www.openstack.org/summit/openstack-summit-atlanta-2014/
20:53:27 <harlowja> i'd be neat to demo some of the remote-worker stuff
20:53:30 <akarpinska1> we will have a lot of new features on may
20:53:31 <harlowja> *it'd
20:53:41 <harlowja> akarpinska1 agreed
20:53:49 <harlowja> issue is 'Submit your talk HERE!  Hurry, the deadline to submit is February 14, 2014.  '
20:53:59 <harlowja> so thats not design sessions but more like the video i did last time
20:54:19 <harlowja> feb 14th not that far away
20:54:53 <harlowja> i'll start an etherpad where we can brainstorm i guess
20:55:12 <harlowja> #link https://etherpad.openstack.org/p/taskflow-atlanta-speaker-ideas
20:55:52 <harlowja> design sessions also, think about those
20:55:57 <harlowja> cinder persistence maybe?
20:56:05 <harlowja> or nova
20:56:14 <harlowja> or glance + remote works + taskflow
20:56:22 <akarpinska1> maybe we should ask Stas to
20:56:30 <harlowja> agreed
20:56:41 <harlowja> anyone that has ideas is welcome :)
20:56:47 <akarpinska1> prepare a techtalk about worker-based engine
20:57:02 <harlowja> first though a little writeup
20:57:09 <harlowja> cause speaker sessions get voted afaik
20:57:20 <harlowja> so techtalk i think if it gets approved
20:57:26 <harlowja> if he wants to do one anyway, thats cool to
20:57:48 <akarpinska1> I'm not sure if he could go to the summit, but he could help with presentation
20:58:15 <harlowja> np
20:58:20 <harlowja> i don't mind doing all of them
20:58:23 <harlowja> if i have to :)
20:58:28 <harlowja> *i'll be damn tired though, haha
20:59:04 <harlowja> iv_m akarpinska1 be nice to have u 2 go :)
20:59:13 <harlowja> anyways, time almost up
20:59:43 <akarpinska1> I'm not sure if I can :( but I want to go
20:59:53 <harlowja> :)
21:00:02 <akarpinska1> depends on our managers
21:00:05 <harlowja> agreed
21:00:09 <iv_m> akarpinska1: we'll try to ping the mighty ones
21:00:16 <harlowja> alright #openstack-state-management for further
21:00:19 <harlowja> #endmeeting