20:00:36 <harlowja> #startmeeting state-management
20:00:38 <openstack> Meeting started Thu Oct  3 20:00:36 2013 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:41 <openstack> The meeting name has been set to 'state_management'
20:00:47 <harlowja> howdy!
20:00:52 <harlowja> anyone around today :-P
20:00:53 <melnikov> hi there
20:00:58 <harlowja> hey
20:01:17 <Caitlin56> here
20:02:11 <harlowja> howdy
20:02:19 * harlowja waits a few minutes for others
20:02:29 <harlowja> #link http://eavesdrop.openstack.org/meetings/state_management/2013/state_management.2013-09-26-19.59.html (last meeting)
20:02:42 <harlowja> #link https://wiki.openstack.org/wiki/Meetings/StateManagement#Agenda_for_next_meeting (this meeting)
20:05:32 <harlowja> ok dokie
20:05:33 <harlowja> anyays
20:05:38 <harlowja> guess its just us, so might be quick :-P
20:05:49 <harlowja> #topic action-items
20:05:52 <harlowja> i guess i just had one, ha
20:06:44 <harlowja> so Caitlin56 it doesn't appear u can cross link blueprints :(
20:06:49 <harlowja> *cross project link
20:07:14 <Caitlin56> So enter them twice and type the URL in yourself, I suppose.
20:07:34 <harlowja> or like create one, then create a 'link' one that in its description has a link to the other one :-/
20:07:41 <harlowja> sorta not so nice
20:08:04 <harlowja> *especially for a project like openstack where alot of stuff is cross-linked
20:09:52 <harlowja> cool
20:10:01 <harlowja> #topic coordination
20:10:19 <harlowja> so i think there is some work going on with the celery stuff that could benefit from a little more coordiation
20:10:35 <harlowja> let me see if any of those guys are around, kebray yt
20:10:47 <jlucci> I'm here for like five minutes
20:10:54 <jlucci> : X
20:10:57 <harlowja> k
20:11:35 <harlowja> so i was thinking that if we get the real basics in, even with @celery.task decorator, then we can proceed forward with fixing that problem
20:11:44 <harlowja> does that seem reasonable, i'm not sure how easy it will be to fix that
20:11:59 <harlowja> *the dependence on celery.task and ultimately its static registry
20:12:05 <jlucci> Yeah, I'm okay with that
20:12:13 <jlucci> Not sure what changes I need to make for that to happen though
20:12:22 <jlucci> Just pull out the event thread to consumer stuff?
20:12:30 <jlucci> s/pull out/change
20:12:30 <harlowja> sure
20:12:47 <harlowja> i think thats fair, and i think we need to writeup what the issue is, and have a little plan to address it
20:12:54 <jlucci> Will that change let distributed in, I guess was the question
20:12:56 <harlowja> which i think melnikov, u, and me can explore
20:13:18 <harlowja> sure, that change, + bugs/blueprints/plan on next steps to fix that would be great
20:13:23 <harlowja> i think thats reasonable
20:13:29 <jlucci> kk - Must go for school stuff, but I will get that doe
20:13:30 <jlucci> done *
20:13:37 * harlowja for those that have no idea what we are talking about, the writeup/plan would help
20:13:58 <harlowja> ok, so thats good
20:14:26 <harlowja> melnikov does that seem ok with u, i'd almost want to put the distributed_engine in some sorta of 'alpha' area if i could, due to these restrictions
20:15:08 <harlowja> but at least documenting bugs, blueprints, a plan to get out of the problematic situation would be a start
20:15:18 <harlowja> at least then we agree it is a problem and have some sort of path to fixing it
20:15:22 <melnikov> sounds reasonable
20:15:24 <harlowja> *instead of no path
20:15:41 <harlowja> *whether it can be fixed is another question, but we can talk about that outside of this meeting i gues
20:15:50 <harlowja> ok cool
20:16:09 <harlowja> #topic resumption-migrations
20:16:51 <harlowja> so melnikov and i have been throwing around ideas for how to migrate the persisted flow/task details and just wanted to make people aware (or get other input)
20:16:53 <harlowja> #link https://blueprints.launchpad.net/taskflow/+spec/resumption-migrations
20:16:59 <harlowja> thx melnikov for making that blueprint
20:17:10 <harlowja> there is a couple of prototypes up
20:17:46 <harlowja> the general idea though is that when u have a flow with a set of tasks running, while those tasks are running taskflow is actively persisting what those tasks have done
20:18:08 <harlowja> but now say half-way through running that set of tasks, the program is stopped, say for a software upgrade
20:18:40 <harlowja> then what happens when the program comes back online and needs to migrate the persisted data for those tasks to some newer format
20:18:48 <harlowja> so that the flow that was running can resume running
20:19:12 <harlowja> if anyone wants to comment on that blueprint with ideas, its fine also
20:19:29 <harlowja> a couple different code reviews with different ideas also
20:19:30 <harlowja> #link https://review.openstack.org/#/c/48773/
20:19:35 <harlowja> #link https://review.openstack.org/#/c/49380/
20:19:54 <harlowja> it'd be nice to see what other people think, are we makign it to complex, to simple, shouldn't do it at all (any of the above)
20:21:26 <harlowja> thats about all i had, seeking of course more input on designs and such :)
20:21:34 <harlowja> any other topics before open-discuss?
20:22:03 <harlowja> #topic open-discuss
20:22:12 <harlowja> so just to keep everyone updated
20:22:16 <harlowja> #link https://etherpad.openstack.org/TaskflowHKIdeas
20:22:25 <harlowja> also feel free to update that, still collecting ideas
20:22:51 <harlowja> melnikov i was thinking maybe i can focus on improving some examples and such, or maybe anastasia wants to, either or
20:22:54 <harlowja> or both of us can
20:23:06 <harlowja> get the resumption stuff in
20:23:30 <harlowja> and i can also start on whatever the talk will be about with kebray (who i think is going now!)
20:23:43 <melnikov> anastasia is on vacations until oct 14th
20:23:49 <harlowja> np
20:24:02 <harlowja> i can do examples then also, and whatever other stuff y! throws at me
20:24:30 <harlowja> maybe i can start a 'best-practices-for-taskflow' wiki also
20:24:33 <harlowja> that seems like a good idea
20:24:41 <melnikov> yes, good idea
20:24:52 <Caitlin56> +1
20:24:54 <harlowja> #action harlowja start taskflow-best-practices wiki
20:25:13 <harlowja> since i think we'll hit alot of the same questions over and over
20:25:26 <harlowja> and things that taskflow is good at, and thinks that it is not
20:25:41 <harlowja> so this seems like a good place to direct people to for common stuff like that
20:25:53 <harlowja> will do that
20:26:13 <harlowja> Caitlin56 is any of the nextenta people doing a session for cinder
20:26:16 <harlowja> if u know
20:26:33 <harlowja> ah, i see http://summit.openstack.org/cfp/details/70
20:26:40 <harlowja> cool
20:27:18 <Caitlin56> planned but not formally scheduled as of yet,
20:27:21 <harlowja> sure sure
20:27:41 <harlowja> most of those seem 'Unreviewed' still
20:27:53 <Caitlin56> I wouldn't be opposed to presenting a version in a second session if you'd like.
20:27:57 <harlowja> should start transitioning to 'approved' (or not) hopefully i guess in the next couple of weeks
20:28:30 <Caitlin56> jgriffith is fighting havana bugs - not thinking about icehouse yet
20:28:38 <harlowja> either or, i was just thinking u might have some good ideas for https://etherpad.openstack.org/TaskflowHKIdeas
20:28:44 <harlowja> and we can combine our idea power!
20:28:45 <harlowja> ha
20:29:26 <harlowja> and if i can help out with your session, let me know also
20:29:34 <Caitlin56> But I am finally confirmed for Hong Kong.
20:29:41 <harlowja> thats step #1 i guess ;)
20:29:48 <kebray> harlowja   hey, I'm here, but dealing with an internal issue... so, not really here.
20:29:51 <harlowja> np
20:30:01 <harlowja> kebray jessica popped in, we i think have a good plan
20:30:19 <harlowja> just i need to connect with u on talk and stuff
20:30:32 <harlowja> can do after/outside meeting
20:32:03 <harlowja> ok, cool, any other stuff for people to talk about, or we can end early :)
20:32:09 <harlowja> speak now!, ha
20:34:17 <harlowja> alright then
20:34:34 <harlowja> for more stuff #openstack-state-management folks!
20:34:40 <harlowja> u'll find most of us in there
20:36:46 <harlowja> thx for coming folks melnikov Caitlin56 ;)
20:36:56 <harlowja> #endmeeting