19:59:27 <harlowja> #startmeeting state-management
19:59:28 <openstack> Meeting started Thu Sep 26 19:59:27 2013 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:59:32 <openstack> The meeting name has been set to 'state_management'
19:59:35 <harlowja> to quick, ha
20:00:50 <harlowja> #link https://wiki.openstack.org/wiki/Meetings/StateManagement#Agenda_for_next_meeting
20:00:57 <harlowja> anyone around
20:01:00 <harlowja> if not thats ok :-P
20:01:05 <harlowja> #link http://eavesdrop.openstack.org/meetings/state_management/2013/state_management.2013-09-19-20.00.html
20:01:05 <melnikov> hi there
20:01:08 * caitlin56 waves
20:01:13 <harlowja> hi hi
20:01:26 * harlowja waits a few minutes for others i guess
20:01:42 <adrian_otto> o/
20:02:04 <harlowja> howday
20:02:48 <harlowja> ok dokie,
20:03:14 <harlowja> so lets see
20:03:17 <harlowja> #topic action-items
20:03:57 <harlowja> so i drafted with the help of caitlin56 https://blueprints.launchpad.net/taskflow/+spec/task-flow-attributes
20:04:03 <ekarlso> yello..
20:04:14 <harlowja> just noticed caitlin56 put up https://blueprints.launchpad.net/taskflow/+spec/backend-activity-attributes :)
20:04:45 <harlowja> caitlin56 does the later 'task-flow-attributes' need to exist if there is 'backend-activity-attributes'
20:04:59 <harlowja> ekarlso yo
20:05:29 <caitlin56> harlowja: no, but I didn't know how to edit that one safely, so I made a new one.
20:05:33 <harlowja> kk
20:05:34 <harlowja> np
20:05:46 <caitlin56> Slightly different focus, but clearly overlapping.
20:05:48 <harlowja> k
20:05:58 * harlowja not sure if there is a way to link them, i will find something
20:06:50 <harlowja> cool, so if anyone wants to check those out, it would be neat, its about how to publish attributes of tasks and flows that others can find and use to create an overall 'strategy'
20:07:02 <caitlin56> harlowja: while you are researching, find out if there is a way to list a blueprint to two projects.
20:07:09 <harlowja> hmmm
20:07:15 <harlowja> sure, will see what i can find
20:07:27 <harlowja> #action harlowja investigate blueprint magic
20:07:30 <caitlin56> this is definitely a fence-sitter.
20:07:52 <harlowja> sure sure
20:08:20 <harlowja> ok dokie, so i'll try to look over those and stuff, others feel free to also :)
20:08:26 <harlowja> more comments the better
20:08:44 <harlowja> #topic announcements
20:09:10 <harlowja> so there will be a speaker (likely me) session at the summit for taskflow
20:09:10 <harlowja> woot!
20:09:12 <harlowja> ha
20:09:24 <harlowja> as well as multiple design sesssions
20:09:41 <harlowja> so maybe i can start an etherpad with ideas about what to show/present
20:10:02 <harlowja> #link https://etherpad.openstack.org/TaskflowHKIdeas i guess works
20:10:32 <harlowja> feel free to throw stuff up there
20:11:11 <harlowja> any ideas are welcome :-P
20:11:28 <harlowja> *not involving harlowja  doing crazy thigns on stage, thx much
20:11:37 <adrian_otto> if you want help with the session, I'll volunteer to lend a hand
20:11:45 <harlowja> sure
20:11:46 <caitlin56> So where do you do crazy things?
20:11:49 <harlowja> ha
20:11:53 <harlowja> off-stage?
20:11:55 <harlowja> lol
20:12:24 <harlowja> adrian_otto thx, i think maybe brainstorm a little via that etherpad
20:12:30 <adrian_otto> whatever helps the most. I do a reasonable amount of public speaking, so I'll offer that skill.
20:12:34 <harlowja> :)
20:12:34 <ekarlso> how did the gearman thing go ?
20:12:46 <harlowja> what gearman thing? :-P
20:12:54 <harlowja> i don't think it went very far, lol
20:13:17 <harlowja> but jessica would know best
20:13:28 <harlowja> but she's not around at the moment i think
20:13:31 <ekarlso> is she here ? :p
20:13:32 <ekarlso> doh
20:13:47 <harlowja> :)(
20:14:10 <harlowja> *mistype, just supposed to be sad face
20:14:23 <harlowja> anyways, so thats good news
20:14:24 <ekarlso> harlowja: where are ytou hiding her ? ;p
20:14:26 <harlowja> ha
20:14:31 <harlowja> kebray adrian_otto are, not me
20:14:41 <harlowja> lol
20:15:09 <ekarlso> what's good news ?
20:15:41 <harlowja> our speaker session for taskflow made it through the gauntlet
20:15:44 <harlowja> the voting gauntlet
20:15:51 <harlowja> and we passed
20:16:09 <ekarlso> ooh
20:16:12 <harlowja> ya
20:16:30 <harlowja> i also put up quite a few other sessions @ http://summit.openstack.org/
20:16:34 <harlowja> but those are design releated ones
20:16:39 <harlowja> if others think of more let me know
20:17:04 <ekarlso> harlowja: do you see taskflow in quantum later ?
20:17:21 <harlowja> unsure, i know like not so much about quantum :-P
20:17:32 <harlowja> but if it makes sense, why not, ha
20:17:37 <ekarlso> or neutron rather
20:17:42 <ekarlso> ok :)
20:17:47 <harlowja> maybe, unsure
20:17:50 <harlowja> #topic integration
20:18:01 <harlowja> so thats a good question
20:18:25 <harlowja> we should start to track some ideas around this, but it'd be nice to consult with neutron folks maybe
20:18:44 <harlowja> ekarlso also for billingstack, we should be able to help u use the new engine concept and adjust your usage there
20:18:48 <harlowja> hopefully nothing to bad
20:18:57 <harlowja> all those reviews are in
20:19:05 <caitlin56> There is a huge difference between a task that works *within* a virtual network and one that creates virtual networks.
20:19:14 <caitlin56> More value and more risk with the latter.
20:19:41 <harlowja> ya, i have not enough knowledge about neturon to know about either, haha, i know it makes virtual networks :-P
20:19:45 <harlowja> and stuff
20:20:01 <harlowja> other people on my team at y! might know more, or just the neutron people themselves, ha
20:20:01 <ekarlso> :o
20:20:42 <harlowja> so ekarlso we should work with u, unless u are in FF (like everyone else) to get u up to speed
20:20:43 <caitlin56> If we want to construct ad hoc virtual networks we could make them a lot less risky if we constrain them to be subsets of pre-configured virtual networks.
20:21:08 <harlowja> caitlin56 no idea, seems like neutron specifics :)
20:21:29 <harlowja> so ya, idk if/how taskflow could be used there
20:21:52 <caitlin56> Unless people have specific tasks they want flowed that involve ad hoc network creation I'd stick with working within the networks neutron creates.
20:22:26 <harlowja> i think ekarlso was more of thinking about the workflows neutron is already doing, like maybe those could use taskflow
20:22:48 <harlowja> the other review that i am tracking, and one of the reasons i put up a glance design session is
20:22:50 <harlowja> #link https://review.openstack.org/#/c/46117/
20:23:15 <ekarlso> the fun thing is
20:23:24 <ekarlso> BillingStack isn't really in a "advanced" state yet
20:23:33 <harlowja> k
20:23:33 <kebray> hi!
20:23:37 <kebray> sorry I'm late.
20:23:37 <ekarlso> i guess the more cool stuff will come when doing billing runs etc later on
20:23:55 <harlowja> kebray its ok
20:23:58 <kebray> harlowja got my approval... will book travel today.
20:24:01 <harlowja> sweet
20:24:55 <harlowja> ekarlso so billingstack doesn't have the same FF process right that the other projects have
20:25:04 <harlowja> slushy freeze
20:25:05 <harlowja> ha
20:25:05 <ekarlso> FF?
20:25:07 <ekarlso> nope
20:25:11 <harlowja> *feature freeze
20:25:13 <ekarlso> it's still in "alpha" :p
20:25:16 <harlowja> ya, np
20:25:27 <ekarlso> so it can change whatever it wants :)
20:25:34 <harlowja> cool
20:26:24 <harlowja> ya, so integration i think is waiting a little for the FF to thaw
20:26:27 <harlowja> and icehouse to open up
20:26:33 <harlowja> then we can continue integration
20:27:26 <harlowja> anyways, lets just open-up for discussion, i don't think to much is new and people are sorta just heads down working
20:27:33 <harlowja> #topic open-discuss
20:28:10 <kebray> harlowja since jlucci isn't here, do you know what's left on her gerrit review before distributed is merged in?
20:28:22 <kebray> I haven't been able to sync with her the past two days.
20:28:26 <harlowja> ya, quite a few comments i think
20:28:30 <kebray> or, do you have a link to the review?
20:28:35 <kebray> handy?
20:28:46 <harlowja> https://review.openstack.org/#/c/47609/
20:28:49 <kebray> thx!
20:29:06 <harlowja> i think there is going to be a constant struggle to keep the engine types feature equivalent
20:29:19 <harlowja> so its transparent to the user which one they are using
20:29:33 <harlowja> so some of the review comments that i'd like addressed are to keep it transparent
20:29:34 <kebray> We need to solve this before the summit.
20:29:51 <kebray> Even if we acknowledge that it can't be transparent.
20:30:17 <kebray> I only see one comment on the latest merge proposal... were there other comments still not addressed?>
20:30:24 <harlowja> yup
20:30:31 <harlowja> i got tired of reposting all my previous comments
20:31:04 <harlowja> so check the previous patch sets
20:31:32 <harlowja> as for ' acknowledge that it can't be transparent' i don't buy that yet
20:31:55 <harlowja> it doesn't have to be to start fully equivalent
20:32:02 <harlowja> but it has to at least like have a run() method that operates the same
20:32:07 <kebray> the concern I'm having is that the underlying fundamentals keep changing out from under jlucci.
20:32:22 <kebray> so, it's been a total moving target for her to stay compatible.
20:32:27 <harlowja> they haven't changed in the last 1.5 weeks
20:32:29 <harlowja> so i don't buy it
20:32:34 <kebray> my point exactly!
20:32:51 <harlowja> so we are all supposed to wait around?
20:32:52 <kebray> we had a stable idea of the functional components months ago.
20:33:19 <harlowja> and that was determined not to b stable
20:33:22 <kebray> no, but changing things every week or two makes it difficult for a big patch like this to ever land.
20:33:35 <harlowja> i don't think thats the true problem
20:33:44 <harlowja> it has to function at some minimal level
20:33:48 <harlowja> the engine change didn't alter that much
20:34:10 <harlowja> the review comments would of been the same without engines
20:34:13 <kebray> basically, I'm coming at it from the point that we all either need to agree that distributed is important, and we want to work together to support other engine styles, or if that's in contention, we need to figure out if we need to fork for distributed and build as a separate project.  goals don't seem aligned right now.
20:34:17 <harlowja> threads just can't be lost
20:34:46 <kebray> I'll dig through the comments more... I need to do that for sure.
20:34:53 <harlowja> yes, please do before
20:34:59 <harlowja> it has to function at a mimimal level
20:35:10 <kebray> distributed functions... I've watched it work on many occassions.
20:35:15 <harlowja> before u say fork it and then have code that still doesn't work :-/
20:35:29 <kebray> distributed works... and, all tests pass.
20:35:29 <harlowja> ya, working and having code that is acceptable are different concepts
20:35:50 <kebray> I'd like to see the feature land, and then we raise blueprints to make it better.
20:36:08 <harlowja> except it will be broken if it lands and i don't want that it the codebase
20:36:18 <harlowja> *that in the codebase
20:36:20 <kebray> I'm concerned that our definitions of acceptable are too far apart, so we'll things will keep changing such that we can never make the feature land.
20:36:30 <kebray> what's broken if it lands today?
20:36:35 <harlowja> read the comments...
20:36:38 <kebray> As I understand things, you don't even plan to use it.
20:36:40 <kebray> :-P
20:36:45 <kebray> and, all tests pass.
20:37:02 <harlowja> just read the comments
20:37:05 <kebray> k.
20:37:14 <harlowja> basic stuff has to be right, just the basics
20:37:49 <kebray> k.. I'll come back to you if I need clarification on what you mean by basics... as, I've seen all the basics working.  but, let me review the comments and come back to you.
20:37:56 <harlowja> just review the comments
20:38:50 <harlowja> and it really seems like a WIP kebray
20:39:00 <harlowja> def on_consume_end(self, connection, channel):
20:39:00 <harlowja> print "ENDING"
20:39:00 <harlowja> connection.release()
20:39:18 <harlowja> which is fine, but jessica needs to just finish it up, which is fine to
20:39:33 <ekarlso> gearman support anyone ? :o
20:39:37 <harlowja> :-P
20:40:42 <harlowja> anyways
20:41:40 <kebray> no gearman.
20:41:49 <kebray> :-P
20:42:11 <kebray> harlowja not seeing your point from that code snippet.. don't have the context there.
20:42:22 <harlowja> u don't put print statements in library code, ha
20:42:24 <kebray> will read the comments soon.
20:42:43 <kebray> log instead... sure.
20:42:57 <harlowja> so thats why i don't think jessica is ready to put it in yet anyway
20:43:32 <changbl> guys, do we plan any release of taskflow soon? i still see many features are being added
20:43:39 <harlowja> and i know she's busy, but this would be an area that i can't help with, me not HR :-P
20:43:45 <harlowja> changbl so sure, i would like to
20:44:10 <harlowja> but i don't think feature adding is tied to releasing
20:44:10 <changbl> harlowja, that is great
20:44:22 <harlowja> features will always be added, thats how software goes :)
20:44:41 <harlowja> add/remove/refactor
20:44:57 <changbl> harlowja, oh, i mean things like actions/engines/API could break already implemented code using taskflow
20:45:38 <harlowja> ya, so i think we have stablilized on those and so releasing i think is a useful thing to do
20:45:41 <changbl> if i implement sth with taskflow, i want the code to be able to stay stabalized
20:45:47 <harlowja> i was just hoping to have a basic celery stuff in also
20:46:05 <harlowja> changbl code never stays stabilized :-P but versions of course are useful
20:46:19 <harlowja> so i am for a release of like 0.1
20:46:21 <changbl> yes, at least mostly stabilized:)
20:46:42 <changbl> e.g.,  create_volume in cinder
20:47:00 <harlowja> ya, i know, i did that one, and it will require a little refactoring
20:47:06 <harlowja> but thats just how it goes
20:47:22 <kebray> harlowja  the typical openstack release is to have everyone focus on stabilizing a release for a period of time before branching and working/focusing on new things.
20:47:35 <changbl> +1 kebray
20:47:40 <kebray> are you thinking different for taskflow?
20:48:10 <harlowja> not really thinking much about that actually, but it seems like we can start thinking about that
20:48:23 <kebray> new stuff can be in flight, but as a managed project, focus should switch between new stuff and no new stuff (stabilization).
20:48:30 <harlowja> sure
20:48:54 <harlowja> i have nothing against that, and i think we are stabalizing
20:49:08 <harlowja> the reviews i've seen in the past 2-3 weeks haven't been anything fundamentally changing
20:49:31 <changbl> harlowja, that is a good thing
20:49:34 <harlowja> agreed
20:49:44 <changbl> If the API can has no change or minimal change, then it will be great:)
20:50:14 <harlowja> sure sure, that would be ideal, and hopefully we can make that happen, but of course i can't sign my life away to that, ha
20:50:23 <changbl> lol
20:50:38 <harlowja> <--- not gonna sign here, ha
20:50:40 <harlowja> ha
20:50:46 <changbl> we are going to merge Ivan's "simpler API" commit right?
20:50:57 <harlowja> i think we want to make sure jessica is ok with it
20:50:59 <changbl> having been there for a while
20:51:03 <changbl> ah, i see
20:51:10 <harlowja> ya, its just more of waiting on jessica to look at it
20:51:18 <harlowja> and make sure she's fine with it
20:51:21 <changbl> k
20:52:08 <harlowja> i think like the following reviews would be nice to have, then 0.1 release
20:52:29 <harlowja> https://review.openstack.org/#/c/47275/
20:52:39 <harlowja> https://review.openstack.org/#/c/47670/ (cleanup)
20:52:48 <harlowja> https://review.openstack.org/#/c/47609/ (distributed)
20:53:03 <harlowja> and https://review.openstack.org/#/c/46458/ (the one api)
20:53:13 <harlowja> and any other cleanups that aren't that big
20:53:17 <harlowja> does that seems reasonable?
20:53:22 <changbl> yes
20:53:49 <harlowja> i'd like https://review.openstack.org/#/c/47561/ also (exception saving)
20:54:07 <harlowja> the other reviews i don't think i would call 'critical'
20:54:11 <kebray> and I'd like distributed to go in.
20:54:12 <melnikov> i see no point in releasing without  resumption from db actually working, because making it work require some breaking changes
20:54:21 <harlowja> ok melnikov
20:54:22 <kebray> will work with jlucci to make it happen.
20:54:44 <harlowja> so melnikov i think anastsia is working on resumption
20:55:14 <harlowja> what breaking changes do u think it will cause?
20:57:06 <harlowja> well anyways we should discuss, maybe in the main channel
20:57:08 <harlowja> since time is running out
20:57:24 <melnikov> i feel like i'll need to bend some things to make them fit together better
20:58:23 <harlowja> ok, lets discuss it i guess in the main channel
20:58:28 <harlowja> and we can see what to do
20:58:32 <harlowja> but i don't think we are that far away
20:59:08 <harlowja> so followup there folks!
20:59:20 <harlowja> #endmeeting