15:00:13 <mriedem> #startmeeting stable
15:00:14 <openstack> Meeting started Tue Apr  5 15:00:13 2016 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:17 <openstack> The meeting name has been set to 'stable'
15:00:18 <ihrachys> o/
15:00:26 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/StableTeam
15:00:50 <mriedem> it's going to be a fast one today
15:00:58 <mriedem> #topic status
15:01:05 <mriedem> https://etherpad.openstack.org/p/stable-tracker is pretty empty
15:01:20 <mriedem> the periodic-stable jobs have been failing due to infra issues, e.g. build timeouts on vexxhost nodes
15:01:32 <mriedem> but that's happening to all jobs
15:01:44 <mriedem> i'm not aware of any other blocking stable branch issues
15:01:51 <ttx> o/
15:02:02 <mriedem> there are no action items from the previous meeting so skipping that
15:02:10 <mriedem> #topic release news
15:02:17 <sigmavirus24> o/
15:02:18 <mriedem> i don't really have any news here
15:02:18 <ttx> mriedem: I have one
15:02:23 <mriedem> ttx: go
15:02:36 * ttx gets notes
15:03:09 <ttx> mugsie had a question for you about a fix that may or may not be acceptable for stable/mitaka post-release
15:03:23 <ttx> basically adding a dep that was previously only a transitive dep
15:03:33 <mugsie> yup - I think we sorted that out
15:03:35 <mriedem> ttx: yeah, we talked about it in -stable
15:03:47 <ttx> oh ok missed that
15:03:59 * ttx needs another pair of eyes and a dozen extra screens
15:04:50 <mriedem> ttx: anything else?
15:04:50 <ttx> mriedem: so it's ok post-release ? I'm fine with that
15:05:34 <mriedem> ttx: by post-release you mean like adding to stable/mitaka?
15:05:53 <mriedem> designate already requires the dep via transitive deps
15:06:02 <mriedem> the change would just add it as an explicit dependency
15:06:06 <mriedem> which i think is ok
15:07:20 <mriedem> i don't have any other release news
15:07:30 <mriedem> but i haven't checked the releases repo for stable branch release proposals either
15:07:34 <mriedem> #topic tagging
15:07:50 <mriedem> there is nothing i'm aware of, trove and keystone have the stable:follows-policy tag now
15:08:00 <mriedem> #topic stuck reviews
15:08:06 <mriedem> nothing on the agenda, anyone have anything here?
15:08:18 <bknudson> no
15:08:21 <mugsie> I had one
15:08:40 <mriedem> go ahead
15:08:46 <mugsie> for designate, should we be looking after stable/kilo EOL, or is that handeled by the -stable team?
15:09:01 <mriedem> stable/kilo is still a coordinated release,
15:09:07 <mriedem> so it will be handled by the stable maint team
15:09:15 <mriedem> the release and EOL that is
15:09:49 <mriedem> Daviey is coordinating stable/kilo releases
15:09:50 <mugsie> cool. I wasnt sure - we seem to have been left off the list previously when there is releases done by the stable team, so wasnt sure
15:10:41 <mriedem> ttx: do you know if there is a list of which projects are handled for the coordinated release?
15:10:51 <mriedem> it used to just be the 'integrated' projects
15:11:11 <mugsie> yeah, thats what I thought - we never quite made it to 'integrated'
15:11:52 <mriedem> i don't see anything here about which projects, only the dates https://wiki.openstack.org/wiki/StableBranchRelease#Planned_stable.2Fkilo_releases_.2812_months.29
15:12:14 <mriedem> #action figure out where we define which projects are part of the coordinated stable/kilo release
15:12:26 <mriedem> #undo
15:12:28 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0xb1133d0>
15:12:36 <mriedem> #action mriedem to figure out where we define which projects are part of the coordinated stable/kilo release
15:12:51 <mriedem> #topic tooling
15:12:55 <mriedem> this is just a reminder,
15:13:01 <mriedem> ihrachys has some tooling reviews up here https://review.openstack.org/#/q/owner:ihrachys%2540redhat.com+status:open+openstack-infra/release-tools
15:13:05 <mriedem> #help review tooling changes https://review.openstack.org/#/q/owner:ihrachys%2540redhat.com+status:open+openstack-infra/release-tools
15:13:21 <mriedem> #topic open discussion
15:13:25 <mriedem> two items
15:13:29 <ihrachys> yeah, would be cool.
15:13:32 <mriedem> more just fyi
15:13:33 <mriedem> 1. Stable team fishbowl session is scheduled for 1:30pm on Thursday of the Design Summit.
15:13:36 <mriedem> #info Stable team fishbowl session is scheduled for 1:30pm on Thursday of the Design Summit.
15:13:42 <ihrachys> also, I have another stable patch for tools:
15:13:42 <ihrachys> #link https://review.openstack.org/#/c/296701/
15:13:53 <ihrachys> that should fix automating stable releases
15:14:17 <mriedem> ok
15:14:20 <ihrachys> dhellmann: ^ please check the patch again, I think I fixed your comments.
15:15:23 <mriedem> #info Possible cross-project session to discuss stable branch EOL policy, see #13 in https://etherpad.openstack.org/p/newton-cross-project-sessions
15:15:47 <ihrachys> also #10 line 144 may be interesting
15:15:51 <mriedem> what i planned on going over in the design summit fishbowl session, i also proposed to the tuesday cross-project list
15:16:03 <ihrachys> tl;dr it suggests dropping coordinated deps
15:16:09 <mriedem> if that's accepted for tuesday, then we can spend the session on thursday going over impl details
15:16:46 <mriedem> ihrachys: yeah, that's come up before as an alternative to upper-constraints and the backwards compat spec
15:17:12 <mriedem> plus more and more deployment tools are using containers to solve this too
15:17:28 <ihrachys> I honestly hate the suggestion. Me wearing downstream hat in addition to upstream one, I see a lot of value in deps being in line.
15:17:49 <mriedem> well, it proposes to still have a single reqs file
15:17:49 <ihrachys> mriedem: I am note sure most consumers are there with their container solutions yet.
15:18:32 <mriedem> anyway, that's it for agenda items
15:18:35 <mriedem> anyone else have anything?
15:19:11 <mriedem> ok, let's end the meeting
15:19:13 <mriedem> thanks everyone
15:19:15 <mriedem> #endmeeting