15:01:12 <mriedem> #startmeeting stable
15:01:17 <openstack> Meeting started Tue Mar 8 15:01:12 2016 UTC and is due to finish in 60 minutes. The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:21 <openstack> The meeting name has been set to 'stable'
15:01:27 <ihrachys> o/
15:01:28 <ttx> o/
15:01:38 <mriedem> wow humans!
15:01:51 <mriedem> tonyb around?
15:02:20 <mriedem> i think we can get started, it's a pretty light agenda today
15:02:23 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/StableTeam#Agenda
15:02:33 <mriedem> #topic status
15:02:42 <mriedem> #link known issues https://etherpad.openstack.org/p/stable-tracker
15:02:49 <mriedem> things are mostly quiet right now
15:03:08 <mriedem> we do need some backports to kilo for openstack/requirements to move again https://review.openstack.org/#/c/246114/
15:03:31 <mriedem> #help get openstack/requirements on kilo working https://review.openstack.org/#/c/246114/
15:04:08 <mriedem> i haven't dug into periodic stable fails yet today, but quick look it looks like trove on liberty has issues
15:04:14 <mriedem> i'll dig into that after the meeting
15:04:17 <ihrachys> mriedem: I did for neutron
15:04:29 <ihrachys> the fix is https://review.openstack.org/289918
15:04:39 <mriedem> Could not open requirements file: [Errno 2] No such file or directory: '/home/jenkins/workspace/periodic-neutron-python27-liberty/upper-constraints.txt' ?
15:04:43 <ihrachys> yes
15:04:57 <ihrachys> periodic jobs were not preparing file for us
15:05:24 <mriedem> ok, did something recently change to regress that?
15:05:41 <ihrachys> yes, the commit message has a link
15:05:48 <ihrachys> we made tox targets using the file
15:06:06 <ihrachys> before that, we had -constraints targets for that
15:06:16 <mriedem> ah ok
15:06:26 <ihrachys> and now we enforce the file for all targets + switched gate to using the 'usual' tox targets
15:07:25 <mriedem> ok, cool, thanks for being quick on that
15:07:35 <mriedem> i looked at one of the trove failures, it's the same thing that's been busted for awhiel now
15:07:38 <mriedem> *awhile
15:07:50 <mriedem> https://bugs.launchpad.net/trove/+bug/1538506
15:07:50 <openstack> Launchpad bug 1538506 in Trove "proboscis tests randomly fail in stable/liberty with "TypeError: create() got an unexpected keyword argument 'slave_of'"" [High,In progress] - Assigned to Craig Vyvial (cp16net)
15:08:12 <mriedem> i need to ask some people on the trove team about that again,
15:08:18 <mriedem> else they should just disable the tests if they aren't going to fix them
15:08:42 <mriedem> #topic action items from previous meeting
15:08:55 <mriedem> 1. mriedem to ping lifeless about fixtures bug https://bugs.launchpad.net/python-fixtures/+bug/1542984
15:08:55 <openstack> Launchpad bug 1542984 in Python Fixtures "fixtures 1.2.0 isn't compatible with testtools 2.0.0" [Undecided,Fix released] - Assigned to Robert Collins (lifeless)
15:08:59 <mriedem> that's fixed now
15:09:04 <ihrachys> yay
15:09:05 <mriedem> 1.2.1 is out and kilo was working again
15:09:17 <mriedem> 2. tonyb to push up his initial script for scraping backport potential bugs
15:09:22 <mriedem> i haven't seen those yet
15:09:30 <mriedem> 3. mriedem to talk to dhellmann about cross-project discussion for stable/liberty timeline
15:09:48 <mriedem> i had a good conversation with fungi in the stable channel yesterday
15:09:53 <mriedem> #link discussion with fungi about stable eol http://eavesdrop.openstack.org/irclogs/%23openstack-stable/%23openstack-stable.2016-03-07.log.html#t2016-03-07T18:54:05
15:10:13 <mriedem> i've requested a fishbowl session at the summit to go over that between the stable/qa/infra/vmt/release teams
15:10:29 <fungi> expect me there
15:10:38 <ttx> me too
15:10:47 <mriedem> cool
15:11:05 <mriedem> any questions on that?
15:11:06 <fungi> ttx and i can pull a good cop/bad cop routine
15:11:24 <mriedem> i'v watched 'the wire' twice
15:11:27 <mriedem> so i know how to handle that
15:11:37 <ihrachys> mriedem: on the script, I had one for neutron
15:11:43 <ihrachys> mriedem: lemme scrap my gerrit, sec
15:11:44 <ttx> we can also do bad cop / bad cop if needed
15:11:57 <mriedem> ihrachys: ok
15:11:59 <ihrachys> #link https://review.openstack.org/#/c/245219/
15:12:34 <ttx> mriedem: I propose we share a common half-day meetup on the Friday, in case stable peeps don't know where to go
15:13:07 <mriedem> just for stable stuff?
15:13:19 <ttx> release management + stable
15:13:53 <ttx> we'll use hte room for releasemanagement anyway
15:13:56 <mriedem> i'd be fine coming to the release mgmt meetup room on friday for things that dhellmann wanted to go over with automation,
15:14:16 <ttx> altarentaively we can make it the release management meetup and be done
15:14:23 <ttx> wow that came out weird
15:14:25 <mriedem> i wasn't planning on reserving a meetup room just for stable stuff, since i think most of the stable team people will actually be in other meetup rooms for most of friday, since we all work on other projects
15:14:36 * ttx blames mosh latency
15:14:53 <ttx> mriedem: ack that's a good point
15:15:00 <ttx> I'll make it mine then
15:15:04 <mriedem> ok
15:15:37 <mriedem> did anyone else have anything about summit they wanted to talk about now?
15:16:00 <mriedem> #info stable + release mgmt will share some time in the release mgmt meetup room on friday at the summit
15:16:41 <mriedem> #info there will be a fishbowl session to talk about stable branch eol policy between the stable/vmt/infra/qa/release teams at the summit
15:16:49 <mriedem> #topic release news
15:16:59 <mriedem> Check for stable/liberty point release candidates as we wind down to m-3
15:17:04 <mriedem> #link http://lists.openstack.org/pipermail/openstack-dev/2016-February/086362.html
15:17:07 <mriedem> m-3 is past
15:17:12 <mriedem> but still a reminder
15:17:38 <mriedem> #action mriedem to check which projects haven't done a stable/liberty release since m-1
15:17:54 <mriedem> #topic tagging
15:17:59 <ttx> yay
15:18:05 <mriedem> the stable:follows-policy tag is official
15:18:10 <mriedem> #link stable:follows-policy tag http://governance.openstack.org/reference/tags/stable_follows-policy.html
15:18:28 <mriedem> #info Projects need to start proposing patches to the governance repo to apply the stable:follows-policy tag to their project.
15:18:30 <ttx> There was some pushback that we should limit usage of stable:* to stable-compliant things
15:18:42 <ttx> and use series:* for other things
15:18:55 <mriedem> ttx: are you referring to flaper87's comments?
15:19:00 <ttx> but then infra has stable/* hardcoded in a lot of places so it's not trivial
15:19:17 <ttx> mriedem: also comments during the meeting
15:19:28 <mriedem> oh, i wasn't there
15:19:28 <ttx> I sold the tag as a good first step
15:19:42 <mriedem> so people wanted a series:follows-policy tag?
15:19:48 <ttx> but we might want to explore that option long-term
15:19:50 <ttx> no
15:19:58 <ttx> they wantes to reserve the branch namespace
15:20:03 <ttx> wanted*
15:20:21 <ttx> i.e. only allow stable-compliant tings to name branches stable/something
15:20:36 <mriedem> oh
15:20:50 <mriedem> so, if you're not stable compliant, you don't even get stable branches?
15:20:55 <ttx> but it's not trivial. Like what happens when you need to reame a branch because it's no longer compliant, to series/something
15:21:11 <ttx> mriedem: you get series branches.
15:21:16 <mriedem> so series/liberty
15:21:20 <ttx> yeah.
15:21:28 <mriedem> and you can backport features and api changes to series/liberty?
15:21:49 <ttx> you can do whatever you want to series/liberty, even things against stable policy
15:21:56 <ttx> I still think the tag is a better idea
15:21:57 <mriedem> hmmm
15:21:59 <mriedem> yeah
15:22:04 <ttx> it's more flexible
15:22:18 <ttx> like we don't screw up everyone if we remove it
15:22:22 <mriedem> i don't see the point in a series/liberty thing, except for people that want to stay stuck in time and backport features to the release they are running in production and don't want to upgrade
15:22:47 <ttx> I'd rather incentivize stable branches to behave properly, and the tag is a stronger way of doing that
15:22:51 <mriedem> IMO, people should do that out of tree if that's what they want, or fork a repo in github and backport stuff to it there
15:23:18 <mriedem> yeah
15:23:23 <ttx> anyway, just mentioning it, since it was raised
15:23:24 <mriedem> i also plan on using the tag as a signal for eol
15:23:28 <mriedem> ok, thanks
15:23:30 <ttx> no action on our part I think
15:23:36 <mriedem> no action is best action
15:23:43 <mriedem> let's move on
15:23:49 <ttx> I'll probably propose the removal of the "has-stable-branches" tag though
15:23:49 <mriedem> #topic stuck reviews
15:24:06 <ttx> unless you think this can be redefined to something of value
15:24:29 <mriedem> well, only question i had on removing that was, do it before or after projects have requested the stable:follows-policy tag?
15:24:31 <mriedem> or does'nt matter?
15:24:41 <ttx> If projects have has-stable-branches but not follows-stable-policyt
15:24:55 <ttx> doesn't matter imho
15:25:01 <mriedem> agree
15:25:03 <ttx> but a tthis stage we can wait a bit
15:25:13 <mriedem> sure, i just proposed the tag for nova yesterday
15:25:14 <mriedem> and novaclient
15:25:35 <ttx> let's wait for the usual suspects to have claimed the follows-policy tag and then we'll retire has-stable-branches
15:25:41 <ttx> when it will be even clearer it's useless
15:25:43 <mriedem> i wonder if anyone actually consumes the has-stable-branches tag and makes decisions based on it
15:25:58 <ttx> mriedem: no, it doesn't answer any useful question
15:26:08 <ttx> and it's woefully out of date anyway
15:26:10 <mriedem> yeah, +1 for waiting for the integrated gate projects to request the new tag
15:26:31 <ttx> so it answers the "does it have a stable/* branch" and then you better check the git repo for the authoritative answer
15:26:40 <mriedem> right :)
15:26:51 <mriedem> doesn't mean you can install that branch
15:27:01 <ttx> it's worse than useless in fact, it's confusing
15:27:30 <mriedem> #topic tooling
15:27:47 <mriedem> 1. dhellmann's WIP script to check for unreleased changes
15:27:49 <mriedem> #link https://review.openstack.org/#/c/270273/
15:28:04 <mriedem> that was blocked waiting for the stable:follows-policy tag, which exists now, but doesn't have any projects using it yet
15:28:35 <mriedem> 2. ihrachys's neutron script to remove backport-potential tag on fixed bugs https://review.openstack.org/#/c/245219/
15:29:03 <mriedem> in the last meeting when tonyb was going to push up his WIP script for review, i think we said release-tools could be the repo to do that in
15:29:13 <mriedem> which is what dhellmann was using for #1 above
15:29:28 <ihrachys> I agree it belongs to release-tools
15:29:29 <mriedem> ihrachys: i guess if your script is adopted we could eventually generalize it and put it into release-tools
15:30:13 <mriedem> #topic open discussion
15:30:19 <mriedem> there was nothing on the agenda,
15:30:22 <mriedem> so anyone have anything?
15:30:51 <mriedem> not sounding like it
15:31:04 <mriedem> let's end early, thanks everyone for showing up
15:31:07 <mriedem> #endmeeting