17:00:15 <devkulkarni> #startmeeting Solum Team Meeting
17:00:22 <openstack> Meeting started Tue Jan 26 17:00:15 2016 UTC and is due to finish in 60 minutes.  The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:26 <openstack> The meeting name has been set to 'solum_team_meeting'
17:00:28 <devkulkarni> #topic Roll Call
17:00:32 <devkulkarni> Devdatta Kulkarni
17:00:35 <james_li> james li
17:00:54 <ashishjain> Ashish Jain
17:02:59 <devkulkarni1> sorry my adium client got disconnected for some reason
17:03:36 <devkulkarni1> james_li, ashishjain: good to see you
17:03:39 <devkulkarni> here is link to today's agenda: https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2016-01-26_1700_UTC
17:04:41 <devkulkarni1> lets wait for few minutes for folks to join in
17:06:15 <devkulkarni1> james_li, ashishjain: looks like vijendar is not able to join for some reason
17:06:23 <devkulkarni1> having network connectivity issues
17:06:50 <devkulkarni1> lets continue, he should join in as soon as he is able to
17:07:12 <devkulkarni1> #topic Announcements
17:07:21 <devkulkarni1> hi vijendar
17:07:30 <vijendar> Hi devkulkarni1
17:07:40 <devkulkarni1> we have james_li and ashishjain here as well
17:07:50 <vijendar> Hi all
17:07:59 <devkulkarni1> here is the agenda for today: https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2016-01-26_1700_UTC
17:08:06 <devkulkarni1> we are in the Announcement topi
17:08:21 <devkulkarni1> #success Solum's vagrant+devstack setup is back to deploying applications till READY state.
17:08:23 <openstackstatus> devkulkarni1: Added success to Success page
17:08:40 <devkulkarni1> so just wanted to announce above ^
17:09:22 <devkulkarni1> basically we need to pin nova to a previous commit as chasing the nova head is leading to failures for us
17:09:47 <james_li> great
17:09:48 <devkulkarni1> Pin nova to commit specified in https://github.com/devdattakulkarni/solum-provenance/blob/master/service-dependencies.txt and restart nova services
17:10:00 <devkulkarni1> james_li: +1
17:10:04 <vijendar> nice to see 'READY' state
17:10:38 <devkulkarni1> yeah.. vijendar and ashishjain: in case you end up trying deploying apps, I would be eager to hear if you get to READY state as well
17:10:46 <devkulkarni1> Follow steps given in this bug https://bugs.launchpad.net/solum/+bug/1536341 to startup devstack
17:10:47 <openstack> Launchpad bug 1536341 in Solum "devstack-startup" [High,New]
17:11:14 <devkulkarni1> so that was the announcement I had..
17:11:25 <devkulkarni1> do any of you have any announcements to make?
17:12:13 <devkulkarni1> alright.. lets move to next topic
17:12:23 <devkulkarni1> #topic Review Action Items
17:12:35 <devkulkarni1> There were no action items from last time
17:12:50 <devkulkarni1> so lets continue to next topic
17:13:04 <devkulkarni1> #topic Blueprint/Bug Review and Discussion
17:13:15 <devkulkarni1> We have four reviews today
17:13:24 <devkulkarni1> 1) Deploying already created DU
17:13:28 <devkulkarni1> https://review.openstack.org/#/c/271111/
17:13:32 <devkulkarni1> https://review.openstack.org/#/c/271115/
17:13:41 <devkulkarni1> let me give a background for this feature
17:14:03 <devkulkarni1> The idea is to support deploying of DUs without having to create them first
17:14:32 <devkulkarni1> The DU might be already created.. perhaps in a previous build step
17:14:59 <devkulkarni1> or the DU might be present in a public repository (such as dockerhub)
17:15:16 <vijendar> does that mean, you can register one app and deploy different DU?
17:15:30 <vijendar> by accident?
17:15:49 <devkulkarni1> that's a good question..
17:15:57 <vijendar> is there any way to check/restrict?
17:16:10 <devkulkarni1> you are saying we should lock down the DUs that can be deployed only for the app that has been registered
17:16:14 <devkulkarni1> actually it makes sense
17:16:16 <vijendar> other question is, do we really want to restrict
17:17:05 <devkulkarni1> both look to be valid use cases
17:17:30 <devkulkarni1> if you just want to deploy an image, say of rabbitmq which is already present in dockerhub,
17:17:54 <devkulkarni1> then you are asking should that have to be associated with an app first
17:18:19 <devkulkarni1> may be user doesn't want to create an app and just do 'solum deploy <rabbit-image>'
17:18:22 <vijendar> correct
17:18:34 <devkulkarni1> so that is one use case
17:19:01 <devkulkarni1> the other is, the image is associated with an app .. so 'solum app deploy <app-name> <image-id>'
17:20:16 <devkulkarni1> for the use case of deploying an image without associating with an app .. would we not still want to track some meta data about the deployment?
17:20:43 <devkulkarni1> this will essentially be the workflow for that deployment
17:21:18 <devkulkarni1> right now workflows are directly associated with apps
17:22:00 <devkulkarni1> if we want to support deployments which are not associated with an app (like above use-case), then at the implementation level we will have to make workflows as top-level entities independent of apps
17:22:08 <devkulkarni1> but that is implementation details
17:22:20 <devkulkarni1> real question is
17:22:42 <devkulkarni1> what kind of applications would such a feature enable..
17:22:56 <devkulkarni1> I am just thinking out loud here.. don't have immediate answers
17:22:56 <vijendar> I am not sure
17:23:43 <devkulkarni1> hmmm.. the patches start adding support for the use case when a DU is already built for an app
17:24:01 <devkulkarni1> we can certainly think about the other use-case
17:24:16 <devkulkarni1> may be we can file a wishlist bug to track that
17:24:32 <devkulkarni1> let me take an action item for that
17:25:16 <devkulkarni1> #action devkulkarni1 to file a bug to track the use-case of deploying docker images directly from solum, without first having to associate those images with an app
17:25:57 <devkulkarni1> the above patches are a start towards implementing the feature to allow deploying DUs which may be in glance or swift
17:26:07 <devkulkarni1> vijendar: I saw your comments on the patch
17:26:15 <devkulkarni1> will address those..
17:26:28 <devkulkarni1> would like to reply to one of the comments here
17:26:41 <devkulkarni1> I think you were asking about support for swift
17:26:58 <devkulkarni1> I have purposely not added it, as I wanted to do that in a separate patch
17:27:07 <vijendar> ok
17:27:17 <devkulkarni1> this patch only adds support for glance..
17:27:27 <vijendar> makes sense
17:27:31 <devkulkarni1> ashishjain: this patch should enable your work for Jenkins integration
17:27:44 <ashishjain> yes correct devkulkarni
17:28:15 <devkulkarni1> cool.. so please review these patches .. there is one patch for API and one for CLI
17:28:22 <ashishjain> yeah sure
17:28:36 <devkulkarni1> ok.. lets move to the next item
17:28:47 <devkulkarni1> 2) Converting bash scripts to Python
17:28:57 <devkulkarni1> https://review.openstack.org/#/c/181181/
17:29:08 <devkulkarni1> So here is some background on this patch
17:29:37 <devkulkarni1> In Solum, we have couple of bash scripts which perform some of the most important functions within Solum
17:29:42 <devkulkarni1> these are build-app and build-lp
17:29:53 <devkulkarni1> for a long time we have wanted to convert these to python
17:30:11 <devkulkarni1> to allow us to perform better error handling, debugging, etc.
17:30:31 <devkulkarni1> james_li had started on the bash-to-python conversion work sometime back
17:31:23 <devkulkarni1> he had almost finished it, and had submitted three separate patches which together implemented the functionality of currently build-app, and built-lp
17:31:36 <devkulkarni1> s/currently/current/
17:31:55 <devkulkarni1> that work though required some changes to the way solum-worker would be started
17:32:04 <vijendar> devkulkarni1: I am currently reviewing those patches
17:32:21 <devkulkarni1> and that required generating of an additional config parameter option which is supposed to be used by solum-worker
17:32:42 <devkulkarni1> and that required to use newer oslo-config generator
17:33:17 <devkulkarni1> so all the three patches from james_li were blocked on us introducing this new oslo-config generator within solum
17:33:48 <james_li> devkulkarni1: yeah the patch adds a new cmd option to solum-worker as we need to pass in different value for different worker process.
17:34:27 <devkulkarni1> recently, a member of the community submitted the patch to add the new oslo config generator
17:34:33 <devkulkarni1> we merged this patch last week
17:34:46 <devkulkarni1> and it has now unblocked james_li's patches
17:34:53 <devkulkarni1> so that is the background
17:35:16 <devkulkarni1> vijendar, ashishjain: if you get a chance, review james_li's patches
17:35:29 <james_li> crystal clear thanks devkulkarni1
17:35:40 <devkulkarni1> :)
17:35:49 <devkulkarni1> on the patches you will find lot of discussion
17:36:16 <james_li> they have been sitting there for months
17:36:17 <devkulkarni1> about different design options, why certain things are defined the way they are defined, etc. james_li has answered all the questions (at least the ones that I had)
17:36:36 <devkulkarni1> james_li: I am very excited to see these land soon
17:36:45 <devkulkarni1> I have already given +2 to the first patch..
17:36:55 <devkulkarni1> if you have rebased others, I will review them today
17:37:14 <james_li> I hope we can merge them now, and I will add tests later as following patches.
17:37:23 <devkulkarni1> sure james_li
17:37:41 <devkulkarni1> that will be fine
17:37:50 <devkulkarni1> just to make it clear to all..
17:38:01 <devkulkarni1> these patches are not replacing the build-app and build-lp
17:38:11 <devkulkarni1> they are just adding the new functionality
17:38:45 <devkulkarni1> once we have thoroughly tested the new paths then only we will take a decision of when to deprecate build-lp and build-app
17:39:20 <devkulkarni1> any questions/thoughts/comments about this?
17:39:40 <devkulkarni1> 'this' as in, the patches themselves and the way forward
17:40:26 <devkulkarni1> alright.. lets continue with next one
17:40:35 <devkulkarni1> 3) Saving workflow result
17:40:39 <devkulkarni1> https://review.openstack.org/#/c/269842/
17:41:02 <devkulkarni1> this patch is from vijendar.. it is adding support to store result of workflow execution
17:41:17 <devkulkarni1> vijendar: do you want to give some background on this which will help with the review?
17:41:29 <vijendar> devkulkarni1: sure
17:42:16 <vijendar> when a workflow is executed, we might want to store the output of the workflow
17:42:37 <vijendar> for example, if a workflow fails, we may store quick summary/stack trace of the workflow
17:43:50 <devkulkarni1> when workflow succeeds, are we going to store things like the ids of the deployed DUs?
17:44:05 <vijendar> with magnum integration, we may need to store the containers/bays info etc
17:44:31 <vijendar> devkulkarni1: correct
17:44:39 <devkulkarni1> makes sense
17:44:56 <devkulkarni1> this is good vijendar
17:45:02 <devkulkarni1> will review the patch today
17:45:18 <devkulkarni1> james_li, ashishjain: if you also get a chance, please review the patch
17:45:18 <vijendar> devkulkarni1 ashishjain james_li please take a look when you get a chance
17:45:29 <devkulkarni1> will do
17:45:37 <ashishjain> Sure vijendar devkulkarni
17:45:45 <vijendar> thanks
17:45:49 <devkulkarni1> ok, lets move to next one
17:45:54 <devkulkarni1> 4) App parameters
17:45:58 <devkulkarni1> https://review.openstack.org/#/c/267182/
17:46:07 <devkulkarni1> this patch is from vijendar as well
17:46:16 <devkulkarni1> vijendar: could you provide some background on this one too..
17:46:55 <vijendar> currently parameters are a flat list of key/value pairs
17:47:36 <vijendar> with this patch, we are introducing sections in the parameters file instead of a flat list
17:48:16 <devkulkarni1> vijendar: cool
17:48:52 <devkulkarni1> this allows us to pass in different things such as creds for deployments, application env variables, etc.
17:49:10 <vijendar> if some one would like to write custom plugin to solum and wanted to allow some parameters, they can just add a new section
17:49:21 <vijendar> in parameters file
17:49:29 <devkulkarni1> that is awesome
17:49:55 <devkulkarni1> vijendar: could the values be dictionaries?
17:50:02 <vijendar> for example, magnum integration may need some credentials to pass
17:50:11 <devkulkarni1> right
17:50:39 <vijendar> devkulkarni1: params is a yaml file
17:51:01 <devkulkarni1> ok, so the values could be any valid yaml
17:51:14 <james_li> I think this one is a followup for https://review.openstack.org/#/c/267181 ?
17:51:27 <james_li> vijendar: ^
17:51:34 <vijendar> oh..right
17:52:00 <devkulkarni1> yes, I saw that james_li you had some comments on the patch
17:52:07 <james_li> I made some comments on 267181, could you please address?
17:52:16 <james_li> vijendar: ^
17:52:20 <vijendar> james_li: sure. will do
17:52:25 <james_li> thx!
17:52:34 <vijendar> james_li: thanks for reviewing
17:52:38 <james_li> np
17:52:42 <devkulkarni1> cool..
17:52:48 <devkulkarni1> so we have about 8 minutes
17:53:03 <devkulkarni1> next up is open discussion
17:53:09 <devkulkarni1> #topic Open DIscussion
17:53:31 <devkulkarni1> I wanted to check with how folks are doing with their submission preparations?
17:54:00 <devkulkarni1> do you need any help? this week is the last week before submission
17:54:29 <devkulkarni1> ashishjain1: the patches that I have for deploying pre-created DUs should help with your Jenkins + Solum submission
17:54:29 <ashishjain1> vijendar: How are you going about bridge adapter in vagrant
17:54:44 <ashishjain1> devkulkarni1: yeah
17:55:04 <ashishjain1> vijendar: I add a new "public_network" in vagrantfile
17:55:09 <devkulkarni1> ashishjain1: james_li might also have some experience around making github webhook calls within solum vm
17:55:10 <james_li> devkulkarni1: I will try to make some updates on my proposal last time and resubmit
17:55:31 <devkulkarni1> james_li: +10
17:55:45 <james_li> devkulkarni1: are you submitting anything?
17:55:52 <devkulkarni1> james_li: let me know if you need any help (with any patch or with poc or with write up etc.)
17:56:04 <devkulkarni1> james_li: I am going to try do a poc for multi-container apps
17:56:09 <james_li> ah
17:56:12 <james_li> nice
17:56:30 <devkulkarni1> if I get something before the deadline then would submit it.
17:56:45 <devkulkarni1> looks like there will be atleast 3 solum submissions
17:56:53 <james_li> cool
17:56:56 <devkulkarni1> 1) Jenkins + Solum from ashish
17:56:58 <ashishjain1> it works when I bring up the vagrant machine, however it stops working when the stack.sh at its last stage
17:57:00 <vijendar> ashishjain1: I don't remember updating the vagrant file for network errror
17:57:10 <devkulkarni1> 2) Solum + Carina from vijendar
17:57:19 <devkulkarni1> 3) Your submission
17:57:33 <devkulkarni1> and if I am able to do the poc then we will have fourth one
17:57:50 <devkulkarni1> james_li: quick question about issue that ashishjain1 is running into..
17:58:21 <james_li> ashishjain1: I used grok
17:58:23 <devkulkarni1> when you were working with the trigger api and using ngrok, did you do anything special to your vagrant vm so that solum api was reacheable from outside?
17:58:58 <james_li> ashishjain1: https://ngrok.com/docs
17:59:19 <james_li> just run ngrok, thats it
17:59:57 <ashishjain1> james_li: okay will try that out
18:00:01 <devkulkarni1> alright.. lets continue the discussion in solum irc channel..
18:00:11 <devkulkarni1> thanks for joining today james_li, ashishjain1, vijendar
18:00:15 <devkulkarni1> the deadline is next monday
18:00:17 <james_li> bye
18:00:19 <devkulkarni1> for the submission
18:00:24 <devkulkarni1> ping me if you need any help
18:00:30 <ashishjain1> thanks devkulkarni
18:00:33 <devkulkarni1> see you next week
18:00:38 <devkulkarni1> #endmeeting