17:00:22 <devkulkarni> #startmeeting Solum Team Meeting
17:00:23 <openstack> Meeting started Tue Jan  5 17:00:22 2016 UTC and is due to finish in 60 minutes.  The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:27 <openstack> The meeting name has been set to 'solum_team_meeting'
17:00:30 <devkulkarni> #topic Roll Call
17:00:32 <devkulkarni> Devdatta Kulkarni
17:00:42 <james_li> james li
17:00:47 <ashishjain> Ashish jain
17:00:51 <devkulkarni> Morning James
17:00:53 <devkulkarni> Hi Ashish
17:01:03 <ashishjain> Hi dev
17:01:07 <james_li> HI devkulkarni, happy new year
17:01:07 <muralia> murali allada
17:01:08 <muralia> hi all
17:01:11 <devkulkarni> Great to see you
17:01:13 <devkulkarni> hey muralia
17:01:15 <muralia> happy new year to everyone
17:01:17 <devkulkarni> great to see you
17:01:17 <adrian_otto> o/
17:01:21 <devkulkarni> happy new year
17:01:22 <adrian_otto> Happy NEw Year
17:01:23 <ashishjain> Helli muralia
17:01:25 <devkulkarni> hi adrian_otto
17:01:31 <ashishjain> Happy new year to all
17:01:33 <devkulkarni> great to see you
17:01:37 <muralia> hey ashishjain.
17:01:45 <devkulkarni> this is great.. we have several folks today :)
17:01:51 <devkulkarni> here is the agenda for today:
17:02:01 <devkulkarni> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2016-01-05_1700_UTC
17:02:42 <devkulkarni> will wait for a minute to see if anyone else joins us.. will proceed to next topic after that
17:03:37 <devkulkarni> alright..
17:03:48 <devkulkarni> #topic Announcements
17:04:07 <devkulkarni> Wipro workshop notes: http://www.slideshare.net/devkulkarni/contributing-to-openstack
17:04:31 <vijendar> Hi all
17:04:33 <ashishjain> Devkulkarni thanks a lot for the session
17:04:38 <devkulkarni> As I had mentioned in our meeting in December, ashishjain had invited me to do a workshop at Wipro's office in Pune India
17:04:49 <devkulkarni> Above are the notes of that session
17:05:14 <devkulkarni> ashishjain: it was my pleasure.. hopefully, folks got something out of the workshop
17:05:41 <ashishjain> It was a really good one and was well appreciated by lot of attendees
17:05:55 <devkulkarni> please let your teams know that they can join irc channel and irc meetings to participate in design discussions and implementation
17:06:03 <devkulkarni> ashishjain: that is great to know
17:06:08 <ashishjain> We look forward to many more ☺
17:06:35 <devkulkarni> ashishjain: :) .. openstack-dev mailing list is also a good place to participate
17:06:53 <dimtruck> o/
17:06:57 <devkulkarni> ashishjain: I am looking forward to working closely with you and your teams
17:07:02 <devkulkarni> hi dimtruck, vijendar
17:07:08 <devkulkarni> thanks for joining us
17:07:19 <devkulkarni> alright.. that was the announcement that I had
17:07:23 <ashishjain> Definitely will ask teams to work closely with our team
17:07:33 <devkulkarni> do any of the team members have any announcements?
17:07:35 <ashishjain> Same here devkulkarni
17:08:30 <devkulkarni> #topic Review Action Items
17:08:47 <devkulkarni> There have been two action items pending on me from December
17:08:58 <devkulkarni> (pending) devkulkarni to figure out details about diverse-affiliation tag associated with solum.
17:09:26 <devkulkarni> actually, adrian_otto might know about this one..
17:10:02 <devkulkarni> adrian_otto: do you know where to find various tags that are given to a project by the TC?
17:10:23 <devkulkarni> ashishjain had asked a question sometime back about the diverse-affiliation tag for solum
17:10:24 <dimtruck> devkulkarni: https://governance.openstack.org/reference/tags/team_diverse-affiliation.html#requirements
17:10:26 <dimtruck> this?
17:10:40 <devkulkarni> dimtruck: cool
17:10:59 <adrian_otto> devkulkarni: yes, it's in the projects.yaml file. I can find a link to it for you.
17:11:06 <ashishjain> http://governance.openstack.org/reference/projects/
17:11:33 <ashishjain> This link gives the details about all the projects
17:11:39 <devkulkarni> thanks adrian_otto, ashishjain
17:12:32 <adrian_otto> thanks ashishjain
17:13:14 <devkulkarni> so basically we currently don't have this tag
17:13:15 <ashishjain> Adrian_otto devkulkarni , my pleasure
17:13:20 <adrian_otto> the raw data comes from here:
17:13:28 <adrian_otto> #link https://github.com/openstack/governance/blob/master/reference/projects.yaml OpenStack Projects
17:13:43 <adrian_otto> so you can submit reviews against that in Gerrit to propose changes
17:14:16 <devkulkarni> https://github.com/openstack/governance/blob/master/reference/projects.yaml#L3421
17:14:22 <devkulkarni> is an example of project which has this tag
17:14:27 <devkulkarni> ok, makes sense
17:14:44 <devkulkarni> thanks adrian_otto
17:15:21 <devkulkarni> ashishjain: does this discussion answer your question?
17:15:37 <ashishjain> Devkulkarni yes
17:15:57 <devkulkarni> ashishjain: cool.. so I will mark that pending action item as done :)
17:16:03 <ashishjain> We just need to provide info i guess
17:16:24 <devkulkarni> ashishjain: rigt
17:16:26 <ashishjain> But wouldn't it be validated by openstack eam
17:16:36 <ashishjain> *team
17:17:02 <devkulkarni> ashishjain: for validation I think the info will be pulled in automatically based on the number of reviews, commits, etc.
17:17:08 <devkulkarni> once we propose a change
17:17:14 <ashishjain> We can mark it closed than
17:17:23 <ashishjain> Thanks devkulkarni
17:17:32 <devkulkarni> ashishjain: sounds good
17:17:45 <devkulkarni> the other action item which is pending is:
17:18:06 <devkulkarni> how to retire this site: http://solum.readthedocs.org/en/latest/
17:18:40 <devkulkarni> for this I need to follow up with the openstack-infra folks
17:19:02 <devkulkarni> will continue it forward as I haven't yet gotten around to doing that
17:19:11 <devkulkarni> #action devkulkarni to figure out how to retire solum readthedocs site
17:19:38 <devkulkarni> were there any other action items that any of you remember which we haven't covered today, or in last couple of meetings?
17:20:32 <devkulkarni> alright.. lets move to patch reviews and discussion
17:20:41 <devkulkarni> #topic Blueprint/Bug Review and Discussion
17:20:54 <devkulkarni> 1) Release model change as suggested by ttx
17:21:02 <devkulkarni> #link https://review.openstack.org/#/c/263294/
17:21:09 <devkulkarni> let me give some background on this
17:21:44 <devkulkarni> each openstack project needs to follow a model of when the project can be released.. currently there are three release models defined by the release team
17:22:16 <devkulkarni> a) release:independent, b) release:cycle-with-intermediary, c) release:end-of-cycle
17:22:33 <devkulkarni> OpenStack release cycle is of 6 months
17:22:56 <devkulkarni> Solum has been following the release:independent model till now
17:23:06 <ashishjain> Yeah
17:23:36 <devkulkarni> Recently OpenStack release team reached out to me saying that they recommend that we move to release:cycle-with-intermediary release model
17:24:01 <devkulkarni> the rationale for doing this was by doing so, it will be possible for Solum to be released with other OpenStack projects
17:24:05 <devkulkarni> at the end of the cycle
17:24:21 <ashishjain> That seems to be a good option
17:24:29 <devkulkarni> the cycle-with-intermediate release model has advantages of both the independent model and the end-of-cycle model
17:24:36 <devkulkarni> ashishjain: yeah
17:24:53 <devkulkarni> so above patch basically makes that change
17:25:15 <devkulkarni> this patch needs to be merged by January 20th as advised by the release team
17:25:40 <devkulkarni> you all can give your votes on the patch as well
17:26:12 <devkulkarni> any thoughts/questions in this regard?
17:27:06 <muralia> sure. patch looks good. is that all that needs to be changed?
17:27:19 <devkulkarni> muralia: yes, that is all is required
17:27:34 <muralia> cool
17:27:48 <devkulkarni> OpenStack release team will hopefully merge it before their deadline
17:27:55 <devkulkarni> from our side we just had to submit the patch
17:28:29 <devkulkarni> alright.. the next item is a big one
17:28:38 <devkulkarni> 2) Devstack gate failing due to plugin architecture changes
17:28:56 <devkulkarni> #link https://review.openstack.org/#/c/249432/ (representative patch)
17:29:09 <devkulkarni> #link http://logs.openstack.org/03/261803/1/check/gate-solum-devstack-dsvm/ccbdd0d/console.html.gz#_2015-12-27_07_09_06_679 (failure 1)
17:29:17 <muralia> the UI has changed so much, how do i give a +1?
17:29:21 <devkulkarni> #link http://logs.openstack.org/03/261803/1/check/gate-solum-devstack-dsvm/ccbdd0d/logs/devstacklog.txt.gz#_2015-12-27_06_49_44_668 (failure 2)
17:29:28 <devkulkarni> muralia: hit the "Reply" button
17:29:34 <muralia> ah :)
17:29:44 <devkulkarni> btw, I am not liking the new UI
17:30:15 <devkulkarni> ashishjain: the timing of the UI change was a bit unfortunate.. as my notes for Wipro workshop contains screenshots of the old UI
17:30:26 <devkulkarni> anyways.
17:30:28 <vijendar> yeah.. new UI is confusing
17:30:35 <muralia> me too. its so cluttered
17:30:45 <devkulkarni> +1 vijendar muralia
17:30:46 <ashishjain> I was also confused with new ui
17:30:57 <devkulkarni> dimtruck seems to like the new UI though
17:31:02 <devkulkarni> ashishjain: +1
17:31:03 <dimtruck> hahahaha, i'm used to it
17:31:05 <ashishjain> Somehow pressed the reply button nd that did it
17:31:19 <dimtruck> it's been in gerrit-dev for months now
17:31:46 <devkulkarni> dimtruck: you should give us a quick run down on where things are in the ne e UI
17:31:52 <devkulkarni> new UI
17:31:56 <devkulkarni> compared to the old UI
17:32:08 <dimtruck> what are you missing?
17:32:26 <devkulkarni> I know vijendar was missing a combined file view.. right?
17:32:31 <dimtruck> (not saying that it's not convoluted)
17:32:32 <dimtruck> oh
17:32:41 <dimtruck> so in the patch view
17:32:44 <devkulkarni> I personally just miss the simplicity of the old UI
17:33:03 <dimtruck> there's a green/red button on the top left
17:33:07 <dimtruck> next to the arrows
17:33:19 <vijendar> devkulkarni dimtruck I was able to see all the files on the top of the review
17:33:20 <devkulkarni> yes, see that
17:33:27 <dimtruck> i think that's what you're looking for?
17:33:29 <dimtruck> cool!
17:33:34 <dimtruck> sorry for the tangent :)
17:34:00 <devkulkarni> dimtruck: :) .. this is not a tangent
17:34:14 <devkulkarni> lets discuss more about UI in the Open discussion
17:34:27 <devkulkarni> for now, let me go back to the more pressing issue of devstack gate being broken
17:34:55 <devkulkarni> dimtruck, james_li: especially need your attention on this topic
17:35:05 <devkulkarni> let me provide some background to set the context
17:35:41 <devkulkarni> sometime back devstack team had changed the way different projects are integrated into devstack
17:35:51 <devkulkarni> they had introduced the 'plugin' model
17:36:26 <devkulkarni> starting the Tokyo summit they had announced that all the projects need to move over to start using this plugin model
17:36:43 <devkulkarni> otherwise the devstack gate will start failing starting mid december
17:37:10 <devkulkarni> for solum, venkatmaheshkotha and dimtruck rallied together to produce the plugin patch
17:37:22 <devkulkarni> it was merged in late november
17:37:44 <devkulkarni> so, technically we have done what has been required from us
17:38:07 <devkulkarni> however, when mid december rolled in, our devstack gate started failing
17:38:20 <devkulkarni> as was said by the tempest/devstack team
17:38:37 <devkulkarni> currently all our patches are getting a -1 from the devstack gate
17:38:46 <james_li> lets fix it!
17:39:09 <devkulkarni> so either a) our devstack plugin patch did not work as was expected, or b) something else changed which is causing the gate to fail
17:39:13 <devkulkarni> awesome james_li
17:39:32 <devkulkarni> the failure that we are seeing is
17:39:43 <devkulkarni> none of the solum services seem to be starting up
17:39:56 <devkulkarni> #link http://logs.openstack.org/03/261803/1/check/gate-solum-devstack-dsvm/ccbdd0d/console.html.gz#_2015-12-27_07_09_06_679
17:40:12 <devkulkarni> 'solum-api' is not running is the message printed in
17:40:14 <dimtruck> devkulkarni: were you able to reproduce this locally?
17:40:27 <devkulkarni> dimtruck: no, not yet.
17:40:35 <dimtruck> ah ok
17:40:43 <devkulkarni> yesterday I tried to spin up devstack gate locally as you had mentioned to do
17:40:54 <devkulkarni> but my VM got stuck in some earlier step
17:41:02 <devkulkarni> I am going to try to spin up devstack locally again
17:41:17 <dimtruck> yeah, i can try it too
17:41:20 <devkulkarni> btw, dimtruck has shared an etherpad link of how to create local devstack instance
17:41:36 <devkulkarni> #link https://etherpad.openstack.org/p/devstack_gate
17:41:50 <dimtruck> i moved it here: https://etherpad.openstack.org/p/magnum_devstack_gate...since devstack_gate might be too specific
17:42:02 <dimtruck> err, not specific enough
17:42:08 <dimtruck> i don't know...felt weird haha
17:42:08 <devkulkarni> dimtruck: I see
17:42:15 <devkulkarni> #link https://etherpad.openstack.org/p/magnum_devstack_gate
17:42:34 <dimtruck> let's copy it over to solum_devstack_gate etherpad url and take out magnum specific bits
17:43:02 <devkulkarni> dimtruck: sounds good.. if you can do that, that will be awesome.. in the mean while I will provide details about the error
17:43:21 <devkulkarni> so to provide details about the plugin architecture:
17:43:42 <devkulkarni> the plugin architecture needs the following:
17:43:54 <devkulkarni> 1) top level 'devstack' directory in the project's source
17:44:07 <devkulkarni> 2) plugin.sh file inside this directory
17:44:21 <devkulkarni> 3) a settings file, which contains env variables etc.
17:44:31 <devkulkarni> we have this here: https://github.com/openstack/solum/tree/master/devstack
17:44:58 <devkulkarni> In settings file, we are enabling solum services
17:45:04 <devkulkarni> https://github.com/openstack/solum/blob/master/devstack/settings#L78
17:45:47 <devkulkarni> and in plugin.sh, we check this and then start the services
17:45:49 <devkulkarni> https://github.com/openstack/solum/blob/master/devstack/plugin.sh#L388
17:46:22 <devkulkarni> this is the documentation of devstack's plugin interface:
17:46:25 <devkulkarni> #link http://docs.openstack.org/developer/devstack/plugins.html
17:47:34 <devkulkarni> if you spend some time looking through the plugin documentation and the corresponding code that we have, you will notice that we have what is required to make a plugin
17:47:37 <james_li> not sure if this is valid: I don't see solum under [service_available] http://logs.openstack.org/25/263625/2/check/gate-solum-devstack-dsvm/1ce83f8/logs/devstack-gate-post_test_hook.txt.gz#_2016-01-05_09_54_20_033
17:48:37 <dimtruck> hmmm
17:49:08 <devkulkarni> james_li: I don't know whether it used to be there earlier.. also that particular output is tempest's conf file.. I don't think solum services will show under that.. or would they?
17:49:36 <devkulkarni> james_li: wait
17:49:43 <devkulkarni> may be you are right
17:49:49 <dimtruck> yeah...
17:49:58 <devkulkarni> you mean, something like 'solum = true' ?
17:50:03 <dimtruck> right
17:50:12 <devkulkarni> or 'solum-api = true', 'solum-worker = true'
17:50:20 <devkulkarni> hmm.. good observation
17:50:33 <james_li> not sure that will work, but worth a try?
17:50:49 <dimtruck> so i'm looking at magnum's setup
17:50:50 <dimtruck> http://logs.openstack.org/05/263505/1/check/gate-functional-dsvm-magnum-api/1484014/console.html#_2016-01-05_16_38_38_558
17:50:55 <dimtruck> and magnum isn't there
17:51:04 <dimtruck> a bunch of other core services are...but no magnum
17:51:04 <devkulkarni> james_li: yes, definitely that is worth looking at
17:51:50 <devkulkarni> dimtruck: there is a magnum section below service_available section
17:51:52 <dimtruck> (the magnum section below was added explicitly and not via a plugin...it's specific to tempest)
17:52:01 <devkulkarni> oh I see
17:52:09 <dimtruck> err, specific to magnum tempest tests
17:52:55 <devkulkarni> dimtruck: comparing to magnum's plugin code, is there anything that we are doing different in solum's plugin?
17:54:17 <devkulkarni> btw, the message 'solum-api is not running' is output from https://github.com/openstack/solum/blob/master/functionaltests/run_tests.sh#L34
17:54:20 <dimtruck> https://github.com/openstack/solum/blob/master/devstack/settings#L77-L81
17:54:28 <dimtruck> https://github.com/openstack/magnum/blob/master/devstack/settings#L34-L36
17:54:32 <dimtruck> that should be it
17:56:01 <dimtruck> i wonder if this doesn't run in gate: https://github.com/openstack/solum/blob/master/devstack/plugin.sh#L395-L408
17:56:03 <devkulkarni> hmm.. seem similar
17:56:34 <devkulkarni> but there is this: https://github.com/openstack/magnum/blob/master/devstack/plugin.sh#L15
17:56:47 <devkulkarni> which must be running for magnum, right?
17:57:35 <devkulkarni> dimtruck: I am wondering if this is not running https://github.com/openstack/solum/blob/master/devstack/plugin.sh#L417
17:58:07 <devkulkarni> actually, comparing plugin.sh of the two, they look very similar to me
17:58:15 <dimtruck> that could be it devkulkarni
17:58:21 <dimtruck> where do we actually start the api
17:58:23 <devkulkarni> even the 'extra' section is there in magnum
17:58:46 <devkulkarni> dimtruck: don't know.. https://github.com/openstack/magnum/blob/master/devstack/plugin.sh#L40
17:58:55 <devkulkarni> ^^ is similar to what we have in solum
17:59:01 <dimtruck> right
17:59:15 <dimtruck> anyway, we should add a bunch of stdouts and debug through this
17:59:21 <dimtruck> i bet it's a silly condition or something
17:59:25 <devkulkarni> agree..
17:59:34 <devkulkarni> lets continue discussion in solum
17:59:43 <devkulkarni> we are almost at the end of the meeting time
17:59:52 <devkulkarni> #Open Discussion
18:00:00 <devkulkarni> #topic Open discussion
18:00:08 <devkulkarni> Heads up about Austin summit
18:00:15 <devkulkarni> deadline to submit talks is Feb 1
18:00:26 <devkulkarni> we can chat more about the summit in coming weeks
18:00:34 <devkulkarni> and in the irc channel
18:00:43 <devkulkarni> its time..
18:01:00 <devkulkarni> thanks everyone for joining today. hope to see you all next week. have a great year ahead
18:01:07 <devkulkarni> #endmeeting