17:00:12 <devkulkarni> #startmeeting Solum Team Meeting
17:00:14 <openstack> Meeting started Tue Nov 24 17:00:12 2015 UTC and is due to finish in 60 minutes.  The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:17 <openstack> The meeting name has been set to 'solum_team_meeting'
17:00:21 <devkulkarni> #topic Roll Call
17:00:28 <devkulkarni> Devdatta Kulkarni
17:00:39 <ashishjain> Ashish Jain
17:00:41 <datsun180b> Ed Cranford
17:00:52 <devkulkarni> hi ashishjain, datsun180b
17:01:10 <devkulkarni> here is the agenda for today: #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-11-24_1700_UTC
17:01:18 <ashishjain> hi devkulkarni,datsun180b
17:01:24 <devkulkarni> hopefully others will join us soon
17:01:56 <devkulkarni> ashishjain: did you get a chance to file the two bugs
17:02:24 <ashishjain> devkulkarni: I will do it soon just wanted to give it a try again
17:02:31 <devkulkarni> ashishjain: sounds good
17:02:33 <devkulkarni> no rush
17:02:41 <ashishjain> tnx
17:02:44 <dimtruck> o/
17:02:46 <devkulkarni> just wanted to see if we want to discuss them at the meeting
17:02:51 <devkulkarni> hello dimtruck
17:02:54 <dimtruck> hi
17:02:57 <devkulkarni> we are just getting started
17:03:53 <devkulkarni> will wait for another minute and then move along with the announcements
17:04:21 <ashishjain> We can highlight the issue probably but I would want to run little more checks to provide some inputs on my own
17:04:31 <devkulkarni> ashishjain: makes sense
17:04:44 <devkulkarni> alright, moving on to announcements
17:04:55 <devkulkarni> #topic Announcements
17:05:05 <devkulkarni> 1) Solum Liberty release
17:05:10 <devkulkarni> #link https://launchpad.net/solum/liberty/4.0.0
17:05:17 <devkulkarni> #link https://pypi.python.org/pypi/python-solumclient/1.2.7
17:05:29 <devkulkarni> finally we cut the liberty release last week
17:05:45 <devkulkarni> all the important outstanding patches were merged
17:05:56 <devkulkarni> and ttx helped us with the release steps
17:06:08 <datsun180b> that's great news
17:06:11 <devkulkarni> the client is also up-to-date now on pypi
17:06:14 <devkulkarni> datsun180b: yep
17:06:37 <ashishjain> congrats for this new release!!!
17:06:45 <devkulkarni> in case you get a chance to spin up vagrant, you would be glad to work with the new api
17:06:51 <devkulkarni> thanks ashishjain
17:07:03 <devkulkarni> hope to get your patches as part of the next release :)
17:07:19 <ashishjain> Definitely :)
17:07:25 <devkulkarni> :)
17:07:32 <devkulkarni> 2) Virtual hackday
17:07:51 <devkulkarni> We had our first virtual hackday last Wednesday (November 18)
17:07:54 <devkulkarni> 18
17:08:15 <devkulkarni> We ended up doing several things; Bugs tagged; bugs triaged; assembly/plan related bugs marked as 'Won't fix'; submitted a patch to fix a CLI bug
17:08:24 <devkulkarni> let me go over each of these
17:08:42 <devkulkarni> a) bugs tagged
17:08:45 <devkulkarni> https://bugs.launchpad.net/solum/
17:09:00 <devkulkarni> I spent some time tagging all the outstanding bugs
17:09:16 <devkulkarni> you will notice that there are several 'Tags' now
17:09:48 <devkulkarni> the main ones imo are the following tags 'solum-api' solum-worker solum-deployer
17:09:53 <devkulkarni> documentation
17:09:59 <devkulkarni> functional-tests
17:10:34 <devkulkarni> if you want to pick a bug to work on, these above mentioned tags are something that you want to focus on
17:10:51 <devkulkarni> the bugs tagged with any of the above tags are directly affecting solum right now
17:11:05 <devkulkarni> alright
17:11:13 <devkulkarni> b) bugs triaged;
17:11:32 <devkulkarni> I triaged a couple of bugs and submitted a patch for one of them
17:11:47 <devkulkarni> I think it was a cli bug;
17:11:59 <devkulkarni> the patch is merged
17:12:11 <devkulkarni> c) assembly/plan related bugs marked as 'Won't fix';
17:12:29 <devkulkarni> we had several bugs which were related to assembly/plan abstraction
17:12:43 <devkulkarni> I checked with gpilz if he was planning to submit any patches on it
17:12:56 <devkulkarni> but he mentioned that right now he is occupied with other things
17:13:32 <devkulkarni> since we have moved on and started using app and workflow abstraction, I felt that it is appropriate if we mark assembly/plan bugs as 'Won't fix'
17:13:48 <dimtruck> +1
17:14:15 <devkulkarni> this helps in keeping our bug list focused only on those things which are currently relevant
17:14:18 <ashishjain> +1
17:14:29 <devkulkarni> cool
17:14:55 <devkulkarni> overall the bug traige day was a success.. it gave a focused time to work on all the above things
17:15:10 <devkulkarni> may be if folks are interested we can do another such event sometime in January
17:15:41 <devkulkarni> alright.. those were the announcements I had prepared
17:15:57 <devkulkarni> anyone has any announcements to make?
17:16:20 <devkulkarni> oh I have one more.. I will be traveling to Pune tomorrow
17:16:30 <ashishjain> ohh cool
17:16:41 <ashishjain> I remember you have a hackathon there
17:16:52 <adrian_otto> o/
17:16:55 <devkulkarni> I will be there till the end of December.. I plan to work from there for a couple of weeks
17:16:57 <ashishjain> devkulkarni: do you plan to be in bangalore
17:17:00 <devkulkarni> hi adrian_otto
17:17:05 <adrian_otto> hi devkulkarni
17:17:27 <devkulkarni> ashishjain: yes, I was working with coolsvap to figure out if we can hold a hackathon in Pune
17:17:32 <devkulkarni> haven't heard from him yet
17:17:52 <ashishjain> devkulkarni: hackathon on solum?
17:17:53 <devkulkarni> ashishjain: right now, I don't have any plans to travel to Bangalore.
17:18:10 <devkulkarni> actually we were thinking of more general hackathon on all things openstack
17:18:27 <devkulkarni> coolsvap was thinking of getting all the stackers together from Pune and organizing something
17:18:47 <ashishjain> okay
17:18:58 <devkulkarni> don't know if we might get enough ppl if it is just for solum; so we were thinking of doing a more general one
17:19:06 <ashishjain> Do let me know I can see if some folks from my company can join in pune as well
17:19:14 <devkulkarni> ashishjain: if you can make it to Pune for that that will be awesome
17:19:17 <devkulkarni> ashishjain: cool
17:19:23 <devkulkarni> will surely let you know
17:19:38 <ashishjain> devkulkarni: sure will let you know
17:19:54 <devkulkarni> alright.. any other announcements from team members.. will wait for 30 seconds before proceeding
17:20:50 <devkulkarni> #topic Review Action Items
17:21:03 <devkulkarni> (done) devkulkarni to update Mitaka roadmap to include a feature for setting app parameters both at app create time and app deploy time
17:21:12 <devkulkarni> #link https://wiki.openstack.org/wiki/Solum/HighLevelRoadmap#Milestone:_Mitaka
17:21:25 <devkulkarni> to give some context on this ..
17:21:55 <devkulkarni> currently we support setting application parameters as part of 'solum app create' (i.e. at the time of application registration)
17:22:31 <devkulkarni> we have discussed previously that we should also support passing in parameters as part of 'solum app deploy' (ie at the time of app deployment)
17:23:05 <devkulkarni> this is for purposes such as overriding the variables that were set at the create time; or sometimes the parameters may not be known at the create time
17:23:22 <devkulkarni> muralia suggested that we add this feature to the Mitaka roadmap;
17:23:31 <devkulkarni> which made sense
17:23:42 <ashishjain> makes sense
17:24:00 <devkulkarni> yeah.. so I have updated the roadmap
17:24:13 <devkulkarni> the second action item was:
17:24:17 <devkulkarni> devkulkarni to figure out how to retire solum readthedocs
17:24:32 <devkulkarni> this is still pending
17:24:36 <devkulkarni> will carry it forward
17:24:40 <devkulkarni> #action devkulkarni to figure out how to retire solum readthedocs
17:25:02 <devkulkarni> there were no other action items
17:25:18 <devkulkarni> #topic Blueprint/Bug Review and Discussion
17:25:42 <devkulkarni> we have couple of bugs for review
17:25:58 <devkulkarni> should be quick, if cores can take a look at them
17:26:02 <devkulkarni> #link https://review.openstack.org/#/c/248376/
17:26:10 <devkulkarni> #link https://review.openstack.org/#/c/247648/
17:26:42 <adrian_otto> ok
17:26:55 <devkulkarni> thanks adrian_otto
17:27:12 <devkulkarni> datsun180b: if you can take a look as well that would be super helpful
17:27:28 <adrian_otto> he already voted on the first one
17:27:54 <datsun180b> i'm quick
17:28:05 <devkulkarni> ha ha
17:28:07 <devkulkarni> thanks datsun180b
17:28:08 <adrian_otto> those were easy ones
17:28:19 <adrian_otto> setting records for the most tiny patches?
17:28:22 <datsun180b> no victory too small to celebrate
17:28:37 <devkulkarni> :)
17:28:50 <devkulkarni> helps to have cores like you guys around :)
17:29:22 <devkulkarni> the next two patches are related to adding reno to our repo
17:29:33 <devkulkarni> this patch https://review.openstack.org/#/c/243295/6
17:29:39 <devkulkarni> has two -1
17:29:50 <devkulkarni> I need to submit a follow up patch addressing the comments
17:30:08 <devkulkarni> the second patch: https://review.openstack.org/#/c/243301/
17:30:33 <devkulkarni> has two +2s. I need to ping folks on openstack-infra to get it approved
17:31:08 <devkulkarni> dimtruck: btw, we did not see email about list of jobs which are not converted over to use devstack plugin
17:31:24 <devkulkarni> at least I did not see email last week
17:31:32 <devkulkarni> probably all the projects moved over?
17:31:56 <devkulkarni> to give some context..
17:32:18 <devkulkarni> we were one of the few projects who had not converted our devstack gate job to use the new plugin model of devstack
17:32:21 <dimtruck> awesome!!!
17:32:35 <devkulkarni> dimtruck submitted patch last week (which got merged)
17:33:01 <devkulkarni> I remembered about this right now, as that patch too needed to be approved by folks from openstack-infra
17:33:35 <devkulkarni> anyways, let me take an action item to ping openstack-infra folks to approve our reno patch
17:34:13 <devkulkarni> #action devkulkarni to follow up with openstack-infra on the patch for adding release notes job for solum
17:34:56 <devkulkarni> I think that completes the list of patches which needed review
17:35:21 <devkulkarni> are there any other patches/bugs which we have not covered but we should discuss?
17:35:44 <devkulkarni> waiting for a minute before opening up for open discussion
17:37:27 <devkulkarni> ok
17:37:34 <devkulkarni> #topic Open Discussion
17:39:02 <ashishjain> devkulkarni: Just a question
17:39:08 <devkulkarni> ashishjain: sure
17:39:32 <ashishjain> I see the solum liberty release being done today although openstack liberty was done long back
17:39:36 <ashishjain> why is that?
17:40:02 <devkulkarni> ashishjain: oh.. so solum is following independent release model
17:40:28 <ashishjain> okay
17:40:36 <devkulkarni> the projects following this model can release independently without keeping in sync with the other openstack projects
17:40:44 <ashishjain> Is solum not under the big tent?
17:40:48 <devkulkarni> which follow release-with-cycle model
17:40:55 <devkulkarni> ashishjain: we are under big tent
17:41:02 <devkulkarni> but the release model is not tied to that
17:41:08 <ashishjain> okay
17:41:17 <devkulkarni> basically, there are three release models currently
17:41:27 <devkulkarni> release-at-end-of-cycle
17:41:40 <devkulkarni> release-with-intermediate
17:41:43 <devkulkarni> release-independent
17:42:04 <devkulkarni> release-with-cycle (first one above), requires a project to follow a strict release cycle
17:42:20 <devkulkarni> it includes following the three milestones releases
17:42:32 <devkulkarni> for instance, for mitaka, the first milestone is next week
17:42:47 <ashishjain> okay
17:42:57 <devkulkarni> which means, any project that is following the release-with-cycle model, will have to cut a release for mitaka-m1 next week
17:43:19 <devkulkarni> the release-with-intermediate model is where you don't need to strictly follow the three milestone dates
17:43:39 <ashishjain> okay
17:43:40 <devkulkarni> but you are still required to release at some points before the following summit comes around
17:44:17 <devkulkarni> so basically, for Mitaka release, it will be sometime before the Austin summit comes around (I think there are exact dates defined by which the release needs to be cut)
17:44:38 <devkulkarni> the release-independent model does not have any of the above restrictions
17:45:01 <ashishjain> solum follows release-independent model
17:45:04 <devkulkarni> such projects can release whenever they find it appropriate
17:45:15 <ashishjain> okay
17:45:27 <devkulkarni> ashishjain: yes, when we submitted our application to the big tent, we specified in our governance patch
17:45:36 <devkulkarni> that we will be following the release-independent model
17:46:12 <devkulkarni> the reason for doing that was so that we don't have strictly follow the release dates
17:46:24 <ashishjain> okay got it
17:46:29 <devkulkarni> cool
17:46:45 <devkulkarni> btw, the release process is undergoing a change
17:47:20 <devkulkarni> you might have seen emails about this recently
17:47:37 <ashishjain> what change is being being brought in ... sorry I have not seen
17:47:40 <devkulkarni> in fact, ttx has been helping us with the release
17:47:49 <ashishjain> I think I need to apply some filters
17:47:57 <devkulkarni> the changes are what I mentioned above
17:48:03 <devkulkarni> that there are three release models now
17:48:08 <ashishjain> okay got it
17:48:17 <devkulkarni> and how one should choose which release model for their project
17:48:18 <devkulkarni> etc.
17:48:36 <devkulkarni> another thing they are going to change is what happens to the status of a bug when a patch for that is merged
17:48:58 <devkulkarni> right now, the way gerrit and launchpad is setup, when a bug is merged, its status is changed to 'Fix Committed'
17:49:19 <devkulkarni> then, the release manager has to manually change these status to 'Fix Released' when a release is cut
17:49:43 <devkulkarni> apparently the infra team had been noticing that using launchpad to keep track
17:49:54 <devkulkarni> of what was released was not always accurate
17:50:19 <devkulkarni> so they introduced reno to track what went into a release
17:50:47 <devkulkarni> so now they are going to change what status a bug will be set to when a patch is merged
17:51:07 <ashishjain> okay
17:51:08 <devkulkarni> instead of 'Fix committed', such bugs are going to be marked as 'Fix Released'
17:51:21 <devkulkarni> I don't understand the full details yet, but
17:51:37 <devkulkarni> from release manager's pov, the work has been reduced
17:51:44 <ashishjain> yeah
17:51:55 <ashishjain> one more question does solum also has diverse-affiliation tag?
17:51:57 <devkulkarni> there is no more manual step to change the bug status from 'Fix Committed' to 'Fix Released'
17:52:23 <devkulkarni> ashishjain: I think yes it does; I will have to double check though
17:52:47 <ashishjain> http://governance.openstack.org/reference/projects/solum.html
17:53:01 <ashishjain> I was just checking this could not find it here
17:53:32 <devkulkarni> yep; I think all the tags are listed in one of the repos
17:53:41 <devkulkarni> probably the governance repo
17:53:56 <devkulkarni> I will check with the tc
17:54:08 <ashishjain> cool thanks for this
17:54:11 <devkulkarni> good questions ashishjain
17:54:33 <ashishjain> thanks devkulkarni
17:54:39 <devkulkarni> #action devkulkarni to check with tc what all tags does solum have currently
17:57:40 <devkulkarni> alright.. looks like we are almost at the end of our meeting time. will end the meeting in 30 seconds
17:58:34 <devkulkarni> thanks for joining today
17:58:37 <devkulkarni> see you next week
17:58:44 <devkulkarni> #endmeeting