17:00:09 <devkulkarni> #startmeeting Solum Team Meeting
17:00:10 <openstack> Meeting started Tue Nov 17 17:00:09 2015 UTC and is due to finish in 60 minutes.  The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:15 <openstack> The meeting name has been set to 'solum_team_meeting'
17:00:20 <devkulkarni> #topic Roll Call
17:00:21 <james_li> james li
17:00:23 <devkulkarni> Devdatta Kulkarni
17:00:31 <devkulkarni> hey james_li
17:01:04 <james_li> Hi Dev
17:01:14 <devkulkarni> here is agenda for today's meeting: https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-11-17_1700_UTC
17:01:31 <devkulkarni> I know that adrian_otto and vijendar are out today
17:02:02 <devkulkarni> I don't see datsun180b either in solum irc room
17:02:38 <devkulkarni> lets give few minutes for folks to join
17:02:44 <muralia1> o/
17:02:49 <devkulkarni> I know that muralia1 and dimtruck are in magnum meeting
17:02:52 <devkulkarni> oh there they are
17:02:54 <dimtruck> hello
17:03:01 <devkulkarni> hi muralia1 and dimtruck
17:03:06 <devkulkarni> we have james_li
17:03:07 <muralia1> hi all
17:03:13 <devkulkarni> adrian_otto and vijendar are out today
17:03:24 <devkulkarni> and I haven't seen datsun180b as well
17:03:39 <devkulkarni> so it might be only four of us today
17:03:42 <devkulkarni> here is the agenda:
17:03:48 <devkulkarni> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-11-17_1700_UTC
17:04:11 <devkulkarni> #topic Announcements
17:04:22 <devkulkarni> 1) Solum Liberty release
17:04:32 <devkulkarni> #link https://etherpad.openstack.org/p/solum-liberty-release
17:04:38 <devkulkarni> #link https://review.openstack.org/#/c/245963/
17:04:43 <devkulkarni> #link https://launchpad.net/solum/+milestone/4.0.0
17:04:49 <devkulkarni> #link https://launchpad.net/python-solumclient/+milestone/1.2.7
17:05:02 <devkulkarni> let me give some background and explaining what is going on on the release front
17:05:38 <devkulkarni> so upstream has modified the ways releases are done (basically decoupling projects to be in-sync with each other from release pov)
17:06:13 <devkulkarni> doug hellmann and ttx wanted us to come up with a bullet list of steps for making the release
17:06:27 <devkulkarni> I created these steps on that etherpad mentioned above
17:06:45 <devkulkarni> doug and ttx then provided guidance on what steps were required, what were optional, etc.
17:06:58 <devkulkarni> they also recommended that the version for solum that we should use is 4.0.0
17:07:10 <devkulkarni> this is also part of the new changes to the release process
17:07:28 <devkulkarni> then, I had to submit a review to openstack/releases repository
17:07:45 <devkulkarni> that review is mentioned above
17:07:46 <james_li> sounds a plan
17:07:59 <devkulkarni> after that, there was some launchpad work to be done
17:08:41 <devkulkarni> basically, we had to create a 'milestone' in liberty series and tag all the bugs and blueprints that we fixed to that milestone
17:08:48 <devkulkarni> I have done that as well
17:08:54 <dimtruck> nice!
17:09:00 <devkulkarni> #link https://launchpad.net/solum/+milestone/4.0.0
17:09:04 <muralia1> yes, saw all the changes you made
17:09:12 <devkulkarni> #link https://launchpad.net/python-solumclient/+milestone/1.2.7
17:09:21 <devkulkarni> we have fixed several bugs
17:09:30 <devkulkarni> some of which were actually features
17:09:35 <devkulkarni> ok
17:09:49 <devkulkarni> so now we are waiting for ttx to help us with the next steps
17:10:11 <devkulkarni> he has been considerate and has volunteered to do the liberty release for us
17:10:21 <devkulkarni> from our side, we have completed all the steps
17:10:32 <devkulkarni> the client will be released to pypi as well
17:10:39 <devkulkarni> I think there is a gate job which does it
17:10:51 <devkulkarni> ttx is traveling this week
17:11:05 <devkulkarni> but he said he would be checking his emails
17:11:21 <devkulkarni> so hopefully, by the end of the week we would have solum's liberty release cut
17:11:39 <devkulkarni> so that is all on that topic
17:11:59 <devkulkarni> if you happen to look through lp and find a bug which should be tagged to 4.0.0 release
17:12:05 <devkulkarni> please feel free to do that
17:12:28 <devkulkarni> set the status of that bug as 'Fix Released'
17:12:54 <devkulkarni> ttx mentioned that when we cut a final release, all the bugs need to be marked as 'Fix Released'
17:13:24 <devkulkarni> alright
17:13:34 <devkulkarni> next announcement is
17:13:41 <devkulkarni> 2) Virtual hackday tomorrow (Wednesday, November 18th)
17:13:47 <devkulkarni> #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/079161.html
17:13:53 <devkulkarni> #link https://etherpad.openstack.org/p/solum-hackday-nov18-2015
17:14:16 <devkulkarni> so as you may recall, we had discussed about holding such a hack day in last two meetings
17:14:35 <devkulkarni> I have created etherpad (linked above) with relevant details
17:14:45 <ttx> I'll try to cut it in the coming hours
17:14:57 <devkulkarni> ttx: nice !!
17:15:34 <devkulkarni> ttx: quick question about the release-docs job failing on my patch: https://review.openstack.org/#/c/245963/
17:15:42 <devkulkarni> any suggestions on how to fix it?
17:16:30 <devkulkarni> ok, continuing with the hackday discussion
17:16:55 <devkulkarni> please add yourself to the etherpad even if you would be participating for a few hours
17:17:15 <devkulkarni> also, may be the times when you would be around
17:17:37 <devkulkarni> will be good with the exposure for others
17:18:07 <devkulkarni> our vagrant environment should be good for you to try out all the new features
17:18:19 <ttx> devkulkarni: you should ask on #openstack-release
17:18:23 <devkulkarni> thoughts/comments/questions?
17:18:28 <devkulkarni> ttx: ok, will do
17:21:01 <devkulkarni> alright, continuing to next topic
17:21:09 <devkulkarni> #topic Review Action Items
17:21:17 <devkulkarni> devkulkarni to figure out how to retire solum readthedocs
17:21:29 <devkulkarni> #action devkulkarni to figure out how to retire solum readthedocs
17:21:31 <ttx> devkulkarni: I'll likely have to wait until the patch is fixed before cutting the release
17:21:40 <ttx> I'll look into that failure see if I see why it fails
17:21:42 <devkulkarni> ttx: yeah, that's what I thought
17:21:58 <devkulkarni> ttx: that would be super helpful
17:22:26 <devkulkarni> ttx: also, after our irc meeting is over, I will get on to openstack-release to discuss about it
17:23:00 <devkulkarni> #topic Blueprint/Bug Review and Discussion
17:23:08 <devkulkarni> 1) devstack plugin
17:23:14 <devkulkarni> #link https://review.openstack.org/#/c/236212/
17:23:21 <dimtruck> that's merged now :)
17:23:24 <devkulkarni> looks like this patch is merged
17:23:29 <devkulkarni> dimtruck: nice!!
17:23:35 <devkulkarni> so little background on that patch
17:24:01 <dimtruck> actually, no it's not...looks like it's missing a verification?
17:24:20 <devkulkarni> dimtruck: it should merge hopefully
17:24:26 <dimtruck> ok
17:24:31 <devkulkarni> the verification gates run before merging
17:24:38 <devkulkarni> going back to the background on this patch
17:24:50 <devkulkarni> it started with this email from sdague
17:24:53 <devkulkarni> #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/079135.html
17:25:31 <devkulkarni> the email identifies all the projects for which the devstack gate jobs would start failing unless we change our gate job to use devstack plugin model
17:25:44 <devkulkarni> notice that we are on that list
17:25:57 <devkulkarni> james_li, even designate on that list
17:26:09 <devkulkarni> don't know if you guys are on top of it already or not
17:26:31 <devkulkarni> if not, I would recommend making that as a priority as no patches will merge
17:26:48 <devkulkarni> after December 1st (I think) until this is fixed
17:26:59 <devkulkarni> so going back to our situation..
17:27:27 <devkulkarni> the way to use devstack plugin on the gate job is to create that plugin as part of our repository
17:27:39 <devkulkarni> we have known about this requirement for a while
17:28:12 <devkulkarni> an independent contributor, venkatamahesh had submitted a patch to add this plugin in our repository
17:28:23 <devkulkarni> dimtruck worked from that patch
17:28:31 <devkulkarni> and tested it yesterday
17:28:37 <devkulkarni> right dimtruck?
17:28:43 <dimtruck> correct
17:29:25 <devkulkarni> so now that we have got this patch merged
17:29:49 <devkulkarni> the next thing is to submit a patch to openstack/project-config to change our gate job configuration to use this plugin
17:30:04 <devkulkarni> dimtruck: are you planning to submit that patch as well?
17:30:13 <dimtruck> yes sir
17:30:17 <devkulkarni> awesome
17:30:38 <dimtruck> i wanted to check with venkatamahesh if that was on his roadmap since he submitted the original patch
17:30:43 <dimtruck> but yeah - that's the next step
17:30:54 <devkulkarni> dimtruck: I would suggest you do it
17:30:58 <dimtruck> ok
17:31:10 <devkulkarni> add venkatamahesh as a reviewer
17:31:19 <devkulkarni> but I haven't been able to get hold of him on irc yet
17:31:33 <devkulkarni> since this is time critical, it will be good if one of us does it
17:31:59 <devkulkarni> cool. so I will look forward to your patch sometime soon :)
17:32:01 <dimtruck> ok, i'll have that in
17:32:20 <devkulkarni> next one is
17:32:22 <devkulkarni> 2) Adding Reno for managing release notes
17:32:27 <devkulkarni> #link https://review.openstack.org/#/c/243295/6
17:32:33 <devkulkarni> #link https://review.openstack.org/#/c/243301/
17:34:10 <devkulkarni> dimtruck, muralia1: don't know if magnum has added reno yet, but if not you can check out above patche
17:34:13 <devkulkarni> patches
17:34:52 <muralia1> thanks
17:35:30 <devkulkarni> ok
17:36:02 <devkulkarni> the next one is:
17:36:12 <devkulkarni> oslo-incubator went away recently. What do we need to do?
17:36:18 <devkulkarni> #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/079343.html
17:36:24 <devkulkarni> so some background on this
17:36:55 <devkulkarni> above email mentions that oslo-incubator is no longer a thing
17:37:07 <muralia1> oh…
17:37:12 <devkulkarni> all the patches from incubator has been moved over in their own libraries
17:37:15 <dims> devkulkarni : you essentially take over that code you have and move it into your own namespace/package structure. remove things you don't need
17:37:29 <devkulkarni> dims: was about to ping you about this :)
17:37:37 <devkulkarni> we have this in our repo: https://github.com/openstack/solum/tree/master/solum/openstack
17:38:05 <dims> devkulkarni most of those files you can find in different oslo libraries
17:38:16 <devkulkarni> so based on what you mentioned above, we have to move this code in our own namespace/package
17:38:20 <dims> if you choose to use them
17:38:35 <devkulkarni> dims: yeah, makes sense
17:38:49 <dims> my preference is for you to use the official oslo libraries first, any missing files, use the copy you have
17:39:06 <devkulkarni> dims: as a step-by-step process, do you recommend that we first move those in our package, and then replace them/remove unused?
17:39:13 <dims> looking at that list, you are way behind in oslo adoption
17:39:18 <devkulkarni> dims: oh I see
17:39:30 <devkulkarni> dims: that is true, unfortunately :(
17:39:45 <dims> devkulkarni : it does not make sense to move them first as it really does not matter
17:40:17 <devkulkarni> dims: yeah, you are right..
17:40:35 <dims> devkulkarni : probably because you don't have a liaison for oslo yet https://wiki.openstack.org/wiki/CrossProjectLiaisons#Oslo
17:41:00 <devkulkarni> dims: what is the the best way for us to move forward on this? would the gates start failing anytime soon because we have not yet moved over?
17:41:09 <devkulkarni> dims: yes, that is true
17:41:10 <dims> nope
17:41:24 <devkulkarni> in fact I was going to check with the team about oslo liaison today
17:41:30 <devkulkarni> while discussing about your email
17:41:42 <dims> :)
17:42:23 <devkulkarni> dims: let me check with others in the team
17:42:36 <devkulkarni> in any case, we definitely want to be on top of this
17:42:56 <devkulkarni> so at least I would start attending oslo meetings from next time
17:43:02 <dims> ++ thanks devkulkarni
17:43:48 <devkulkarni> cool
17:43:54 <devkulkarni> so that is on that topic
17:44:07 <devkulkarni> next one is
17:44:13 <devkulkarni> 3) Mitaka Roadmap discussion
17:44:18 <devkulkarni> #link https://wiki.openstack.org/wiki/Solum/HighLevelRoadmap#Milestone:_Mitaka
17:44:30 <devkulkarni> we had discussed about this in last week's meeting
17:44:47 <devkulkarni> any thoughts/comments after a week?
17:45:22 <muralia1> no
17:46:18 <devkulkarni> alright.. we can always discuss/debate on what specific items we want to prioritise
17:46:30 <devkulkarni> or even add to the roadmap
17:46:38 <devkulkarni> as things evolve
17:47:06 <devkulkarni> right now, we can use the above list as a guiding set of features on where we want to go next
17:47:13 <muralia1> devkulkarni, i think we should include one more to the list. move app config from app create to app deployment time
17:47:42 <devkulkarni> muralia1: you mean, application parameters?
17:47:47 <muralia1> yes
17:48:30 <devkulkarni> muralia1: sure, we can add that.. although, I think we had said that there is value in having app parameters both at the app create and app deploy
17:48:52 <muralia1> sure. as long as we can update params during deployment
17:48:58 <devkulkarni> the parameters set at 'app create' can be overridden at 'app deploy'
17:49:00 <devkulkarni> yeah
17:49:31 <devkulkarni> I can take an action item to update the roadmap to add this
17:49:31 <muralia1> do we already support that?
17:49:41 <devkulkarni> no, we don't support that right now
17:49:58 <muralia1> ah ok. i thought i missed that patch :)
17:50:05 <devkulkarni> dimtruck: your patch has been merged
17:50:13 <dimtruck> saw that :)
17:50:28 <devkulkarni> muralia1: no, you haven't missed much patches.. thanks for all the reviews :)
17:50:57 <devkulkarni> dimtruck: now you can submit your project-config patch
17:51:02 <dimtruck> yup!
17:51:08 <devkulkarni> dimtruck: I am wondering how would we test it though?
17:51:17 <dimtruck> in the gate ;)
17:51:38 <dimtruck> i'm assuming that once we update the project.config, it'll run our tests?
17:51:55 <devkulkarni> for that to happen
17:52:03 <devkulkarni> won't we have to submit a patch to our repo
17:52:06 <devkulkarni> some patch
17:52:14 <devkulkarni> so may be what we could do is:
17:52:36 <devkulkarni> retrigger one of our existing patches (or submit a new patch) which has a dependency on the project-config patch
17:53:06 <devkulkarni> would that cause the new project-config changes to be used on the gate?
17:53:21 <devkulkarni> dimtruck: ^^
17:53:56 <devkulkarni> #action: devkulkarni to update Mitaka roadmap to include a feature for setting app parameters both at app create time and app deploy time
17:54:16 <devkulkarni> we are almost at the end of our meeting
17:54:25 <devkulkarni> let me move to open discussion
17:54:30 <devkulkarni> #topic Open Discussion
17:54:40 <dimtruck> makes sense
17:59:30 <devkulkarni> alright, thanks for joining today folks
17:59:35 <dimtruck> thanks devkulkarni
17:59:41 <devkulkarni> will see you tomorrow in the virtual hack day
17:59:42 <muralia> see you all
17:59:46 <devkulkarni> or next week
17:59:55 <devkulkarni> #endmeeting