21:00:28 <devkulkarni> #startmeeting Solum Team Meeting
21:00:29 <openstack> Meeting started Tue Jun 23 21:00:28 2015 UTC and is due to finish in 60 minutes.  The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:32 <openstack> The meeting name has been set to 'solum_team_meeting'
21:00:44 <devkulkarni> #Roll call
21:00:51 <datsun180b> Ed Cranford
21:00:53 <devkulkarni> #topic Roll Call
21:00:58 <devkulkarni> Devdatta Kulkarni
21:00:59 <adrian_otto> Adrian Otto
21:01:04 <muralia> murali allada
21:01:13 <james_li> james li
21:01:16 <mkam> Melissa Kam
21:01:54 <pritic_> Priti Changlani
21:02:18 <devkulkarni> hi adrian_otto, datsun180b, pritic_ mkam, james_li, muralia
21:02:25 <adrian_otto> hi
21:02:28 <muralia> hey hey
21:02:32 <mkam> :)
21:02:35 <adrian_otto> I will be able to join you for a short time
21:02:45 <devkulkarni> thanks adrian_otto
21:02:53 <devkulkarni> I will let you have the floor
21:02:56 <devkulkarni> #topic Announcements
21:02:58 <devkulkarni> there
21:03:11 <adrian_otto> 1) Solum joining OpenStack
21:03:27 <devkulkarni> gpilz: hi
21:03:40 <adrian_otto> the following governance motion is set for approval, with enough votes to pass:
21:03:49 <adrian_otto> #link https://review.openstack.org/190949 Add Solum to OpenStack Projects List
21:04:04 <devkulkarni> awesome !! congratulations to all
21:04:10 <adrian_otto> it did have 7 +1 votes, but needed to be rebased which cleared them
21:04:24 <datsun180b> well let's not count our chickens before their review merges
21:04:25 <adrian_otto> so ttx will be merging it as soon as it re-votes to 7 again.
21:04:41 <muralia> nice!
21:04:44 <james_li> cool
21:05:03 <adrian_otto> in the TC meting there was no opposition in 2 weeks of discussion
21:05:11 <adrian_otto> only questions beyond the scope of the motion
21:05:25 <datsun180b> good to hear
21:05:36 <devkulkarni> adrian_otto: cool.. so it cleared without hurdles?
21:05:38 <devkulkarni> nice
21:05:50 <adrian_otto> yes, ans we do not need to wait another week for the motion to pass
21:06:06 <adrian_otto> we just wait for the same participants to re-vote to match the prior ones
21:06:53 <adrian_otto> so devkulkarni it's all yours now.
21:07:03 <devkulkarni> adrian_otto: this is very nice!! thanks for all the hard work over all the past cycles to get us till this point !! what are the next steps? how do we go about changing repositories
21:07:14 <devkulkarni> etc.?
21:07:18 <jungleboyj> o/
21:07:19 <adrian_otto> we will post a review for that as well
21:07:28 <adrian_otto> but this one merging is a prerequisite
21:07:35 <adrian_otto> I can show you the example of the magnum one
21:07:41 <devkulkarni> makes sense..
21:07:46 <devkulkarni> sure, that will be very helpful
21:07:57 <adrian_otto> I'll look for that one while you proceed
21:08:22 <devkulkarni> about integration with magnum.. one of these days we need to start that discussion as well.. ann gentle had some questions there
21:08:41 <devkulkarni> adrian_otto: sure
21:08:49 <adrian_otto> can put a blueprint up for that
21:09:00 <adrian_otto> and list any concerns in the whitepoard.
21:09:07 <adrian_otto> we can fit that in when it makes sense
21:09:09 <devkulkarni> sounds good. (I think there was already a blueprint on that)
21:09:19 <devkulkarni> sounds good.
21:09:46 <devkulkarni> thanks adrian_otto. we will let you get back to your vacation..
21:09:59 <devkulkarni> any more announcements from others?
21:10:26 <devkulkarni> hi jungleboyj
21:10:43 <jungleboyj> Hello.  Sorry for joining late.
21:11:00 <devkulkarni> np, we just got started
21:11:38 <devkulkarni> ok, lets proceed with the next topic
21:11:53 <devkulkarni> #topic Review Action Items
21:12:20 <devkulkarni> We had couple of action items in the week before. adrian_otto completed those
21:12:42 <devkulkarni> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-06-16_2100_UTC Our Agenda — agenda from last week
21:13:39 <devkulkarni> there was an action item to file a bp for solum - magnum integration.. that is also completed by adrian_otto
21:13:42 <devkulkarni> #link https://blueprints.launchpad.net/solum/+spec/magnum-integration
21:14:22 <devkulkarni> were there any other action items?
21:16:39 <adrian_otto> no, my two were the only ones
21:16:49 <devkulkarni> cool
21:17:03 <devkulkarni> #topic Blueprint/Task Review
21:17:33 <devkulkarni> last week we all took out time to triage and assign all the bps and bugs to owners
21:17:58 <devkulkarni> does folks feel good about the assignments? thoughts?
21:18:26 <devkulkarni> have there been follow-up on any of the bugs/bps that we all need to discuss?
21:18:34 <datsun180b> no problems here
21:18:42 <james_li> I am good about it
21:18:43 <muralia> they look fine to me too
21:18:45 <devkulkarni> btw, datsun180b - thanks for replying to the two threads on ML
21:18:59 <datsun180b> takes me a little longer than most but i managed
21:19:21 <devkulkarni> datsun180b: :) .. I think the app resource is almost ready #link https://review.openstack.org/#/c/185147/
21:19:47 <devkulkarni> how long do you all think we should wait to receive feedback, if any, from the API working group?
21:19:51 <datsun180b> the only thing presently keeping me from submitting an update is the oslo_db update i just submitted twenty minutes ago
21:20:11 <devkulkarni> datsun180b: ok
21:20:35 <devkulkarni> muralia, james_li, adrian_otto: thoughts?
21:20:54 <devkulkarni> I am actually quite satisfied with the way the app resource has shaped up
21:21:00 <muralia> I'm good with the app resource. i've reviewed the patch. just had one comment in the latest patch
21:21:41 <datsun180b> i don't like creating dependent reviews so i'll push the app resource changes after the oslo_db one merges
21:21:51 <datsun180b> that should give sufficient reply time to the api WG
21:21:51 <devkulkarni> datsun180b: makes sense
21:21:53 <james_li> look forward to datsun180b's next work
21:22:03 <datsun180b> validation on those resources is next
21:22:17 <devkulkarni> james_li: should we take that comment as you are fine with the current patch? :)
21:22:21 <datsun180b> ...and any bug fixes that get in the way
21:22:33 <james_li> devkulkarni: sure :)
21:22:36 <devkulkarni> *wants to get an agreed on this point* :)
21:23:10 <datsun180b> but if we acknowledge we're waiting on the API WG then what weight does an #agreed bear for now?
21:23:28 <devkulkarni> ok then.. I am going to propose we take votes for 'agreed' on getting datsun180b's app resource patch merged once he addresses muralia's comments.
21:23:40 <muralia> +1
21:23:41 <devkulkarni> datsun180b: that is the question I am raising.. how long do we wait?
21:23:49 <datsun180b> devkulkarni: no more than a week
21:24:12 <devkulkarni> james_li, muralia: thoughts?
21:24:26 <muralia> we can always come back and make changes suggested by the API WG. in the mean time I'd like that patch to merge so I can work on top of it
21:24:35 <james_li> wait for API group's comments?
21:24:36 <devkulkarni> muralia: +1
21:24:46 <datsun180b> i like that
21:24:50 <james_li> don't think we should be blocked by that
21:24:54 <devkulkarni> james_li: yes.. if we have to wait, how long?
21:24:57 <devkulkarni> james_li: agreed
21:25:09 <james_li> a week seems fine
21:25:38 <devkulkarni> james_li: but that may block work, as mentioned by muralia.
21:25:57 <devkulkarni> well not actually, we can always base our patches on top of the unmerged patch
21:26:02 <devkulkarni> muralia: what do you think?
21:26:27 <muralia> i dont see why we need to wait.
21:26:33 <datsun180b> right, we can submit further reviews to fix any concerns found
21:26:36 <muralia> let vote and go with the highest vote
21:26:42 <devkulkarni> since datsun180b has replied to everett's email today, I am fine waiting for at least a day
21:26:58 <james_li> yeah and oslo thing is a blocker now
21:27:09 <devkulkarni> james_li: yeah.
21:27:10 <datsun180b> just passed tests
21:27:32 <devkulkarni> how about we give at least a day for someone from API wg to respond on the patch..
21:27:50 <james_li> devkulkarni: how about targeting merge app resource by the end of tomorrow?
21:27:51 <datsun180b> awaiting mkam's approval when her gauntlets have been completed
21:27:53 <devkulkarni> after that we don't block anymore if the patch is ready
21:28:08 <devkulkarni> james_li: yes
21:28:13 <devkulkarni> muralia: you good with that?
21:28:18 <muralia> yes
21:28:25 <devkulkarni> ok..
21:29:44 <devkulkarni> #agreed We will wait for a day for the API WG to give feedback on the app resource patch. If we haven't received any feedback till 6/25/2015 and if the patch is ready to be merged, we will move forward with merging it
21:29:47 * adrian_otto heads out
21:30:11 <adrian_otto> 6/7 votes on that motion with 2 who voted +1 previously awaiting re-vote
21:30:22 <devkulkarni> datsun180b: mind updating us on the oslo db issue?
21:30:28 <devkulkarni> adrian_otto: cool..
21:30:37 <adrian_otto> so there is enough support to pass https://review.openstack.org/190949
21:30:40 <adrian_otto> enjoy!
21:31:06 <datsun180b> what's to say? no more _session_maker, among other deprecations
21:31:17 <datsun180b> taken care of in https://review.openstack.org/#/c/194817/
21:31:38 <datsun180b> only thing i'm not 100% certain about in that change is the config changes
21:31:47 <devkulkarni> datsun180b: so that needs to be merged asap, right?
21:31:54 <devkulkarni> otherwise no other patch will pass?
21:32:11 <datsun180b> provided we've verified that i haven't tanked our config with those changes, yes
21:32:46 <devkulkarni> you mean because of the changes that you have made in the .rc file?
21:33:22 <datsun180b> no, a change in oslo_db recently removed an already-deprecated feature we were using, fwict
21:34:33 <datsun180b> there's half a chance i could reduce that patch to just changing the use of _session_maker in one of our files
21:35:03 <datsun180b> but you know me, i like to meddle
21:35:05 <devkulkarni> ok.. I am still confused.. you mentioned that we need to verify whether the configs are still workable for us.. but gerrit has voted +1.. what verification are you talking about?
21:35:16 <james_li> datsun180b: so you only changed oslo.db, not the session_maker?
21:35:38 <datsun180b> james_li: i replaced our use of deprecated _session_maker with the apparent replacement get_session
21:35:53 <datsun180b> and while there just replaced olso.db with oslo_db wholesale
21:36:17 <datsun180b> i could probably scale back that patch if i need to
21:36:28 <devkulkarni> mkam: have you weighed in on that patch? https://review.openstack.org/#/c/194817/
21:36:53 <datsun180b> that patch contains lines that change references to config sections, and i'm not 100% sure they're right
21:37:07 <james_li> I think we need more time before merging https://review.openstack.org/#/c/194817
21:37:17 <mkam> the testing is still in progress, but none have failed so far
21:37:31 <datsun180b> which is why i'm asking that our robots take a whack at it. if they can't get their configs anymore, there's a problem.
21:37:38 <devkulkarni> james_li: any particular concerns you have on it?
21:38:10 <james_li> I need to understand what get_session does in oslo_db
21:38:30 <james_li> and if other openstack projects do the same way
21:38:51 <datsun180b> agree with james_li WRT taking down a fence we don't know the purpose of
21:39:01 <devkulkarni> james_li: fair enough.. but we need that patch merged soon otherwise other patches won't get in
21:39:07 <james_li> basically need to make sure our call of get_session is correct
21:39:40 <james_li> devkulkarni: the investigation won't take too long
21:39:45 <devkulkarni> james_li: you are concerned about things like db pooling?
21:40:22 <devkulkarni> james_li: ok.. datsun180b, james_li: how should we investigate this?
21:40:28 <devkulkarni> aren't our tests enough?
21:40:55 <james_li> read some oslo db docs, check glance nova heat code ...
21:41:09 <james_li> don;t want us to miss anything
21:41:14 <datsun180b> we talked about chewing our reviews a little better before we swallow
21:41:42 <devkulkarni> james_li: datsun180b: ok
21:41:59 <devkulkarni> I am just concerned that this patch may become blocker for other patches
21:42:00 <datsun180b> and i agree. we won't just let it sit for a day; in the interim i'm going to try to throw some manual tests to be certain
21:42:10 <james_li> we can still target merging it tomorrow though, as I said it won't take too long
21:42:11 <devkulkarni> datsun180b: sounds good
21:42:51 <devkulkarni> james_li: okay.. also, if the functionality is not affected by this patch and if our research is not yet done then we can always go back and change it
21:42:57 <devkulkarni> ?
21:43:11 <devkulkarni> if need be
21:43:50 <devkulkarni> james_li: you planning to do the investigation on it then?
21:43:57 <james_li> yes I will
21:44:05 <devkulkarni> thanks james_li
21:44:19 <devkulkarni> datsun180b: will look forward to your tests as well
21:44:45 <datsun180b> mainly i want to make sure we're still getting the right configs and that we're really dropping all our connections
21:44:46 <devkulkarni> so looks like the app resource patch will have to wait anyways for some time
21:44:57 <devkulkarni> datsun180b: +1
21:45:24 <devkulkarni> any other bugs/bps that we should discuss today?
21:45:44 <datsun180b> i can rebase the app resource just for fun, the changes asked for are in place already
21:46:07 <devkulkarni> datsun180b: you mean rebase on the oslo_db change patch?
21:46:36 <datsun180b> devkulkarni: right
21:46:51 <devkulkarni> datsun180b: sounds good to me
21:47:13 <devkulkarni> moving to open discussion then..
21:47:20 <devkulkarni> #topic Open Discussion
21:47:48 <devkulkarni> I have two topics: 1) OpenStack summit; 2) Vagrant setup
21:48:08 <devkulkarni> #link https://www.openstack.org/summit/tokyo-2015/
21:48:22 <devkulkarni> looks like the call for speakers is now open for Tokyo
21:48:34 <devkulkarni> #link https://www.openstack.org/summit-login/login?BackURL=%2Fsummit%2Ftokyo-2015%2Fcall-for-speakers%2F
21:48:40 <devkulkarni> the deadline is July 15th
21:48:57 <devkulkarni> I believe there could be multiple Solum related talks at the summit..
21:49:25 <devkulkarni> I would like to encourage folks to submit talks before the deadline
21:49:59 <devkulkarni> feel free to pull in team members to work on the talk by reaching out on #solum or individually
21:50:10 <devkulkarni> 2) Vagrant setup
21:50:39 <devkulkarni> So I had worked on this a while back.. but recently I haven't been able to get to a complete deployment of an app
21:50:48 <devkulkarni> anyone else has had success recently?
21:51:41 <muralia> me too. i keep getting stack failures
21:51:56 <devkulkarni> oh really? my stack creates are successful
21:52:04 <devkulkarni> the app never starts up for me
21:52:15 <devkulkarni> the app status is stuck in 'STARTING_APP'
21:52:45 <muralia> ok. looks like we need to investigate this
21:52:52 <devkulkarni> I am planning to look into this in the next week or so
21:53:12 <devkulkarni> datsun180b: what has been your experience recently?
21:53:52 <devkulkarni> last few minutes.. any other topics for open discussion today?
21:53:54 <datsun180b> been working a little more conceptually as of late
21:54:02 <datsun180b> haven't had much opportunity to see real-mode failures
21:54:10 <devkulkarni> datsun180b: fair enough.
21:56:01 <devkulkarni> james_li: I saw docker 1.7 was released
21:56:10 <james_li> devkulkarni: really cool
21:56:27 <james_li> going to check if it includes the thing I want
21:56:30 <devkulkarni> are there any immediate gains for us by adopting it?
21:56:34 <devkulkarni> cool
21:57:02 <devkulkarni> #link https://blog.docker.com/2015/06/announcing-docker-1-7-multi-host-networking-plugins-and-orchestration-updates/
21:58:11 <devkulkarni> ok, two minutes remaining
21:59:33 <devkulkarni> closing out now..
21:59:37 <devkulkarni> thanks all for joining today
21:59:50 <datsun180b> good talk
21:59:54 <devkulkarni> #endmeeting