21:00:11 <adrian_otto> #startmeeting Solum Team Meeting
21:00:12 <openstack> Meeting started Tue May 12 21:00:11 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:16 <openstack> The meeting name has been set to 'solum_team_meeting'
21:00:20 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-05-05_2100_UTC Our Agenda
21:00:30 <adrian_otto> #topic Roll Call
21:00:37 <adrian_otto> Adrian Otto
21:00:37 <james_li> james li
21:00:41 <devkulkarni> devdatta kulkarni
21:00:45 <datsun180b> ed cranford
21:00:46 <muralia> murali allada
21:01:07 <adrian_otto> hello james_li, devkulkarni, datsun180b, and muralia
21:01:25 <james_li> Hi adrian_otto
21:01:28 <devkulkarni> hello adrian_otto
21:03:58 <mkam> Melissa Kam
21:05:03 <adrian_otto> hello mkam
21:05:07 <adrian_otto> let's begin
21:05:14 <adrian_otto> #topic Announcements
21:05:23 <adrian_otto> 1) Reminder: There will be no team meeting on 2015-05-19 due to the OpenStack Summit.
21:05:35 <adrian_otto> any announcements from team members?
21:05:54 <devkulkarni> I have a couple
21:06:08 <adrian_otto> devkulkarni: proceed
21:06:08 <devkulkarni> 1) Vagrant env is back up and running fine
21:06:18 <adrian_otto> does that use nova-docker?
21:06:24 <devkulkarni> yes
21:06:27 <adrian_otto> ok, thanks.
21:06:54 <adrian_otto> Awesome, that's great to hear that it's working now.
21:07:08 <devkulkarni> 2) to show the recent development in Solum, I have cut a screen cast and have uploaded link here: https://wiki.openstack.org/wiki/Solum
21:07:20 <devkulkarni> Search for Solum Demos
21:07:37 <devkulkarni> there should be two links there
21:08:21 <devkulkarni> those of us who are going to the summit next week, please use opportunity to get users trying out Solum on Vagrant
21:08:24 <devkulkarni> if possible
21:08:36 <devkulkarni> that is all adrian_otto
21:09:24 <james_li> thats nice, devkulkarni
21:09:29 <adrian_otto> sweet, thanks devkulkarni
21:09:40 <adrian_otto> any other announcements?
21:09:59 <adrian_otto> #topic Tagging or next release
21:10:07 <adrian_otto> Are we ready to tag our next release?
21:10:15 <datsun180b> not yeeeeet
21:10:38 <datsun180b> some changes to ownership of triggers and trusts is in the gate even now
21:10:49 <datsun180b> changes ... are in the gate
21:11:22 <devkulkarni> adrian_otto what is the latest in this week that we can ping you to cut a release?
21:11:33 <jungleboyj> o/
21:11:51 <adrian_otto> any time
21:12:07 <devkulkarni> cool.. the reason I asked is,
21:12:19 <adrian_otto> #topic Review Action Items
21:12:22 <devkulkarni> apart from the trigger changes there are couple of other patches which would be good to have merged
21:12:32 <adrian_otto> #action adrian_otto to spring clean our blueprints
21:12:40 <adrian_otto> #action adrian_otto to spring clean our bug list
21:12:53 <adrian_otto> #action adrian_otto to email the dev list concluding the Solum PTL Election
21:13:21 <adrian_otto> that third is easy. should not have forgotten about it
21:13:34 <adrian_otto> will do that as soon as we adjourn
21:13:50 <adrian_otto> I really want to cut the release and do the bug clearing at the same time
21:13:59 <devkulkarni> for the bug list clean up.. I think datsun180b had done some for the python-solumclient
21:14:02 <adrian_otto> because there are a ton of bugs in Fix Committed state
21:14:02 <devkulkarni> right datsun180b?
21:14:18 <devkulkarni> agreed adrian_otto
21:14:24 <adrian_otto> and I want to advance all of those to Fix Released
21:14:30 <datsun180b> well all i did last week was run through the most recent three months of bugs and make sure the cli ones were targeted appropriately
21:14:38 <adrian_otto> that's why I keep nagging about this
21:14:47 <devkulkarni> no worries adrian_otto
21:14:53 <datsun180b> i bet we've got older ones that didn't get updated by robots because we'd been filing everything as solum only
21:15:18 <adrian_otto> thanks for getting that ironed out datsun180b
21:15:37 <datsun180b> twerent nothin
21:15:45 <adrian_otto> I know our bug list for python-solumclient is basically empty
21:16:01 <devkulkarni> tell you what.. we will try to merge the outstanding patches soon.. if we are not done latest by Friday then I think we can go ahead with the release..
21:16:02 <adrian_otto> it's the solum one I want to polish nice and clean
21:16:13 <devkulkarni> what do others think?
21:16:22 <gpilz> +1
21:16:28 <datsun180b> sounds good
21:17:21 <muralia> +1
21:17:27 <devkulkarni> I will ping you adrian_otto on Thursday/Friday for cutting the release
21:17:53 <adrian_otto> ok, thanks
21:18:13 <adrian_otto> #topic BP/Task Review
21:18:26 <adrian_otto> any work items up for team discussion today?
21:18:51 <devkulkarni> nothing that jumps out for me
21:19:09 <adrian_otto> #topic Open Discussion
21:19:17 <devkulkarni> I have 2 topics here
21:19:24 <datsun180b> i think jungleboyj had a o/ earlier
21:19:43 <jungleboyj> datsun180b: Sorry, wrong meeting room.  As you were.  :-)
21:20:00 <datsun180b> due diligence
21:21:18 <devkulkarni> adrian_otto: first topic concerns nova-docker driver. read the emails about where the driver should live.. given that solum uses it in the devstack setup, how might we be affected, if any?
21:21:47 <adrian_otto> the discussion is about whether it should be in the Nova tree
21:22:11 <adrian_otto> currently there is only one active maintainer who is also on the Magnum team
21:22:41 <adrian_otto> and the Magnum team discussed the possibility of adopting nova-docker maintenance duty
21:22:46 <adrian_otto> and we dicided against taht for now
21:22:54 <devkulkarni> oh okay
21:22:57 <adrian_otto> *decided
21:23:04 <adrian_otto> so most likely it willr emain unchanged
21:23:26 <devkulkarni> I see..
21:23:34 <adrian_otto> what might make sense for Solum is to see about integrating with Magnum once heat resources are available
21:23:45 <adrian_otto> that should be as simple as a change to a heat template
21:24:03 <devkulkarni> if that would be the case then that will be easy
21:24:13 <adrian_otto> and we can rely on whatever Nova instance type the given cloud supports
21:24:17 <devkulkarni> btw, how far along are heat resources for magnum?
21:24:25 <devkulkarni> sure
21:24:47 <adrian_otto> I just learned about them a week ago. My understanding is that they are in progress. I have not been keeping track of them.
21:24:55 <devkulkarni> ok
21:25:04 <adrian_otto> randallburt knows about them, so you might check with him
21:25:10 <devkulkarni> is there a magnum + heat session next week?
21:25:31 <devkulkarni> sure, I will ping randallburt
21:25:44 <adrian_otto> no, but we could talk about that in the Friday meetup which is intended for this sort of thing.
21:26:12 <devkulkarni> I see.. will reach out to randallburt to find out more
21:26:25 <devkulkarni> that is all from me on this topic
21:26:35 <adrian_otto> ok
21:26:45 <devkulkarni> so the second topic was mostly a request
21:27:15 <adrian_otto> conceptually it would make sense for Solum to create a Magnum Bay (Swarm Cluster) per tenant
21:27:26 <devkulkarni> I was wondering, when you take our case to TC adrian_otto, would you let us know.. I am curious to be part of that meeting (in spectator role)
21:27:39 <adrian_otto> and then deploy apps onto that just as we would with the docker daemon we launch today
21:28:06 <adrian_otto> devkulkarni: yes, I'll keep you in the loop so you can participate
21:28:22 <devkulkarni> adrian_otto: thank you!!
21:28:46 <devkulkarni> adrian_otto: is there a screen cast of magnum demo that you can share with us?
21:29:00 <devkulkarni> I haven't kept up with magnum terms/concepts
21:29:09 <adrian_otto> not yet, but I am making one now
21:29:13 <devkulkarni> cool
21:29:44 <adrian_otto> to my amusement, my laptop was previously incapable of running Quicktime
21:29:55 <datsun180b> for your own good
21:29:56 <adrian_otto> it would crash hard with a GPU panic every time it started recording
21:29:57 <devkulkarni> really?
21:30:10 <adrian_otto> eyah, most amusing quirk I have seen in years
21:30:13 <devkulkarni> which version of mac os you had?
21:30:33 <adrian_otto> so I just got a replacement system today, but it's totally blank (no software except OSX)
21:30:51 <adrian_otto> so now I can record using that.
21:30:59 <devkulkarni> might want to keep the previous one around for the next week, no?
21:31:09 <adrian_otto> just will take some work to set it up
21:31:21 <adrian_otto> well, I'm going to Vancouver
21:31:52 <adrian_otto> so I want to be moved over to the new one ASAP so I'm not schlepping two computers around
21:32:06 <devkulkarni> thats true too
21:32:14 <adrian_otto> anyway, Magnum will have a screencast soon
21:32:21 <devkulkarni> will look forward to it
21:32:26 <adrian_otto> there was an article you might find interesting:
21:32:36 <devkulkarni> is there a Vagrant setup for magnum?
21:32:36 <datsun180b> just run ssh on the old one and shell from the new one when you need something
21:33:10 <datsun180b> leave the old one at home running the whole time, that can't possibly go wrong for a number of security or physical reasons
21:33:24 <adrian_otto> http://www.theplatform.net/2015/05/11/openstack-aims-magnum-at-containers/
21:33:42 <devkulkarni> thanks for sharing
21:33:49 <devkulkarni> will magnum also support lxd?
21:34:12 <adrian_otto> it could if someone shows up ready to make an LXD bay type for it
21:34:29 <adrian_otto> canonical did make an LXD nova driver
21:34:35 <adrian_otto> so that's possible
21:34:48 <devkulkarni> curious, are they participating in magnum?
21:35:02 <adrian_otto> not that I know of, but I'm finding it difficult to keep track
21:35:13 <devkulkarni> good problem to have
21:35:13 <adrian_otto> ther have been several new committers recently
21:35:19 <adrian_otto> yes, indeed
21:35:47 <adrian_otto> ok, maybe we should wrap up for today, thoguhts?
21:35:52 <devkulkarni> sounds good
21:36:37 <adrian_otto> thanks everyone for attending. Our next team meeting will be Tuesday 2015-05-26 at 2100 UTC.
21:36:47 <adrian_otto> I might need a hand on that day… not sure yet
21:37:10 <devkulkarni> thanks adrian_ottot
21:37:15 <devkulkarni> *adrian_otto
21:37:17 <adrian_otto> catch you then
21:37:21 <devkulkarni> have fun next week
21:37:22 <adrian_otto> #endmeeting