21:00:19 <adrian_otto> #startmeeting Solum Team Meeting
21:00:19 <openstack> Meeting started Tue Feb 10 21:00:19 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:23 <openstack> The meeting name has been set to 'solum_team_meeting'
21:00:23 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-02-10_2100_UTC Our Agenda
21:00:30 <adrian_otto> #topic Roll Call
21:00:33 <adrian_otto> Adrian Otto
21:00:47 <devkulkarni> devdatta kulkarni
21:00:58 <ravips> Ravi Sankar Penta
21:01:06 <roshanagr> Roshan Agrawal
21:01:15 <datsun180b> ed cranford
21:02:40 <adrian_otto> hello devkulkarni ravips roshanagr datsun180b and james_li
21:02:58 <roshanagr> Hi adrian_otto
21:03:00 <muralia> murali allada
21:03:05 <devkulkarni> hi adrian_otto
21:03:24 <adrian_otto> hi muralia
21:03:29 <adrian_otto> ok, let's begin
21:03:31 <james_li> Hi adrian_otto
21:03:37 <adrian_otto> #topic Announcements
21:03:40 <muralia> Hi adrian
21:03:58 <adrian_otto> for the next 3 meetings I will be away
21:04:10 <adrian_otto> Those dates are: 2015-02-17, 2015-02-24, and 2015-03-03. Our chair will be: devkulkarni
21:04:14 <dimtruck> \o
21:04:27 <mkam> Melissa Kam
21:04:35 <adrian_otto> This friday I am going on Vacation through the following friday, followed by two conferences
21:04:36 <devkulkarni> glad to lead the meetings on those days
21:04:56 <adrian_otto> so I will be checking email, but generally not around on IRC much during that time.
21:05:08 <adrian_otto> thanks devkulkarni. I appreciate it!
21:05:18 <adrian_otto> any other announcements from team members?
21:06:05 <adrian_otto> I submitted a talk for Vancouver ODS for Solum.
21:06:17 <adrian_otto> once the voting ink becomes available I will share that with you.
21:06:21 <muralia> nice
21:06:26 <dimtruck> awesome!
21:06:31 <james_li> cool
21:06:50 <adrian_otto> I'm looking forward to giving you all credit for all the awesome work you've completed in this cycle.
21:07:17 <adrian_otto> #topic Review Action Items
21:07:24 <adrian_otto> we did not have any last week.
21:07:31 <adrian_otto> #topic Administrative
21:07:52 <adrian_otto> several of you have noticed -1 votes on your review submissions for administrative reasons
21:08:14 <adrian_otto> the purpose of this is to give more complete visibility to what is included as we cut releases
21:08:25 <adrian_otto> Please include links to "Implements blueprint BLUEPRINT" or "Closes-Bug: #NNNN" on the last line of the commit message.
21:08:41 <adrian_otto> if you notice a review without one of these, please vote -1 and request that it be added.
21:08:57 <adrian_otto> if there is not a bug ticket already, you can file one yourself
21:09:07 <adrian_otto> NOTE: The bug does not need to be previously approved to be linked to a review.
21:09:16 <adrian_otto> questions or concerns about this?
21:09:36 <datsun180b> sounds reasonable
21:09:51 <devkulkarni> sounds fine
21:10:02 <adrian_otto> ok, if this ends up causing unreasonable friction for whatever reason, let's revisit it.
21:10:11 <adrian_otto> thanks for your help with this.
21:10:16 <adrian_otto> #topic Blueprint/Task Review
21:10:28 <adrian_otto> before I dive into specific work items
21:11:01 <adrian_otto> I want to mention that our gates are all complaining about a missing library for tempest
21:11:16 <devkulkarni> dimtruck fixed the issue recently
21:11:18 <adrian_otto> from what I have seen the devstack job is failing on allpatches
21:11:23 <adrian_otto> oh?
21:11:24 <dimtruck> correct
21:11:28 <dimtruck> https://review.openstack.org/#/c/154650/
21:11:29 <adrian_otto> please elaborate
21:12:02 <dimtruck> we now need this in our run_tests.sh:
21:12:04 <adrian_otto> ok, so I will happily order rechecks on open reviews once that merges
21:12:22 <dimtruck> pip install -r $TEMPEST_DIR/requirements.txt
21:12:29 <dimtruck> to install latest requirements
21:12:41 <dimtruck> that was able to successfully pass jenkins
21:12:47 <adrian_otto> dimtruck: thanks for the fix!!
21:12:51 <dimtruck> other projects (murano) did the same
21:13:00 <dimtruck> there was a nice chain about it at openstack-qa
21:13:03 <james_li> Thanks dimtruck
21:13:12 <dimtruck> np
21:13:14 <roshanagr> dumtruck rocks!
21:13:24 <roshanagr> dimtruck
21:13:34 <dimtruck> that way i can get my 2 month old patch in as well :)
21:13:57 <adrian_otto> also, I want to highlight that we held a short debate yesterday about how to address storage constraints on the build node caused by accumulated git repos and DU images
21:14:03 <adrian_otto> https://bugs.launchpad.net/solum/+bug/1419978
21:14:03 <openstack> Launchpad bug 1419978 in Solum "Delete LP Images and repos when storage is low" [Wishlist,Triaged]
21:14:12 <adrian_otto> that's the resolution we agreed to.
21:14:29 <adrian_otto> muralia submitted revisions to the open reviews in accordance with this decision
21:14:35 <muralia> yes
21:14:41 <adrian_otto> thanks muralia
21:14:49 <devkulkarni> muralia: did you see my comment on them?
21:14:51 <adrian_otto> any further discussion on this topic?
21:14:59 <muralia> not yet
21:15:15 <devkulkarni> ok. we can discuss it on the patch itself
21:15:43 <adrian_otto> ok, that was a good compromise I thought.
21:16:00 <adrian_otto> any other work items we should discuss as a team today?
21:16:24 <roshanagr> adrian_otto, I made roadmap cleanup
21:16:31 <roshanagr> worth reviewing?
21:16:34 <adrian_otto> thanks roshanagr
21:16:39 <adrian_otto> yes, we have time for that
21:16:44 <roshanagr> Also, have documentation for new cli
21:16:48 <roshanagr> cool
21:16:49 <adrian_otto> have the link handy?
21:17:03 <roshanagr> I cleaned up high level roadmap
21:17:05 <roshanagr> https://wiki.openstack.org/wiki/Solum/HighLevelRoadmap#Milestone:_Kilo
21:17:06 <adrian_otto> use #link LINK DESC
21:17:22 <roshanagr> #https://wiki.openstack.org/wiki/Solum/HighLevelRoadmap#Milestone:_Kilo High Level Roadmap
21:17:36 <devkulkarni> #link https://wiki.openstack.org/wiki/Solum/HighLevelRoadmap#Milestone:_Kilo
21:17:43 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/HighLevelRoadmap#Milestone:_Kilo Roadmap
21:17:48 <adrian_otto> ok, let's dig in!
21:18:09 <roshanagr> will give it a few minutes for folks to take a look
21:19:40 <ravips> new cli looks great, minor suggestion..can we do 'solum app deploy <app_name>' instead of 'solum app deploy --name <app_name>'  that will make it consistent with solum app build/show/delete
21:19:43 <adrian_otto> well done roshanagr
21:20:24 <adrian_otto> ravips: agreed, because name is required and can not be confused with other options.
21:20:31 <datsun180b> ravips: i think name's supposed to be required, yes
21:20:37 <roshanagr> thanks adrian_otto.
21:21:01 <roshanagr> ravips: makes sense
21:21:20 <roshanagr> I will reflect that change
21:21:21 <ravips> roshanagr: awesome, doc was very easy to understand
21:21:38 <roshanagr> cool, thanks ravips
21:21:59 <adrian_otto> So when would you like to tag a new release?
21:22:08 <adrian_otto> maybe this week?
21:22:28 <devkulkarni> sounds good to me
21:22:55 <adrian_otto> kilo2 is scheduled to land now
21:23:06 <adrian_otto> and March 19 for kilo3
21:23:36 <adrian_otto> Kilo release is scheduled for April 30
21:23:52 <adrian_otto> is it reasonable to expect that we will complete the roadmap items by then?
21:24:23 <adrian_otto> May 21 is the OpenStack Design Summit
21:24:37 <devkulkarni> seems possible
21:24:57 <devkulkarni> we have not divided different features into kilo-1, 2, 3
21:24:59 <adrian_otto> ok, anyone worried that it's too much?
21:25:09 <adrian_otto> well we are at kilo2 now
21:25:22 <adrian_otto> so I am going to merge in open reviews, and tag kilo2
21:25:26 <devkulkarni> but by April 30 it should be probably okay
21:25:34 <adrian_otto> so it's what we can do between now and April 30
21:25:52 <devkulkarni> right
21:25:57 <adrian_otto> the official OpenStack feature freeze is March 19
21:26:18 <devkulkarni> for Kilo3? that might not be possible to reach
21:26:21 <adrian_otto> so if we tracked with that, we would resolve bugs (defects and tech debt) until April 30.
21:27:19 <roshanagr> devkulkarni: what would you propose we cut from scope for kilo
21:27:20 <adrian_otto> we could revisit it in March
21:27:33 <adrian_otto> to decide whether to do a feature freeze or not
21:27:54 <roshanagr> adrian_otto: +1
21:27:56 <devkulkarni> right now, I think we should not change
21:28:04 <devkulkarni> but towards mid March we should re-evaluate
21:28:30 <adrian_otto> ok, I'll make a note on our meeting agenda (I can set up a few agendas in advance)
21:29:24 <adrian_otto> #action adrian_otto to schedule follow-up discussion for mid-March to determine when a feature freeze should be applied. Should it be March 19?
21:30:01 <adrian_otto> #topic Open Discussion
21:30:13 <adrian_otto> I have one topic for this section
21:30:24 <adrian_otto> relating to inactive core reviewers
21:30:44 <devkulkarni> I suggest we consider either March 17 or 24
21:30:50 <adrian_otto> traditionally core reviewers that have been inactive for a long time are polled by the PTL to ask if they have a continued interest in the project
21:30:54 <devkulkarni> those are Tuesdays (our meeting days)
21:31:05 <adrian_otto> and if not, the PTL proposes to remove them from the core group
21:31:28 <adrian_otto> would you like me to initiate this process, as we have several members of that group
21:31:34 <adrian_otto> ?
21:31:53 <datsun180b> anyone in particular?
21:31:54 <devkulkarni> seems like logical step
21:32:00 <devkulkarni> given that folks have not been active
21:32:20 <adrian_otto> devkulkarni: ok, we can tentatively discuss the feature freeze again on March 17
21:32:37 <adrian_otto> does anyone feel we should keep inactive cores around?
21:32:51 <roshanagr> + 1 on inactive core reviewers
21:33:08 <adrian_otto> roshanagr: to be clear you are supporting a purge, correct?
21:33:15 <roshanagr> yes
21:33:17 <adrian_otto> ok
21:33:34 <adrian_otto> any other thoughts?
21:34:04 <adrian_otto> would you like me to record this as an #agreed, or as an action item?
21:34:12 <adrian_otto> or perhaps both
21:34:14 <devkulkarni> +1
21:34:25 <datsun180b> sounds like an action item
21:34:35 <roshanagr> probably both
21:34:45 <adrian_otto> I'm not hearing any arguments to the contrary
21:35:10 <datsun180b> alternatively, i'm not seeing any other votes in favor
21:35:25 <adrian_otto> so I think a #agreed is appropriate. The reason for my question is that we have not purged in a long time, so I wanted to be confident that the current core group feels comfortable.
21:35:43 <devkulkarni> folks can be re-included again when they get back into the rhythm of the project
21:35:55 <adrian_otto> yes, they can.
21:36:19 <adrian_otto> in fact anyone interested in joining core is welcome to contact me for guidance about how to accomplish that.
21:36:31 <adrian_otto> I'm happy to help with that.
21:36:35 <devkulkarni> yes, I think the current group of core is very comfortable with the form and shape of the project (as it stands) and where it needs to evolve
21:37:05 <adrian_otto> #agreed We will contact inactive core group members, and ask if they want to continue as part of that group, or be proposed for removal.
21:37:25 <adrian_otto> #action adrian_otto to contact inactive core reviewers to ask if they want to continue as part of that group, or be proposed for removal.
21:37:46 <adrian_otto> ok, we are in open discussion. I have no more topics for you :-)
21:39:29 <adrian_otto> if there is nothing more to discuss we can adjourn. I'll wait a bit.
21:40:17 <roshanagr> adios. good meeting
21:40:23 <adrian_otto> Our next meeting is 2015-02-17 at 2100 UTC
21:40:28 <adrian_otto> take care!
21:40:32 <adrian_otto> #endmeeting