21:03:19 <adrian_otto> #startmeeting Solum Team Meeting
21:03:20 <openstack> Meeting started Tue Dec 30 21:03:19 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:03:23 <openstack> The meeting name has been set to 'solum_team_meeting'
21:03:51 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-12-30_2100_UTC Our Agenda
21:03:56 <adrian_otto> #topic Roll Call
21:03:59 <adrian_otto> Adrian Otto
21:04:20 <akshayc> Akshay Chhajed
21:04:37 <adrian_otto> hi akshayc
21:04:44 <akshayc> hi adrian
21:05:04 <adrian_otto> we'll wait a few minutes to see if we can muster a quorum
21:05:10 <akshayc> ok
21:05:28 <adrian_otto> I'm confident that most of us are out on vacation this week
21:05:43 <akshayc> yep…. likely….
21:07:50 <dimtruck> here!
21:07:54 <dimtruck> sorry i'm late
21:08:13 <dimtruck> i think the rest of the folks are out on vacation
21:08:25 <adrian_otto> akshayc: do you have anything in particular you would like to cover today?
21:08:37 <adrian_otto> If not, I'll move to adjourn and we can meet again next week.
21:08:52 <akshayc> ya…. i have a few questions
21:09:08 <adrian_otto> #topic Open Discossion
21:09:13 <adrian_otto> whoops
21:09:18 <adrian_otto> #topic Open Discussion
21:09:36 <adrian_otto> akshayc: proceed with questions.
21:10:03 <akshayc> i am working on fixing #link https://bugs.launchpad.net/solum/+bug/1377976
21:10:04 <uvirtbot> Launchpad bug 1377976 in solum "Add delete call to ImagesController" [Wishlist,New]
21:10:37 <adrian_otto> ok
21:10:52 <akshayc> but there seems to no direct way to get glance_image_id from image object
21:10:59 <adrian_otto> implementing that properly will involve the use of Keystone trust tokens
21:11:48 <adrian_otto> I see
21:12:02 <akshayc> image object does have a base_image_id
21:12:12 <akshayc> but it is set to none
21:12:35 <adrian_otto> where are we currently storing glance_image_id?
21:12:40 <adrian_otto> in plans?
21:13:05 <akshayc> i have not been able to find the data models
21:13:15 <akshayc> that is what I wanted to know
21:13:52 <adrian_otto> one sec while I peek at it
21:13:56 <akshayc> ok
21:14:37 <adrian_otto> well first of all, solum/builder/controllers/v1/image/ImageController.py is not in the codebase yet
21:14:53 <akshayc> ok….
21:14:56 <adrian_otto> solum/builder/controllers/v1/image.py is
21:15:23 <adrian_otto> and that defines created_image_id
21:15:32 <adrian_otto> which is what you'll want to be able to delete
21:15:54 <adrian_otto> that's the id of the created image in glance
21:16:16 <akshayc> yep…. but that is "none"
21:16:35 <adrian_otto> heh, well, that's a bug then
21:16:36 <akshayc> is it ok to delete the object, if it is set to none?
21:16:53 <adrian_otto> if you are confident that there is not actually anything in Glance, then yes
21:16:59 <akshayc> ok….
21:17:08 <adrian_otto> but if we are just not setting it properly when we make the entry in glance, then we need to fix that first
21:17:17 <akshayc> another bug #link https://bugs.launchpad.net/solum/+bug/1406647
21:17:19 <uvirtbot> Launchpad bug 1406647 in solum "Language Pack Test get all missing cleanup" [Undecided,New]
21:17:36 <adrian_otto> ok
21:17:37 <akshayc> small bug
21:17:41 <akshayc> i have a fix
21:18:16 <adrian_otto> ok, terrific!
21:18:21 <adrian_otto> any question on this one?
21:18:43 <akshayc> nothing much now…. i will send that for review
21:18:55 <akshayc> i have a dev here #link https://github.com/akshaychhajed/vagrant-solum-dev/tree/solum_stable_juno
21:19:16 <akshayc> i have removed mistral….
21:19:27 <akshayc> what was it being used for?
21:19:38 <adrian_otto> for the Pipelines resource
21:19:47 <akshayc> i was able to run ghost and ex1 samples without it
21:20:25 <adrian_otto> yes, those use Plan and Assembly, and if you don't need a custom CI, then you don't have to use Pipelines… at least as the project stands today.
21:21:02 <akshayc> ok…. that was breaking the build due to dependency isuue
21:21:42 <adrian_otto> we shoul dnot hesitate to reach out to the Mistral developers for help with situations like that
21:22:23 <akshayc> ok…. most of it is because they do not have a branch for stable juno
21:22:37 <adrian_otto> could not hurt to request one
21:22:42 <akshayc> mistral is running off master
21:22:46 <adrian_otto> it's rather easy to tag a release, and we can pin to that.
21:22:54 <akshayc> ok….
21:23:12 <adrian_otto> I can help out with that
21:23:35 <akshayc> will commits off stable/juno break gate tests?
21:23:44 <adrian_otto> #action adrian_otto to follow up with mistral devs to arrange a tagged release that we can use as a stable dependency.
21:23:53 <adrian_otto> anything else, akshayc?
21:24:27 <akshayc> nothing else
21:24:57 <adrian_otto> ok, super
21:25:19 <adrian_otto> our next meeting is scheduled for 2015-01-06 at 2100 UTC. I look forward to seeing you then!
21:25:25 <adrian_otto> #endmeeting