22:01:13 <adrian_otto> #startmeeting Solum Team Meeting
22:01:14 <openstack> Meeting started Tue Sep 30 22:01:13 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:01:18 <openstack> The meeting name has been set to 'solum_team_meeting'
22:01:38 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum Our Agenda
22:01:46 <adrian_otto> #topic Roll Call
22:01:50 <datsun180b> Ed Cranford
22:01:54 <adrian_otto> Adrian Otto
22:01:55 <muralia> murali allada
22:01:56 <Roshan> Roshan Agrawal
22:01:57 <james_li> james li
22:02:00 <ravips> Ravi Sankar Penta
22:02:10 <devkulkarni> Devdatta Kulkarni
22:02:58 <adrian_otto> hi everyone
22:03:39 <adrian_otto> I'll give us another minute or so for Roll Call before beginning announcements. If you have an announcement for the team be ready, your queue is coming soon.
22:04:05 <adrian_otto> #topic Announcements
22:04:12 <adrian_otto> 1) Core Reviewers
22:04:26 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2014-September/047493.html Motion for Core Reviewer changes
22:04:33 <gpilz> Gilbert Pilz
22:04:39 <adrian_otto> cores, please find and vote on that.
22:04:45 <PaulCzar> o/
22:04:54 <dimtruck> Dimitry Ushakov
22:05:26 <adrian_otto> ok, any other announcements from team members?
22:05:37 <adrian_otto> I skipped one
22:05:43 <adrian_otto> 2) F20 Gate
22:06:03 <adrian_otto> Our F20 gate is now non-voting. Thanks PaulCzar for submitting that change.
22:06:17 <adrian_otto> (pausing for a minute for team member announcements)
22:06:18 <devkulkarni> thanks Paul
22:06:25 <ravips> I found the issue why barbican failed on F20
22:06:32 <adrian_otto> ravips: oh?
22:06:43 <ravips> long story short we need to fix barbican api config param host_href to point to 10.0.2.15:9311, I will submit a patch
22:07:03 <ravips> also we got heads up from barbican team
22:07:20 <ravips> https://review.openstack.org/#/c/124889/1 will again break some of our test cases
22:07:42 <adrian_otto> ok, how will we resolve that?
22:07:43 <ravips> so if there is a test failure involving barbican/private-repo, we know where to look for
22:08:25 <ravips> before starting solum, we need to fix barbican-api.conf and restart barbican if it is already running
22:08:36 <ravips> i couldn't think of any better solution
22:08:36 <adrian_otto> should we proactively create a bug ticket in anticipation of that trouble?
22:09:00 <muralia> I have something related to this barbican issue in the works. It's not a fix for this issue but let me explain.
22:09:10 <PaulCzar> ravips: shouldn't we push barbican to have the correct conf by default rather than us fixing it post-install ?
22:09:12 <adrian_otto> that way we can have a place to record our plans to address it so it should lubricate that effort
22:09:45 <gpilz> +1
22:10:35 <muralia> This might be a good time for me to bring up a patch I'm working on.
22:10:44 <ravips> PaulCzar: it's not barbican issue, its the config param, default host_href=http://localhost: 9311 and we need that to be http://10.0.2.15:9311
22:10:46 <adrian_otto> we are still in announcements
22:10:53 <muralia> Within Rackspace, we are running an instance of solum which does not use barbican.
22:11:17 <adrian_otto> muralia: one moment please
22:11:25 <muralia> ok
22:11:47 <adrian_otto> ravips: wiould you be willing to accepta n action item to open a bug ticket for this issue, and help us get it assigned to a Stacker who can drive it to resolution?
22:12:03 <adrian_otto> maybe that's you, me, or someone else
22:12:06 <ravips> sure, we already have a bug for this one
22:12:27 <adrian_otto> for the upcoming patch https://review.openstack.org/#/c/124889/1?
22:12:59 <ravips> not for that one, I will create a new one
22:13:13 <adrian_otto> ok, if we make an action for it?
22:13:47 <ravips> sure, we can prepare a patch before hand
22:13:50 <adrian_otto> #action ravips to file a bug ticket for resolving anticipated compatibility problem with https://review.openstack.org/#/c/124889/1 when it merges.
22:14:01 <adrian_otto> thanks ravips
22:14:11 <adrian_otto> muralia: I will come back to you in just a moment.
22:14:16 <muralia> sure
22:14:28 <adrian_otto> any other announcements?
22:15:07 <adrian_otto> #topic Review Action Items
22:15:13 <adrian_otto> adrian_otto to investigate using alternatives to openstack/common in Solum, and report back to the team with options.
22:15:19 <adrian_otto> Status: In progress.
22:15:23 <adrian_otto> #action adrian_otto to investigate using alternatives to openstack/common in Solum, and report back to the team with options.
22:15:30 <adrian_otto> to carry it to next week for the report
22:15:42 <adrian_otto> we can also cover this in Open Discussion later
22:15:54 <adrian_otto> adrian_otto to email a link to a Paris Summit topics etherpad to the ML
22:16:15 <adrian_otto> I did not email it, but I did create it:
22:16:20 <adrian_otto> #link https://etherpad.openstack.org/p/solum-paris-summit List of DIscussion Topics for Paris Design Summit
22:16:41 <adrian_otto> please make note, and add your topics for consideration
22:16:55 <adrian_otto> #topic Blueprint/Task Review
22:17:08 <adrian_otto> strategy to sync up openstack/common in solum with upstream (devkulkarni)
22:17:20 <adrian_otto> I owe you a list of options here
22:17:28 <devkulkarni> this is the action item that we discussed above..
22:17:32 <adrian_otto> unless anyone else has been driving this in parallel
22:17:34 <devkulkarni> I chatted with Noorul about this
22:17:56 <devkulkarni> it was on the patch that replaced tests with oslotest.
22:18:04 <devkulkarni> it was recently merged
22:18:19 <devkulkarni> the option that we are following currently seems the best option..
22:18:39 <devkulkarni> https://review.openstack.org/#/c/120255/
22:18:45 <adrian_otto> ok, so should we close this action item?
22:18:45 <devkulkarni> #link https://review.openstack.org/#/c/120255/
22:19:02 <adrian_otto> it does not require further discussion next week?
22:19:11 <devkulkarni> take a look at the discussion therein.. that will inform whether we want to discuss it next week
22:19:21 <adrian_otto> ok, thanks
22:19:24 <devkulkarni> if that looks okay then we can close it
22:19:34 <adrian_otto> muralia: please proceed. You have the floor.
22:19:43 <adrian_otto> (Re: Barbican)
22:19:59 <muralia> yes, im working on a patch related to the barbican service.
22:20:24 <muralia> the patch allows operators to choose not to run barbican for storing keys
22:20:40 <muralia> and just store them on the local file system.
22:21:03 <adrian_otto> Secure by default, so this would need to be optional, and defaulting to off.
22:21:08 <muralia> this option is great for testing and to run internal previews without running an extra openstack service for solum
22:21:18 <adrian_otto> is that what you were planning?
22:21:19 <muralia> yes, secure by default
22:21:55 <muralia> so, keep an eye out for that patch
22:21:55 <adrian_otto> ok, I'm fine with that. Any thoughts from other team members?
22:22:30 <ravips> yep, good option for testing
22:22:38 <PaulCzar> adrian_otto: I would almost suggest we use non-barbican by default
22:22:40 <PaulCzar> for tests
22:22:41 <datsun180b> more options is nice
22:22:42 <PaulCzar> and for devstack
22:23:16 <adrian_otto> PaulCzar: please explain your rationale
22:23:35 <PaulCzar> adrian_otto: barbican has already made breaking changes on us once, and have plans for another
22:23:51 <PaulCzar> so if we switch off while instability continues then we don't break our gating
22:24:01 <PaulCzar> devstack is not designed to be secure
22:24:10 <PaulCzar> so I think this is a reasonable path
22:24:22 <adrian_otto> ok, that's a sensible argument
22:24:23 <PaulCzar> also I don't think barbican is secure unless using a HSM
22:24:55 <adrian_otto> it's more secure than saving unencrypted secrets in plaintext on a host's filesystem
22:25:16 <adrian_otto> and it gives you a central point to audit if you have multiple Solum API nodes
22:25:37 <adrian_otto> it would simplify the changing of secrets in that case
22:26:13 <PaulCzar> adrian_otto: that's true.  if we want we could extend from storing in FS to a database table...  but for basic functionality/devstack I think the FS is sufficient
22:26:32 <PaulCzar> adrian_otto: we should add 'test with barbican' to release process
22:26:45 <PaulCzar> to make sure that when we cut a release we know that the barbican stuff is working
22:27:14 <adrian_otto> a nonvoting gate would also work for that
22:27:36 <PaulCzar> adrian_otto: yeah something along those lines
22:27:53 <PaulCzar> anyways,  lets wait until muralia's patch has landed and then have this conversation again
22:28:09 <muralia> cool. I'll keep barbican as default
22:28:21 <adrian_otto> ok, sounds good. I'm willing to detect that we are running in devstack and use non-barbican in that case.
22:28:38 <adrian_otto> defaulting to using barbican otherwise, maybe?
22:28:44 <PaulCzar> barbican should be default in solum.conf.    we can change that in the contrib/devstack to suit how we want to test
22:28:50 <PaulCzar> exactly :)
22:29:01 <adrian_otto> PaulCzar: yeah, that would strike a balance
22:29:15 <adrian_otto> cool. Any more thoughts on this topic?
22:29:18 <ravips> +1
22:29:30 <PaulCzar> will also help with devstack size ..  we're having to run 6gb VMs now for solum's devstack
22:29:54 <PaulCzar> (memory)
22:30:56 <datsun180b> fyi that's line 231 of our Vagrantfile, "modify_vm --memory 6144" is about 6 gigs
22:31:25 <ravips> are we going to test barbican on non-voting gate?
22:32:23 <PaulCzar> ravips: once the alternative code is merged we'll figure out the specifics
22:32:29 <adrian_otto> I'd like to plan that, as I see this as an important long term capability that deserves ongoing test coverage, not just at release events.
22:33:12 <ravips> non-voting gate will help to fix the issues sooner instead of waiting till the end of the release
22:33:18 <adrian_otto> but I agree that as sands shift below us, we should be positioned to proceed by disabling those features.
22:33:21 <PaulCzar> +1
22:33:48 <adrian_otto> ok, so I'm happy to pick this back up later as suggested.
22:33:56 <adrian_otto> #topic Open DIscussion
22:34:50 <PaulCzar> I have to leave unless anybody has something specific they want to talk to me about
22:35:07 <ravips> just to avoid any duplicate effort, I wanna let the team know that
22:35:27 <ravips> I took the initial stab at porting some of our shell code to python, mostly code around app clone/build/develop
22:35:38 <devkulkarni> +10 ravips
22:35:43 <datsun180b> last i check julien held the conch on that
22:35:43 <PaulCzar> ravips: awesome!
22:35:52 <ravips> this is my plan: http://paste.openstack.org/show/117285/ , feedback helps
22:35:52 <adrian_otto> I would like to wrap up early as well
22:36:11 <gpilz> one thing on the OpenStack Summit
22:36:12 <datsun180b> there's a bug about it, i'm digging
22:36:23 <gpilz> is there any discount for contributors?
22:36:37 <gpilz> I thought I remembered hearing something about that once
22:36:42 <gpilz> but I think I remember a lot of stuff
22:36:43 <PaulCzar> gpilz: yeah,  ATCs are free ( on early bird price )
22:36:44 <adrian_otto> gpilz: yes, ATC's get free admission
22:36:50 <devkulkarni> ravips: Patch 3 may not be possible
22:36:53 <adrian_otto> but you need to land a patch in openstack in the release
22:36:58 <roshanagr> OpenStack Paris: who among us will be there?
22:37:06 <gpilz> I will be there
22:37:06 <adrian_otto> so chances are that you don't have one of those yet.
22:37:30 <roshanagr> gpilz: great. I will be there as well
22:37:49 <adrian_otto> I expect julienvey and stannie.
22:37:55 <adrian_otto> as they are locals.
22:38:00 <PaulCzar> ravips: looks pretty good to me.    with docker we can use the api over http rather than the socket ... that removes requirement to run as root.
22:38:02 <roshanagr> nice, yes of course
22:38:04 <ravips> devkulkarni: docker-py is not stable or can't run sudo command? or any other particular reason?
22:38:29 <devkulkarni> there was an issue with it getting adding to global requirements
22:38:40 <devkulkarni> datsun180b did you find the bug
22:38:44 <datsun180b> looking
22:38:45 <devkulkarni> I think that has the details
22:39:03 <devkulkarni> but otherwise this is great ravips
22:39:11 <datsun180b> #link https://bugs.launchpad.net/solum/+bug/1302552
22:39:13 <uvirtbot> Launchpad bug 1302552 in solum "Tech Debt: Convert bash scripts in contrib into python code and add tests" [Medium,Triaged]
22:39:28 <PaulCzar> heat gives us precedence to add in via contrib - https://github.com/openstack/heat/blob/master/contrib/heat_docker/requirements.txt
22:39:35 <ravips> datsun180b: thanks, I will take a look
22:39:57 <devkulkarni> PaulCzar: good. we can follow that lead then.
22:41:13 <adrian_otto> ok, you all happy to wrap up now?
22:41:21 <PaulCzar> +2
22:41:30 <devkulkarni> sure
22:41:34 <ravips> yes
22:41:41 <muralia> yes
22:41:46 <gpilz> +1
22:42:25 <adrian_otto> Thanks everyone for attending today. Our next meeting is UTC 2200 on Tuesday 2014-10-14
22:42:29 <adrian_otto> #endmeeting