16:01:11 <adrian_otto1> #startmeeting Solum Team Meeting
16:01:12 <openstack> Meeting started Tue May 20 16:01:11 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto1. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:15 <openstack> The meeting name has been set to 'solum_team_meeting'
16:01:37 <adrian_otto1> #link https://wiki.openstack.org/wiki/Meetings/Solum Our Agenda
16:01:47 <adrian_otto1> #topic Roll Call
16:01:49 <paulmo> Paul Montgomery
16:01:54 <adrian_otto1> Adrian Otto
16:01:58 <ravips> Ravi Sankar
16:01:59 <devkulkarni> Devdatta Kulkarni
16:02:00 <muralia> Murali Allada
16:02:03 <james_li> James Li
16:03:07 <aratim> Arati
16:04:12 <funzo> Chris Alfonso
16:04:18 <ewindisch> Eric Windisch (spectating?)
16:04:19 <paulczar> Paul Cz
16:04:27 <adrian_otto> hi Eri	c. Welcome.
16:04:44 <danpb> Daniel Berrange
16:04:56 <s1rp> Rick Harris
16:05:45 <adrian_otto> I'm going to wait just a bit longer for additional attendees,a s we have some policy decisions to make
16:05:54 <adrian_otto> hi s1rp!
16:06:01 <s1rp> howdy!
16:06:04 <adrian_otto> hi danpb
16:06:06 <devkulkarni> adrian_otto: could you please post the agenda link
16:06:19 <adrian_otto> irc://irc.freenode.net:6667/#link https://wiki.openstack.org/wiki/Meetings/Solum Our Agenda
16:06:23 <tomblank> tom blankenship
16:06:28 <devkulkarni> adrian_otto: thanks!
16:07:25 <adrian_otto> ok, let's begin
16:07:28 <adrian_otto> #topic Announcements
16:08:01 <adrian_otto> There is now an openstack-containers team, and #openstack-containers. For more information:
16:08:04 <adrian_otto> #link https://wiki.openstack.org/wiki/Teams/Containers
16:08:31 <adrian_otto> I urge you to attend. The initial meeting schedule is like solum, but on alternating weeks
16:09:01 <devkulkarni> Is this happening today in the evening (CST)?
16:09:03 <noorul> Noorul Islam
16:09:09 <adrian_otto> yes, 2200 UTC
16:09:14 <adrian_otto> welcome noorul
16:10:25 <adrian_otto> ok, any other announcements from team memebers?
16:10:39 <adrian_otto> #topic Review Action Items
16:10:42 <adrian_otto> (none)
16:10:51 <adrian_otto> #topic PTL Election Discussion
16:11:13 <adrian_otto> we are at the point in time where we need to decide how to proceed with a PTL election
16:11:34 <adrian_otto> our ofunding members of Solum requested a lightweight governance process. We have avoided making anything more complicated than contributors want.
16:11:56 <adrian_otto> so, we don't have a procedure for handling an election
16:12:09 <adrian_otto> I wanted input from the contributors on how we should address this.
16:12:28 <adrian_otto> here are some declarations that I think nobody will object to:
16:12:41 <adrian_otto> 1) The definition of the electorate:
16:12:42 <adrian_otto> The electorate is comprised of all individuals who made contributions to Solum during the 2014.01.01 release (concurrent with OpenStack Icehouse).
16:12:55 <adrian_otto> 2) Candidacy
16:13:02 <adrian_otto> Candidates may send an email to openstack-dev@lists.openstack.org with the subject [Solum] Solum PTL Candidacy
16:13:24 <adrian_otto> we should put a deadline to determine when any new candidates must declare condidacy
16:13:37 <adrian_otto> are we all in agreement so far, or should we discuss the above?
16:13:45 <funzo> seems to make sense
16:13:47 <muralia> I'm good so far
16:13:48 <devkulkarni> typically how much time is set aside for this in OpenStack projects?
16:13:49 <paulmo> Agree
16:14:10 <adrian_otto> devkulkarni: a couple of weeks is typical
16:14:13 <noorul> +1
16:14:22 <tomblank> +1
16:14:37 <ewindisch> it was only one week this time around for candidacy and another week for the elections themselves
16:14:45 <paulmo> I assume there is a prescribed OpenStack election process for core projects, why not follow a similar model?
16:15:03 <muralia> paulmo +1
16:15:05 <adrian_otto> paulmo: good question
16:15:12 <adrian_otto> that requires a secret ballot system
16:15:20 <ewindisch> I’d argue that teh electorate should also be foundation members, but that is probably implicit by being a contributor?
16:15:25 <adrian_otto> which we don't have access to, unless I ask for special permission to use it.
16:15:44 <muralia> can we create an anonymous poll?
16:16:02 <adrian_otto> ewindisch: my definition of the electorate is consistent with the OpenStack definition. You have to be an ATC on the project to vote for the PTL.
16:16:02 <muralia> using the same site we use for other polls
16:16:13 <ewindisch> adrian_otto: I believe they simply use this tool: http://civs.cs.cornell.edu/
16:16:18 <ewindisch> (it’s open and public)
16:16:34 <adrian_otto> ok, so let's take the points one at a time
16:16:46 <adrian_otto> is a June 2nd deadline for candidates reasonable?
16:17:14 <adrian_otto> any objections to a #agreed on that date?
16:17:15 <paulmo> That seems like plenty of time
16:17:25 <muralia> +1
16:17:29 <aratim> +1
16:17:35 <paulczar> heaps of time, I would suggest shorter …  i.e. by next meeting
16:17:49 <adrian_otto> ok, good.
16:17:53 <tomblank> paulczar: +1 i think 1 week to declare is sufficient
16:18:11 <adrian_otto> any objections to May 26th, one day prior to our May 27 meeting?
16:18:27 <devkulkarni> June 2nd is good
16:18:55 <devkulkarni> -1 to next week as some of our cores are missing from todays meeting (don't know if that matters)
16:18:56 <paulmo> May 26 is a holiday right?  I think we may need a bit more time especially for those not able to attend this meeting.
16:19:05 <adrian_otto> the only drawback to a later date that I can see is that if another PTL prevails, that he/she would have a shorter term than 6 months.
16:19:37 <noorul> devkulkarni: I think this will be announced in ML
16:19:38 <devkulkarni> adrian_otto: oh I see. you have a point..
16:19:49 <adrian_otto> but it's already eating into the time of a second term, so I'm not sure that another week would be a big deal.
16:19:53 <noorul> devkulkarni: So they will anyhow get a chance to see it
16:20:09 <danpb> paulmo: yes, May 26 is a holiday in some countries
16:20:09 <adrian_otto> ok, so let's settle on June 2, understanding the drawback
16:20:30 <devkulkarni> ok, cool.
16:20:30 <adrian_otto> any objections?
16:20:53 <devkulkarni> none from me
16:21:00 <gokrokve> no
16:21:03 <noorul> no
16:21:03 <adrian_otto> #agreed 2014-06-02 at 00:00 UTC will be the deadline for Solum PTL candidates
16:21:07 <adrian_otto> next point...
16:21:18 <adrian_otto> 3) Election Official
16:21:31 <adrian_otto> I would like to appoint an election official to run the election
16:21:51 <adrian_otto> my thought is that I will ask a favor from one of the previous openstack election officials
16:22:07 <noorul> +1
16:22:14 <adrian_otto> if I am unable to get an agreement from one of them, then I will make a proposal at our may 27th meeting
16:22:17 <devkulkarni> +1 btw, what are this persons typical responsibilities?
16:22:24 <muralia> that sounds good.
16:22:33 <gokrokve> +!
16:22:37 <gokrokve> +1
16:22:40 <adrian_otto> devkulkarni: verrify the candidates and voters are ATC's on Solum
16:22:57 <tomblank> +1
16:22:57 <adrian_otto> and to make sure that nothing shady ahs happened with respect to collecting or counting votes
16:23:18 <adrian_otto> so we are selecting someone we feel we can trust to perform that function
16:23:19 <devkulkarni> adrian_otto: thanks
16:23:52 <funzo> adrian_otto: that rules me out ;)
16:23:52 <adrian_otto> another option is that I could act as the official, but I don't like that option as much because I don't want any appearance of conflict of interest
16:24:16 <adrian_otto> any objections to the approach of finding an external election official who has served this role before?
16:24:23 <devkulkarni> yes, that will create conflict-of-interests
16:24:30 <devkulkarni> no objections
16:24:36 <funzo> the official is responsible for selecting the polling tool, or is http://civs.cs.cornell.edu/ just a given
16:24:39 <tomblank> adrian_otto: no objections
16:24:49 <adrian_otto> funzo: yes!
16:25:12 <ewindisch> +1 on http://civs.cs.cornell.edu/
16:25:18 <muralia> +1
16:26:05 <adrian_otto> #agreed adrian_otto will appoint an election official to select a polling tool, and conduct an election, as needed to select our next PTL. Solum team suggests: http://civs.cs.cornell.edu/ as the polling tool. Suitable candidates are ones who have acted as OpenStack election officials in the past.
16:26:14 <adrian_otto> ok, next point...
16:26:21 <adrian_otto> Election Rules
16:26:24 <adrian_otto> 4) Election Rules
16:26:35 <adrian_otto> The candidate with the largest number of votes prevails as the new PTL, as confirmed by the election official.
16:26:49 <adrian_otto> any objections to that one?
16:27:00 <devkulkarni> how to break ties?
16:27:11 <adrian_otto> good question devkulkarni
16:27:16 <muralia> :)
16:27:33 <ewindisch> https://wiki.openstack.org/wiki/Governance/TieBreaking
16:27:33 <adrian_otto> we would need to repeat the election, I suppose in a runoff
16:27:34 <paulmo> rock paper scissors spock lizard? :)
16:28:08 <funzo> coin-toss
16:28:09 <funzo> nice
16:28:11 <devkulkarni> ewindisch: :)
16:28:46 <adrian_otto> ok, so can we agree to the same tie breaking procedure?
16:29:05 <devkulkarni> fine with me
16:29:06 <muralia> +1 :)
16:29:18 <tomblank> +1
16:29:20 <james_li> +1
16:29:27 <adrian_otto> #agreed in the event of the tie, the election official shall use the tie breaking procedure described at https://wiki.openstack.org/wiki/Governance/TieBreaking
16:29:31 <adrian_otto> ok, next point...
16:29:51 <adrian_otto> if there are no other candidates proposed, should we bother to hold an election at all, or just skip it?
16:30:05 <paulczar> +1 skip
16:30:06 <devkulkarni> skip it
16:30:20 <tomblank> skip it...
16:30:23 <adrian_otto> or just extend the term of the current PTL, and revisit the election at the next release cycle.
16:30:33 <adrian_otto> ok, any opposing viewpoints?
16:30:36 <devkulkarni> that would be the case right?
16:30:41 <devkulkarni> no
16:30:53 <adrian_otto> yes, I will serve as PTL until another is elected to replace me
16:30:59 <adrian_otto> I am willing.
16:31:03 <muralia> yes, we should extend
16:31:06 <paulmo> 0 candidates = current PTL continues, 1 candiate = no election, new candidate is PTL
16:31:19 <adrian_otto> ok, good
16:31:35 <adrian_otto> #agreed 0 new candidates = current PTL continues, 1 candiate = no election, new candidate is PTL
16:31:53 <noorul> ok
16:32:01 <adrian_otto> next point
16:32:13 <adrian_otto> am I required to declare a candidacy as an incumbant?
16:32:25 <paulczar> adrian_otto: yes I think so
16:32:28 <muralia> yes
16:32:40 <adrian_otto> so if at 2014-04-01 23:59 another candidate surfaces, am I displaced?
16:32:51 <ewindisch> no, PTLs step down from time to time. It isn’t required that you continue
16:32:59 <muralia> no, then we have 2. so there will be an election
16:33:09 <devkulkarni> yeah, then there is an election
16:33:13 <aratim> +1 on having an election
16:33:18 <paulczar> adrian_otto: would you not stand if there’s another cantidate ?
16:33:21 <paulczar> I think you should
16:33:28 <paulczar> unless you don’t want to be
16:33:41 <ewindisch> that is, it’s your choice to stand or not stand.
16:33:53 <adrian_otto> ok, this is clear, we can advance to the next point...
16:34:02 <paulmo> Out of curiosity, is there a core OpenStack project PTL term limit?
16:34:14 <adrian_otto> actually that was the last on this subject
16:34:24 <adrian_otto> paulmo: no term limits
16:34:42 <adrian_otto> it's driven by the choice of the electorate,a dn the willingness of the candidate to continue
16:35:22 <adrian_otto> if I am suddenly unable to continue as PTL for any reason, I'd like the core reviewers to elect an appointed substitute until an election can be held.
16:35:28 <adrian_otto> can we agree to that?
16:35:52 <paulczar> agreed
16:36:04 <muralia> +1
16:36:11 <devkulkarni> makes sense to me. at that point we would just request the substitute to announce the candidacy and follow the procedure probably?
16:36:18 <tomblank> +1
16:36:55 <adrian_otto> #agreed if the PTL is unable to finish his/her term the core reviewer team shall elect a pro-tem PTL to serve until the election procedure can be carried out.
16:37:28 <adrian_otto> that way we have continuity of leadership, and democratic election of a successor
16:37:40 <adrian_otto> ok, we are at the end of this topic
16:37:49 <adrian_otto> sorry for the formality around this
16:38:20 <adrian_otto> I will take an action item to post these decisions on our wiki for future reference, and to arrange an election official.
16:38:33 <devkulkarni> thanks for doing all this in an open manner
16:38:43 <adrian_otto> #adrian_otto arrange an election official to serve int he event we require a PTL election
16:38:59 <adrian_otto> #adrian_otto to announce open call for PTL candidates
16:39:37 <adrian_otto> #adrian_otto to publish election policy and rules to the Solum Wiki page (new sub-page)
16:39:50 <adrian_otto> we can ratify that next week prior to any election
16:40:09 <adrian_otto> #topic Review Design Summit
16:40:26 <adrian_otto> First of all I want to thank everyone for making the trip to Atlanta
16:40:54 <adrian_otto> this was an important milestone for our project, and I am very proud to represent all of the work we have done together
16:41:36 <adrian_otto> in our agenda, I called attention to 3 focus areas for the Juno release
16:41:42 <adrian_otto> 1) Pipeline
16:41:47 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/Pipeline Pipeline Proposal
16:42:03 <adrian_otto> 2) Evironments
16:42:03 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/Environments Environments Proposal
16:42:10 <adrian_otto> 3) Flesh out features shown in the Demo
16:42:17 <adrian_otto> #link https://vimeo.com/94905913 Solum Demo Video
16:42:32 <adrian_otto> we now have a responsibility to deliver on the future vision we have shared with our community
16:43:16 <adrian_otto> we were well represented in a number of different venues at the summit, and a large number of Stackers have seen the demo video
16:43:18 <devkulkarni> Here is the etherpad with various points discussed during the half-day design workshop on Wednesday: https://etherpad.openstack.org/p/SolumSummitAgenda
16:44:11 <adrian_otto> #link https://etherpad.openstack.org/p/SolumSummitAgenda Solum Design Session Notes
16:44:14 <adrian_otto> thanks devkulkarni
16:44:22 <devkulkarni> I think the wiki pages above might be bit old as compared to the agenda
16:44:31 <devkulkarni> i.e. the etherpad
16:45:00 <adrian_otto> devkulkarni: should we plan to true up the wiki pages with the outcome of our design session?
16:45:10 <gokrokve> Are there blueprints for these features?
16:45:15 <devkulkarni> adrian_otto: yes, we should do that
16:45:27 <devkulkarni> gokrokve: for some, yes. others, we need to create
16:45:41 <adrian_otto> #action adrian_otto to file/update blueprints for Pipeline and Environments
16:45:55 <gokrokve> devkulkarni: Cool. We need to have quite granular BPs to distribute work.
16:46:03 <adrian_otto> I will tie those to the juno milestone
16:46:20 <adrian_otto> any other thoughts on last week's summit?
16:46:33 <devkulkarni> gokrokve: yes, we should. once we start creating bps, we should review them for completeness, design, etc.
16:46:48 <paulczar> it was good to see people were in general a lot more accepting of both Solum and docker
16:47:02 <adrian_otto> +1 paulczar
16:47:09 <devkulkarni> adrian_otto: are we in the open discussion now?
16:47:13 <adrian_otto> not yet
16:47:19 <adrian_otto> we have Review Tasks
16:47:43 <adrian_otto> but I am tempted to skip that, because not much has changed since we have been occupied with the Summit
16:48:02 <adrian_otto> but I will give our team a chance to raise questions about tasks, then open discussion
16:48:13 <adrian_otto> #topic Review Tasks
16:48:21 <adrian_otto> #Link https://launchpad.net/solum/+milestone/2014.1.2
16:48:24 <adrian_otto> #link https://launchpad.net/solum/+milestone/2014.1.2
16:48:41 <adrian_otto> does anyone have questions or concerns about the current tasks?
16:49:19 <adrian_otto> #topic Open Discussion
16:49:28 <adrian_otto> devkulkarni: you have the floor
16:49:32 <devkulkarni> I have a question for us to discuss..
16:50:01 <devkulkarni> From Eric's nova docker presentation, it seemed like heat plugin for docker is a simpler option than nova docker. Why are we not using that?
16:50:20 <adrian_otto> devkulkarni: good question.
16:50:42 <adrian_otto> the Heat provider does not have a scheduler like Nova does
16:51:05 <adrian_otto> if the Nova Scheduler were abstracted as a separate thing, then the Heat provider could use that
16:51:24 <ewindisch> devkulkarni: solum’s use-case would require an undercloud running Nova. It could deploy on Ironic or VMs.
16:51:25 <devkulkarni> but I thought it first selects the VM and then talks to docker daemon on it. VM selection will be done by Nova resource provider in usual manner
16:51:27 <paulczar> devkulkarni: it would mean that we would need to have VMs with docker driver installed running for each user
16:51:42 <ewindisch> devkulkarni: the heat plugin is also relatively new and immature compared to the nova plugin, fwiw
16:52:07 <devkulkarni> ewindisch: ah okay.
16:52:28 <ravips> I could not make it to the summit this time, looked at session notes...there was discussion around project scope for Murano and Solum, can someone give some more insights..will there be an integration with murano in the future?
16:52:59 <devkulkarni> ravips: we are going to use Murano's heat template generation capabilities to start with
16:53:00 <adrian_otto> ravips: yes, we advanced our clarity on that
16:53:26 <noorul> gokrokve: Any outcome from Friday's discussion?
16:53:26 <adrian_otto> we see Murano as a source for an application catalog, and potentially something to help with HOT generation
16:53:29 <devkulkarni> there may be other features around application catalog which Solum *may* need
16:53:48 <ravips> adrian_otto: devkulkarni : are we going to move from CAMP and will use Heat/TOSCA?
16:54:05 <adrian_otto> the important takeaway form the joint session Heat+Murano+Solum was that each of those projects has no intent to overlap funcitonality
16:54:24 <gokrokve> noorul: There is an etherpad with the logs. https://etherpad.openstack.org/p/9XQ7Q2NQdv
16:54:53 <devkulkarni> ravips: no decision on that yet.. need to check what Solum wants and what the DSLs of Murano and TOSCA provide in addition to (or different from) the current approach of using Plans
16:54:57 <noorul> gokrokve: cool
16:55:15 <adrian_otto> ravips: the model interpreter will generate the orchestration template, but there will still need to be a way to express the needs of the application in a context that is a higher level that what HOT is intended for.
16:55:25 <adrian_otto> and we would like that to be simple, clean, and elegant
16:55:34 <adrian_otto> if CAMP or TOSCA can help with that, great
16:55:50 <adrian_otto> what I care about most is that the user experience for the app developer is really clean
16:56:25 <ravips> adrian_otto: devkulkarni : got it, thanks that was helpful
16:56:27 <adrian_otto> only require them to fool with complicated templates when if it's absolutely necessary.
16:56:35 <adrian_otto> regardless of the format
16:57:17 <adrian_otto> ok, just a few minutes remaining.
16:57:52 <TravT> Hey Solum team.
16:58:02 <adrian_otto> I look forward to seeing you in the OpenStack Containers Team meeting
16:58:06 <adrian_otto> TravT: hi!
16:58:10 <TravT> I'm from the Graffiti team.
16:58:12 <gokrokve> Do we need a meeting with Mistral team?
16:58:24 <devkulkarni> adrian_otto: is there an agenda for containers meeting?
16:58:29 <devkulkarni> gokrokve: yes, that would be helpful
16:58:31 <paulmo> gokrokve: I have a bunch of questions on Mistral
16:58:35 <devkulkarni> when do they meet?
16:58:35 <paulmo> I think it would be good
16:58:36 <adrian_otto> devkulkarni: I am finalizing it now
16:58:42 <ravips> gokrokve: thx for the ^^ etherpad link
16:58:43 <muralia> hi TravT
16:58:50 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Containers
16:58:55 <TravT> I know that Adrian expressed some interest in Graffiti and asked if we can review some of your needs.
16:59:00 <devkulkarni> adrian_otto: thanks!
16:59:17 <TravT> To see if Graffiti might be able to help in expressing application requirements for Solum
16:59:21 <devkulkarni> TravT: could you send us the Graffiti wiki link?
16:59:26 <TravT> Sure...
16:59:30 <devkulkarni> thanks
16:59:38 <adrian_otto> TravT: yes, let's get you on the next meeting agenda to discuss further
16:59:54 <adrian_otto> thanks for attending everyone
16:59:56 <TravT> That sounds good adrian_otto
17:00:01 <TravT> https://wiki.openstack.org/wiki/Graffiti/Architecture
17:00:04 <devkulkarni> TravT: we are in #solum
17:00:05 <devkulkarni> thanks
17:00:06 <adrian_otto> #endmeeting
17:00:32 <adrian_otto1> #endmeeting