22:00:11 <adrian_otto> #startmeeting Solum Team Meeting
22:00:12 <openstack> Meeting started Tue Apr 29 22:00:11 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:15 <openstack> The meeting name has been set to 'solum_team_meeting'
22:00:21 <adrian_otto> #topic Roll Call
22:00:23 <adrian_otto> Adrian Otto
22:00:30 <roshanagr1> Roshan Agrawal
22:00:35 <tomblank1> Tom Blankenship
22:00:40 <julienvey> Julien Vey
22:00:40 <ravips> Ravi Sankar
22:00:52 <devkulkarni> Devdatta
22:01:24 <funzo> Chris Alfonso
22:01:36 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-04-29_2200_UTC Our Agenda
22:02:46 <roshanagr1> Ravi, welcome to Solum !
22:02:49 <adrian_otto> paulmo and muralia we are doing Roll Call
22:02:58 <paulmo> Paul Montgomery here, sorry, tad late :)
22:03:02 <muralia> murali
22:03:46 <aratim> Arati
22:03:59 <adrian_otto> before we do Announcements today, I have asked Roshan to lead a quick discussion about Environments, and give a status on the working group.
22:04:08 <adrian_otto> #topic Environments
22:04:12 <roshanagr1> sure Adrian
22:04:15 <adrian_otto> roshanagr1: all yours
22:04:22 <roshanagr1> Thanks!
22:04:44 <roshanagr1> First, scheduling the first working group session on Environments
22:04:51 <adrian_otto> #link http://doodle.com/n4w9gmekwz58ekdz Working Group
22:04:56 <roshanagr1> We have folks across 5 times zones
22:05:05 <asalkeld> o/
22:05:12 <roshanagr1> There is no single time that works for all of us
22:05:17 <adrian_otto> hi asalkeld
22:05:30 <roshanagr1> so we need to make some hard choices :-)
22:05:43 <roshanagr1> There are 3 options:
22:05:46 <adrian_otto> should we alternate that meeting time too?
22:05:48 <roshanagr1> Option A: 9 am Wednesday [this will be 12 mid night for Angus?]
22:05:49 <roshanagr1> Option B: 4:30 pm Wednesday [ = 3 am for India]
22:05:49 <roshanagr1> Option C: 8 am Wednedsay [= 6 am for Adrian]
22:06:02 <roshanagr1> @adrian: let us see if we can avoid it
22:06:22 <roshanagr1> if not then we could split into alternating sessions
22:06:47 <asalkeld> that's ok
22:06:48 <roshanagr1> Option A: 9 am Wednesday
22:07:07 <roshanagr1> Angus will feel the most pain with this option
22:07:08 <asalkeld> how about mostly etherpad/email
22:07:22 <asalkeld> stress less about irc meetings
22:07:47 <adrian_otto> you can always have the time for the meeting planned, and cancel it if there is no agenda to cover there
22:07:49 <asalkeld> then only use meeting to sort out contensious stuff
22:08:14 <adrian_otto> with the goal to only hold them when we feel we need an interactive session
22:08:22 <asalkeld> sure
22:08:35 <tomblank1> agree adrian...
22:08:35 <adrian_otto> for reference:
22:08:37 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/Environments
22:08:48 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2014-April/032652.html ML Thread: Use Cases
22:08:55 <adrian_otto> that should be our homework
22:09:13 <roshanagr1> I like the approach.
22:09:17 <adrian_otto> to review/comment, etc.
22:09:45 <roshanagr1> shoud we go ahead and put something on the calendar just in case?
22:10:00 <julienvey> This mail too http://lists.openstack.org/pipermail/openstack-dev/2014-April/033930.html
22:10:05 <roshanagr1> 9 am CST - I think most people can make it
22:10:07 <adrian_otto> ok, so I propose option A, not super convenient for me, but that will keep me honest with what I am promising to Angus about only holding them as needed
22:10:47 <roshanagr1> cool. done. Option A (Wed 9 am CST, next week)
22:10:55 <asalkeld> is that the midnight one (for me)?
22:10:56 <roshanagr1> meanwhie, work on ML/etherpad
22:11:02 <asalkeld> that's ok
22:11:11 <asalkeld> if it's not too often
22:11:11 <roshanagr1> asalkeld: :-) yes,
22:11:23 <roshanagr1> which is why let us hope we don't need it
22:11:50 <roshanagr1> for the ML/etherpad discussion
22:11:51 <adrian_otto> ok
22:12:04 <roshanagr1> it is very easy to get wound up in implementation details
22:12:19 <roshanagr1> we need to keep the discussion with the goal in mind-
22:12:22 <julienvey> asalkeld: I will take time to comment on your etherpad tomorrow
22:12:31 <asalkeld> thanks julienvey
22:12:38 <roshanagr1> which is to answer where does Environments  as a project belong in OpenStack
22:12:48 <adrian_otto> #agreed 9:00 AM US/Central for Environemnts Working Group for weekly irc meetings as-needed. Cancellations to be posted on the wiki page for Environments working group (url tbd)
22:12:49 <roshanagr1> and what are the dependent projects
22:12:59 <asalkeld> roshanagr1, that's easy - no
22:13:37 <asalkeld> (it's just a concept in each project)
22:13:46 <asalkeld> heat has "environments"
22:13:54 <julienvey> murano has too
22:13:56 <asalkeld> solum can have "environments"
22:14:08 <adrian_otto> we might want a REST API endpoint for an Environment resource.
22:14:37 <adrian_otto> something extensible that multiple projects could easily leverage?
22:15:02 <adrian_otto> we can continue that idea on the ML
22:15:03 <roshanagr1> sso the question then is: which project implements the REST API endpoint.
22:15:16 <asalkeld> adrian_otto, our client could just insert the env into barbacan
22:15:16 <roshanagr1> cool. back to you Adrian
22:15:17 <adrian_otto> but I think taht topic deserves discussion
22:15:24 <adrian_otto> thanks roshanagr1
22:15:37 <adrian_otto> I know you have to leave early today, thanks for attending
22:15:42 <adrian_otto> #topic Announcements
22:15:44 <roshanagr1> thanks!
22:15:50 <adrian_otto> Welcome to Ravi Penta from Red Hat
22:16:09 <julienvey> welcome ravips
22:16:09 <adrian_otto> Ravi is in the process of coming up to speed
22:16:14 <adrian_otto> please welcome him!
22:16:22 <paulmo> Welcome Ravi!
22:16:22 <roshanagr1> Welcome Ravi !
22:16:26 <tomblank1> welcome Ravi!
22:16:29 <asalkeld> hi ravips
22:16:57 <adrian_otto> we are all thrilled to grow our contributor base, so we are very happy to have you
22:17:10 <adrian_otto> fins us in #solum
22:17:11 <ravips> Thank you all to the solum team, excited to be here..looking forward to working with you all..
22:17:34 <adrian_otto> ravips: anything special you would like to share with the team about your interests?
22:18:52 <ravips> Interested in opensource projects, worked with redhat openshift team for the last 3 years..
22:19:23 <adrian_otto> sweet. We look forward to getting to know you.
22:19:33 <adrian_otto> next announcement….
22:19:36 <adrian_otto> Bug list fully triaged, prioritized, and targeted to releases. See: https://wiki.openstack.org/wiki/Solum/Bugs
22:19:59 <adrian_otto> last few meetings were a bit less organized, and contributors were a bit foggy about what to work on
22:20:34 <adrian_otto> now the bug list is where I would like us to focus. Anything targeted for "2014.1.2 Maintenance Release", and in accordance of priority
22:20:41 <adrian_otto> we will cover a few later in our agenda.
22:20:58 <adrian_otto> so you can trust that to stay pruned and prioritized. It is part of my daily workflow now.
22:21:19 <tomblank1> adrian_otto: thanks...
22:21:24 <adrian_otto> next announcement (drumroll please)
22:21:44 <adrian_otto> we have a web UI in the works! (Actually parallel efforts around this)
22:21:46 <adrian_otto> New solum-dashboard repo at: http://git.openstack.org/cgit/stackforge/solum-dashboard/
22:22:08 <adrian_otto> thanks to asalkeld for kicking this off
22:22:19 <adrian_otto> it's a Horizon plugin
22:22:25 <asalkeld> it's pretty simple
22:22:40 * asalkeld is not a ui expert
22:22:49 <asalkeld> but does the job
22:22:51 <adrian_otto> we also have some GUI elements that we are working on to enhance our Solum demo for Atlanta.
22:23:10 <adrian_otto> so we are working to fit those efforts together
22:23:33 <adrian_otto> if you are a UI maven, or know one who can chip in, this is the time to get involved.
22:23:55 <adrian_otto> next announcement:
22:23:57 <adrian_otto> New WIKI pages:
22:24:10 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/Testing
22:24:55 <adrian_otto> this explains how newcomers can run unit tests and functional tests. james_li has been testing with this, and adding more functional tests to our suite
22:25:12 <adrian_otto> we also have the Bugs page, mentioned above which is new
22:25:26 <asalkeld> also note I added a solum-group on stackalytics http://stackalytics.com/?release=juno&metric=commits&project_type=all&module=solum-group&company=&user_id=
22:25:33 <adrian_otto> and: https://wiki.openstack.org/wiki/Solum/TestingApiModel
22:25:41 <adrian_otto> whoops
22:25:49 <adrian_otto> that is wrong
22:26:04 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/ApiModel
22:26:12 <julienvey> asalkeld: metrics are strange
22:26:17 <adrian_otto> discusses new concept of the Pipeline resource
22:26:26 <asalkeld> julienvey, it just for juno
22:26:31 <julienvey> asalkeld: oh ok ;P
22:27:05 <adrian_otto> asalkeld: thanks for the new group!
22:27:30 <adrian_otto> Numergy is also working on a new project for a release managment dashboard
22:28:12 <asalkeld> release management of what?
22:28:12 <adrian_otto> anyone with input on the new wiki content is encouraged to submit changes
22:28:29 <adrian_otto> asalkeld: good question. for the Solum project itself.
22:28:35 <julienvey> asalkeld: just a solum specific dashboard
22:28:41 <adrian_otto> we should have something to share next week
22:28:49 <asalkeld> okie dokie
22:28:56 <julienvey> let me find a link
22:28:59 <adrian_otto> #topic Review Action Items
22:29:31 <adrian_otto> the name "solum Dashboard" was already spoken for, so the Release Management Dashboard will be taking on a new name to avoid confusion
22:29:48 <julienvey> https://github.com/parasitid/solum-dashboard
22:29:51 <adrian_otto> adrian_otto to announce the alternating meeting schedule to the ML [complete] See: http://lists.openstack.org/pipermail/openstack-dev/2014-April/033628.html
22:30:00 <adrian_otto> adrian_otto to rename milestone-N milestones in LP to YYYY.R.R format [complete] See: https://launchpad.net/solum
22:30:10 <julienvey> just a little projet we use atNumergy and we wanted to share
22:30:19 <adrian_otto> on this subject, we have two open milestones: 2014.1.2 (bugfixes)
22:30:34 <adrian_otto> and juno-1 for new features
22:30:57 <adrian_otto> adrian_otto to follow up with Lauren Sell about "OpenSource at OpenStack Summit" [in-progress, awaiting reply, expected on 2014-04-24]
22:37:55 <asalkeld> ooo, ui for lp
22:37:55 <adrian_otto> asalkeld: exactly.
22:37:55 <adrian_otto> KPI for LP
22:37:55 <asalkeld> should be lauchpad-dashboard
22:37:55 <adrian_otto> julienvey: can you relay that feedback to @yandegat please?
22:37:55 <julienvey> adrian_otto: sure
22:37:55 <adrian_otto> tx!
22:37:55 <asalkeld> tho' note openstack is probably moving towards other things
22:37:55 <asalkeld> general dislike of lauchpad
22:37:55 <adrian_otto> has anyone seen "OpenSource at OpenStack Summit" announcements on the ML
22:37:55 <adrian_otto> ?
22:37:55 <asalkeld> julienvey, you should show the infra guys
22:37:55 <julienvey> asalkeld: good idea
22:37:55 <adrian_otto> If you are attending the Juno Design Summit, please mark your calendars with:
22:37:55 <adrian_otto> #link http://junodesignsummit.sched.org/event/b7f067ff055ff7db9c92867f3febe1d9#.U2AomccTQT4
22:37:55 <adrian_otto> #link http://junodesignsummit.sched.org/event/556d10915a1a0a2f1aee3ba286826b60#.U2Aoy8cTQT4
22:37:55 <adrian_otto> that is 90 minutes on Tuesday morning after the plenaries.
22:37:55 <asalkeld> yip
22:37:56 <adrian_otto> there is also a half day session on Wednesday
22:37:56 <adrian_otto> TBA
22:37:56 <asalkeld> 2pm there is mistral too
22:37:56 <adrian_otto> ok, I will let you know when the scheduel it set
22:37:56 <adrian_otto> it will be on the main agenda
22:37:57 <adrian_otto> so everyone will now when and where
22:38:18 <adrian_otto> but we are definitely on the schedule and will have time together at the Summit on location.
22:38:47 <adrian_otto> #topic Review Tasks
22:39:08 <adrian_otto> #link https://launchpad.net/solum/+milestone/2014.1.2 Task List for Maintenance Release
22:40:01 <asalkeld> julienvey, https://github.com/openstack-infra/storyboard, https://github.com/openstack-infra/storyboard-webclient
22:40:02 <adrian_otto> Hope this link also works:
22:40:07 <adrian_otto> #link https://bugs.launchpad.net/solum/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&fie
22:41:19 <asalkeld> I need to go in 5min (take kids to school)
22:41:34 <adrian_otto> so, please take a moment and look for unclaimed CRITICAL and HIGH priority items
22:42:42 <adrian_otto> We use tags now, like this: https://bugs.launchpad.net/solum/+bugs/?field.tag=errors
22:42:53 <adrian_otto> those are the most important ones for us to fix
22:43:18 <asalkeld> ok
22:43:39 <asalkeld> I'll get there just trying to get trusts to work
22:43:46 <adrian_otto> thanks asalkeld catch you next time
22:43:57 <adrian_otto> https://bugs.launchpad.net/solum/+bug/1314255
22:44:19 <adrian_otto> that one needs additional information from james_li on the tempest setup used in steps to reproduce
22:44:37 <adrian_otto> all of the other bugs tagged "errors" have owners, so we are in good shape
22:44:44 <james_li> I will update it with more info.
22:45:12 <adrian_otto> are there any tasks that tem members would like to give an update on?
22:45:20 <adrian_otto> thanks james_li
22:46:00 <paulmo> Expect a vagrant packaged Solum M2 demo hopefully tomorrow!
22:46:07 <paulmo> (preview that is for folks to look at)
22:46:11 <adrian_otto> paulmo: WHOOT
22:46:29 <adrian_otto> #topic Open Discussion
22:47:53 <adrian_otto> aratim: about https://bugs.launchpad.net/solum/+bug/1314255
22:48:04 <adrian_otto> Openstack Gerrit marked that one as in-progress
22:48:18 <paulmo> I think she just took a bio break
22:48:36 <adrian_otto> ok, we can come back to that.
22:49:28 <adrian_otto> devkulkarni: how about this one: https://review.openstack.org/89883
22:49:49 <devkulkarni> will review it again
22:49:50 <adrian_otto> can you take your −1 off that review?
22:49:59 <devkulkarni> yes
22:50:00 <adrian_otto> because it did not actually have a pep8 error.
22:50:04 <adrian_otto> gate was just busted.
22:50:41 <adrian_otto> if others woudl review https://review.openstack.org/89883 that one is important for us to advance
22:56:06 <adrian_otto> aratim: back yet?
22:56:06 <paulmo> Not yet
22:56:07 <adrian_otto> devkulkarni: please review: https://review.openstack.org/90235
22:56:07 <adrian_otto> should be ready for approval
22:56:07 <adrian_otto> I also re-wrote the Getting Started Guide
22:56:08 <adrian_otto> and expect to submit that for review tonight or tomorrow morning after I have a chance to test it (full testing takes about 3 hours)
22:56:08 <adrian_otto> following all the steps
22:56:37 <devkulkarni> adrian_otto: okay. will do. james_li: how do the steps look?
22:57:19 <devkulkarni> I like the new gerrit ui
22:57:50 <james_li> just gave my +1
22:58:07 <aratim> hi adrian_otto
22:58:17 <adrian_otto> I am very converned about https://bugs.launchpad.net/solum/+bug/1311112
22:58:22 <devkulkarni> adrian_otto: 3 hours? from git clone all the way to curling the app?
22:58:37 <adrian_otto> is that the same issue with WSEM, or is this something else?
22:58:50 <adrian_otto> devkulkarni: it's three setups of devstack
22:59:05 <aratim> its an error bcoz the context is None
22:59:06 <adrian_otto> each takes roughly one hour to run through
22:59:36 <adrian_otto> it is marked as in-progrss, but I did not notice a link to a code review
22:59:48 <adrian_otto> (meeting will conclude in 1 min)
23:00:06 <adrian_otto> so please link in the review, and I will follow up in #solum for a sec.
23:00:24 <aratim> ok
23:00:39 <aratim> I am planning to abandon the current patch and submit a new one
23:00:41 <adrian_otto> thanks everyone for attending today. Next meeting is 1600 UTC on May 6th
23:00:45 <tomblank1> thanks...
23:00:45 <adrian_otto> #endmeeting