16:03:03 <adrian_otto> #startmeeting Solum Team Meeting
16:03:04 <openstack> Meeting started Tue Jan 21 16:03:03 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:08 <openstack> The meeting name has been set to 'solum_team_meeting'
16:03:13 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum Our Agenda
16:03:28 <adrian_otto> #topic Roll Call
16:03:31 <adrian_otto> Adrian Otto
16:03:34 <kraman> Krishna Raman
16:03:36 <coolsvap> Swapnil
16:03:37 <paulmo> Paul Montgomery
16:03:37 <tomblank> Tom Blankenship
16:03:40 <nmarchenko> Nikita Marchenko, Mirantis
16:03:41 <julienvey> Julien Vey
16:03:47 <paulczar> Paul Czarkowski
16:04:12 <stannie> Pierre Padrixe
16:04:44 <gokrokve> Georgy Okrokvertskhov
16:05:03 <noorul> Noorul Islam
16:05:15 <aratim> Arati Mahimane
16:05:41 <adrian_otto> ok, welcome everyone!! Feel free to chime in as we proceed with Today's agenda. You can say anything in the channel during our meeting to record your attendance.
16:05:45 <adrian_otto> #topic Announcements
16:05:53 <adrian_otto> 1) CLI Working Group cancelled.
16:06:03 <adrian_otto> it turns out that we did not need another meeting for that
16:06:23 <adrian_otto> I'm open to revisiting this if renewed interest builds around this topic
16:06:34 <adrian_otto> 2) New core reviewers will be nominated this week . I will do this with a message to the ML.
16:07:04 <adrian_otto> we will also have another round of additions and pruning in a couple of months.
16:07:31 <adrian_otto> #topic Review Action Items
16:07:43 <adrian_otto> 1) COMPLETED: adrian_otto to update https://wiki.openstack.org/wiki/Solum/HighLevelRoadmap with links to find milestone blueprints
16:07:51 <adrian_otto> 2) COMPLETED: adrian_otto to remove R2.2 from M1 in the roadmap wiki
16:08:02 <adrian_otto> 3) COMPLETED: adrian_otto to drop https://blueprints.launchpad.net/solum/+spec/user-authentication from the weekly agenda and mark the BP as finished
16:08:12 <adrian_otto> 4) COMPLETED: adrian_otto to add a note to the agenda to follow up about any Glance blueprints for https://blueprints.launchpad.net/solum/+spec/specify-lang-pack
16:08:19 <adrian_otto> 5) PENDING: adrian_otto to schedule a meeting about security context and logging features for M1
16:08:25 <adrian_otto> Status: We can discuss these items today. See agenda items below.
16:08:34 <adrian_otto> so in a few minutes, this will also be completed
16:08:43 <adrian_otto> paulmo
16:08:47 <paulmo> Yes
16:08:50 <adrian_otto> I will need input from you on the next two
16:09:04 <adrian_otto> and probably also noorul
16:09:06 <adrian_otto> #topic Security Context feature for M1 (paulmo)
16:09:12 <adrian_otto> and also gokrokve
16:09:19 <adrian_otto> What should the scope and expectations be for M1?
16:09:55 <paulmo> Well, we just need some place to put session data for use around the solum project.  Right now we have 2 options available that need discussion.
16:10:09 <paulmo> There are pull requests up for both.
16:10:13 <adrian_otto> are we happy with what has already posted in reviews?
16:10:26 <adrian_otto> or are we contemplating additional scope beyond that?
16:10:35 <paulmo> We have some divergent reviews right now (for and against each option)… probably needs more discussion to reach consensus.
16:10:54 <paulmo> Oh, no, I'm not looking to extend scope right now so much as consolidate on a single approach.
16:11:08 <adrian_otto> do we need additional preparation to have that discussion, or can we hammer that out in this meeting?
16:11:26 <paulmo> Is Angus here?  I think he had a vested interest in this topic.
16:11:41 <adrian_otto> no, it's really early AM his time
16:11:56 <paulmo> We could talk now but without him, I'm not sure we'll have all key folks together.
16:12:12 <paulmo> Perhaps this afternoon we could schedule a meeting?
16:12:21 <adrian_otto> ok, in that case I can revisit the #5 action item again, and do this a bit later in the day
16:12:31 <paulmo> Thanks :)
16:12:45 <adrian_otto> paulmo are you open to leading the meeting and scheduling it?
16:12:54 <adrian_otto> I will be on flights later today
16:12:55 <paulmo> Sure, no problem!
16:13:17 <paulmo> Oh apologies, just looked at my calendar, I have no time this afternoon unfortunately… would tomorrow work instead?
16:13:17 <adrian_otto> #action paulmo to schedule follow up IRC chat about Security Context
16:13:24 <adrian_otto> sure
16:13:31 <paulmo> Cool; apologies
16:13:35 <adrian_otto> I just want to be sure we don't lose track of the item
16:13:41 <paulmo> Agreed
16:13:49 <adrian_otto> same for Logging Features
16:13:57 <adrian_otto> or do we have everyone present needed for that?
16:14:05 <adrian_otto> #topic Logging Features for M1 (paulmo)
16:14:24 <adrian_otto> What should the scope and expectations be for M1?
16:14:31 <paulmo> russellb angus here?  I think they had interest in this topic.
16:14:40 <paulmo> angus isn't obviously :)
16:14:44 <russellb> hi, fighting gate fires, but around kinda
16:14:47 <adrian_otto> ok, seems that we could bundle these two topics inthe same follow-up
16:15:06 <adrian_otto> it's probably best not to force a decision
16:15:08 <paulmo> Probably a good idea, I think they are related and getting the context set will also give a better idea for the logging path.
16:15:38 <adrian_otto> #action paulmo to add Logging Features to the Security Context followup meeting agenda
16:15:46 <adrian_otto> that fair?
16:15:50 <paulmo> Yep!
16:15:55 <adrian_otto> ok, thanks!
16:16:04 <adrian_otto> #topic Review Blueprints: https://launchpad.net/solum/+milestone/milestone-1
16:16:33 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-minimal-cli Command Line Interface for Solum (devdatta-kulkarni)
16:16:49 <adrian_otto> #link https://review.openstack.org/66617 (WIP)
16:16:57 <adrian_otto> #link https://review.openstack.org/58067 (Pending Review)
16:17:16 <adrian_otto> Devdatta is not attending today, right?
16:17:17 <paulmo> So I have a pull request outstanding on that and there is discussion ongoing.  Hopefully we can reach a consensus in the next day or two. :)
16:17:22 <paulmo> Right, he is flying now.
16:17:27 <adrian_otto> ok
16:17:41 <noorul> The client is ready fore review
16:18:01 <paulmo> If you have time after noorul, can we work through some review topics?
16:18:05 <adrian_otto> SHould we toggle off the WIP designation on 66617 if it is now a merge candidate?
16:18:09 <noorul> And couple more resources are added here https://review.openstack.org/#/c/66184/
16:18:33 <noorul> paulmo: sure
16:18:55 <adrian_otto> #link https://review.openstack.org/66184 CLI resource managers
16:18:59 <paulmo> Good, I think working through just a few review topics will get our code to the point of merging very soon
16:19:08 <adrian_otto> ok, that's great news
16:19:17 <adrian_otto> anything more on this topic?
16:19:25 <paulmo> Not from me
16:19:35 <noorul> paulmo: Why are we adding commands that are not yet implemented in solum
16:19:48 <noorul> I mean commands for API that is not yet in solum repo
16:19:54 <paulmo> I can remove them… just seemed weird to not have a list command to see if things are working.
16:20:04 <adrian_otto> I asked for that
16:20:18 <adrian_otto> because M1 will need to demo nicely
16:20:29 <adrian_otto> and without a list function it will be really awkward to demo
16:21:03 <noorul> Right now there is only one API implemented in solum and that is listing
16:21:04 <adrian_otto> noorul: do you want additional assistance with fleshing out the API?
16:21:26 <paulmo> If it is an extra unplanned burden noorul, perhaps I could offer my help?
16:21:28 <adrian_otto> as it pertains to enabling the CLI
16:22:19 <noorul> There are no API to consume for create, delete, etc
16:22:47 <noorul> I think that should be implemented first, right?
16:23:18 <adrian_otto> yes, we need those
16:23:19 <paulmo> Unfortunately, muralia isn't here today but I think he is working on expanding the API.
16:23:38 <aratim> shs
16:23:49 <adrian_otto> I can make sure that we have enough Stackers working on the enablement of the CLI
16:23:51 <paulmo> If there is something you need sooner, perhaps we can chat with him to prioritize
16:23:59 <aratim> sorry  - pls ignore
16:24:21 <noorul> ok
16:24:33 <tomblank> yes, we can prioritize this work (CLI) if needed
16:25:07 <adrian_otto> ok, any more thoughts on this subject?
16:25:17 <paulmo> So it sounds like create and delete app and assembly would be first APIs you'd want if I take a guess right?
16:25:34 <paulmo> (sorry, didn't mean to rathole there, we can move on) :)
16:25:46 <adrian_otto> Nest is...
16:25:49 <adrian_otto> next is...
16:25:51 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/logging Logging Architecture (paulmo)
16:25:57 <adrian_otto> I think we can skip it
16:26:03 <noorul> paulmo: Yes
16:26:05 <adrian_otto> pursuant to other comments earlier, correct
16:26:12 <paulmo> Yes, agreed
16:26:14 <adrian_otto> next
16:26:16 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-zuul-integration Solum integration with Zuul (devdatta-kulkarni)
16:26:24 <adrian_otto> We got an exciting update on this last week:
16:26:30 <adrian_otto> #link https://github.com/kraman/zuul/compare/solum_hacks POC presented last week
16:26:49 <adrian_otto> kraman: can you update us?
16:27:18 <kraman> sure
16:27:44 <kraman> the solum_hacks branch accepts a message via queue and triggers the build of lang pack
16:28:13 <kraman> i didnt make as much preogress last week but am trying to cleanup the branch and send patches upstream to zuul
16:28:30 <kraman> this should allow us to complete the git-pull BP
16:28:42 <adrian_otto> For anyone who missed last week, we are working on a POC to demonstrate that we can use Zuul as the basis for a build service for Git integration
16:29:03 <adrian_otto> kraman: good, do you need any help, or are you all set?
16:29:14 <kraman> We also decided last week that git-push workflow should be done after m1
16:29:25 <kraman> the workgroup on git is already helping
16:29:35 <kraman> I should be fine with their help
16:29:40 <kraman> so all set
16:29:55 <adrian_otto> ok, awesome
16:29:58 <kraman> thats it from my end
16:30:02 <adrian_otto> #topic Open Discussion
16:30:13 <adrian_otto> I do have one item for this
16:30:48 <adrian_otto> I'd like to ask us to consider moving this meeting to later in the day
16:30:53 <aratim> adrian_otto: I think we missed review for BP https://blueprints.launchpad.net/solum/+spec/specify-lang-pack
16:31:03 <adrian_otto> aratim:
16:31:20 <adrian_otto> ok, do you have an update for us? We can do that now.
16:31:35 <aratim> sure
16:31:38 <aratim> Details about language pack attributes: https://etherpad.openstack.org/p/Solum-Language-pack-json-format
16:31:45 <aratim> Pull request: https://review.openstack.org/#/c/67292/  (Created a language pack resource and implemented GET request. This code is based on the new API worker architecture)
16:31:58 <aratim> adrian_otto: each language pack will also be listed as a service and I will be working on it.
16:32:19 <adrian_otto> Are there any glance blueprints to discuss?
16:32:35 <adrian_otto> for the lang pack?
16:32:46 <aratim> i dont think so
16:33:12 <adrian_otto> ok, thanks
16:33:17 <aratim> I will need to ask devdatta once he is back
16:33:22 <adrian_otto> any more on this topic for this week?
16:33:22 <aratim> thanks
16:33:44 <adrian_otto> ok, so let's continue Open Discussion
16:34:09 <adrian_otto> if we attempt to move the meeting to later in the day, how would that impact our attendees?
16:34:22 <adrian_otto> meeting = Solum Team Meeting (weekly)
16:34:37 <coolsvap> adrian_otto: later by how much time?
16:34:55 <noorul> will be an issue for IST people I believe
16:34:56 <adrian_otto> maybe UTC 2100 instead?
16:35:14 <kraman> adrian_otto: doodle poll to find a good time for everyone?
16:35:25 <adrian_otto> kraman: good suggestion
16:35:31 <paulmo> That is a fine time for me.
16:35:46 <adrian_otto> I think that would work for any US attendees
16:36:13 <adrian_otto> the only time I might expect India and Australia, and the US to be awake at the same time is in the evening for the US
16:36:32 <adrian_otto> in the 7PM US/Pacific timeframe
16:36:33 <coolsvap> I think it would be around 0230 here
16:37:08 <adrian_otto> another possibility might be alternating the meeting time
16:37:13 <adrian_otto> on alternate weeks
16:37:32 <paulczar> +1 for alternating
16:37:47 <adrian_otto> so those who are inconvenienced by one of the meeting times could at least attend every other week
16:37:56 <coolsvap> I think 7PM PST can work
16:38:45 <adrian_otto> ok, so maybe thing a bit on that one, and let's see if we can do better to include more of our contributors. I know it's hard working with so many different timezones.
16:39:01 <adrian_otto> s/thing/think/
16:39:12 <paulczar> 7pm is 9pm for CST
16:39:21 <adrian_otto> yep.
16:39:39 <coolsvap> :)
16:39:48 <adrian_otto> it's outside business hours for the majority of us
16:40:15 <adrian_otto> at any rate, I'm open to more suggestions if there are other ideas
16:40:50 <kraman> adrian_otto: can we change the day? or do you want to keep it tuesday?
16:41:00 <kraman> T/Th 7pm would not work for me
16:41:19 <adrian_otto> sure, we could do any day besides Fri-Sun
16:42:05 <adrian_otto> Monday can also be tricky, as we would frequently contend with holiday schedules
16:42:34 <adrian_otto> so I'll put up a doodle poll
16:42:47 <adrian_otto> when you look at the doodle poll, remember that you can make comments on it
16:42:53 <paulmo> Yeah, this may be the hardest problem in the project. :)
16:42:56 <adrian_otto> and make suggestions for additional times
16:43:19 <adrian_otto> working groups help to mitigate this to some extent
16:44:02 <adrian_otto> any other discussion topics?
16:44:53 <adrian_otto> ok, looks like we might wrap up a bit early today
16:45:41 <adrian_otto> Thanks everyone for attending. We'll meet again next week!
16:45:48 <adrian_otto> #endmeeting