16:00:18 <adrian_otto> #startmeeting Solum Team Meeting
16:00:19 <openstack> Meeting started Tue Jan 14 16:00:18 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:22 <openstack> The meeting name has been set to 'solum_team_meeting'
16:00:26 <adrian_otto> #topic Agenda
16:00:26 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-01-14_1600_UTC Today's Agenda
16:00:36 <adrian_otto> #topic Roll Call
16:00:38 <adrian_otto> Adrian Otto
16:00:42 <coolsvap> Swapnil
16:00:44 <gokrokve_> Georgy Okrokvertskhov
16:00:45 <paulmo> Paul Montgomery
16:00:46 <noorul> Noorul Islam
16:00:47 <muralia> murali
16:00:53 <paulczar> Paul Czarkowski
16:00:55 <devkulkarni> Devdatta
16:00:59 <aratim> Arati Mahimane
16:01:00 <nmarchenko> Nikita Marchenko, Mirantis
16:01:02 <julienvey> Julien Vey
16:01:07 <le089> Leonid Kornilenko, Mirantis
16:01:16 <stannie> Pierre Padrixe
16:01:26 <claytonc> Clayton
16:01:46 <psumkin> Pavel Sumkin, Mirantis
16:01:50 <adrian_otto> good morning everyone!
16:02:16 <muralia> morning, and happy new year to everyone.
16:02:21 <adrian_otto> feel free to chime in to record your attendance as we proceed
16:02:29 <adrian_otto> #topic Announcements
16:02:36 <adrian_otto> Welcome to the first Solum Team Meeting of 2014. Happy New Year!
16:02:51 <gokrokve_> Happy New Year!
16:02:54 <coolsvap> Happy New Year!
16:03:08 <adrian_otto> Our planned announcements:
16:03:13 <adrian_otto> 1) I updated our Roadmap wiki at: https://wiki.openstack.org/wiki/Solum/HighLevelRoadmap to transition version numbering to milestone name, and added an additional feature grouping for additional granularity.
16:04:12 <adrian_otto> I wanted to call this to your attention just in case there was any input from the team that should be integrated at this stage. We will continue to revise the roadmap, so this should not be considered a permanent plan.
16:04:13 <devkulkarni> milestone based grouping is looking nice
16:04:24 <gokrokve_> Are we going to implement R2.2?
16:04:35 <gokrokve_> It looks like quite complex task.
16:04:53 <adrian_otto> gokrokve_: good catch
16:05:07 <adrian_otto> we did actually put that out of scope, so I will move that to M2
16:05:42 <adrian_otto> other thoughts on this?
16:05:54 <gokrokve_> R2.3 also looks out of scope.
16:06:26 <adrian_otto> gokrokve_: R2.3 is currently targeted for M2
16:06:54 <devkulkarni> adrian_otto: what is meaning of P1, P2 etc.+
16:07:00 <gokrokve_> Ok. We will need to check progress in this direction. I don't see anything for that in the code.
16:07:16 <gokrokve_> P2 is a second priority.
16:07:25 <adrian_otto> the R coes are what we used in the roadmap before we had all the BP's created.
16:07:40 <adrian_otto> We could just link the the BP's, or link to the BP list for the release
16:07:56 <adrian_otto> devkulkarni: does that make sense?
16:08:19 <paulmo> ls
16:08:23 <paulmo> oops
16:08:25 <devkulkarni> yes. linking BPs would help..
16:08:29 <adrian_otto> gokrokve_: yes, the language pack framework is a WIP still
16:08:55 <adrian_otto> #action adrian_otto to update https://wiki.openstack.org/wiki/Solum/HighLevelRoadmap with links to find milestone blueprints
16:09:08 <gokrokve_> Who is driving LP development?
16:09:18 <adrian_otto> #action adrian_otto to remove R2.2 from M1 in the roadmap wiki
16:09:21 <devkulkarni> LP working group
16:09:26 <gokrokve_> Probably we can split this ctivity and do something in parallel.
16:09:38 <adrian_otto> gokrokve_: the working group for LP. I will get you the link for the meeting series, one sec
16:09:49 <gokrokve_> I have it.
16:09:53 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/BreakoutMeetings
16:10:23 <adrian_otto> ok, any more thoughts on the roadmap update before I proceed to other announcements?
16:10:42 <adrian_otto> next announcement:
16:10:45 <adrian_otto> 2) Notice that we have a CLI action item on our agenda after the BP updates.
16:11:06 <dtroyer> and I made it in time… ;)
16:11:14 <adrian_otto> so when we get our BP update for the CLI work item, we will be tempted to discuss that, but please hold back a bit until we get to that part of the agenda
16:11:16 <devkulkarni> dtroyer: thanks :)
16:11:24 <adrian_otto> dtroyer: YES! THanks for coming
16:11:38 <adrian_otto> Are there other announcements other team members would like to make?
16:12:14 <adrian_otto> ok, proceeding
16:12:15 <adrian_otto> #topic Review Blueprints
16:12:24 <adrian_otto> #link https://launchpad.net/solum/+milestone/milestone-1 Milestone-1 Blueprints
16:12:34 <adrian_otto> NOTE: I don't expect a ton of progress to be reported on these because many of us took a holiday break. If there is no progress, that's okay, just indicate such with a "no change" update.
16:12:44 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-minimal-cli Command Line Interface for Solum (devdatta-kulkarni)
16:13:03 <devkulkarni> Updates are as follows:
16:13:24 <devkulkarni> 1) Noorul has been working on the API side that can be consumed by cli
16:13:32 <devkulkarni> 2) paulmo has been working on the cli proper.
16:13:48 <devkulkarni> noorul, paulmo, you want to give updates etc. from your side?
16:13:59 <noorul> It is ready for review https://review.openstack.org/#/c/58067/
16:14:17 <adrian_otto> links to the respective reviews will be provided in a few minutes as well. They are in the new wiki page
16:14:18 <devkulkarni> noorul: great!!
16:14:20 <paulmo> I just made a pull request with a hopefully pep8 compliant argparse-based CLI: https://review.openstack.org/#/c/66617/1
16:14:33 <devkulkarni> paulmo: cool
16:14:35 <adrian_otto> thanks to all of you for your progress on this.
16:14:46 <noorul> np
16:15:06 <devkulkarni> thats it for minimal-cli
16:15:12 <adrian_otto> ok, so we will come back to this in just a moment after the other bp updates, and set some clarity on our direction for next steps
16:15:30 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/user-authentication User authentication for incoming requests (gokrokvertskhov)
16:15:33 <adrian_otto> #link https://review.openstack.org/58811 Change I16aa0ba6: This patch adds a user authentication of incoming request. (merged)
16:15:43 <adrian_otto> Congratulations gokrokve_!
16:15:49 * paulmo cheers!
16:16:02 <devkulkarni> gokrokve_: congrats!!
16:16:11 <gokrokve_> Thank you!
16:16:12 <adrian_otto> any remarks on this? I think we are ready to drop it form the status list and mark the BP as completed
16:16:24 <noorul> +1
16:16:51 <adrian_otto> #action adrian_otto to drop https://blueprints.launchpad.net/solum/+spec/user-authentication from the weekly agenda and mark the BP as finished
16:17:08 <adrian_otto> thanks to gokrokve_ and our reviewers for a lot of attention to that work
16:17:18 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/specify-lang-pack pecify the language pack to be used for app deploy (devdatta-kulkarni)
16:17:31 <adrian_otto> +s
16:17:37 <devkulkarni> Okay. so updates on this are as follows:
16:18:16 <devkulkarni> this bp is about storing langpacks; we discussed in the metadata repository meeting to create bps against glance to store langpack metadata
16:18:20 <adrian_otto> we have Change Ib5a05908: WIP: Defined a resource to query available language packs. (abandoned)
16:18:42 <adrian_otto> is that work no longer relevant to this BP?
16:18:45 <devkulkarni> oh yes. that WIP was based on the code that murali had not merged yet.
16:18:59 <adrian_otto> should that be re-opened, or are we starting over?
16:18:59 <devkulkarni> it can be abandoned; or reviewed to make it follow murali's current work
16:19:15 <devkulkarni> I will touch base with Murali about it.
16:19:26 <muralia> sure
16:19:34 <gokrokve_> devkulkarni: I don't think we have to wait for Glance here.
16:19:51 <adrian_otto> can we issue some action items for the tasks to open the glance blueprints? Who should draft those?
16:19:52 <gokrokve_> There is no final decision in Glance when this repository will be implemented.
16:19:55 <devkulkarni> gokrokve_: yes, for the GET calls we don't have to wait
16:20:21 <devkulkarni> gokrovkve_: what is the current status of the metadata repository working group?
16:20:23 <gokrokve_> devkulkarni: I propose to have somethink done in SOlum and then move it to Glance.
16:20:39 <devkulkarni> gokrokve_: sure. makes sense.
16:20:46 <gokrokve_> devkulkarni: We are waiting for the mini-sumit which will occur on Jan 27th
16:21:00 <devkulkarni> I will follow up my WIP with the additional work then
16:21:10 <adrian_otto> clarification: the Glance mini-summit happens Jan 27
16:21:18 <gokrokve_> devkulkarni: We will work with Glance team to understand how this new repo will be implemented.
16:21:47 <gokrokve_> Yep. Glance mini-sumit in Washington DC, Jan 27th-28th
16:21:48 <devkulkarni> okay. so that is little long term. for solum, as you are suggesting, we can do work first here and parallely work with Glance team
16:22:19 <gokrokve_> devkulkarni: Sure. Right now our LP is not big. Just keep all LP data in SQL DB for now.
16:22:36 <devkulkarni> adrian_otto: so to answer your question, here is what I propose.
16:22:40 <adrian_otto> #action adrian_otto to add a note to the agenda to follow up about any Glance blueprints for https://blueprints.launchpad.net/solum/+spec/specify-lang-pack
16:22:48 <gokrokve_> Otherwise we will not finish LP work before M2.
16:23:06 <devkulkarni> gokrokve_: yep! I was about to say exactly that.
16:23:27 <adrian_otto> devkulkarni: was there more to your thought about what you propose?
16:23:31 <gokrokve_> adrian_otto: I will be on this summit. Do you have anyone from Solum team as a representative?
16:23:51 <devkulkarni> adrian_otto: you kind of captured it. I will touch base with murali
16:23:52 <adrian_otto> gokrokve_: where is it being held?
16:23:53 <devkulkarni> that is all.
16:24:37 <adrian_otto> are there other Stackers besides gokrokve_ who we should send to attend in person?
16:24:48 <gokrokve_> Hilton Washington Dulles Airport
16:24:49 <gokrokve_> 13869 Park Center Road
16:24:49 <gokrokve_> Herndon, Virginia 20171
16:24:51 <gokrokve_> adrian_otto: Washington DC,
16:24:57 <devkulkarni> gokrokve_: randall_burt is going to there as well (representing heat). I am syncing up with him on solum requirements
16:24:58 <adrian_otto> gokrokve_: tx
16:25:11 <adrian_otto> ok, that will work nicely I think
16:25:42 <adrian_otto> claytonc or kraman do either of you plan to attend?
16:25:45 <gokrokve_> devkulkarni: Cool!
16:25:59 <kraman> I wont be able to attend this one
16:26:03 <claytonc> adrian_otto: not currentyl planned, going to sync with other red hatters who might be there
16:26:17 <gokrokve_> adrian_otto: What do you think about Solum mini-summit? Do we need to meet face 2 face?
16:26:22 <devkulkarni> adrian_otto: as an aside, the specify-lang-pack bp is just a part of the overall lang-pack work. I think we should discuss the overall lang-pack work as well.
16:27:21 <gokrokve_> devkulkarni: Do you need help with specify LP BP?
16:27:25 <adrian_otto> ok, let's come back to the Solum summit question during open discussion
16:28:03 <devkulkarni> gokrokve_: let me check back with you (need to sync up with murali about the current state of the code)
16:28:17 <devkulkarni> gokrokve_: thanks for the offer
16:28:29 <paulmo> ls
16:28:31 <claytonc> re: lang pack the working item right now is https://blueprints.launchpad.net/solum/+spec/lang-pack-examples which paulczar and funzo have been working on.  funzo is under the weather, but we have working templates for the existing images and have poc'd the docker cloud-init flow
16:28:35 <gokrokve_> We plan to add one more engineer from Mirantis to Solum.
16:29:04 <devkulkarni> gokrokve_: cool
16:29:26 <muralia> woohoo!
16:29:27 <adrian_otto> gokrokve_: that's terrific!
16:29:37 <devkulkarni> claytonc: thanks for the updates
16:29:43 <claytonc> there was discussion about using disk image builder to generate images - the issue raised was security isolation of the images (since prepare is an untrusted set of code) and steve dake shared some examples of dib running untrusted.  however for right now the flow that will work will be cloud-init with nova
16:29:48 <adrian_otto> ok, so we have just a couple more BP's to visit
16:29:55 <claytonc> so we're ready to integretae at least some of those flows with krishna's git-flow
16:30:00 <paulczar> POC'd cloud-init flow is described here - https://gist.github.com/paulczar/db83487376fcbc9b75de
16:30:20 <paulczar> I need to move that to the wiki, and see if I can puts together some scripts for contrib/
16:30:30 <paulczar> ^ docker
16:31:15 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/logging Logging Architecture (paulmo)
16:31:36 <adrian_otto> I'm pretty sure we don't have news on this one, right?
16:31:48 <paulmo> That is on hold right now with CLI activity.  Also, I don't think we have consensus on direction with this one.
16:32:29 <adrian_otto> paulmo: what is your suggestion for proceeding on this?
16:32:56 <paulmo> Well, gokrokve_ and I have 2 different pull requests for context implementation consideration...
16:33:09 <paulmo> I think we need to have a meeting and wrestle this topic to the ground soon.
16:33:31 <gokrokve_> paulmo: These security context is a small part of logging.
16:33:34 <adrian_otto> ok, would you like any help with arranging that, or will you work that out individually?
16:33:34 <paulmo> For instance, is supportability in scope for Solum (logging control plane issues and letting the customers take a peak at it)
16:33:45 <paulmo> I would love help… this has been churning for a while.
16:34:10 <gokrokve_> paulmo: I can start thinking in logging direction too if you want.
16:34:12 <adrian_otto> #action adrian_otto to schedule a meeting about security context and logging features for M1
16:34:25 <adrian_otto> ok, we'll make a time for that
16:34:37 <devkulkarni> adrian_otto, paulmo, gokrokve_: +1
16:34:38 <adrian_otto> anyone interested in that, so I can be sure to make you aware of the meeting time?
16:34:52 <paulmo> I think russellb is needed, he had a vested interest
16:34:58 <kgriffs> adrian_otto: me
16:35:10 <coolsvap> +1
16:35:14 * kgriffs would like to attend that security/logging thing
16:35:17 <paulmo> claytonc interested since you were involved early?
16:35:31 <claytonc> paulmo: sure cc me
16:35:41 <paulczar> there's probably a second topic in that of how much exposure to logs we'd give the customer via solum vs letting the operator solve it.  either way the context stuff is super important.
16:35:48 <paulmo> I think that covers the folks I know of with a vested interest in this topic.
16:36:07 <adrian_otto> ok, if anyone else wants to be clued in, just let me know
16:36:17 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-zuul-integration Solum integration with Zuul (devdatta-kulkarni)
16:36:19 <paulmo> Yes, I think this isn't so much of a technical discussion but more of a discussion about how far Solum will cover supportability and other such areas.
16:36:35 <devkulkarni> kraman will be the person to discuss about this bp :)
16:36:49 <kraman> I have a hacked up POC https://github.com/kraman/zuul/compare/solum_hacks
16:36:50 <adrian_otto> devkulkarni: tx
16:37:00 <adrian_otto> oh!
16:37:03 <kraman> need to run this by mordred and jeblair when they are back from vacation
16:37:20 <kraman> and plan to submit patches to zuul after the discussion
16:37:45 <adrian_otto> so this is a patched zuul?
16:37:47 <kraman> the POC accepts a message over M and triggers a workflow which can handle LP build for now
16:37:52 <kraman> adrian_otto: yes
16:38:08 <kraman> M = message queue
16:38:43 <adrian_otto> that's great news. I'm happy to hear about progress on this, thanks!
16:38:48 <kraman> we didnt have enough participants for git workflow group last week so will continue discussion in tomorrows meeting
16:39:05 <adrian_otto> ok, good, thanks
16:39:06 <kraman> thats about it
16:39:22 <adrian_otto> please drop a reminder now to remind our team when that meeting is tomorrow
16:39:52 <kraman> Tomorrow's meting is at 9 AM PST in #solum. http://www.worldtimebuddy.com/?qm=1&lid=100,8,524901,2158177&h=100&date=2014-01-15&sln=17-18
16:40:01 <adrian_otto> ok, and the last blueprint on the agenda today:
16:40:02 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/api-worker-architecture API service/worker architecture for async operation (murali-allada)
16:40:09 <muralia> ok, so here are some updates since we met last.
16:40:19 <muralia> 1) the patch for the API workers framework has got two +2's and is waiting to be merged. https://review.openstack.org/#/c/62466/
16:40:29 <muralia> The gate is currently broken, so it's not merged yet. We should talk about that during open discussion.
16:40:46 <adrian_otto> noorul: were you looking at the merge problem?
16:41:06 * paulmo gives a big cheer to Murali!  That was a decent chunk of code. :)
16:41:10 <muralia> I'd be happy to help anyone working on fixing the gate.
16:41:37 <noorul> https://review.openstack.org/#/c/65507/
16:41:48 <noorul> That fixes the gate
16:42:07 <noorul> Needs one more +2 and +a
16:42:09 <muralia> thanks. we need another +2 for this
16:42:14 <adrian_otto> ok kgriffs can you look at that?
16:42:23 <muralia> ok, moving on.
16:42:24 <muralia> 2) I've been doing some research this week to extend this framework with a DB layer. I've looked at Trove and Marconi for ideas. I've looked at old logs from the Solum Irc channel and mailing list to see if we discussed which DB to use and why, I don't think we have. So I'm working on a blueprint to open this up for discussion. I'm going with MySql so far. If everyone is ok with that, I won't bother starting a blueprint or email t
16:43:14 <paulmo> Just a comment: Don't use cascading triggers with MySQL.
16:43:21 <adrian_otto> we discussed that a bit at the Solum F2F in November
16:43:42 <claytonc> mysql i believe was consensus
16:44:04 <paulmo> Yep, MySQL + InnoDB
16:44:07 <russellb> sqlalchemy?
16:44:08 <devkulkarni> that is what I am remembering too
16:44:09 <claytonc> the abstraction is there to allow a future implementor to choose  to add a non-relational store, but as long as the abstraction isn't broken we're ok
16:44:10 <claytonc> yes
16:44:10 <adrian_otto> yes, using SQLalchemy, right?
16:44:13 <paulmo> Yes russellb
16:44:16 <claytonc> sqlalchemy
16:44:17 <russellb> shouldn't assume mysql only
16:44:21 <briancline> As long as the way it's implemented still provides compatibility between MySQL/MariaDB/Percona, that seems fine
16:44:25 <russellb> ideally postgres will work too
16:44:32 <briancline> +1 for Postgres
16:44:33 <russellb> should be fine without much extra effort
16:44:39 <claytonc> objects/sqlalchemy is the sqlalchemy abstraction to the object persistence model
16:44:49 <russellb> don't waste your time with sqlite though IMO (other than perhaps for unit tests)
16:44:50 <paulmo> I personally like postgres better but yeah, don't use any MySQL specific features
16:45:12 <russellb> easy enough to support both
16:45:14 <claytonc> folks making model changes there have to take into account transacitonal operations (tohse have to be wrapped in a single method call and take objects that can be transformed into a transactional save), and it also should be reviewed with an eye for live updatse
16:45:16 <russellb> with sqlalchemy that is
16:45:18 <muralia> for now I'm going to work with sqlalchemy and mysql. we can come back to defining a proper abstraction layer, the way marconi has to plug in any DB
16:45:25 <claytonc> muralia: we have that abstraction layer
16:45:30 <claytonc> it's objects/sqlalchemy
16:45:36 <paulmo> SQLAlchemy is that abstraction :)
16:45:39 <muralia> yes, the nova object model.
16:45:49 <russellb> you don't want to use the sqlalchemy models throughout your code base
16:45:50 <muralia> and sqlalchemy
16:45:52 <flaper87> marconi++
16:45:53 <russellb> it's painful
16:46:00 * flaper87 STFU
16:46:04 <claytonc> russellb: yeah the objects abstract that
16:46:09 <russellb> claytonc: +1 :)
16:46:19 <paulmo> flaper87 ?
16:46:21 <claytonc> also fyi on objects/sqlalchemy you are allowed to use any method defined on the public objects
16:46:28 <claytonc> but not depend on any sqlalchemy underlying methods
16:46:34 <muralia> ok, should do we need an email to take this discussion further?
16:46:35 <claytonc> will -1 heavily for that as we review changes
16:46:43 <claytonc> muralia: ground rules and concept would be good
16:46:45 <muralia> or just work with mysql and sqlalchemy for now
16:46:46 <claytonc> to make sure everyone understands
16:46:59 <muralia> claytonc: sounds good
16:47:01 <adrian_otto> muralia: good idea. I want to be sure we revisit the CLI topic because we invited experts to participate
16:47:01 <kgriffs> muralia: if we are limiting solum to SQL backends, then you won't need a higher-level storage driver model like marconi has
16:47:15 <kgriffs> s/won't/may not
16:47:18 <claytonc> kgriffs: we said we'd be open to nosql but we wouldn't be doing the implementaiton ourselves
16:47:23 <adrian_otto> sounds like we have enough input to make a meaningful ML discussion on this.
16:47:28 <kgriffs> claytonc: gtk
16:47:36 <muralia> great.
16:47:37 <paulmo> I can't imagine that the Solum control plane could really feasibly use a nosql db could it?
16:47:41 <kgriffs> claytonc: that informs the architecture
16:47:46 <claytonc> paulmo: it could, just probably not worth doing
16:47:56 <kgriffs> we can't couple tightly to sqlalchemy if you want to afford nosql
16:47:57 <adrian_otto> ok, last comments on this one?
16:48:04 <muralia> ok, lastly.
16:48:07 <muralia> 3) I'm also working on blueprint that discusses how we should go about integrating the DB layer with the API framework. Trove and Marconi do things a little differently, so it'll be great to open this up for discussion with this blueprint.
16:48:11 <claytonc> kgriffs: will go over via email but we covered that mostly
16:48:23 <claytonc> at the f2f
16:48:27 <kgriffs> cool beans
16:48:32 <muralia> thats it from me.
16:48:55 * kgriffs secretly hates email
16:49:04 * kgriffs prefers realtime communications
16:49:14 <adrian_otto> muralia: please be sure to subscribe claytonc and me, and the others who made remarks aove as subscribers to that new BP
16:49:26 <muralia> yes. will do
16:49:28 <adrian_otto> tx
16:49:30 <adrian_otto> That concludes our BP status review.
16:49:37 <adrian_otto> #topic CLI Development Planning
16:49:45 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/BreakoutMeetings#CLI_Working_Group_Series CLI working group
16:50:03 <adrian_otto> this is a new (probably short term) working group for the CLI topic
16:50:07 <adrian_otto> Please participate in the Doodle poll to help us select good times to hold CLI specific discussions. I am open to additional suggestions for the schedule.
16:50:21 <adrian_otto> Once enough input has been supplied by CLI stakeholders, I will close the poll and publish the meeting schedule to by published on our wiki at the link provided above.
16:50:31 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/CLI CLI Wiki Page
16:50:46 <adrian_otto> Please review this with links to relevant materials and a statement of our intended development approach.
16:50:51 <paulmo> All 8-10 PM times?
16:51:14 <adrian_otto> I did that initially to accommodate noorul, but he expects to be out of the office
16:51:32 <paulmo> Ah, thought the AM and PM flipped, sorry :)
16:51:33 <adrian_otto> so we could move that to an earlier timeslot, particularly if we have no attendees from AUS
16:51:56 <adrian_otto> AUS = Australia
16:52:02 <rajdeep> i was planning to attend from india if time is not too odd
16:52:33 <adrian_otto> ok, so you are welcome to make comments on the Doodle poll about the scheduling, and I will incorporate your input
16:52:44 <adrian_otto> thoughts on the wiki page?
16:52:49 <rajdeep> thankss
16:52:51 <devkulkarni> +1 to rajdeep's suggestion.
16:53:17 <adrian_otto> Are we all happy with this, or should it be revisited?
16:53:43 <adrian_otto> basically we are suggesting that we have an approach for each of the CLI blueprints referenced
16:54:01 <paulmo> I like it :)
16:54:02 <adrian_otto> one that's for a minimal prototype that helps us clear the M1 milestone ASAP
16:54:12 <kgriffs> looks good to me
16:54:16 <adrian_otto> and another that gets us a CLI that we will own long term
16:54:25 <paulmo> noorul: Are you good with this direction?
16:54:37 <adrian_otto> that's consistent with the state of the art for OpenStack and fits well
16:54:50 <kgriffs> I think the prototype thing can also act as a source for feedback into improving OSC
16:54:53 <noorul> I have no issues
16:55:13 <kgriffs> when we migrate over to OSC stuff we may discover gaps or whatever that dtroyer can use to improve OSC
16:55:15 <paulmo> And here it is, passing pep8 finally: https://review.openstack.org/#/c/66617/
16:55:22 <kgriffs> anyway, just my $0.02
16:55:24 <paulmo> App/assembly create and delete are in there
16:55:32 <adrian_otto> paulmo: thanks for grinding through that!
16:56:39 <paulmo> Once I get some comments on that, I'll make it non-WIP
16:56:45 <adrian_otto> ok, sounds like we have no controversy to resolve, awesome
16:56:49 <devkulkarni> seems like a good plan
16:56:51 <paulmo> Yay!
16:56:52 <adrian_otto> #topic Open Discussion
16:57:03 <paulmo> Just an announcement:
16:57:29 <dtroyer> FWIW I think that is a workable plan.  I would suggest keeping https://wiki.openstack.org/wiki/OpenStackClient/HumanInterfaceGuidelines#Command_Structure in mind when structuring your commands…
16:57:29 <paulmo> The OpenStack Security Group accepted our Solum security guidelines and are adopting them to promote across all projects: https://wiki.openstack.org/wiki/Security/Guidelines
16:57:47 <noorul> paulmo: Congrats!
16:57:53 <adrian_otto> #agreed to proceed with both a prototype and long term CLI, as described in 2014-01-13 revision of https://wiki.openstack.org/wiki/Solum/CLI
16:58:00 <adrian_otto> paulmo: WHOOT
16:58:00 <kraman> Are we planning another F2F?
16:58:40 <adrian_otto> kraman: currently we are not, but that's a good idea to consider
16:59:07 <paulmo> Isn't there an OpenStack meeting in Atlanta coming up soon?
16:59:21 <adrian_otto> paulmo: that's in April
16:59:36 <adrian_otto> kraman is aking about something between now and then
16:59:42 <adrian_otto> asking
16:59:45 <paulmo> Ah, forgot it was so far out :)
17:00:38 <adrian_otto> in November we got a ton of value from our F2F meeting. Several attendees mentioned they felt it was more productive than our time at OSC in HKG.
17:00:44 <dtroyer> Next Design Summit is May 12-16
17:00:49 <adrian_otto> because we can focus just on Solum topics
17:01:07 <adrian_otto> dtroyer: tx! sorry for the misinformation!
17:01:22 <dtroyer> it has been april until now…threw me too
17:01:26 * paulmo notes that Austin is 70F right now and pretty central. :)
17:01:29 <devkulkarni> adrian_otto: is that right? then f2f will be useful again as well
17:02:02 <adrian_otto> I am sure that Rackspace is willing to host the event again if you wanted a Texas venue
17:02:29 <adrian_otto> it might be nice to think about rotating the host role too
17:02:30 <katyafervent> Hi everyone
17:02:37 <adrian_otto> #endmeeting