16:03:07 <datsun180b> #startmeeting solum
16:03:08 <openstack> Meeting started Tue Jul 29 16:03:07 2014 UTC and is due to finish in 60 minutes.  The chair is datsun180b. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:11 <openstack> The meeting name has been set to 'solum'
16:03:23 <datsun180b> let's see how this thing works
16:03:26 <datsun180b> #topic roll call
16:03:36 <muralia> murali allada
16:03:39 <datsun180b> <- ed
16:03:46 <james_li> James Li
16:03:50 <ravips> Ravi Sankar Penta
16:03:54 <gpilz> gil pilz
16:04:09 <stannie> Pierre Padrixe (available for a few mins :/)
16:04:23 <datsun180b> #link https://wiki.openstack.org/wiki/Meetings/Solum is what i'm referencing. bear with me, not used to running the show
16:04:40 <datsun180b> #topic announcements
16:04:53 <datsun180b> also feel free to speak up at any time, you'll be counted present if you do
16:04:54 <julienvey> Julien Vey
16:05:13 <datsun180b> Any announcements for Solum this week?
16:06:30 <datsun180b> sounds like a no. moving right along
16:06:53 <datsun180b> no action items to speak of, looks like, so on to bp/task review?
16:06:59 <datsun180b> #topic bp/task review
16:07:16 <datsun180b> first up is pipelines
16:07:49 <datsun180b> tough crowd
16:08:09 <julienvey> i approved some reviews from angus yesterday
16:08:14 <stannie> ye same here
16:08:39 <datsun180b> you know i think all angus' reviews for pipelines are merged now
16:09:20 <datsun180b> so how about we move on to "build farm". how's that coming along?
16:09:39 <stannie> we've started to implement the guestagent stuff
16:10:10 <julienvey> yep, we should be able to plug everything soon
16:10:21 <stannie> and added in solum the dockerfiles, dibs images etc for the guestagent
16:10:36 <datsun180b> cool, we can get that reviewed in short order
16:10:50 <stannie> so we will be able soon to install the guestagent in the current infra images: jenkins, drone
16:11:06 <stannie> also we need more review on the spec direclty
16:11:28 <stannie> #link https://review.openstack.org/#/c/102866/
16:11:36 <datsun180b> noted. our spec repo is a little slim, but not for lack of submissions!
16:12:05 <datsun180b> anything else of note for build farms/guest agent?
16:12:20 <julienvey> seems good
16:12:32 <datsun180b> baton pass to ravips with private git repo integration!
16:12:42 <ravips> this task is very close to completion, code changes for api/worker/cli and unit/functional tests done
16:12:58 <ravips> pending items: need to fix 3 errors reported by gate and code review from the team
16:13:04 <datsun180b> i notice your barbican review got shot down for compatibility with another patch, how can we help with that?
16:13:14 <muralia> good stuff.
16:13:23 <ravips> pull requests for review: https://review.openstack.org/#/c/105605/ , https://review.openstack.org/#/c/109468/
16:13:47 <datsun180b> and did you manage to figure out your tox/testr problems from yesterday? if not, we can talk it out in #solum today
16:14:09 <ravips> we are ok without that change to python-barbican..they have added a workaround that
16:14:20 <datsun180b> oh good, so it's not a blocker
16:14:23 <ravips> enables us to use barbican
16:14:33 <ravips> yes, no blocker for us
16:14:59 <datsun180b> cool, anything else?
16:15:06 <ravips> i hope we can get this into master sometime this week
16:15:20 <datsun180b> we'll do our part to review it all
16:15:32 <ravips> thx :)
16:16:18 <datsun180b> moving on to chained trusts--i don't see asakeld here so it's all you, julienvey
16:16:44 <julienvey> I absolutely don't know what happened on this the past 2 weeks :P
16:16:56 <datsun180b> vacances have that effect
16:17:36 <julienvey> angus had a workaround anyway
16:17:44 <julienvey> creating an empty stack
16:18:18 <datsun180b> guess we can ask him a little later then
16:18:36 <datsun180b> oh looks like i missed one more topic before we move to open discussion
16:18:42 <datsun180b> J2 development tasks
16:18:47 <datsun180b> #link https://launchpad.net/solum/+milestone/juno-2
16:19:30 <datsun180b> guess we've already got updates on a couple of those
16:20:31 <datsun180b> any other comments on those tasks? otherwise we move to open discussion
16:21:24 <datsun180b> #topic open discussion
16:22:23 <aratim> can we discuss the changes required in build-app due to nova-docker changes?
16:22:32 <datsun180b> oh sure
16:22:58 <datsun180b> nova-docker changed recently to use glance instead of docker-registry
16:23:20 <datsun180b> problem was, we were also using docker-registry and were letting nova-docker install it for us
16:24:14 <datsun180b> so the change to build-app is just in keeping with that change, storing our DUs in glance the same way
16:24:40 <datsun180b> as a side effect our devstack environment isn't using docker-registry now, so hooray fewer dependencies?
16:25:01 <aratim> :)
16:25:06 <gpilz> DUs ?
16:25:14 <ravips> deployment unit
16:25:17 <aratim> thanks datsun180b. this helps keep everyone upto speed on what's happening at this end.
16:25:20 <gpilz> thanx
16:25:23 <datsun180b> sorry i hadn't communicated that clearly in my reviews, i was geared on making it work again
16:26:15 <ravips> where is the corresponding rst file for this link https://wiki.openstack.org/wiki/Solum/Testing
16:26:16 <datsun180b> i'm a little worried that i couldn't quite get it to use the --is-public=True flag for glance but that doesn't seem to be a problem at present
16:27:12 <datsun180b> I don't know that we have a file in our repos for that link, ravips
16:27:25 <datsun180b> let me check
16:27:47 <aratim> I dont think we have it
16:27:58 <ravips> i want to add some notes on running specific unit or functional tests instead of running the whole test suite
16:28:27 <datsun180b> do you want me to make adding that doc to our repo an action item?
16:28:44 <ravips> that will be very helpful
16:29:06 <datsun180b> #action ravips to add testing docs to repo (https://wiki.openstack.org/wiki/Solum/Testing)
16:29:07 <ravips> some of our docs related to cli is not upto date
16:29:25 <datsun180b> "assembly create"'s syntax changed, i know
16:30:46 <datsun180b> so anything else? i don't want to keep you all if we're all done
16:31:01 <aratim> I also have to add documentation for "languagepack build" but that is currently still in progress
16:31:35 <datsun180b> oh that's a big one--i haven't created my own LP yet and might do to learn soon
16:32:42 <datsun180b> okay, anything else to discuss before i end this?
16:33:51 <datsun180b> thanks everyone. i'm not used to running these but i hope we covered everything
16:34:00 <datsun180b> see you all in #solum
16:34:02 <datsun180b> #endmeeting