17:09:32 <yamahata> #startmeeting servicevm-device-manager
17:09:33 <openstack> Meeting started Wed Mar 11 17:09:32 2015 UTC and is due to finish in 60 minutes.  The chair is yamahata. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:09:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:09:36 <openstack> The meeting name has been set to 'servicevm_device_manager'
17:10:18 <yamahata> #topic Open Discussion
17:10:27 <yamahata> #chair s3wong SridharRamaswamy tcs
17:10:28 <openstack> Current chairs: SridharRamaswamy s3wong tcs yamahata
17:11:12 <SridharRamaswamy> s3wong: one thing i want discuss .. you mentioned tacker could ultimately support more than openstack on the SB
17:11:21 <s3wong> SridharRamaswamy: yes
17:11:46 <s3wong> SridharRamaswamy: the most obvious one would actually be hardware appliances
17:11:50 <SridharRamaswamy> that would mean everything hitting the so-called "VIM" needs to be pluggable ?
17:12:11 <s3wong> SridharRamaswamy: an "instance" of service "VM" would be hosted on the hardware appliance, for example
17:12:22 <s3wong> SridharRamaswamy: yes
17:12:50 <s3wong> SridharRamaswamy: start an instance, the image for the instance, the network port for the instance to plug into...etc
17:13:03 <s3wong> SridharRamaswamy: all these should be abstracted out
17:13:11 <SridharRamaswamy> s3wong: the implication is not just nova call .. even VM templates / catalog cannot directly bind to say for e.g. glance API for image mgmt
17:13:52 <s3wong> SridharRamaswamy: good point, I haven't looked into how Glance is being consumed by Nova
17:14:30 <s3wong> SridharRamaswamy: are Glance APIs consumed directly by Nova? or there are also tenant APIs?
17:15:06 <s3wong> SridharRamaswamy: is there is direct call from Nova to Glance (as it is from Nova to Neutron), then we don't abstract out the calls between plugins
17:15:07 <SridharRamaswamy> s3wong: I'm not sure .. i'd imagine that would be the case
17:15:23 <s3wong> SridharRamaswamy: we would simply mandate that with Nova driver you need to have Glance
17:15:41 <SridharRamaswamy> s3wong: yeah,
17:15:54 <yamahata> Nova directly calls glance rest API
17:16:00 <s3wong> SridharRamaswamy: we would simply get the northbound APIs to enable them
17:16:09 <yamahata> at least with libvirt driver
17:16:13 <s3wong> yamahata: there must be user / tenant inputs though, right?
17:17:20 <SridharRamaswamy> yamahata: you bring up a good point .. I've seen openstack used to control VMware env (vCenter)
17:17:54 <yamahata> s3wong: yes.I guess it just reuse the one passed to nova.
17:18:02 <s3wong> SridharRamaswamy: the OpenStack orchestrated vCenter is now an official product from VMware
17:18:04 <yamahata> nova.image.glance
17:18:41 <s3wong> yamahata: so user would need to specify the image via Nova, right?
17:19:06 <s3wong> yamahata, SridharRamaswamy: if so, then our image management APIs would invoke those from Nova instead of Glance, which is fine :-)
17:19:15 <yamahata> yes, user applies id for image to nova boot command
17:19:46 <yamahata> then nova downloads image from glance using the supplied image id
17:19:47 <SridharRamaswamy> s3wong: that doesn't make sense
17:20:05 <s3wong> SridharRamaswamy: how so?
17:20:22 <SridharRamaswamy> s3wong: user would create entries in the catalog which inturn will call glance API to store the VNF image
17:20:25 <yamahata> but to manage image itself, we need to use glance command. not nova command
17:20:47 <SridharRamaswamy> s3wong: Nova would just reference the image-id and grab it from glance during the nova boot
17:21:07 <SridharRamaswamy> the typical openstack flow is sufficient for VNF catalog functions
17:21:17 <s3wong> SridharRamaswamy, yamahata: fair enough --- then those commands would be abstracted by Tacker which would in turn invoke Glance APIs
17:21:30 <SridharRamaswamy> s3wong: yep
17:22:04 <s3wong> SridharRamaswamy: I am not proposing we reinvent the wheel (that would not make sense), but I am advocating that we need to not bind it to OpenStack calls directly
17:22:17 <SridharRamaswamy> define_vnf(http-url-to-img, vnf-properties) --> glance-image-create()
17:22:36 <s3wong> SridharRamaswamy: exactly
17:23:15 <SridharRamaswamy> s3wong: sounds good, define_vnf() would be tacker API
17:23:24 <s3wong> SridharRamaswamy: I mean --- instead of calling glance-image-create, we just go through a set of higher level APIs that would map to the OpenStack native APIs
17:24:01 <s3wong> SridharRamaswamy: absolutely
17:24:47 <SridharRamaswamy> s3wong: yamahata: I know we have some existing API but given we are rebooting tacker .. shall we attempt to redefine tacker API from scratch
17:25:08 <SridharRamaswamy> and see how matches with what is already in the repo and go from there
17:25:15 <SridharRamaswamy> (instead of other way around)
17:25:35 <s3wong> SridharRamaswamy: I am fine with that
17:25:49 <yamahata> SridharRamaswamy: I have no objection, quite fine.
17:26:01 <s3wong> SridharRamaswamy, yamahata: and it would also allow us to better define the scope of Tacker
17:26:10 <s3wong> now that we are doing VNF Manager...
17:26:11 <SridharRamaswamy> s3wong: EXACTLY !
17:26:38 <SridharRamaswamy> define the API .. you define your produce :)
17:26:47 <SridharRamaswamy> *product
17:27:11 * SridharRamaswamy laughing at my typo
17:27:44 <s3wong> :-)
17:28:37 <SridharRamaswamy> Should we attempt to write up the API in the wiki ?
17:28:50 <s3wong> SridharRamaswamy: how do you propose we should proceed? do it via some Google doc?
17:29:00 <SridharRamaswamy> we should use the new ETSI-ish nomenclature
17:29:14 <yamahata> I'm fine with any way. wiki google-doc, gerrit...
17:29:21 <s3wong> SridharRamaswamy: do you have the ETSI document?
17:30:10 <SridharRamaswamy> Not off my hand, but I can send it to you offline .. that would be their public ETSI-MANO document
17:30:31 <s3wong> SridharRamaswamy: OK, that would be great
17:30:51 <s3wong> SridharRamaswamy: from there, we can write what our projected APIs would be, and discuss
17:32:01 <SridharRamaswamy> Sounds good. I'd vote to keep it super simple - wiki or gerritt lets not do google doc.. it was a pain in the last round
17:32:20 <s3wong> SridharRamaswamy: yes, let do Wiki then
17:32:48 <SridharRamaswamy> s3wong: sounds good
17:33:09 <s3wong> SridharRamaswamy: you want to create a wiki page under serviceVM and send the link to us?
17:33:18 <SridharRamaswamy> s3wong: sure, will do
17:33:31 <yamahata> #action SridharRamaswamy create a wiki page under serviceVM and send the link
17:33:32 <s3wong> SridharRamaswamy: Thanks!
17:33:39 <yamahata> thank you
17:33:51 <SridharRamaswamy> s3wong: did you know more details about telefonica's openmano..
17:34:02 <SridharRamaswamy> their github is empty :(
17:34:10 <s3wong> SridharRamaswamy: nothing at all
17:34:24 <s3wong> SridharRamaswamy: seems like we would have to wait for code becoming available
17:34:59 <s3wong> SridharRamaswamy: in the meantime, as we discussed in the email, there's still value to have VNF Manager in OpenStack repo
17:35:24 <SridharRamaswamy> s3wong: agree
17:35:29 <s3wong> (at least that's what we are hoping :-)  )
17:36:29 <SridharRamaswamy> anything else ?
17:36:43 <s3wong> SridharRamaswamy, yamahata: that's it for me
17:36:54 <yamahata> nothing from me.
17:37:11 <yamahata> okay to close the meeting?
17:37:18 <SridharRamaswamy> yamahata: sure
17:37:22 <s3wong> yamahata: please go ahead
17:37:26 <yamahata> thank you bye
17:37:29 <s3wong> bye
17:37:30 <yamahata> #endmeeting