17:05:28 <yamahata> #startmeeting servicevm-device-manager
17:05:29 <openstack> Meeting started Wed Feb  4 17:05:28 2015 UTC and is due to finish in 60 minutes.  The chair is yamahata. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:05:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:33 <openstack> The meeting name has been set to 'servicevm_device_manager'
17:05:45 <yamahata> #chair s3wong SridharRamaswam1
17:05:46 <openstack> Current chairs: SridharRamaswam1 s3wong yamahata
17:06:22 <s3wong> seems like just the three of us
17:07:04 <yamahata> giving few minutes others...
17:09:14 <s3wong> well, bobmel and hareeshpc aren't on channels
17:09:51 <yamahata> unfortunately.
17:10:04 <yamahata> okay let's start.
17:10:09 <yamahata> #topic Announcement
17:10:24 <yamahata> thank you for attending the f2f last week.
17:10:41 <SridharRamaswam1> sure
17:11:11 <yamahata> the conclusion is,
17:11:31 <yamahata> the important thing is to articulate the need and use cases for the value
17:11:58 <yamahata> The very shot version.
17:12:10 <yamahata> SridharRamaswam1: s3wong do you want to add more?
17:13:14 <s3wong> yamahata: I sent out a meeting minute --- so it was captured there
17:13:16 <SridharRamaswam1> yes, s3wong has nicely summarized the outcome in the email
17:13:35 <yamahata> Ah yes.
17:13:50 <yamahata> s3wong: do you mind that is's public on wiki?
17:14:51 <yamahata> Sorry. Let's move on.
17:14:59 <s3wong> yamahata: np. sure
17:16:07 <yamahata> #topic discussion on L3 service insertion and its scope
17:16:23 <yamahata> is there vks?
17:17:07 <yamahata> After the irc meeting last week, vks wanted to discuss it and added this topic to the wiki.
17:18:28 <yamahata> we don't have vks.
17:18:52 <s3wong> yamahata: what is l3 service insertion?
17:19:36 <yamahata> I guess how/where service is instantiated. But I'm not sure what he wanted to discuss.
17:19:51 <yamahata> Personally I think FWaaS is pioneering on this front.
17:20:13 <yamahata> For Kilo cycle, FWaaS just tries simple one.
17:20:23 <yamahata> #link https://blueprints.launchpad.net/neutron/+spec/fwaas-router-insertion
17:20:33 <yamahata> #link https://review.openstack.org/#/c/138672/
17:22:22 <yamahata> #topic Open Discussion
17:22:27 <yamahata> move on
17:22:41 <s3wong> yamahata: FWaaS insertion, by SridarK, is to insert FW into per router rather than on all routers, AFAIU
17:22:57 <yamahata> #undo
17:22:58 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x3635ed0>
17:23:32 <s3wong> L3 service insertion can mean a variety of things
17:24:11 <s3wong> for FW, most likely it means traffic ingress from a particular subnet (router interface(s)) should be subjected to the FW service
17:24:27 <s3wong> or traffic egress to a particular subnet should be subjected to FW service
17:24:38 <s3wong> this currently cannot be represented by Neutron
17:25:02 <s3wong> during the meeting, SridarK put up a use case that is even simpler
17:25:36 <s3wong> a Neutron port to another Neutron port on the same Neutron network, can we selectively direct traffic to a service
17:25:40 <s3wong> "bump in the wire"
17:26:43 <s3wong> so overall, one suggestion during last Friday's meeting is to find ways to provide these kinds of abstraction (on API layer) and the appropriate driver / plugin to implement the behavior as part of Tacker framework
17:27:26 <s3wong> and if it means the Tacker "service insertion" driver needs to be of the same type (for example, OVS) as Neutron, that is OK
17:28:22 <s3wong> furthermore, SridharRamaswam1 suggested we should extend this to a flow level forwarding abstraction, which excludes a very big chunk of current Neutron plugins/drivers; and we are fine with that
17:31:48 <yamahata> thanks for good summary.
17:32:16 <yamahata> #topic Open Discussion
17:32:29 <yamahata> anything else to discuss?
17:32:58 <s3wong> "Call for Speaker" proposal deadline for the L-Summit is next Monday
17:33:34 <yamahata> good point
17:33:40 <yamahata> #info "Call for Speaker" proposal deadline for the L-Summit is next Monday
17:33:51 <s3wong> I do realize we are somewhat in a limbo on Tacker (seems like we don't really have a fixed direction yet); but perhaps we can put our vague new direction as a way to introduce Tacker to the wider community?
17:34:48 <yamahata> Sure, I'll try to come up with some abstract for "Call for Speaker"
17:35:07 <s3wong> yamahata: I can work on a rough draft too, and send it to you also
17:35:13 <s3wong> SridharRamaswam1: are you interested?
17:35:24 <yamahata> #action yamahata, s3wong sent a draft of CfS
17:37:27 <s3wong> well, that's all I have anyway
17:37:39 <yamahata> thank you everyone
17:37:51 <yamahata> #endmeeting