05:00:36 <yamahata> #startmeeting servicevm-device-manager
05:00:37 <openstack> Meeting started Tue Sep  2 05:00:36 2014 UTC and is due to finish in 60 minutes.  The chair is yamahata. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
05:00:40 <openstack> The meeting name has been set to 'servicevm_device_manager'
05:01:12 <yamahata> Do we have bob?
05:01:19 <yamahata> let's give him minutes.
05:01:41 <s3wong> hello
05:01:50 <yamahata> s3wong: hello
05:02:17 <s3wong> yamahata: it is a US holiday today - though bmelande isn't in US :-)
05:02:32 <yamahata> labour day?
05:02:39 <vishwanathj> yes
05:03:33 <yamahata> seems he's absent today. let's begin
05:03:37 <yamahata> #topic Announcement
05:03:55 <yamahata> neutron feature freeze Sep 9.
05:04:07 <s3wong> yes
05:04:09 <yamahata> CSR1kv patch is merged. congrats to Bob.
05:04:21 <yamahata> vyatta vrouter patch is still under review
05:04:38 <yamahata> #action everyone review vrouter patch
05:04:54 <yamahata> #link https://review.openstack.org/#/c/102336/ Implementation of Brocade Vyatta vRouter L3 Plugin
05:05:19 <s3wong> unfortunately the service insertion patch got a -2 from markmccclain...
05:05:51 <yamahata> Neutron blueprint for Kilo will be open after RC1
05:05:56 <yamahata> So I'd like to have working reference implementation at that time. and update l3 routervm plugin. I hope.
05:06:07 <yamahata> s3wong: that's bad. service insertion is really wanted.
05:06:29 <yamahata> I uploaded WIP patch at gerrit
05:06:46 <yamahata> #link https://review.openstack.org/#/c/116773/ WIP: router vm l3 plugin/driver/agent
05:06:48 <s3wong> yamahata: according to enikanorov_ during last week's adv service meeting, flavor is unlikely to make it neither
05:07:10 <yamahata> Oh, flavour framework too.
05:07:28 <s3wong> yamahata: spec was never approved
05:07:47 <natarajk_> i had few questions on what was discussed last week
05:07:58 <yamahata> natarajk_: sure.
05:08:08 <s3wong> natarajk_: sorry for hijacking the meeting :-)
05:08:11 <yamahata> Before that I'd like to announce I'll be absent next week sep 9.
05:08:13 <natarajk_> there was some mention on integrating route vm with l3 agent
05:08:18 <natarajk_> can you clarify
05:08:38 <yamahata> If someone is willing to chair this meeting, please go ahead. otherwise it will be cancelled on sep 9.
05:09:05 <yamahata> #topic integrating routervm with l3 agent
05:09:59 <yamahata> What I have in mind is to integrate config agent with l3 agent.
05:10:21 <yamahata> vyatta routervm case, it doesn't use any agent.
05:10:59 <natarajk_> config agent model followed by cisco's team ?
05:11:02 <yamahata> I suppose, for fwaas, agent will be used. correct?
05:11:06 <yamahata> natarajk_: Yes.
05:11:28 <natarajk_> for fwaas, firewall agent is coupled with l3 agent
05:11:37 <natarajk_> so we use the firewall agent
05:11:39 <yamahata> At this point, I'm not sure it will make sense to consolidate l3 agent with config agent.
05:12:22 <yamahata> I'm playing with the code. I haven't concluded it personally. Off course discussion is welcome. I'm open.
05:13:28 <yamahata> The current model of l3 agent is tied to network node.
05:13:39 <natarajk_> can you explain who creates the linux routers when we have config agent
05:14:19 <yamahata> natarajk_: do you mean reference l3 (legacy, non-DVR) agent case?
05:14:25 <natarajk_> yes
05:15:01 <yamahata> In that case, neturon router is on network node.
05:15:18 <yamahata> When neutron router is created, l3 agent is chosen = network node is chosen.
05:15:35 <natarajk_> i understand that, but with config agent integration will anything change there ?
05:15:41 <yamahata> Then RPC is sent to the l3 agent which creates router on that networn node.
05:15:56 <natarajk_> So, config agent integration is only for router vm cases ?
05:16:18 <yamahata> The difference is that cfg agent isn't tied to network node.
05:16:29 <natarajk_> ok
05:16:33 <yamahata> natarajk_: Yes. or Xaas VM case.
05:16:40 <yamahata> like FWaaS
05:17:02 <yamahata> At this point, Bob has only routervm case, but I guess they will propose fwaas one for Kilo cycle.
05:17:36 <yamahata> In order to generalize, driver architecture will be introduced to allow any service
05:18:04 <natarajk_> ok
05:19:37 <yamahata> If you want your own agent, it's not prophibited.
05:20:02 <yamahata> natarajk_: If it's allowed, I'd like to see your fwaas agent implementation
05:20:39 <yamahata> anyway you don't have to use config agent. you can use your own agent.
05:22:07 <natarajk> having some IRC connectivity issues
05:22:38 <natarajk> i'll look into config agent code in cisco's plugin
05:22:48 <natarajk> to get more details
05:22:54 <yamahata> great
05:23:27 <yamahata> It just offload api call for vm from neutron server to agent.
05:23:50 <natarajk> ok
05:23:56 <yamahata> any other topic?
05:24:17 <yamahata> #topic Open Discussion
05:24:54 <yamahata> #action yamahata announce cancellation of Sep 9 meeting
05:25:36 <natarajk> i had question on jenkins errors
05:25:54 <natarajk> for the transient issues, do we just run "recheck no bug"
05:26:09 <natarajk> it triggers all the CIs
05:26:28 <natarajk> is there a way to just recheck jenkins ?
05:26:43 <yamahata> natarajk: Unfortunately I don't know.
05:26:49 <natarajk> ok
05:27:00 <yamahata> basically each thirdparty CI provides their own way to recheck, like recheck-vmware
05:27:15 <natarajk> yes, but recheck no bug triggers everything
05:28:33 <yamahata> any other topic?
05:29:45 <yamahata> okay, thank you everyone. and sorry for my absence next week. see you two weeks later.
05:29:53 <s3wong> see you
05:30:05 <yamahata> #endmeeting