17:00:33 <LouisF> #startmeeting service_chaining
17:00:34 <openstack> Meeting started Thu Oct  1 17:00:33 2015 UTC and is due to finish in 60 minutes.  The chair is LouisF. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:38 <openstack> The meeting name has been set to 'service_chaining'
17:00:57 <johnsom> o/
17:01:13 <LouisF> hi all
17:01:13 <xgerman> o/
17:01:40 <s3wong> hello
17:01:56 <vikram> hi
17:02:06 <LouisF> vikram: hi
17:02:18 <vikram> LouisF: hello ;)
17:02:26 <amotoki> hi, long time no see :)
17:02:41 <vikram> amotoki: welcome to the party ;)
17:02:53 <davidlenwell> hi
17:03:02 <LouisF> lets discuss issues relating to the patches
17:03:41 <LouisF> vikram: do you have questions about the patches?
17:04:02 <vikram> LouisF: Yes I do!
17:04:09 <LouisF> vikram: go ahead
17:04:36 <vikram> LouisF: amotoki has raised a concern on having migration,db and extension changes together
17:04:49 <vikram> LouisF: I believe he has a valid point
17:05:19 <vikram> what is the opinion on this?
17:05:37 <LouisF> we split them up so the review process would be manageable
17:06:15 <amotoki> LouisF: generally speaking, db models and db migration scripts need to be reviewed at the same time.
17:06:56 <amotoki> LouisF: and they need to be consistent.
17:07:07 <amotoki> This is my poiint.
17:07:18 <vikram> amotoki: +1
17:07:38 <LouisF> we can combine commits 2/6, 3/6 4/6 if all agree
17:07:58 <vikram> LouisF: Actually, we can have separate patches ..
17:08:12 <vikram> LouisF: 2/6: Just address db-migration framework
17:08:44 <amotoki> I am fine to combine them. Another option is that 2/6 introduces db-migraetion framework only.
17:08:48 <vikram> LouisF: 3/6: Flowclassifier db + data  model + extension
17:09:01 <vikram> LouisF: 4/6: for port chain
17:09:21 <LouisF> vikram: i would prefer to have them combined
17:09:26 <vikram> amotoki: If we have only one then it will become very dense
17:09:33 <s3wong> vikram: I thought amotoki mentioned we want to have DB model and migration in the same patch?
17:09:56 <amotoki> s3wong: yes. right.
17:09:59 <vikram> s3wong: I mean to have separate patches for flowclassifer and port chain
17:10:18 <LouisF> vikram: prefer to have fc and pc in same patch
17:10:22 <vikram> addressing their API and DB model togethet
17:10:27 <s3wong> vikram: so no need to have a DB migration framework patch, right?
17:10:49 <vikram> LouisF: I have no issues, but the patch will become dense again
17:10:58 <pcarver_> The original patch was just too huge, but in breaking them up we need to have them in usable chunks
17:11:31 <pcarver_> I think it makes sense to group DB model and migration as the first, because that needs to be merged before the other parts can do anything
17:11:47 <LouisF> pcarver_: agree we can have a separate patch for services, drivers
17:12:01 <vikram> pcarver_, Louis: I don't have issues
17:12:03 <s3wong> pcarver_: +1
17:12:06 <pcarver_> but we don't want to have a situation where we have to merge everything simultaneously, otherwise it's no different than one big patch with multiple Gerrit numbers
17:12:10 <vikram> pcarver_, Louis: We only got to review ;)
17:12:17 <amotoki> In usual convention in neutron, we introduce extensions and db models in a same patch and then implements drivers or other stuffs.
17:12:20 <amotoki> pcarver_: +1
17:12:28 <LouisF> +1
17:12:35 <s3wong> pcarver_: in that case, we should set up the patchset dependencies accordingly
17:12:36 <vikram> amotoki: that we are anyways doing..
17:12:50 <amotoki> yeah
17:12:51 <vikram> amotoki: We have separate patch for services and driver
17:13:10 <vikram> Only concern is 2/6, 3/6 and 4/6
17:13:22 <vikram> if we all agree we can combine these
17:13:25 <LouisF> vikram: can you create a patch with api, db and migration and I will create one with services, driver..
17:13:33 <pcarver_> s3wong: I agree. Ideally we would have a linear series of dependent patches where we can focus on reviewing and merging each in sequence
17:14:03 <pcarver_> LouisF: does API have to be combined with DB?
17:14:06 <vikram> LouisF: Ok, I can merge those
17:14:20 <vikram> LouisF: One more question
17:14:23 <s3wong> pcarver_: and if there exists a patch set that doesn't depend on anything, or if multiple patch sets depend on another patch set, we should publish them accordingly
17:14:37 <LouisF> pcarver_: that what amotoki suggested
17:14:49 <s3wong> that way, we can review them in proper sequence
17:14:56 <vikram> LouisF: I think we shouldn't merge ovs db changes with that.. You have to do it with the driver patch
17:15:11 <pcarver_> LouisF: My question (and I don't have a preconceived answer in mind) is does DB depend on API?
17:15:14 <LouisF> vi ok
17:15:21 <pcarver_> I know the API won't work if the DB isn't there
17:15:26 <amotoki> pcarver_: LouisF: extensions can be added separately, but in most cases it has no meaning without DB.
17:15:50 <pcarver_> But I think it would be possible to merge the DB + migration changes without needing the API
17:16:08 <LouisF> amotoki: i think they should be in the same patch
17:16:31 <amotoki> we can test a patch with DB and extensions :-)
17:16:34 <vikram> LouisF: Patch size will come close to 6K
17:16:55 <vikram> LouisF: I believe Kyle will not have any concern
17:17:19 <vikram> mestery: ping
17:17:25 <amotoki> I think the size itself is not a problem as long as it is not complicated.
17:17:49 <LouisF> vikram: he did have a comment on the size of our first patch set
17:17:53 <vikram> amotoki: No issues then .. If we all agree then I can merge
17:18:01 <LouisF> +1
17:18:17 <amotoki> +1
17:18:20 <vikram> +1
17:18:25 <s3wong> +1
17:18:43 <LouisF> #agree vikram to combine api, db and migration
17:18:44 <vikram> okay then merge 2/6, 3/6, 4/6
17:19:05 <vikram> LouisF: You got to take care of OVS data model
17:19:19 <LouisF> vikram: ok will do
17:19:23 <vikram> LouisF: ok
17:19:47 <LouisF> another issue is the py34 failure
17:20:07 <vikram> LouisF: Which patch
17:20:26 <LouisF> 3/6
17:20:52 <vikram> LouisF: My mistake.. Will fix it up
17:21:00 <LouisF> ok
17:21:10 <vikram> LouisF: You won't see any failures in the merged patch ;)
17:21:20 <LouisF> vi great
17:21:36 <vikram> Another issue I want to bring to notice
17:21:51 <LouisF> vikram: go ahead
17:22:10 <vikram> Let's review "https://review.openstack.org/#/c/229841"... this address amotoki concerns on parameter issues
17:22:20 <vikram> We got to agree on this quick
17:22:28 <vikram> *quickly
17:23:33 <amotoki> it comes from the discussion in the CLI patch https://review.openstack.org/#/c/210008/
17:23:33 <LouisF> the parameter naming?
17:23:43 <vikram> yes
17:23:46 <amotoki> yes
17:24:26 <LouisF> specifally?
17:24:34 <s3wong> vikram: are you going to address amotoki's nit comments on the next patchset for https://review.openstack.org/#/c/229841?
17:24:42 <amotoki> we accept both name and ID for neutron port. Then source-port and source-port-id cannot be distinguished.
17:24:43 <LouisF> specifically?
17:25:09 <vikram> s3wong: yes, i will .. if it gets merged
17:25:31 <amotoki> s3wong: vikram: my comment on 229841 is just a nit. we can merge it as-is.
17:25:48 <vikram> amotoki: ok
17:26:00 <LouisF> amotoki: ok
17:26:07 <s3wong> vikram, amotoki: OK
17:26:08 <vikram> I will take care of these in the next patch-set..
17:26:22 <vikram> both server + cli patches
17:27:00 <amotoki> sorry for coming in late, but I believe it is worth addressed before the initial merge.
17:27:02 <vikram> Request cores to kindly review and approve the changes ;)
17:27:51 <s3wong> vikram: reviewed and voted
17:28:00 <vikram> s3wong: thanks
17:28:48 <vikram> Some polishing I have done while reviewing
17:28:49 <vikram> https://review.openstack.org/#/c/229765/
17:29:08 <vikram> https://review.openstack.org/#/c/229777/
17:29:20 <vikram> Request team to kindly provide their opinion
17:29:33 <vikram> LouisF: I am done ;)
17:29:49 <LouisF> vikram: ok will review
17:29:59 <vikram> LouisF: Thanks
17:30:40 <LouisF> vikram: we can add content to those docs?
17:30:56 <vikram> LouisF: I didn't get?
17:31:50 <LouisF> ignore my q
17:31:57 <vikram> LouisF: ok
17:32:28 <LouisF> any other comments on these patches?
17:33:07 <LouisF> #topic cli commands
17:33:26 <LouisF> is mohan on?
17:33:41 <vikram> LouisF: Mohan has verified the cli's.. all are working fine
17:33:56 <LouisF> i see he updated the CLI patch
17:34:01 <vikram> mohan not able to make it today
17:34:33 <vikram> LouisF: We need to push another patch-set addressing latest API changes and then we are done ;)
17:34:34 <LouisF> vikram: good to hear, we are also starting to test with those cli commands
17:34:53 <vikram> LouisF: I will post the patch tomorrow
17:34:59 <LouisF> vikram: great
17:35:17 <LouisF> #topic horizon
17:35:49 <LouisF> vikram: do you know when mohan can post the latest horizon code?
17:36:27 <vikram> LouisF: Horizon needs more testing..
17:36:44 <vikram> LouisF: He will be able to post by next week
17:36:49 <vikram> meeting
17:36:56 <LouisF> vikram: thanks
17:37:04 <amotoki> I can review it from the perspective of horizon team next week.
17:37:15 <vikram> amotoki: thanks
17:37:17 <LouisF> amotoki: thanks
17:37:36 <LouisF> #topic testing
17:38:06 <LouisF> i think the unit tests are in good shape
17:38:18 <vikram> LouisF: how about the agent code
17:38:26 <vikram> LouisF: by when we can post them
17:38:34 <LouisF> vikram: post today
17:38:45 <vikram> LouisF: Great!
17:39:12 <vikram> LouisF: Can you please summarize the patch sequence..
17:39:20 <vikram> LouisF: Just to clarify
17:39:40 <vikram> LouisF: Sorry to interrupt :(
17:40:50 <LouisF> vikram: requirements; combined db, migration and api; services and driver manager; drivers
17:41:17 <vikram> LouisF: Perfect.. I am on the same page.. thanks
17:41:42 <LouisF> vikram: great
17:41:55 <LouisF> back to testing
17:42:08 <LouisF> we need to add api, full stack ..
17:43:11 <LouisF> any volunteers to start to look at that?
17:44:02 <vikram> api test i can take care for db patch
17:44:22 <vikram> db patch i can take care E2E..
17:44:40 <LouisF> vikram: ok thanks
17:45:04 <vikram> LouisF: I feel API test we only got to write for db patch..
17:45:23 <vikram> as it will have new API's
17:45:34 <LouisF> vikram: yes, i would agree
17:45:38 <vikram> Please correct me if I am wrong
17:46:30 <LouisF> ok, i will have a look at full stack
17:47:09 <LouisF> any other questions, concerns?
17:47:35 <amotoki> vikram: what do you mean by "API test by db patch"? It is not a unit test.
17:48:01 <vikram> amotoki: I mean tempest tests
17:48:08 <amotoki> vikram: got it. thanks
17:49:13 <LouisF> vikram: when will you post the combined patch?
17:49:47 <vikram> LouisF: Will post by tomorrow EOD my time
17:49:56 <vikram> LouisF: Without API tests ;)
17:50:08 <LouisF> vikram: np, thanks
17:50:26 <LouisF> ok thanks all
17:50:30 <vikram> LouisF: Will post both CLI and server changes.. so that we are not blocked
17:50:40 <LouisF> vikram: thanks
17:51:09 <LouisF> bye all
17:51:47 <LouisF> #endmeeting