17:01:07 <LouisF> #startmeeting service_chaining
17:01:08 <openstack> Meeting started Thu Sep 24 17:01:07 2015 UTC and is due to finish in 60 minutes.  The chair is LouisF. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:12 <openstack> The meeting name has been set to 'service_chaining'
17:01:17 <s3wong> hello
17:01:18 <johnsom> o/
17:01:20 <Swami> hi
17:01:31 <LouisF> hi all
17:01:32 <pcarver> hi
17:01:36 <vikram_> hi
17:02:02 <LouisF> cathy is on a business trip, I will chair today
17:02:03 <mohankumar_> Hi
17:02:20 <pcarver> I put together an agenda wiki page
17:02:23 <pcarver> #link https://wiki.openstack.org/wiki/Meetings/ServiceFunctionChainingMeeting
17:02:31 <s3wong> LouisF: yes, she also mentioned it last time as well as sending out an email on ML
17:02:32 <LouisF> pcarver: thanks
17:02:53 <pcarver> I think that'll be a good place for people to put reminders of things to discuss that occur to them between meetings
17:03:27 <LouisF> pcarver: agree
17:03:33 <vikram_> +1
17:04:03 <mohankumar_> +1
17:04:40 <LouisF> I have split https://review.openstack.org/#/c/207251 into separate patches
17:05:18 <LouisF> See https://wiki.openstack.org/wiki/Meetings/ServiceFunctionChainingMeeting
17:05:33 <LouisF> there are 6 patches
17:05:38 <davidlenwell> o/
17:06:09 <LouisF> vikram_: thanks for adding the list to the wiki
17:06:20 <pcarver> Thanks Louis, that'll be much more convenient to review in chunks
17:06:57 <vikram_> LouisF: ;)
17:07:06 <LouisF> i have made some updates to the patches based on vikram's comments and will continue to do so
17:07:30 <LouisF> please review and comment on these
17:07:49 <pcarver> LouisF: question, are you running tox before uploading patches? I've noticed a lot of Jenkins -1s
17:08:08 <pcarver> I'm wondering if Jenkins is catching issues that you could catch before uploading
17:08:43 <LouisF> pcarver: i have run tox on some but not all
17:09:34 <pcarver> Zuul/Jenkins seems better this week, but last week was running upwards of 13 hours backlog, so it's best to try to avoid uploading patches that are going to get -1'd by automated tests
17:10:41 <LouisF> vikram_: you mentioned adding dependencies in the patches to avoid unit test failures
17:11:15 <vikram_> LouisF: Yes, We need to do that for fixing failures.
17:11:22 <LouisF> vikram_: do you mean using Depends-on: ?
17:11:25 <Swami> LouisF: only if the dependent patch is related to the child patch.
17:11:47 <s3wong> LouisF: yeah, I also noticed that for a chain of patches, none of them have DependsOn set, which looks a bit strange
17:12:09 <LouisF> s3wong: will add that
17:12:24 <vikram_> LouisF: We need to merge the changes on top of the parent patch
17:12:34 <vikram_> LouisF: If you want I can do it
17:12:43 <LouisF> vikram_: ok thx
17:12:44 <Swami> LouisF: But for the unit test to pass you don't need "Depends on". This would be for merging.
17:13:21 <mohan_> Swami: +1
17:13:25 <vikram_> Swami: +1, We need to merge on top of the parent
17:13:43 <LouisF> vikram_: can you do the merge on top of the parent
17:13:56 <vikram_> LouisF: Yes...
17:14:04 <LouisF> vikram_: thanks
17:14:37 <vikram_> LouisF: I will fix all the patches which needs dependencies
17:14:49 <LouisF> vikram_: great!
17:15:27 <vikram_> LouisF: Did you raised patch for all the changes?
17:15:59 <LouisF> vikram_: what do you mean exactly?
17:16:55 <vikram_> LouisF: All the changes are up for review now?
17:17:21 <vikram_> LouisF: "https://review.openstack.org/#/c/207251" completely broken down?
17:17:32 <vikram_> LouisF: on something is left?
17:17:46 <Swami> vikram_: The above shown link is broken
17:18:03 <vikram_> Swami: Ok..
17:19:00 <LouisF> vikram_: all of the patch has been split into the 6 sub-patches
17:19:32 <vikram_> LouisF: Ok..
17:20:11 <LouisF> mohan_: you have updated the CLI patch https://review.openstack.org/#/c/210008
17:20:36 <mohan_> yes
17:20:46 <mohan_> we spend most of the time this week in client cli testing with server changes and we posted tested client patch  requsting everyone to review and share comments
17:20:47 <s3wong> vikram_, LouisF: so we should abandon https://review.openstack.org/#/c/207251?
17:21:07 <LouisF> s3wong: yes
17:21:24 <vikram_> +1
17:21:31 <Swami> +1
17:21:33 <LouisF> mohan_: thanks, everyone please review that
17:22:04 <vikram_> LouisF, All: It's working well .. We have tested :)
17:22:18 <LouisF> vikram_: glad to hear it
17:23:18 <LouisF> pcarver: you made a comment on updating the spec so it is consistent wit the code
17:23:43 <pcarver> LouisF: yes
17:24:09 <pcarver> We can discuss if there are opinions, but I favor updating the .rst in the same commit as the code where you discover you need to alter the spec
17:24:24 <LouisF> pcarver: agree need to ensure consistency
17:24:43 <pcarver> i.e., if you're writing Python and notice something wrong with the spec, fix the spec and add it to your same commit as the correct code you're writing
17:24:54 <LouisF> +1
17:24:59 <pcarver> rather than creating a separate commit to correct the spec
17:25:43 <pcarver> If reviewers feel the spec is correct and the "correction" is wrong, that feedback can be handled in comments on the single review
17:26:01 <vikram_> pcarver: make sense..
17:26:07 <vikram_> pcarver: +1
17:26:53 <mohan_> pcarver: +1 , yes thts the best way
17:27:36 <vikram_> mohan_: please ensure this for CLI changes
17:28:10 <LouisF> #agreed if there is a needed spec change, update spec and code in same patch update
17:28:31 <mohan_> vikram: yes i have few updates , will do that
17:29:07 <LouisF> there was also an update to the Horizon patch https://review.openstack.org/#/c/197056/
17:29:40 <LouisF> but it has some pep8 errors
17:30:03 <mohan_> LouisF: Horizon i am not updated any code ..
17:30:13 <mohan_> we are in middle of integration testing with client code , we wanted to post patch after  some basic testing with client and server cli code .
17:30:34 <vikram_> mohan_: https://review.openstack.org/#/c/197056/ has a recent post
17:31:01 <LouisF> mohan_: ps7
17:31:02 <vikram_> mohan_: https://review.openstack.org/#/c/197056/ can you please confirm why pep8 issues are there for thi
17:31:09 <mohan_> some commit messages get updated !
17:31:27 <vikram_> mohan_: How is the horizon progress
17:31:59 <vikram_> mohan_: When you are planning to post the changes?
17:32:41 <mohan_> some integration testing going on , planning next week  tentatively
17:32:58 <LouisF> mohan_: thanks
17:33:06 <vikram_> mohan_: Is the testing smooth or need any help?
17:34:14 <mohan_> vikram_ :  as of now , no issues , will update if any help needs :)
17:34:30 <LouisF> mohan_: good to hear
17:35:00 <vikram_> mohan_: great!
17:35:05 <LouisF> any other items for discussion?
17:35:28 <pcarver> I need a couple of quick reviews of a doc change https://review.openstack.org/#/c/225254/
17:35:53 <pcarver> Just adding some introductory paragraphs now that the documentation is linked to from docs.openstack.org
17:36:33 <pcarver> The other topic I have is on the Zuul/Jenkins config
17:36:47 <pcarver> specifically, do we want Python 3 jobs to run?
17:36:52 <LouisF> pcarver: go ahead
17:37:49 <LouisF> pcarver: where exactly is that configured?
17:37:53 <pcarver> And the other job that's not currently configured is translations. I assume it isn't the top priority, but we'll need to look into internationalization at some point
17:38:27 <pcarver> Refer to https://review.openstack.org/#/c/221589/
17:38:39 <pcarver> That's the review where I added docs and PyPI publishing
17:39:25 <pcarver> but if you take a look at http://docs.openstack.org/infra/manual/creators.html#configure-zuul-to-run-jobs you'll see an example zuul/layout.yaml snipped
17:39:48 <pcarver> snippet that contains python3-jobs and translation-jobs
17:40:00 <pcarver> I left those out
17:40:21 <pcarver> We need to decide whether we want Jenkins/Zuul to enforce Python 3
17:40:51 <pcarver> Jenkins will post -1s for changes that aren't Python 3 compliant if I add that job.
17:41:00 <LouisF> pcarver: i'm not sure about that - anyone have guidance?
17:41:23 <pcarver> My thought is that if we want to aim for Python 3 compliance, better to do it from the start
17:41:29 <vikram_> pcarver: I feel we must have python 3 support
17:41:40 <vikram_> pcarver: +1..
17:41:44 <pcarver> otherwise we'd possibly have to do a bunch of fixes later
17:41:49 <vikram_> pcarver: It's mandate in neutron now
17:42:06 <LouisF> vikram_: then we should do it
17:42:10 <vikram_> pcarver: All the sub projects are fixing issues
17:42:12 <pcarver> If we're agreed I'll put in a change to add it
17:42:19 <vikram_> +1
17:42:23 <s3wong> +1
17:42:24 <LouisF> pcarver: +1
17:42:51 <Swami> +1
17:42:52 <LouisF> #agreed add python3-jobs
17:43:15 <pcarver> As far as translation-job is concerned, I assume we probably need to talk to someone about how we engage people with the language skills to create translations
17:43:53 <pcarver> At least, I'm assuming translation-jobs has to do with translating English language messages into the corresponding strings in all other supported languages
17:44:27 <LouisF> how is that handled elsewhere in neutron?
17:45:19 <pcarver> I'm not entirely sure, but I guess there must be a bunch of multilingual people who work on translating messages. I don't think this is software at all.
17:45:39 <LouisF> pcarver: I think we can leave that for later
17:45:41 <pcarver> I think there must be files of message strings that the underscore function uses
17:46:15 <pcarver> LouisF: agreed, not at all urgent
17:46:28 <pcarver> just something to keep in mind that we're going to need eventually
17:46:42 <LouisF> pcarver: agree
17:47:01 <LouisF> any other topics for discussion?
17:47:13 <vikram_> LouisF: I have one
17:47:22 <LouisF> vikram_: go ahead
17:47:26 <vikram_> LouisF: I think we
17:47:49 <vikram_> got to address Kyles comment on test sufficiency
17:47:57 <LouisF> vikram_: +1
17:48:27 <LouisF> we need to add api, full-stack tests
17:48:39 <vikram_> LouisF: + functional
17:49:05 <vikram_> LouisF: Existing patches doesn't have these..
17:49:25 <vikram_> LouisF: Getting all the changes done by 10th Oct might be a risk
17:49:34 <LouisF> vikram_: right, I can look at api tests
17:49:35 <vikram_> LouisF: As we discussed in the last meeting
17:50:42 <pcarver> Here's the review to add python3-jobs #link https://review.openstack.org/227445
17:51:50 <LouisF> pcarver: thanks
17:52:18 <vikram_> LouisF: We also got to write the dedvstack changes
17:52:34 <vikram_> LouisF: I think mohan_ is doing that
17:53:03 <LouisF> mohan_: vikram_ thanks
17:53:08 <mohan_> vikram : ys
17:54:06 <LouisF> lets discuss testing in more detail next week
17:55:07 <mohan_> LouisF: ok
17:55:40 <LouisF> I think we made good progress this week - thanks everyone
17:56:43 <LouisF> bye
17:56:48 <s3wong> bye
17:56:52 <pcarver> bye
17:56:58 <mohan_> bye
17:57:01 <LouisF> #endmeeting