17:00:30 <cathy_> #startmeeting service_chaining
17:00:31 <openstack> Meeting started Thu Sep 10 17:00:30 2015 UTC and is due to finish in 60 minutes.  The chair is cathy_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:35 <openstack> The meeting name has been set to 'service_chaining'
17:00:39 <LouisF> hi
17:00:44 <cathy_> hi everyone
17:00:53 <pcarver> hi
17:01:05 <xgerman> hi
17:01:12 <vikram> hi
17:01:22 <mohankumar_> Hi everyone
17:01:34 <s3wong> hello
17:01:59 <cathy_> does anyone have any topic that you would like to discuss?
17:02:56 <johnsom> o/
17:03:18 <cathy_> I have three: status of the project, networking-sfc doc publishing, testing
17:03:25 <cathy_> #topic status of the project
17:04:16 <cathy_> we have got the specs reviewed and merged ! Thanks everyone!
17:05:03 <mohankumar_> cathy_:  great !
17:05:39 <cathy_> The unit test scripts, updated API and DB files, Service Plugin files to be compliant with the approved APIs are planned to be posted this Friday
17:06:28 <cathy_> The first patch of the OVS driver and DB is planned to be posted within the next week or two
17:06:48 <LouisF> bouthors: hi
17:06:56 <cathy_> any question on this topic?
17:07:07 <bouthors> hello
17:07:20 <cathy_> #topic networking-sfc doc publishing
17:07:35 <pcarver> #link https://review.openstack.org/#/c/221589/
17:07:40 <cathy_> Thanks Paul for this work!
17:07:55 <pcarver> Hopefully this will do the trick
17:08:09 <pcarver> hasn't merged yet, but I think it's what's needed
17:08:31 <cathy_> pcarver: openstack-infra needs to approve it to be merged, right?
17:08:41 <pcarver> cathy_: correct
17:08:53 <pcarver> same +2 requirement as any other code I think
17:09:11 <cathy_> maybe you would like to go to the infra channel to let them know this and review it?
17:09:22 <pcarver> I'm guessing that core members of infra project probally watch for +1 reviews and then review them
17:09:29 <pcarver> sure, I can do that
17:09:51 <cathy_> pcarver: thanks!
17:09:57 <pcarver> I also sent a message to the admins of the Launchpad page because there doesn't appear to be a networking-sfc page
17:10:22 <pcarver> i.e. on the list on https://launchpad.net/openstack
17:11:17 <cathy_> pcarver: thanks for straightening all these out!
17:11:19 <pcarver> https://launchpad.net/networking-sfc exists, it just doesn't appear on the OpenStack page with the other networking-X projects
17:11:31 <johnsom> We also need to have the neutron infra liaisons chime in I suspect.
17:11:39 <xgerman> +1
17:11:53 <xgerman> those are the lt. like dougwig, amax, etc.
17:11:57 <xgerman> armax
17:12:22 <pcarver> Also, semi-related, everyone should take a look at
17:12:27 <pcarver> #link https://review.openstack.org/#/c/222256/
17:12:39 <pcarver> which is a devref for sub-projects
17:13:09 <cathy_> pcarver: sure.
17:13:35 <pcarver> It talks about release to PyPi and Launchpad release tagging and tarballs
17:13:55 <vikram> Kyle helped us in releasing for networking-onos
17:14:03 <pcarver> The whole doc is worth reading, not just the part changed in that review
17:14:53 <cathy_> johnsom: could you mean we meed someone from infra to review paul's change of adding networking-sfc doc?
17:15:03 <vikram> I believe only the authorized person can make a release
17:15:38 <johnsom> cathy_ We need a neutron lt. to +1 before infra will look at it.  It's part of the new infra liaison plan
17:15:43 <cathy_> vikram: Yes, let's ask Kyle or Armando to help on this.
17:15:54 <vikram> ok
17:16:19 <pcarver> The maintainer listed on the networking-sfc page on Launchpad is xiaodongwang
17:16:46 <s3wong> who is xiaodongwang?
17:17:15 <cathy_> pcarver: could you post the link of the launchpad?
17:17:45 <pcarver> It may be that https://launchpad.net/networking-sfc is abandoned and needs to be revived
17:17:50 <cathy_> s3wong: xiaodongwang is contributing to this project too
17:18:01 <s3wong> cathy_: I see
17:19:59 <cathy_> pcarver: Do you mean we need to create networking-sfc in https://launchpad.net/openstack, not a separate one in https://launchpad.net/networking-sfc?
17:20:01 <johnsom> cathy_ FYI on infra: https://review.openstack.org/#/c/212622/
17:20:23 <pcarver> cathy_: I don't think so, but I think a connection is missing
17:20:45 <pcarver> Compare with https://launchpad.net/networking-ovn for example
17:21:16 <pcarver> Note that the OVN page (and other networking-X projects) show "Part of OpenStack" on their page
17:21:43 <pcarver> Somehow the SFC page exists but doesn't seem to have the connection to OpenStack that the other networking-X projects have
17:22:31 <pcarver> Assuming we intend to use Launchpad for bug reports we'll want it setup correctly
17:23:27 <pcarver> I already sent an inquiry yesterday using the "Contact this team's admins" link on https://launchpad.net/~openstack-admins but I haven't heard back yet.
17:23:58 <cathy_> pcarver: OK, I see. thanks
17:24:01 <pcarver> If I don't get a response in a couple of days I'll do more asking on the -dev list and/or infra IRC channel
17:25:35 <cathy_> johnsom: thanks for the link!
17:28:50 <cathy_> pcarver: for your patch of adding the networking-sfc doc, you may want to ask the infra channel whether you need to get the Neutron API LT +1 or which Neutron LT you need +1.
17:29:04 <pcarver> It looks like armax is a Neutron Infra Lieutenant
17:29:35 <s3wong> and it seems like armax has already given his +1 :-)
17:29:53 <pcarver> No, I don't think so
17:30:09 <pcarver> oh, wait, I just hit refresh
17:30:29 <cathy_> s3wong: really. Cool! armax always gives us the support at the right time.
17:30:48 <cathy_> pcarver: yes, armax gives it +1
17:31:41 <cathy_> can we go to the next topic?
17:31:46 <pcarver> yes
17:32:00 <cathy_> #topic testing for networking-sfc
17:33:53 <cathy_> Besides UT, any other tests we should do ?
17:34:18 <cathy_> we also need to do tempest
17:34:37 <vikram> cathy: Yes
17:34:49 <vikram> cathy: API & Functional
17:35:17 <cathy_> vikram: do you mean Unit test on API and functional or other types of test
17:35:36 <vikram> I meant tempest tests
17:35:59 <vikram> + there is something called full-stack test
17:36:04 <cathy_> vikram: OK. Yes we will do that
17:36:08 <vikram> We need to check it's applicability
17:36:24 <cathy_> vikram: good point.
17:36:57 <vikram> API --> tempest test... but functional is little different.. .
17:37:52 <cathy_> vikram: Is it a integration test with other component? can you help check that and get back to us?
17:38:07 <vikram> okay .. will check
17:38:15 <cathy_> vikram: thanks!
17:38:35 <LouisF> vikram: looks like full-stack testing would be useful
17:38:46 <vikram> ok
17:39:10 <cathy_> maybe we need to check what other tests neutron core feature does
17:39:42 <cathy_> anyone can help checking out this and get back to us in next meeting?
17:40:34 <cathy_> s3wong: can you help with this?
17:41:18 <s3wong> cathy_: sure
17:41:25 <cathy_> s3wong: thanks!
17:41:34 <pcarver> cathy_: I don't see Abhinav here today, but I did send him an email asking that he plan to spend some time writing functional tests. I haven't heard back from him yet.
17:42:22 <cathy_> pcarver: great! maybe you can ask him to join next meeting and share the info?
17:43:32 <pcarver> cathy_: I'll continue to follow up with him. I don't know exactly what his workload is, but I'm hoping that I can get a percentage of his time committed.
17:43:59 <cathy_> pcarver OK, thanks.
17:44:35 <cathy_> Now I am going to list the action items
17:44:55 <cathy_> #action Louis or Cathy finish and post the UT codes
17:45:46 <cathy_> #action Louis or Cathy finish and post the updated API, DB, DB migration, Driver Manager etc. codes to be compliant with the approved APIs
17:46:46 <cathy_> #action vikram investigate full-stack testing and bring the info back in next IRC meeting
17:47:16 <cathy_> #action s3wong investigate neutron feature testing and bring the info back in next IRC meeting
17:48:04 <cathy_> #action pcarver follow up with Abhinav on functional testing and get back to us in next meeting.
17:49:03 <cathy_> #topic integration of CLI with networking-sfc API on Neutron Server
17:50:11 <cathy_> mohan will start the integration testing with Louis next week, right?
17:50:22 <LouisF> cathy_: ok
17:50:24 <mohankumar_> Yes
17:50:30 <cathy_> cool
17:50:32 <vikram> +1
17:50:40 <cathy_> thanks, folks!
17:51:34 <cathy_> we make some good progress this week. Hope we will do the same next week and two. let's target on getting the codes completed and reviewed by early October
17:51:57 <cathy_> thanks everyone's contribution!
17:51:58 <LouisF> cathy_: sounds like aplan
17:52:09 <mohankumar_> Thumps up !
17:52:42 <cathy_> anything else you would like to discuss?
17:52:44 <vikram> greta
17:52:47 <vikram> great
17:53:08 <s3wong> cathy_: are we doing anything on the design summit?  https://etherpad.openstack.org/p/neutron-mitaka-designsummit
17:53:26 <cathy_> #topic design summit
17:53:55 <pcarver> I added an item to discuss relationship between SFC and BGPVPNs
17:54:14 <s3wong> pcarver: I see
17:54:41 <pcarver> some people at AT&T consider them inextricably entwined
17:54:52 <LouisF> pcarver: is that item 7?
17:54:53 <cathy_> we can also add an item to discuss the relationship between sfc and tacker
17:54:57 <vikram> pcarver: I remember a talk about this in the lat summit
17:55:09 <vikram> cathy_:+1
17:55:26 <s3wong> cathy_: and as Tacker team member I would welcome that
17:55:38 <s3wong> cathy_: though we need to integrate with Heat first...
17:56:00 <LouisF> s3wong: definitely
17:56:02 <pcarver> cathy_: Good idea. s3wong: Is there a separate Etherpad for Tacker?
17:56:02 <vikram> s3wong: mhankumar_ is doing that
17:56:11 <vikram> s3wong: mohankumar_ is doing that
17:56:30 <LouisF> mohankumar_: great!
17:56:39 <s3wong> pcarver: no --- unfortunately, as a project not yet in the tent, we (tacker) didn't get any design session slot
17:56:39 <cathy_> vikram: are you saying that mohankumar_ is doing the integration of heat and networking-sfc? cool!
17:57:05 <vikram> cathy_: yes.. afaik he is:)
17:57:06 <mohankumar_> cathy_: yes
17:57:15 <pcarver> s3wong: Maybe a Friday informal session
17:57:29 <cathy_> mohankumar_: thanks!
17:58:02 <s3wong> pcarver: is there any? My understanding from ttx's email is that all the non-tent session only get to go to lunch tables... :-)
17:58:07 <cathy_> shall we add that item to the Neutron design Summit or which one?
17:58:29 <cathy_> the integration of sfc with tacker one
17:58:34 <pcarver> s3wong: No room reservations, but I believe Friday is supposed to be open and unstructured
17:59:05 <pcarver> at least it was in Vancouver. People were just gathering in small groups without fixed room assignments
17:59:28 <cathy_> pcarver: could you take care of adding that integration of tacker with sfc and let us know which slot? time is up
17:59:38 <s3wong> pcarver: OK
17:59:44 <cathy_> we need to end the meeting now
17:59:45 <vikram> pcarver: I remember seeing a mail saying we have lot of rooms this time:)
18:00:09 <vikram> pcarver: but got to book one for our project
18:00:21 <LouisF> bye
18:00:22 <pcarver> I'll look into it
18:00:25 <vikram> bye
18:00:31 <cathy_> bye
18:00:36 <vikram> pcarver: thanks
18:00:41 <s3wong> orchestration bye!
18:00:41 <cathy_> #endmeeting