15:00:41 <cdent> #startmeeting service-catalog-tng
15:00:43 <openstack> Meeting started Thu Feb 25 15:00:41 2016 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:46 <openstack> The meeting name has been set to 'service_catalog_tng'
15:00:50 <bknudson> hi
15:01:02 <cdent> howdy, no sdague today, he's got daddy daycare
15:01:09 <cdent> anybody here besides bknudson ?
15:01:35 <cdent> #link agenda (from last week): https://wiki.openstack.org/wiki/Meetings/ServiceCatalogTNG
15:01:44 <bknudson> cross-project initiatives aren't going to go far if nobody's involved.
15:01:59 <cdent> #link last weeks notes: http://eavesdrop.openstack.org/meetings/service_catalog_tng/2016/service_catalog_tng.2016-02-18-15.01.html
15:02:24 <cdent> #topic JSON Schema
15:02:43 <cdent> bknudson: you had any time to do any updates with that. both sdague and I have been swamped in nova stuff
15:03:03 <bknudson> I updated https://github.com/brantlk/service-catalog-schema/blob/master/schemas/ng.yaml with the schema we discussed last week
15:03:30 <bknudson> so it's deeply-nested, starting at the region and ending at the interfaces
15:03:49 <bknudson> here's a simple example: https://github.com/brantlk/service-catalog-schema/blob/master/samples/ng/simple.json
15:05:25 <cdent> that seems pretty good. Do you agree that the deep-nesting is the way to go, now that you've played with it a bit?
15:05:45 <bknudson> no reason this shouldn't work
15:07:10 <cdent> I think we should invite people to have a gander?
15:07:11 <bknudson> maybe there's some hidden requirement for the service catalog that I don't know about
15:07:50 <bknudson> y, might as well get comments from the peanut gallery
15:07:58 <cdent> we are the blind leading the blind :)
15:08:04 <bknudson> pick the color on this bikeshed
15:08:20 <cdent> mailing list or openstack-specs?
15:08:22 <breton> who might have this requirement?
15:08:56 <bknudson> breton: deployers might have some odd requirements... there are a lot of different service catalogs out there for some reason
15:09:14 <breton> most of them are not for a specific reason I think
15:09:21 <breton> just because of history
15:09:34 <bknudson> y, we're trying to break from history here
15:10:31 <cdent> let's pick a place to get feedback and move on
15:10:38 <cdent> ml or spec?
15:11:05 <cdent> I tend to think ml is more likely to feedback from the corners, but might be noisy
15:11:28 <bknudson> I agree, spec discussions tend to get more specific feedback
15:11:55 <bknudson> update the existing spec?
15:12:07 <cdent> sure, you want that action?
15:12:11 <bknudson> or is this in keystone's court now?
15:12:27 <bknudson> we're going to need a way to serve this up
15:13:05 <cdent> I think we're probably still some distance from that
15:13:08 <bknudson> let's try to get feedback from sdague and annegentle since they own the spec
15:13:37 <cdent> yeah that makes sense, let's action them instead :)
15:14:00 <cdent> #action sdague and annegentle to review latest schema and decide best how to get feedback, probably via the existing spec
15:14:25 <bknudson> if they want it updated I can go ahead and try to make the changes, just would like to know what's the best way to go about this.
15:14:35 <cdent> makes sense
15:14:35 <bknudson> and maybe the mailing list is better after all
15:14:54 <cdent> we'll see what they say, I'll direct them to the meeting log next time I bump into them...
15:14:56 <cdent> move on?
15:15:07 <bknudson> y, let's just try to catch them later.
15:15:16 <cdent> #topic service registry
15:15:19 <bknudson> #moveon
15:15:36 <cdent> The repo has been created, and the TC bits have been mostly approved, but that's as far as it has gotten
15:15:55 <cdent> It will probably come up in the api-wg meeting which follows this one, to discuss the mechanics of how things will go from here.
15:15:59 <bknudson> I think sdague had the action to propose something to it
15:16:23 <cdent> But as is the usual case...this period of just before freeze is way busy
15:16:49 <cdent> yeah, the repo exists, but empty for now
15:16:59 <cdent> so existing actions remain
15:17:01 <bknudson> we're not going to get this done before mitaka
15:17:06 <cdent> nope
15:17:42 <cdent> #topic open
15:17:45 <cdent> anything else?
15:17:51 <bknudson> nothing else for me.
15:18:31 <cdent> cool, thanks for keeping things rolling on the schema stuff, the friction on this stuff is frustrating, but ...
15:18:34 * cdent shrugs
15:19:07 <bknudson> hopefully we can make this happen
15:19:23 <cdent> bknudson: feel free to come to the api-wg if you're inclined, I'm not sure how much of the service registry stuff we'll get to as there are a few other weird things on the agenda, but we might hit some points worth knowing
15:19:30 <cdent> it has to happen, eventually
15:19:38 <cdent> done?
15:19:57 <bknudson> I'm sure you can handle listing services without me.
15:20:09 <bknudson> he he
15:21:00 <bknudson> I subscribed to the registry repo so I'll get notified
15:21:28 <cdent> the listing is the easy part
15:21:41 <cdent> the politics is the part that is going to get weird
15:21:44 <cdent> ah well
15:21:46 <cdent> #endmeeting