17:00:48 <tmcpeak> #startmeeting security
17:00:49 <openstack> Meeting started Thu Feb  4 17:00:48 2016 UTC and is due to finish in 60 minutes.  The chair is tmcpeak. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:51 <tkelsey> o/
17:00:52 <tmcpeak> o/
17:00:52 <openstack> The meeting name has been set to 'security'
17:01:04 <hyakuhei> wut!
17:01:13 <tmcpeak> #chair hyakuhei
17:01:13 <openstack> Current chairs: hyakuhei tmcpeak
17:01:15 <michaelxin> hi
17:01:16 <bknudson_> hi
17:01:17 <elmiko> heyo/
17:01:21 <browne> hello
17:01:27 <redrobot> o/
17:01:29 <tmcpeak> yo yo
17:02:07 <tmcpeak> #link https://etherpad.openstack.org/p/security-20160204-agenda
17:02:23 <browne> ha, its empty
17:02:38 <bknudson_> not for long
17:02:48 <tmcpeak> that's for YOU to fix
17:02:50 <tmcpeak> ;)
17:03:02 <dg_> o/
17:03:03 <hyakuhei> OpenSource b*tches!
17:03:19 <tmcpeak> 8D
17:03:23 <hyakuhei> hey dg_  thanks for pushing that TA work
17:03:34 <elmiko> hyakuhei: +1
17:03:45 <elmiko> and dg_ i owe you another review ;)
17:04:24 <tmcpeak> allright, let's roll it
17:04:36 <dg_> elmiko that'd be great if you have time, i think the template and guidance are ready for review, process is still not even a draft
17:04:57 <tmcpeak> #topic Bandit
17:04:59 <elmiko> dg_: i'll make the time!
17:05:04 <dg_> ty :)
17:05:05 <tmcpeak> tkelsey: roll it
17:05:32 <ccneill> o/
17:05:40 <tmcpeak> or I can :)
17:05:49 <tmcpeak> I think we're well on our way to 1.0
17:05:53 <bknudson_> do you have a checklist for what's needed for 1.0?
17:05:56 <hyakuhei> fantastic!
17:05:56 <tmcpeak> we'd really like to have that out in time for the summit
17:06:01 <elmiko> nice
17:06:07 <tmcpeak> bknudson_: we don't, but Christopher brought up the very valid point that we sould
17:06:09 <tmcpeak> *should
17:06:15 <browne> ++
17:06:19 <tmcpeak> we probably ought to do them as tagged blueprints
17:06:27 <tkelsey> so we are getting close to 1.0 feature set now
17:06:36 <bknudson_> I started this but didn't update it: https://etherpad.openstack.org/p/security-bandit-1.0
17:06:43 <tmcpeak> so after this meeting I'll spend some time adding and tagging blueprints for work that needs
17:06:45 <tkelsey> im thinking we should aim for a code freeze in March
17:06:56 <tmcpeak> bknudson_: awesome, thank you!
17:07:07 <tmcpeak> I'll probably rip from here to blueprints
17:07:12 <tkelsey> and then release is in april before the summit
17:07:25 <tkelsey> any objections ?
17:07:27 <tmcpeak> tkelsey: +1
17:07:38 <bknudson_> 1.0 or bust
17:07:46 <tmcpeak> :)
17:07:51 <tkelsey> :)
17:07:53 <hyakuhei> tmcpeak: can you hold down the fort for a few minutes? I’ve got to jump on a call
17:07:55 <browne> that works
17:07:56 <hyakuhei> ^ sorry all.
17:07:57 <tmcpeak> it will be good to get Bandit in a nice steady state
17:07:59 <tmcpeak> hyakuhei: yep, will do
17:08:22 <elmiko> tkelsey: +1 for freeze and release
17:08:26 <tmcpeak> ok cool, so after the blueprints are up, anybody can feel free to assign to themselves, etc if they want to implement something
17:08:56 <tmcpeak> allright, anything else for Bandit?
17:08:59 <browne> FYI, i bumped bandit g-r from 0.13.2 to 0.17.3
17:09:02 <tkelsey> awesome, so it will be upto core reviewers to make sure we honour the code freeze in march and only admit bug fixes
17:09:21 <tmcpeak> browne: oh, cool
17:09:23 <tmcpeak> thank you
17:09:40 <tmcpeak> tkelsey: yep yep
17:09:53 <ccneill> sorry if this has been covered in other meetings, but do we have a plan for deploying gate jobs as soon as 1.0 comes out?
17:09:54 <tmcpeak> allright, rolling on
17:09:59 <browne> we should also send that info on the code freeze to ML
17:10:03 <tkelsey> awesome :) 1.0 should be very cool
17:10:05 <tmcpeak> ccneill: what do you mean?
17:10:09 <tmcpeak> browne: good point
17:10:17 <tkelsey> browne: +1 yeah
17:10:19 <tmcpeak> browne: will you be willing to do that?
17:10:27 <tkelsey> or I can
17:10:31 <browne> tmcpeak: ok sure
17:10:36 <tmcpeak> awesome
17:10:36 <ccneill> i.e. do we have contacts with folks who are interested, or people who we're interested in approaching, alerting them that bandit is coming
17:10:37 <tkelsey> browne: cool
17:10:39 <tmcpeak> thank you
17:10:45 <ccneill> and to get ready for the awesome
17:10:47 <ccneill> :)
17:11:00 <bknudson_> keystone has the awesome already
17:11:09 <tmcpeak> ccneill: I think we were going to do something like that, but it's stalled at the moment
17:11:18 <ccneill> tmcpeak: gotcha
17:11:22 <tkelsey> ccneill: im not sure other than Keystone :) but the ML should be a good place to get attention
17:11:35 <tmcpeak> we're generally covering that under the banner of security project evangelism, although to my knowledge nobody has done anything on that front yet
17:11:46 <elmiko> sahara is marching towards voting bandit gate, and i know there is talk about trove adding it as well
17:11:47 <ccneill> tkelsey: yep, just didn't know if we were gonna try to do sort of an "alpha/beta" test
17:12:11 <ccneill> prior to wider adoption
17:12:21 <tmcpeak> elmiko: once we're happy with it we should really go on tour
17:12:28 <tmcpeak> allthethings
17:12:28 <tkelsey> ccneill: probably not worth the admin side of it, a good code freeze/hardening cycle should be sufficient I think
17:12:55 <elmiko> tmcpeak: hehe +1
17:13:15 <tmcpeak> allright, let's do...
17:13:17 <tmcpeak> #topic Anchor
17:13:26 <tmcpeak> dg_: tkelsey
17:13:45 <tkelsey> ccneill: we have integration tests that should server in place of alpha/beta build tests for the 1.0
17:13:56 <hyakuhei> CMC support is coming through in anchor
17:14:01 <tkelsey> s/server/serve/
17:14:09 <dg_> all this talk of 1.0ing bandit has got me thinking - how far are we off anchor 1.0
17:14:24 <ccneill> tkelsey: cool cool
17:14:25 <hyakuhei> dg_: quite far but it’s achievable. I’d like to spend some time on that soon
17:14:32 <ccneill> sorry, trying to do both OSSP and OSQA meetings at once :S
17:14:33 <dg_> ok
17:14:44 <dg_> hyakuhei shall we talk offline on that one tomorrow?
17:14:47 <hyakuhei> yeah
17:14:58 <elmiko> ccneill: very bold ;)
17:15:11 <ccneill> elmiko: yep, it's a challenge lol
17:15:13 <dg_> kk lets shelf that for the mo then. go anchor!
17:15:37 <tmcpeak> what's needef for Anchor 1.0?
17:15:40 <tmcpeak> *needed
17:15:53 <dg_> hyakuhei ^^
17:16:03 <hyakuhei> Quite a bit
17:16:10 <hyakuhei> So we need to stabilise the API properly
17:16:14 <hyakuhei> Documentation is quite lacking
17:16:17 <hyakuhei> severely so
17:16:30 <hyakuhei> Need to double check test coverage but that should be good
17:16:31 <tmcpeak> agreed
17:16:33 <dg_> it builds thou, right?
17:16:42 <hyakuhei> Yeh
17:16:52 <elmiko> and you guys have consulted the api-wg guidelines just to help shore up api, right?
17:16:54 <hyakuhei> Got a fancy Dockerfile for that bro!
17:16:55 <elmiko> ;)
17:17:01 <hyakuhei> elmiko: pffft.
17:17:07 <hyakuhei> It exists to _support_ OpenSTack
17:17:08 * elmiko sadface
17:17:17 <hyakuhei> although that’s probably something that should be on the 1.0 list
17:17:36 <elmiko> i don't mind taking a gander at the anchor api though
17:17:44 <dg_> there are api-wg guidelines?
17:17:47 <elmiko> yea
17:17:48 <elmiko> !
17:17:49 <dg_> #news
17:18:01 <elmiko> #link http://specs.openstack.org/openstack/api-wg/index.html
17:18:07 <dg_> elmiko that would be awesome if you could take a look at the api - we are all rather close to the project
17:18:14 <elmiko> will do
17:18:25 <tmcpeak> given that Bandit and Anchor are already quite good, it would be awesome to get them in a mature steady state so we can concentrate on other cool stuff
17:18:30 <hyakuhei> It’s all very well and good for you to waltz in here now and say this elmiko! where were you when we were designing things :P
17:18:33 <hyakuhei> tmcpeak: exactly
17:18:42 <hyakuhei> Anchor has some really rich features now
17:18:55 <elmiko> hyakuhei: probably goofing off, at a guess
17:18:59 <hyakuhei> :P
17:19:07 <hyakuhei> Ok, that’s all I got for Anchor
17:19:12 <tmcpeak> cool
17:19:16 <tmcpeak> #topic OSSN
17:19:23 <tmcpeak> no nkinder today
17:19:44 <hyakuhei> #link https://bugs.launchpad.net/ossn
17:19:45 <tmcpeak> #link https://bugs.launchpad.net/ossn
17:19:48 <tmcpeak> ^ :P
17:19:51 <tmcpeak> very small queue
17:20:11 <hyakuhei> Where has that new one come from?
17:20:13 <tmcpeak> what's dis? https://bugs.launchpad.net/ossn/+bug/1493422
17:20:14 <openstack> Launchpad bug 1493422 in OpenStack Security Notes "Remove partial fix of bug #1274034" [Undecided,New]
17:20:54 <nsun> hello
17:21:01 <wayward710> hi
17:21:10 <tmcpeak> does this look related to OSSN to anybody?
17:21:27 <nsun> no meeting today?
17:21:44 <hyakuhei> nsun: you might not be in the right place
17:21:47 <hyakuhei> tmcpeak: nope
17:21:59 <tmcpeak> ok hyakuhei good comment, we'll close if nobody responds soon
17:22:05 <hyakuhei> Ah it’s arp spoofing in Nova
17:22:14 <hyakuhei> we’ll see if they reply. definitely more context required.
17:22:18 <elmiko> yea, +1 hyakuhei on the comment
17:22:56 <tmcpeak> also what's the deal with the first one?
17:23:00 <tmcpeak> #link https://bugs.launchpad.net/ossn/+bug/1523646
17:23:01 <openstack> Launchpad bug 1523646 in OpenStack Security Notes "Nova/Cinder Key Manager for Barbican Uses Stale Cache" [Medium,Confirmed] - Assigned to Dave McCowan (dave-mccowan)
17:23:49 <tmcpeak> looks like a bug, not particularly security related unless I'm missing something
17:24:21 <dave-mccowan> assuming we agree on the need for an ossn, i need to update it.  the patch has been merged now in nova and cinder, and has been backported in cinder as a security patch.
17:24:41 <hyakuhei> Yeah we do dave-mccowan - let us know when the OSSN is up for review
17:24:59 <tmcpeak> what are the security implications of it?
17:25:04 <dave-mccowan> the original code caches one user's, and allows another user to then use them.
17:25:11 <hyakuhei> ^ tadaaa!
17:25:12 <tmcpeak> ahh ok
17:25:13 <tmcpeak> yeah
17:25:15 <hyakuhei> lol
17:25:17 <tmcpeak> that sounds legit
17:25:40 <tmcpeak> ok cool
17:25:45 <tmcpeak> so anything else for notes?
17:25:57 <tmcpeak> #topic Sec Guide
17:26:03 <tmcpeak> sicarie, elmiko
17:26:22 <elmiko> afaik, sicarie is still working towards the next pdf version
17:26:29 <sicarie> +1
17:26:39 <tmcpeak> we should roll another print run :P
17:26:41 <elmiko> otherwise we have a few small issues and bug reports that we have been working through
17:26:50 <elmiko> tmcpeak: that's what the new pdf is for
17:26:53 <sicarie> tmcpeak: yep, that's the goal, need the pdf to run the print version
17:26:54 <tmcpeak> ahh cool
17:27:13 <tmcpeak> with a nice big jacket with elmiko and sicarie's face on it
17:27:22 <sicarie> I have the perfect picture of "me"
17:27:27 <elmiko> haha, i'm not sure people could handle that...
17:27:55 <sicarie> elmiko is following up with someone who submitted a GIANT patch set - saw the first of the smaller ones come through
17:27:58 <tmcpeak> nonsense, nothing better to sell books than elmiko
17:28:04 <sicarie> pdesai is also working on some good bugfixes
17:28:07 <elmiko> lol
17:28:13 <sicarie> in short: we're making progress again :D
17:28:33 <tmcpeak> awesome
17:28:38 <tmcpeak> allright, anything else for guide?\
17:28:45 <elmiko> nothing from me
17:28:46 <sicarie> i'm good - elmiko?
17:28:52 <tmcpeak> #topic Threat Analysis
17:28:54 <tmcpeak> dg_:
17:29:29 <dg_> sorry, RL just happened, joys of being in office
17:29:49 <tmcpeak> anybody else want to talk about it?
17:29:56 <dg_> first up, I have pushed another patch set
17:30:03 <dg_> and replied to the reviews on patch set 3
17:30:10 <dg_> (patch set 4 was a noop)
17:30:32 <hyakuhei> How does the stuff in review compare with what was discussed in SA?
17:30:46 <dg_> in patch 5, the template and guidance is ready for review
17:31:10 <dg_> the process is not, i need to talk to hyakuhei about it and try and write down what planned in SA
17:31:35 <dg_> I think the template and guidance support the stuff you talked about in SA and will let us achieve the objectives
17:31:54 <hyakuhei> ok cool. I think I need to come to Bristol so we can iterate on this a few times then bounce it around the Security team
17:32:02 <dg_> yeah, or i can come to wales
17:32:03 <hyakuhei> It’ll be end of Feb.
17:32:12 <hyakuhei> ok, we’ll try to make that work
17:32:15 <dg_> ahh you're afk next week when im in wales anyway?
17:32:24 <hyakuhei> + anyone else who cares, obviously.
17:32:31 <elmiko> i'll be in Inverness in early march if you guys want to do a northern vaca? ;)
17:32:39 <bknudson_> I'm not going to wales.
17:32:45 <dg_> elmiko yeah we could do inverness
17:32:58 <hyakuhei> lol. Well fwiw I’m in seattle at the start of next week
17:32:59 <elmiko> \o/
17:33:04 <hyakuhei> come meet me there dg_
17:33:30 <dg_> cant mate, im in wales
17:33:40 <hyakuhei> lol
17:33:47 <hyakuhei> I think that’s it for TA
17:33:56 <dg_> one other thing
17:34:14 <dg_> i had a play with diagraming tools - attempting to reproduce the sample from the blog
17:34:25 <dg_> results of my experiment are on the etherpad
17:34:50 <dg_> basically blockdiag is a bit broken and has a very steep learning curve, draw.io is awesome and google drawing might be a good option
17:35:22 <elmiko> does draw.io or google output to a nice format we can embed?
17:35:26 <tmcpeak> draw.io FTW o/ \o o/
17:35:32 <bknudson_> as long as we don't have to start over every time we want to make a change.
17:35:38 <elmiko> bknudson_: +1
17:36:00 <dg_> draw.io outputs to proprietry XML which we could check in, but if draw.io went away we'd be left with a bunch of PNG and have to go away
17:36:00 <ccneill> I think draw.io can do pdf or png
17:36:10 <elmiko> k
17:36:15 <hyakuhei> yeh, it’s more about iterating on diagrams ccneill
17:36:22 <hyakuhei> blockdiag had great promise
17:36:37 <hyakuhei> but the initial level of effort required seems very high.
17:36:39 <dg_> +1, I wanted to love blockdiag
17:36:42 <ccneill> hyakuhei: gotcha. yeah, it's not great for saving whole diagram state for future editing (outside their site)
17:37:06 <ccneill> as far as I've seen anyway
17:37:26 <dg_> for comparison, it took  me about 2 hours to reproduce the diagram in blockdiag, 11mins in draw.io and about 20mins in google
17:37:41 <dg_> and it looked a LOT more readble in draw.io than in blockdiag
17:37:59 <bknudson_> draw.io does have import / export, so that should work
17:38:04 <hyakuhei> well, lets make the decision to use draw.io on the understanding that if it goes away, we’ll have to invest effort re-drawing diagrams. Effort that blockdiag would have cost us anyway
17:38:11 <hyakuhei> bknudson_: sure. The question is if it goes away
17:38:30 <dg_> hyakuhei good plan
17:38:34 <tmcpeak> nonsense, web apps are forever :P
17:38:40 <dg_> for the moment i have said 'use a drawing tool, here are some....'
17:38:46 <bknudson_> it's not google so maybe it will stick around
17:39:03 <elmiko> lol
17:39:25 <tmcpeak> allright, onward
17:39:31 <tmcpeak> #topic BYOK
17:39:35 <tmcpeak> what's dis?
17:39:38 <hyakuhei> #link https://openstack-security.github.io/mid-cycle/2016/01/15/mitaka-midcycle.html
17:39:42 <elmiko> bring yer own key
17:39:50 <hyakuhei> Scroll down to “Bring Your Own Key"
17:39:53 <tmcpeak> yes, yes, I mean who's bringing it?
17:39:57 <hyakuhei> User
17:39:58 <tmcpeak> to where will they bring it, etc
17:40:01 <elmiko> you are!
17:40:05 <hyakuhei> #link https://aws.amazon.com/blogs/aws/s3-encryption-with-your-keys/
17:40:08 <elmiko> ;)
17:40:10 <hyakuhei> #link https://technet.microsoft.com/en-gb/library/dn592126.aspx
17:40:16 <hyakuhei> #link http://googlecloudplatform.blogspot.co.uk/2015/07/Bring-Your-Own-Encryption-Keys-to-Google-Cloud-Platform.html
17:40:21 <hyakuhei> All the cool kids are doing it
17:40:26 <hyakuhei> Barbican don’t want to do it
17:40:33 <hyakuhei> I want to make it a thing
17:40:39 <hyakuhei> So do a few barbicaneers
17:40:41 <tmcpeak> what's needed to do so?
17:40:50 <hyakuhei> Two bodies of work
17:41:08 <hyakuhei> 1. To work crossproject to agree a set of header extensions so that services can be offered with BYOK
17:41:19 <hyakuhei> ‘keymat’,’keytype’ etc
17:41:35 <hyakuhei> No idea what they’ll look like but I’m going to try to run a design session on it
17:41:43 <tmcpeak> seems reasonable
17:41:44 <tmcpeak> what else?
17:41:59 <hyakuhei> 2. Improvements to Castellan so that it can take keymat presented to the front end and use it in place of actual key fetching operations
17:42:10 <hyakuhei> Most services are moving towards using Castellan as their key manager
17:42:21 <tmcpeak> how much work is that?
17:42:25 <hyakuhei> So if we can make that ‘byok aware’ we don’t really need to add much logic
17:42:38 <hyakuhei> Depends how much of the original HTTP request gets passed through the middleware
17:42:51 <hyakuhei> It could be a really great feature for us to add though
17:43:01 <elmiko> currently castellan is a very thin wrapper/abstraction layer around barbican (or another) key manager impl
17:43:06 <hyakuhei> Tru
17:43:14 <hyakuhei> It can do KMIP too iirc
17:43:30 <hyakuhei> It doesn’t have to be castellan, we could put our own middleware in
17:43:32 <elmiko> i think you are correct, or those patches are in flight
17:43:40 <hyakuhei> but if services are using it anyway
17:43:41 <redrobot> hyakuhei KMIP support is WIP
17:43:51 <hyakuhei> it’s a nice place to add functionality
17:43:54 <elmiko> castellan may make sense, i just don't know the byok plans well enough to comment at a deeper level
17:44:13 <hyakuhei> This is an interesting opporunity for the Security Project to drive some code changes into other projects
17:44:26 <elmiko> yea, it's a cool idea. no argument from me there =)
17:44:28 <hyakuhei> I’ll try to get a blog post up about BYOK on its own
17:44:54 <hyakuhei> Going into what it might look like, the short is I don’t fully know and I don’t think it’ll get much traction until we get project cores in the same place to talk through the idea
17:45:08 <elmiko> makes sense
17:45:11 <hyakuhei> Is there a sensible place to create a X-project spec for something like this?
17:45:19 <hyakuhei> I mean we could try to discuss this on -dev
17:45:23 <elmiko> the cross-project spec repo =)
17:45:56 <elmiko> and, definitely bring it up on ML to get an agenda item for a cp meeting
17:46:41 <elmiko> or, ping thingee for more ideas. he has been doing an excellent job organizing cp efforts
17:47:04 <hyakuhei> #action hyakuhei to put together a spec and propose some ideas on -dev
17:47:21 <hyakuhei> thanks elmiko I’ll try to rope you into this early for feedback if that’s ok?
17:47:44 <elmiko> hyakuhei: definitely, would love to help
17:48:21 <hyakuhei> Great thanks!
17:48:24 <hyakuhei> So that’s all I had
17:48:46 <tmcpeak> allright next up
17:48:49 <tmcpeak> #topic Blog posting
17:48:57 <tmcpeak> anybody have anything they want to write?
17:49:14 <hyakuhei> BYOK!
17:49:21 <elmiko> lol
17:49:22 <hyakuhei> I’ll do something on the Security track for the summit
17:49:22 <tmcpeak> yes, yes
17:49:36 <hyakuhei> #action hyakuhei to write bloggy things
17:50:06 <tmcpeak> I should write something too
17:50:20 <tmcpeak> that's probably it for blog posts :P
17:50:21 <hyakuhei> So far I think it’s just Travis and I
17:50:25 <tmcpeak> reminder: we have a blog
17:50:33 <hyakuhei> Which is fine but I’d rather this wasn’t the HPE Security Blog
17:50:33 <tmcpeak> blogging is fun
17:50:46 <hyakuhei> So c’mon peoples!
17:50:51 <elmiko> i'd like to write something, but it would most likely be sahara related, is that acceptable?
17:50:56 <hyakuhei> Yup
17:50:58 <elmiko> k
17:51:01 <tmcpeak> for sure
17:51:13 <hyakuhei> So long as it’s related to a) Security b) OpenStack that’s fine.
17:51:22 <hyakuhei> It doesn’t have to be hardcore on either
17:51:34 <elmiko> yup, i was thinking a retro-spective of security enhancements that have been added recently
17:52:18 <hyakuhei> Sounds perfect
17:52:27 <tmcpeak> yeah that would be aweseome
17:52:48 <tmcpeak> bknudson_: a post about using Bandit in keystone would be sweet too if you have time for something like that
17:52:54 <elmiko> ok, just make a post and put it for review in the github repo?
17:53:18 <bknudson_> I could try... I've got a lot on my plate already.
17:53:28 <tmcpeak> fair enough
17:54:30 <tmcpeak> allright
17:54:32 <tmcpeak> #topic AOB
17:54:35 <tmcpeak> anything else?
17:54:38 <tmcpeak> before we wrap
17:54:40 <bknudson_> the draw.io "xml" format is embedded binary (base64).
17:54:41 <elmiko> dg_: quick question about the anchor api
17:54:52 <michaelxin> http://blog.rackspace.com/openstack-mid-cycle-session-leads-to-collaborative-production
17:55:02 <dg_> elmiko sure
17:55:08 <michaelxin> we post this one on our external blog
17:55:27 <michaelxin> sorry, busy with other stuff all the time.
17:55:28 <hyakuhei> That looked really good michaelxin
17:55:30 <tmcpeak> michaelxin: looks awesome! although I'm not thrilled with that doofy look on my face
17:55:37 <elmiko> so, i'm gonna go through the api and check it out. if i find anything that might be worth adding to the api docs, just go ahead and make a patch?
17:55:43 <michaelxin> haha
17:55:52 <tmcpeak> some of my team-mates are already using a cut from that against me
17:55:58 <elmiko> tmcpeak: no...
17:55:59 <dg_> elmiko yup :D
17:56:00 <elmiko> lol
17:56:00 <michaelxin> oh, no
17:56:12 <elmiko> dg_: ack
17:56:21 <tmcpeak> it's ok, we have a history, I knew it would happen ;)
17:56:35 <michaelxin> anyone wants OSSP sticker, send me your address to michael.xin@rackspace.com. We still have some left.
17:57:02 <dg_> elmiko all patches welcome. unless they break the gate
17:57:10 <elmiko> dg_: sweet!
17:57:56 <tmcpeak> anything else?
17:58:14 * tmckay now knows why elmiko is never late for Sahara :)
17:58:22 <elmiko> lol
17:58:26 <elmiko> my secret is out!
17:58:40 <tmckay> maybe I should join the api working group, too
17:58:48 <elmiko> #action elmiko to review anchor api
17:59:10 <elmiko> just wanted to add that, thanks tmcpeak
17:59:14 <tmcpeak> allright
17:59:26 <tmcpeak> #endmeeting