21:02:45 <oneswig> #startmeeting scientific_wg
21:02:46 <openstack> Meeting started Tue Jan 10 21:02:45 2017 UTC and is due to finish in 60 minutes.  The chair is oneswig. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:49 <openstack> The meeting name has been set to 'scientific_wg'
21:02:51 <oneswig> #chair b1airo
21:02:52 <openstack> Current chairs: b1airo oneswig
21:03:01 <Lizhong> hi
21:03:05 <oneswig> Spelled the meeting name correctly again - awesome start to 2017
21:03:09 <oneswig> Hi Lizhong
21:03:11 <priteau> Hello
21:03:17 <oneswig> Hi priteau
21:03:30 <oneswig> Lizhong: Martial coming today?
21:03:33 <b1airo> oneswig, off to a flying start
21:03:51 <oneswig> #link agenda for today is https://wiki.openstack.org/wiki/Scientific_working_group#IRC_Meeting_January_10th_2017
21:03:53 <Lizhong> Yes, he will
21:04:00 <Lizhong> he's in a meeting now
21:04:23 <oneswig> Should we make you chair in his absence? :-)
21:04:36 <b1airo> hi powerd
21:04:44 <oneswig> hi powerd
21:04:57 <powerd> Evening/Morning!
21:05:13 <oneswig> Reminds me, did you guys see this blog post from Bright
21:05:27 <oneswig> #link GPU article from Bright blog http://www.brightcomputing.com/blog/setting-up-gpu-hypervisors-on-bright-openstack
21:05:34 <Lizhong> @oneswig I am quite new with the meeting format. maybe in the future. thanks :-)
21:06:14 <oneswig> No problem, lets get the ball rolling
21:06:29 <powerd> just checking it now - pretty specific to cmsh though.
21:06:38 <oneswig> So there was some housekeeping to get started with first
21:06:51 <oneswig> thanks powerd - be interesting to see you cast your eye over it
21:07:45 <oneswig> The Boston summit needs nominees for judging the talks for the HPC/Research speaker track.  If anyone is interested in volunteering, nominations are due by IIRC Jan 18th
21:08:00 <b1airo> oneswig, haven't seen it, but i'm scratching my head at the need to hack code
21:08:05 <oneswig> #link track chair nominations https://openstackfoundation.formstack.com/forms/openstack_summit_boston2017_track_chair_nominations
21:09:15 <oneswig> tbh I hadn't read it in any depth as I'm busy enough with the stuff in front of me...
21:09:24 <oneswig> (wrt gpus that is)
21:10:02 <b1airo> what are you working on in that department?
21:10:13 <oneswig> me - nothing on gpus right now
21:10:32 <oneswig> mostly on deployment, monitoring and nvm-over-fabric currently
21:10:33 <priteau> oneswig: thanks for the link, I didn't know this process
21:10:59 <b1airo> ah cool, so you took the bait on that one ;-)
21:11:17 <trandles> lol
21:11:27 <b1airo> priteau, actually when i put my nomination in i suggested you :-)
21:11:35 <priteau> heh
21:11:57 <priteau> Maybe I can nominate you to cancel out? ;-)
21:12:23 <oneswig> mutual assured destruction!?
21:12:33 <oneswig> (by committee)
21:12:45 <b1airo> what could go wrong!
21:13:00 <b1airo> so regarding Boston...
21:13:22 <b1airo> it's been a while since I chatted to dfflanders
21:13:47 <oneswig> you were right, the cloud declaration thing is the following week - my mistake
21:13:48 <b1airo> but last time we spoke he was suggesting the scientific-wg would be called upon to suggest several sessions
21:14:40 <oneswig> do you think we can manage a session per activity area, if people come forward for it?  Or something more general?
21:14:50 <b1airo> given how things went in Barcelona i think we could propose 3 working group sessions: a meeting, a BoF, lightning talks
21:15:09 <b1airo> yeah that's probably an option
21:15:47 <oneswig> what is the structure of a Bof if not lightning talks - is any structure needed other than breaking the ice for discussion?
21:16:09 <b1airo> but the foundation staff are keen on us also proposing cross-over sessions with TC teams
21:16:36 <oneswig> b1airo: what would that mean?
21:16:47 <b1airo> oneswig, i see the BoF as mainly open discussion and a forum to shake out new activity areas
21:17:18 <b1airo> e.g. maybe we'd suggest a session on quota management for science clouds
21:17:26 <priteau> b1airo: how do you structure the open discussion though? free for all is hard to manage with a big audience
21:18:18 <b1airo> priteau, yes that's true but you have a moderator and a structure already brainstormed on etherpad
21:18:20 <oneswig> Too bad I can't make this one - I'm a master at making a small audience (out of a big one)
21:18:39 <b1airo> lol
21:18:58 <b1airo> i didn't see anyone leave the keynote when you were speaking
21:19:09 <oneswig> It was dark!
21:19:24 <oneswig> b1airo: What happens in a cross-over session?
21:20:40 <b1airo> oneswig, i think the idea is to attempt to bring devs, ops, etc to a common understanding of a problem as the first goal
21:20:52 <b1airo> that's half the battle
21:21:01 <oneswig> Is our role then to state the problem as clearly as possible?
21:21:45 <b1airo> and in some cases the process to get there might shake out solutions/workarounds that don't require any extra work, but if not then the idea would be to collect enough detail to go forward to specs and/or user stories
21:21:57 <b1airo> yes, i believe so
21:22:10 <trandles> Are there any WG topics/use cases fully-formed enough to bring in another group/TC for discussion?
21:23:05 <oneswig> For example, one issue I'd like to see resolved is how to reconfigure RAID depending on whether a node was for compute or for big data (in which case it would prefer 6 non-RAID disks) - that kind of thing?
21:24:09 <b1airo> trandles, i think there are lots of things that WG members are keen on but we're probably looking for broad issues that may already be fairly well known yet have not had any dev commitment or are waiting on TC to prioritise
21:24:51 <oneswig> b1airo: items from our activity areas from this cycle perhaps?  We ought to have had a few group discussions about those by now
21:25:12 <b1airo> the nested quota (with delegated management) issues that Tim Bell has explained in blog form come to mind
21:26:08 <b1airo> yes, i imagine something on federation would be good - honestly for me that would be a 101 on current technical state from keystone et al
21:26:26 <oneswig> Would be useful to keep that in people's minds, on the nested quotas
21:26:31 <trandles> A strength of the WG would be to present a unified use case with broad applicability to the WG members to a project or set of projects.  Tim Bell's quotas or accounting comes to mind as a good example of that.
21:27:08 <oneswig> trandles: good point, can we cite a gang of related overlapping use case needs
21:27:08 <powerd> id like to propose a talk on the gpu work being done - by the time the summit comes around i should be in a more advanced stage with performance numbers and guidance on setup optimisations
21:27:08 <trandles> Monitoring is another topic
21:27:15 <b1airo> not sure about GPUs though, i think powerd and i just need to finish drafting and then propose it as an addition to the admin guide
21:27:17 <priteau> We should identify who would be the other group for each potential topic (e.g. Keystone devs for federation, Nova and/or Ironic for resource management)
21:27:34 <b1airo> other than that it's about awareness, so talks etc
21:27:47 <oneswig> powerd: a talk's a separate thing, if it goes into the main conference track
21:28:18 <powerd> s/talk/anything appropriate/g
21:28:31 <oneswig> That's better :-)
21:28:40 <b1airo> priteau, yes that's probably the primary concern in the short-term so that the other parties can prioritise the proposals
21:29:34 <b1airo> anyway, i think there is an action for me to catch up with dfflanders and report back - or twist his ear to make sure he attends next week
21:30:02 <oneswig> How can we generate a short list - have the activity leads generate one per area for next session?
21:30:11 <oneswig> Or throw it open on an etherpad?
21:30:16 <oneswig> bit of both?
21:30:18 <b1airo> #action b1airo to chase up dfflanders re. boston forum format / proposals / expectations
21:30:57 <b1airo> i'd go with open, if the leads are engaged then they'll suggest things on that area, no point restricting
21:31:20 <trandles> I prefer etherpad, easier to deal with timezones
21:31:26 <b1airo> +1
21:31:32 <oneswig> trandles: b1airo: sounds good to me
21:31:55 <oneswig> I'll put together 4 etherpads
21:31:56 <b1airo> i'll roll that into my action and can put a preface in about what we're trying to do
21:32:01 <b1airo> ha!
21:32:10 <oneswig> aha - b1airo is going to put together 4 etherpads - even better :-)
21:32:22 <b1airo> let's just have one oneswig - gets hard to track them all
21:32:37 <oneswig> OK b1airo - agreed
21:32:41 <b1airo> i already over 200 browser tabs open...
21:32:48 <b1airo> *have over
21:33:11 <b1airo> (and that's just on *this* laptop)
21:33:32 <oneswig> My desk is the phyiscal manifestation of that
21:33:55 <b1airo> heh, that's a funny image
21:34:30 <oneswig> OK, should we make an early indication of interest on rooms?  Edgar was asking
21:34:51 <b1airo> did you see my reply on that thread?
21:35:30 <oneswig> From last week?
21:35:40 <b1airo> we just need to propose the sessions we want along with the main call, then once it closes the organisers will get back to us about time and space options
21:35:53 <martial> (sorry, the meeting that would not end)
21:36:12 <oneswig> #chair martial
21:36:13 <openstack> Current chairs: b1airo martial oneswig
21:36:17 <oneswig> Hi Martial
21:36:26 <martial> Hello all
21:36:49 <jpr> are there any recommended qualifications for track chair nominations (deep expertise or more a willingness to contribute?)
21:36:50 <b1airo> welcome martial - believe me, i know the feeling, last friday i had a meeting that went 10am->4.30pm o_0
21:36:54 <oneswig> OK so we don't need to worry about earliest indications
21:37:18 <b1airo> jpr, willingness mainly but expertise is of course useful
21:37:22 <oneswig> jpr: don't know.  Keenness to participate is a big plus
21:37:30 <jpr> k thx
21:37:54 <b1airo> so on the session proposals...
21:38:05 <b1airo> that circles back to what i was saying earlier
21:38:21 <oneswig> many people have said the committee meeting needs to be in a bigger room
21:38:29 <b1airo> 1) meeting, 2) lightning talks, 3) BoF and/or activity breakouts ?
21:38:33 <oneswig> And I think the lightning talks were a good success
21:38:52 <b1airo> yes, perhaps just one or two fewer this time though :-D
21:39:58 <oneswig> I think something more's needed to make a separate BoF a success - perhaps have it run immediately after the lightning talks in the hope they stimulate discussion
21:40:01 <b1airo> actually here's an idea: have a BoF session, but structured by activity breakouts with each of those moderated by a respective lead
21:40:27 <oneswig> b1airo: that'd do it
21:41:23 <b1airo> that keeps everybody across and able to participate in the different areas but moves us through them in a structured manner so we don't get stuck anywhere too long
21:41:46 <martial> that might mean a few BoF sessions then ?
21:41:56 <oneswig> serially then not concurrently?
21:42:36 <b1airo> yep i was think serially
21:42:38 <dfflanders> blairo, sorry I was here just got pulled away
21:42:44 * dfflanders reading up
21:43:14 <b1airo> so a double-session BoF with 5 areas (4 current activity areas and time at the end for raising others)
21:43:26 <b1airo> that'd be about 15 mins for each
21:43:36 <martial> 15 minutes seems short
21:44:05 <b1airo> and sweet! ;-)
21:44:14 <trandles> 15 minutes disappears in a blink if anyone goes long
21:44:14 <martial> if my memory of how much we like to speak of our topic of interest is that is :)
21:44:21 <trandles> moderator will have to be draconian ;)
21:45:06 <b1airo> martial, it's not a lightning talk though - it'd be the lead for a particular activity area coordinating discussion on that area from an etherpad they've pre-prepared
21:45:50 <b1airo> we could try asking for individual sessions for each area but then we're looking at a minimum of 6 - and that seems a lot
21:46:06 <oneswig> ... etherpads seeded with the gaps they've identified through discussions this cycle
21:46:24 <b1airo> shall we talk about the Boston Declaration a little?
21:46:33 <martial> sure, which means that we ask people to come prepared and with pre-discussion ready ... feasible
21:47:04 <dfflanders> re expectations for forum, there is this blog post http://superuser.openstack.org/articles/openstack-forum/
21:47:11 <oneswig> time keeping - whoever said it must be strict was right.  I've been in some of those discussions
21:48:05 <dfflanders> however, I would suggest the forum as an open ended event is wide open for interpretation and the scientific-wg should make it work for your purposes and request the time/space needed to achieve those aims/goals
21:48:05 <b1airo> dfflanders, yes i saw that, but it's general rather than talking about the specifics of how it will come together
21:48:37 <b1airo> last time we spoke on this you suggested we should be thinking about cross-over sessions...?
21:48:55 <dfflanders> if it suits your purposes
21:49:59 <b1airo> ok, i'll read that again and we can circle back next week after mulling it over
21:50:15 <dfflanders> most importantly scope the event you want to do which will enable your WG to achieve its aims for that cycle
21:50:47 <dfflanders> the foundation is flexible and want the community to own and craft the forum as their event.
21:52:05 <b1airo> makes sense
21:52:45 <dfflanders> Poster session, lightning talks, goldfish bowls, and/or any other open space event is encouraged... I particularly liked the idea of a poster session you had for Barcelona last time.
21:53:22 <oneswig> I think our aims are generally more vague than can be solved by a discussion with PTLs, other than to detail use cases they may not envisage
21:53:26 <b1airo> martial, it's your moment :-)
21:53:46 <martial> b1airo how so ? :)
21:53:52 <oneswig> posters martial!
21:54:00 <b1airo> your poster didn't really get a proper airing in barcelona
21:54:26 <martial> well I can bring it back :)
21:54:45 <martial> by popular demand and all
21:55:51 <martial> (although I guess I should extend it with the new work we are involved with)
21:56:05 <oneswig> Would this be an alternative format for a BoF or a separate event by itself?
21:56:09 <b1airo> the PTLs are probably interested in hearing about pain points but yes, would be best to have them engaged in something bigger
21:56:29 <b1airo> separate i think...?
21:57:16 <martial> separate sounds like a better plan to me too
21:57:24 <martial> and non overlapping if possible ?
21:57:25 <b1airo> powerd, before we finish - did you do any P100 testing yet?
21:57:26 <oneswig> That sounds like plenty of content for the summit, along with the speaker track
21:58:25 <b1airo> coming up on time
21:58:39 <b1airo> AOB or is everyone still in holiday mode :-)
21:58:48 <oneswig> A bit of resurfacing old news - people were asking about ansible-managed bios settings - finally got to writing it up
21:58:51 <oneswig> #link http://www.stackhpc.com/ansible-drac.html
21:58:55 <powerd> P100 testing: not yet
21:58:57 <oneswig> share and enjoy
21:59:04 <powerd> but its in the lab now
21:59:39 <martial> oneswig: interesting, thanks for sharing
21:59:39 <b1airo> cool
21:59:48 <priteau> oneswig: I saw your tweet today, I will read!
21:59:54 <oneswig> Ha, thanks priteau!
22:00:09 <oneswig> OK, that's it for this week.
22:00:09 <trandles> oneswig: very interested...my production testbed is dell hardware and I've been looking for an ansible-based solution so timely ;)
22:00:20 <oneswig> Thanks all, until next time
22:00:31 <oneswig> #endmeeting