18:02:57 <SergeyLukjanov> #startmeeting savanna
18:02:57 <openstack> Meeting started Thu Mar  6 18:02:57 2014 UTC and is due to finish in 60 minutes.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:03:01 <openstack> The meeting name has been set to 'savanna'
18:03:14 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/Meetings/SavannaAgenda
18:03:21 <SergeyLukjanov> #topic News / updates
18:03:32 <SergeyLukjanov> let's start from it to wait for some more folks
18:04:14 <SergeyLukjanov> #info lawyers response about new name options: "From the trademark search, Sahara and Caravan are the best options."
18:04:27 <mattf> best or only?
18:04:34 <SergeyLukjanov> so, I'd like to discuss it later on the meeting
18:05:25 <SergeyLukjanov> mattf, I've already asked them to clarify that, but I think that we should choose the option that is best from the PoW of lawyers to avoid renaming in future
18:05:37 <SergeyLukjanov> one more, 3rd renaming, it'll kill me :(
18:05:47 <SergeyLukjanov> folks, please
18:05:53 <SergeyLukjanov> share your news/updates
18:06:13 <SergeyLukjanov> Icehouse 3 released, more info in separated topic
18:06:30 <SergeyLukjanov> ylobankov, ping
18:06:31 <mattf> only 2 reviews on api, so no progress there
18:06:55 <ylobankov> sorry, I am here
18:07:13 <crobertsrh> A couple of dashboard bug fixes, a few new bp for the future.
18:07:27 <SergeyLukjanov> mattf, sorry about that - end of cycle is a difficult time for such huge features - anyway, I'm trying to dedicate some time for reviewing it
18:07:27 <ylobankov> I was working on test for transient cluster
18:08:00 <SergeyLukjanov> alazarev, ErikB, tmckay ?
18:08:20 <mattf> SergeyLukjanov, eh, it's been over a month..
18:08:43 <tmckay> I've been tweaking cli tests, currently my environment is messed up with strange errors.   I have some examples to add to savanna-extra
18:09:12 <SergeyLukjanov> ylobankov, the plan is to have two separated lightweight jobs to test transient clusters creation (== trusts usage) on both direct and heat engines, am I right?
18:09:29 <alazarev> Intel finally got environment for openstack development, could probably see contribution to Savanna soon
18:09:30 <ylobankov> SergeyLukjanov: yes
18:09:33 <SergeyLukjanov> tmckay, yup, good start
18:09:58 <SergeyLukjanov> alazarev, that's nice, anyway we already have about 7 commits from them :)
18:10:21 <tmckay> also, we have a new savanna guy, elmiko.  I showed him how to do a gerrit review yesterday :)
18:10:32 <ErikB1> Not many updates from our side this week. We are still plugging away at (Ambari) Blueprints. Hope to get back to Savanna proper soon.
18:11:05 <SergeyLukjanov> ErikB1, we're in FF, so, that's fine ;)
18:11:19 <alazarev> SergeyLukjanov: yeah, but I'm talking about something bigger than changing assertEquals(None, ) to assertNone
18:11:27 <mattf> ErikB1, anything on the neutron wrapper. it aged out this morning.
18:11:28 <SergeyLukjanov> tmckay, gerrit is really scary for newcomers :)
18:12:04 <SergeyLukjanov> sreshetnyak, any updates about vanilla hadoop 2?
18:12:20 <SergeyLukjanov> tmckay, is elmiko working with you?
18:12:26 <sreshetnyak> hi
18:12:30 <ErikB1> mattf: let me follow up on that.
18:12:34 <tmckay> SergeyLukjanov, yes
18:13:20 <SergeyLukjanov> tmckay, cool
18:13:22 <alazarev> also, Mirantis has customer interested in savanna over multi-region environment, planning to add support of multi-regions (already in J)
18:13:25 <sreshetnyak> basic implementation on vanilla hadoop 2 was merged
18:13:37 <SergeyLukjanov> alazarev, yup, this bp is approved
18:13:48 <SergeyLukjanov> sreshetnyak, what's about scaling/testing/edp?
18:14:41 <alazarev> SergeyLukjanov: could you also take care of integration tests for IDH 3.0.2?
18:15:21 <sreshetnyak> in the base implementation has supported scaling, validation, swift and provisioning user configs
18:15:28 <alazarev> sreshetnyak: question for you, not for SergeyLukjanov
18:16:03 <SergeyLukjanov> alazarev, I don't think that sreshetnyak will be able to finish both plugins till the rc
18:16:11 <SergeyLukjanov> alazarev, I thought that you'll do it
18:16:16 <SergeyLukjanov> I mean IDH plugin part
18:17:08 <SergeyLukjanov> any other news/updates?
18:17:32 <SergeyLukjanov> let's move on
18:17:34 <alazarev> SergeyLukjanov: will need to learn from Yaroslav how to write integration tests
18:18:05 <sreshetnyak> alazarev, after the completion working on hadoop vanilla 2 plugin :)
18:18:21 <alazarev> sreshetnyak: do you have estimates?
18:18:28 <SergeyLukjanov> alazarev, please, contact ylobankov and sreshetnyak to clarify how'll help you to write or just write itests for you, it's quite important
18:18:46 <SergeyLukjanov> alazarev, we'll not include plugin to release notes w/o working itests
18:19:15 <sreshetnyak> alazarev, about 2 weeks
18:19:16 <SergeyLukjanov> #info design summit sessions proposition site will be open soon
18:19:33 <SergeyLukjanov> sreshetnyak, it sounds like around the rc
18:20:53 <SergeyLukjanov> ok, alazarev, sreshetnyak, ylobankov, please discuss it and tell us the plan next time
18:21:04 <ylobankov> ok
18:21:08 <alazarev> ok
18:21:13 <SergeyLukjanov> thanks
18:21:14 <SergeyLukjanov> #topic Project naming collision
18:21:23 <SergeyLukjanov> that's the most painfull topic
18:21:37 <sreshetnyak> ok
18:21:47 <SergeyLukjanov> (double l in painful to mark it especially painful)
18:22:05 <SergeyLukjanov> so, we have a response from lawyers
18:22:14 <SergeyLukjanov> "From the trademark search, Sahara and Caravan are the best options."
18:22:34 <SergeyLukjanov> due to the http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_5dd4f18fde38ce8e Sahara is #2 option and Caravan is #5
18:23:15 <mattf> we should have included fusor
18:23:36 <alazarev> "Sahara beats Caravan 10–4"
18:24:37 <SergeyLukjanov> I think that we should avoid any risk to rename again and use options suggested by lawyers
18:25:26 <SergeyLukjanov> any objections?
18:25:28 <ruhe> agree
18:25:42 <ErikB1> agree
18:25:46 <SergeyLukjanov> I see mattf has some, if still yes, please, add details
18:26:29 <mattf> oh, mine is a statement of regret. i wish we'd included it.
18:27:03 <mattf> i'm not suggesting we re-enter the lawyer process or pick something they've not vetted.
18:27:23 <mattf> did they provide any details on why options were ruled out?
18:27:48 <mattf> in my experience there are good reasons and it's easy to provide them so we can all understand the reasoning
18:27:51 <SergeyLukjanov> mattf, not yet, I've requested them, but I'm afraid that it could take a long time again...
18:28:28 <mattf> the reasoning should be readily available "pick sahara or caravan" is just the executive summary
18:29:20 <SergeyLukjanov> mattf, probably, http://www.fusor.net or http://www.fxpansion.com/index.php?page=62&tab=185 or something else
18:29:55 <SergeyLukjanov> anyway, I think that if lawyers say that "Sahara and Caravan are the best options" that it's better to use them
18:30:13 <alazarev> agree
18:30:14 <SergeyLukjanov> and we've choose them as a top 5 candidates
18:30:50 <mattf> feels like we're lingering. no one is going to be happy w/ the change. time to rip the bandaid off...
18:31:41 <SergeyLukjanov> mattf, we need the new name and we had enough time to propose tons of options
18:31:45 <SergeyLukjanov> we've selected top 5
18:31:54 <SergeyLukjanov> and the #2 is available
18:31:55 <mattf> or rather, it's time to rip the adhesive bandage off
18:32:14 <ruhe> SergeyLukjanov: so, do we need a new vote or do you think we can use the one which already won?
18:32:56 <IlyaE> mattf: I have opinion from our lawyers that even keeping Savanna should be fine, as long as product doesn't do the same thing
18:33:10 <IlyaE> the main problem is that foundation believes we have to remove
18:33:18 <IlyaE> and do it before the release
18:33:53 <IlyaE> and it based on advise of their lwayers
18:34:10 <IlyaE> our judgement call is to comply
18:34:30 <SergeyLukjanov> yup
18:34:45 <SergeyLukjanov> the main reason is that we'd like to graduate ;)
18:35:22 <ErikB1> good reason
18:35:57 <SergeyLukjanov> ruhe, IMO "Sahara beats Caravan 10–4" and google.com -> images -> caravan are enough to skip voting
18:36:08 <ruhe> SergeyLukjanov: +1 :)
18:37:00 <SergeyLukjanov> #vote Choose the new name from the options suggested by lawyers *Sahara and Caravan) as the best from the trademarks pov? Yes, No, Abstain
18:37:06 <SergeyLukjanov> #startvote Choose the new name from the options suggested by lawyers *Sahara and Caravan) as the best from the trademarks pov? Yes, No, Abstain
18:37:07 <openstack> Begin voting on: Choose the new name from the options suggested by lawyers *Sahara and Caravan) as the best from the trademarks pov? Valid vote options are Yes, No, Abstain.
18:37:08 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
18:37:13 <SergeyLukjanov> folks, please
18:37:26 <ErikB1> #vote yes
18:37:28 <ruhe> #vote Sahara
18:37:29 <SergeyLukjanov> tmckay, ErikB1, mattf, sreshetnyak, IlyaE, ^^
18:37:29 <openstack> ruhe: Sahara is not a valid option. Valid options are Yes, No, Abstain.
18:37:32 <alazarev> #vote yes
18:37:36 <_nadya_> #vote yes
18:37:38 <ruhe> #vote yes
18:37:39 <sreshetnyak> #voyr yes
18:37:41 <mattf> #vote ruhe
18:37:41 <bob_nettleton> #vote yes
18:37:42 <openstack> mattf: ruhe is not a valid option. Valid options are Yes, No, Abstain.
18:37:42 <tmckay> #vote yes
18:37:44 <mattf> #vote yes
18:37:46 <NikitaKonovalov> #vote yes
18:37:57 <ylobankov> #vote yes
18:38:03 <sreshetnyak> #vote yes
18:38:05 <crobertsrh> #vote yes
18:38:13 <SergeyLukjanov> <@openstack>	 mattf: ruhe is not a valid option. Valid options are Yes, No, Abstain. :(
18:38:21 <SergeyLukjanov> #vote yes
18:38:55 <elmiko> #vote yes
18:39:01 <tmckay> http://www.telegraph.co.uk/travel/picturegalleries/7198319/The-best-retro-caravans.html?image=11
18:39:27 <tmckay> looks just like an openstack guy
18:39:37 <SergeyLukjanov> tmckay, ;)
18:39:46 <SergeyLukjanov> tmckay, OpenStack RetroCaravan, heh
18:39:54 <mattf> tmckay, oh no, are those jeans cuffed?!
18:40:01 <tmckay> lol
18:40:11 * SergeyLukjanov thinking about RetroCaravan vs. Stackadoop
18:40:20 <tmckay> that would be a close one
18:40:22 <elmiko> lol
18:40:30 <SergeyLukjanov> #endvote
18:40:31 <openstack> Voted on "Choose the new name from the options suggested by lawyers *Sahara and Caravan) as the best from the trademarks pov?" Results are
18:40:32 <openstack> Yes (13): bob_nettleton, ruhe, ErikB1, elmiko, ylobankov, NikitaKonovalov, crobertsrh, tmckay, mattf, SergeyLukjanov, alazarev, _nadya_, sreshetnyak
18:40:40 <SergeyLukjanov> yay!
18:40:48 <SergeyLukjanov> democracy!
18:40:52 <SergeyLukjanov> with total agreement
18:41:28 <SergeyLukjanov> and as ruhe proposed to just choose Sahara and start renaming
18:41:44 <alazarev> here how democracy works: "you MUST change name, here is #2 and #5 available, please vote!"
18:41:56 <SergeyLukjanov> alazarev, yup, that's it...
18:42:02 <ruhe> obey the system
18:42:19 <mattf> voting is a component of democracy
18:42:21 * mattf grins
18:43:05 <SergeyLukjanov> #starvote Choose "Sahara" w/o additional voting? Yes, No, Abstain
18:43:15 <IlyaE> #vote yes
18:43:18 <SergeyLukjanov> NOTE: "Sahara beats Caravan 10–4" in the first voting round and google.com -> images -> caravan are enough to skip voting
18:43:21 <sreshetnyak> #vote yes
18:43:24 <tmckay> #vote yes
18:43:27 <SergeyLukjanov> #vote yes
18:43:28 <ruhe> #vote yes
18:43:30 <NikitaKonovalov> #vote yes
18:43:33 <alazarev> #vote yes
18:43:36 <_nadya_> #vote yes
18:43:44 <ErikB1> #vote Abstain
18:43:49 <ylobankov> #vote yes
18:43:50 <elmiko> #vote yes
18:43:57 <mattf> #vote ErikB1
18:44:22 <mattf> what, no chastising?
18:44:27 <mattf> #vote abstain
18:44:34 <bob_nettleton> #vote abstain
18:44:35 * mattf isn't good at this voting thing
18:44:54 <SergeyLukjanov> ooops, I don't see voting bot
18:44:58 <SergeyLukjanov> openstack, ping
18:45:13 <SergeyLukjanov> oops, it was a typo
18:45:21 <SergeyLukjanov> shame on me
18:45:22 <mattf> star vote!
18:45:24 <SergeyLukjanov> please, re-vote
18:45:26 <mattf> *vote!
18:45:35 <SergeyLukjanov> #startvote Choose "Sahara" w/o additional voting? Yes, No, Abstain
18:45:35 <openstack> Begin voting on: Choose "Sahara" w/o additional voting? Valid vote options are Yes, No, Abstain.
18:45:36 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
18:45:42 <tmckay> #vote yes
18:45:46 <SergeyLukjanov> openstack, thank you!
18:45:49 <ruhe> #vote yes
18:45:50 <ErikB1> #vote Abstain
18:45:50 <crobertsrh> #vote yes
18:45:52 <alazarev> #vote yes
18:45:56 <_nadya_> #vote yes
18:45:57 <NikitaKonovalov> #vote yes
18:45:57 <elmiko> #vote abstain
18:45:57 <bob_nettleton> #vote Abstain
18:45:58 <ylobankov> #vote yes
18:46:07 <mattf> #vote ErikB1
18:46:08 <openstack> mattf: ErikB1 is not a valid option. Valid options are Yes, No, Abstain.
18:46:16 <sreshetnyak> #vote yes
18:46:16 <mattf> #vote abstain
18:46:33 <ErikB1> mattf: I see, just testing.
18:46:34 <SergeyLukjanov> #vote yes
18:47:27 <SergeyLukjanov> we're missing some folks...
18:47:28 <SergeyLukjanov> IlyaE, ping
18:47:41 <IlyaE> I voted
18:47:57 <IlyaE> #vote yes
18:47:58 <ErikB1> IlyaE: you need to vote again...
18:48:03 <SergeyLukjanov> IlyaE, one more time please, It wasn't recorded
18:48:40 <SergeyLukjanov> ok, looks like we have all votes
18:48:43 <SergeyLukjanov> #endvote
18:48:44 <openstack> Voted on "Choose "Sahara" w/o additional voting?" Results are
18:48:45 <openstack> Yes (10): NikitaKonovalov, ylobankov, ruhe, crobertsrh, tmckay, SergeyLukjanov, _nadya_, alazarev, sreshetnyak, IlyaE
18:48:46 <openstack> Abstain (4): bob_nettleton, mattf, ErikB1, elmiko
18:49:02 <SergeyLukjanov> noone votes "No"
18:49:10 <tmckay> now we need to vote on pronunciation
18:49:51 <tmckay> har  -- like "hair", or like a pirate "arrrrr"
18:50:12 <tmckay> I hear people do both
18:50:18 <IlyaE> just curios - mattf, ErikB1, elmiko, bob - do you have any concrete alternative proposals?
18:50:24 <SergeyLukjanov> tmckay, Russian folks accent will kill any agreement on pronunciation :)
18:50:30 <tmckay> lol
18:50:50 <SergeyLukjanov> bob_nettleton, mattf, ErikB1, elmiko, which kind of concern do you have? that we need to vote or Sahara name just sucks?
18:51:00 <ErikB1> IlyaE: mine were already knocked out in the voting process
18:51:03 <elmiko> IlyaE, not really, i'm new to the project and i'm still getting up to speed on the reasoning for the name change
18:51:21 <tmckay> elmiko, lawyers
18:51:36 <elmiko> tmckay, kk
18:51:48 <SergeyLukjanov> elmiko, http://www.thetus.com/savanna
18:51:57 <ruhe> tmckay: we pronounce it suh-har-uh (like a pirate)
18:52:12 <mattf> eh, rather not say
18:52:13 <ErikB1> I am +1 with the process and the name we ended up with
18:52:16 <tmckay> ruhe, okay, that works.  Just want to be consistent
18:52:30 <elmiko> SergeyLukjanov, i don't have a good suggestion for an alternate and i'm neutral as to what we change to, although it would be cool to have a name that relates to the project. i'm not sure that's possible.
18:52:40 <mattf> can we close on this topic?
18:52:44 <IlyaE> well, I also don't like situation, but we got to do something
18:52:48 <bob_nettleton> I am also +1 with the naming process.  No objections on my part.  I do like the sound of "
18:52:52 <mattf> next up and some sort of team to do the renaming?
18:52:54 <bob_nettleton> of "Caravan"
18:53:02 <bob_nettleton> but I'm not opposed to Sahara.
18:53:10 <elmiko> SergeyLukjanov, ty for the link
18:53:11 <mattf> do we have a scope for the change from the lawyers?
18:53:53 <mattf> e.g. do we have to change readthedocs, or things is stackforge etc?
18:54:01 <SergeyLukjanov> mattf, everything
18:54:18 <mattf> even the sticker on my laptop!?
18:54:19 * mattf kids
18:54:33 <SergeyLukjanov> I have several stickers too and t-shirts
18:54:43 <ruhe> mattf: even t-shirt which aignatov gave you
18:54:45 * mattf throws his tshirts away
18:54:45 <SergeyLukjanov> don't know how to change them :(
18:54:49 <mattf> tho,m they may be collectors items now
18:54:58 <SergeyLukjanov> mattf, but we'll keep links from old resources and will append (ex. Savanna) to everything ;)
18:55:12 <SergeyLukjanov> ok, looks like we're in agreement
18:55:24 <mattf> so, everything on openstack and stackforge
18:55:39 <SergeyLukjanov> mattf, yup
18:55:43 <mattf> what about in the code, if a variable has savanna in the name but is not user visible?
18:55:57 <alazarev> probably we should keep old resources with redirect for a while
18:56:03 <SergeyLukjanov> mattf, eventually we should rename them but not now
18:56:09 <SergeyLukjanov> alazarev, sure
18:56:22 <SergeyLukjanov> mattf, you still can find quantum in neutron I think
18:56:24 <mattf> what's the scope of things that must change?
18:56:30 <SergeyLukjanov> #agree rename project to "Sahara"
18:56:31 <ruhe> mattf: what about RPM packages? will you have a time to rename?
18:56:47 <SergeyLukjanov> mattf, user visible stuff, like API, docs
18:57:10 <mattf> ruhe, depends. in the past name of package != brand name. but it all depends... so there's some guidance needed here.
18:57:57 <SergeyLukjanov> we'll have new pypi packages too
18:58:17 <SergeyLukjanov> so, I think rpms should be renamed too
18:58:42 <mattf> here's the thing. we should probably spend the next 4 weeks w/ the full team removing all references to savanna across the project's history, but we need to prioritize. so i'm keen to find out what MUST be changed and do it first, save the SHOULD for post graduation.
18:58:55 <SergeyLukjanov> oh, two mins left... I'll email all info about FF, release and etc.
18:58:57 <mattf> sorry, "we COULD probably spend"
18:59:17 <SergeyLukjanov> mattf, I'll check the expectations
18:59:21 <mattf> SergeyLukjanov, did the lawyers provide any guidance on what needs to change?
18:59:23 <SergeyLukjanov> mattf, and mail details
18:59:25 <mattf> thanks
18:59:38 <SergeyLukjanov> mattf, thanks for catching this, good question
18:59:48 <SergeyLukjanov> folks, let's move to the #savanna channel
18:59:53 <SergeyLukjanov> thank you all!
18:59:56 <SergeyLukjanov> #endmeeting