18:01:50 <SergeyLukjanov> #startmeeting savanna
18:01:51 <openstack> Meeting started Thu Feb 27 18:01:50 2014 UTC and is due to finish in 60 minutes.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:51 <ylobankov1> hello
18:01:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:55 <openstack> The meeting name has been set to 'savanna'
18:02:10 <SergeyLukjanov> #info https://wiki.openstack.org/wiki/Meetings/SavannaAgenda
18:02:17 <themistymay> hi
18:02:18 <SergeyLukjanov> #topic News / updates
18:02:21 <SergeyLukjanov> folks, please
18:02:26 <SergeyLukjanov> themistymay, hey
18:03:02 <SergeyLukjanov> #info 5 new name candidates are under lawyers review, results should be available in a few days
18:03:03 <ErikB> We've had a slow week. Working on [Ambari] Blueprints mostly.
18:03:30 <SergeyLukjanov> #info client 0.5.0 was released few days ago with update auth, entrypoint code and CLI
18:03:39 <aignatov> ErikB: it seems there are a lot of questions about proper images of hdp
18:03:44 <crobertsrh> Dashboard bug fixing for me.  Then I should probably make a loop through roadmap/blueprints and see if there are any dashboard items that need to be added.
18:03:57 <aignatov> could you or jspiedel update the docs?
18:04:05 <alazarev> naive attempt to refactor plugin SPI and EDP failed, doing it by small pieces now
18:04:06 <ylobankov1> I am working on adding test for transient cluster
18:04:25 <dmitryme> I am pushing my agent changes through your review guys ;-)
18:04:29 <themistymay> Still reading into code, trying to get acclimated.  Picking up tasks where I can, low-hanging fruit mostly.
18:05:04 <themistymay> Also working to resync oslo-incubator code
18:05:07 <alazarev> EDP on IDH 3.0.2 works in my env, we commit soon
18:05:08 <ErikB> aignatov, RE images, yes we will be taking a deep look at these issues to ensure that the images are ok. Likely next week.
18:05:12 <aignatov> I was mostly working on the savanna in heat, resolved some comments from heat team, also some savannaclient/dashboard manipulation with new release of client )
18:05:15 <aignatov> :)
18:05:27 <aignatov> ErikB: great, thx!
18:05:50 <tmckay> I've been working on savanna cli integration tests.  Not currently the openstack convention, but important for our typical end users.  And, I found bugs in the cli before 0.5.0 using it :)  I'll publish very soon (today/tomorrow)
18:05:53 <sreshetnyak> I am working on hadoop 2
18:06:08 <SergeyLukjanov> alazarev, we'll have code freeze Mar 4
18:06:12 <aignatov> hadoop 2 in vanilla sreshetnyak meant :)
18:06:19 <SergeyLukjanov> and feature freeze right after the i3
18:06:30 <SergeyLukjanov> aignatov, are you expect to complete your refactoring
18:06:31 <SergeyLukjanov> ?
18:06:31 <sreshetnyak> basic prototype on review
18:06:49 <aignatov> SergeyLukjanov: refactoring of what?
18:07:09 <SergeyLukjanov> aignatov, I mean alazarev
18:07:13 <aignatov> ok
18:07:19 <SergeyLukjanov> a + <TAB> :)
18:07:23 <alazarev> SergeyLukjanov: I'm ok with that
18:08:25 <alazarev> SergeyLukjanov: not sure if all refactoring is done, anyway it is just "for developers", can always commit in J
18:08:31 <aignatov> so we should define which features will be landed in icehouse, should not it?
18:08:40 <aignatov> and which are not
18:08:53 <alazarev> SergeyLukjanov: is -> will be
18:09:18 <SergeyLukjanov> aignatov, I'm ok with landing rest Hadoop 2 support patches
18:09:44 <SergeyLukjanov> but I hope that the main code for them will be landed before the FF
18:09:52 <aignatov> so, it's ok to have feature freeze exception and push commits after March 4
18:09:53 <alazarev> more news: bug in swift hadoop driver was found and fixed (https://bugs.launchpad.net/savanna/+bug/1284906)
18:10:00 <aignatov> March 4 is the next week :)
18:10:49 <SergeyLukjanov> it's ok to have FFEs for self-containing patches
18:11:05 <SergeyLukjanov> like work on plugin v2 internals
18:11:05 <alazarev> SergeyLukjanov: with the current speed I'm now sure that IDH 3.0.2 will be merged before Mar 4
18:11:26 <SergeyLukjanov> alazarev, hm
18:11:46 <aignatov> also EDP + Hadoop 2 in all plugins I think should be part of the icehouse
18:11:49 <SergeyLukjanov> alazarev, IIRC version selection mechanism is on review or already landed?
18:12:12 <aignatov> IIRC? :)
18:12:49 <alazarev> SergeyLukjanov: https://review.openstack.org/#/c/73087/ started at Feb 12 and it is still on review
18:13:01 <SergeyLukjanov> if I recall correctly == IIRC
18:13:28 <SergeyLukjanov> alazarev, ok, added to my backlog
18:13:44 <SergeyLukjanov> and what's about the same change for vanilla plugin?
18:13:44 <SergeyLukjanov> aignatov?
18:14:45 <SergeyLukjanov> mm, it's merged already as I see
18:14:54 <SergeyLukjanov> https://review.openstack.org/#/c/74145/
18:15:09 <aignatov> SergeyLukjanov: what was the question on m?
18:15:12 <SergeyLukjanov> I think https://review.openstack.org/#/c/73087/ will be merged before March 4
18:15:13 <aignatov> *me
18:15:34 <SergeyLukjanov> aignatov, about versoins support for vanilla, but I've alreadybanswered
18:15:47 <aignatov> ok
18:16:05 <SergeyLukjanov> aignatov, alazarev, are you expecting any changes in non-plugin code?
18:16:12 <SergeyLukjanov> for EDP support for example?
18:16:20 <SergeyLukjanov> except patches that are currently under review
18:17:01 <aignatov> yep, we had a conversation with alazarev today and agreed to make EDP part more imdepennded from plugin
18:17:31 <aignatov> e. g. remove hive-plugin dependencies from edp stuff
18:17:35 <alazarev> SergeyLukjanov: I want to have https://review.openstack.org/#/c/73713/ merged, but I'm Ok to leave it to J
18:17:52 <SergeyLukjanov> aignatov, if it'll not be merged before the March 4, I prefer to postpone it to J
18:18:21 <SergeyLukjanov> I think that all core code changes should posponed to J if it'll not be merged before the March 4
18:18:36 <alazarev> SergeyLukjanov: and to make it merged I'm going to remove EDP dependency on Hive
18:18:40 <SergeyLukjanov> the only exception - impossibility to enable EDP for plugins
18:18:44 <alazarev> SergeyLukjanov: agree
18:19:10 <SergeyLukjanov> alazarev, btw https://review.openstack.org/#/c/73713/ should be rebased
18:20:09 <SergeyLukjanov> ok, let's move on
18:20:41 <alazarev> SergeyLukjanov: I know, I agree with Mett's comments that extending plugin SPI is not good in that case and EDP usage need to be cleaned first
18:20:41 <SergeyLukjanov> note: master will be opened for J dev. around the rc1 (end of March)
18:21:09 <SergeyLukjanov> alazarev, ok, good
18:21:41 <SergeyLukjanov> it's a good topic to discuss on summit - how edp should work now
18:21:45 <SergeyLukjanov> and in future
18:22:02 <alazarev> SergeyLukjanov: agree
18:22:10 <SergeyLukjanov> aand we already should be under the "Icehouse-3 status" topic :)
18:22:29 <SergeyLukjanov> #topic Icehouse-3 status
18:22:38 <SergeyLukjanov> any questions on this topic?
18:22:49 <alazarev> SergeyLukjanov: I have several thoughts about this, I don't like how EDP is organized now
18:23:02 <ErikB> alazarev: +1
18:23:12 <alazarev> SergeyLukjanov: this is regarding EDP, now i3
18:23:19 <alazarev> *not i3
18:23:24 <SergeyLukjanov> alazarev, yup
18:23:46 <SergeyLukjanov> anyway, we should re-work it, at least due to the intention to support not only oozie for running jobs :)
18:23:58 <SergeyLukjanov> spark, storm, anything else....
18:24:10 <SergeyLukjanov> a big topic for summit
18:24:39 <SergeyLukjanov> and I prefer to not hurry now on trying cleanup stuff in edp
18:24:53 <SergeyLukjanov> we have not enough time to discuss it good
18:25:45 <alazarev> SergeyLukjanov: local improvements are good
18:26:18 <ErikB> we need to discuss integrating with Falcon & Flume IMO
18:26:30 <SergeyLukjanov> alazarev, we have a few days to make them
18:26:55 <SergeyLukjanov> ErikB, I think that we'll have much more slots on this summit to discuss our EDP stuff
18:27:09 <SergeyLukjanov> I think -> I know
18:27:40 <SergeyLukjanov> anything else?
18:27:44 <aignatov> ErikB: good point for discussions, SergeyLukjanov, we have to think about more slots for EDP topics in design tracks :)
18:28:06 <SergeyLukjanov> aignatov, sure
18:28:25 <SergeyLukjanov> #topic Project naming collision
18:28:40 <SergeyLukjanov> #info latest update - candidates are under review
18:28:48 <SergeyLukjanov> and we should rename before I release
18:28:53 <SergeyLukjanov> #info we should rename before I release
18:29:27 <SergeyLukjanov> so, the best time is March 6 - March 27 time range
18:29:45 <SergeyLukjanov> it's a three weeks between i3 and first rc
18:29:46 <alazarev> SergeyLukjanov: is it Ok to have renaming after FF?
18:30:09 <SergeyLukjanov> it'll guarantee that we'll have no breaking changes
18:30:15 <SergeyLukjanov> and there are no more options
18:30:42 <SergeyLukjanov> it's better than rename after rc
18:30:43 <SergeyLukjanov> :(
18:31:01 <SergeyLukjanov> probably, we'll postpone rc1 for one more week
18:31:22 <SergeyLukjanov> to have 1w of code freeze to move the stuff
18:32:25 <SergeyLukjanov> I think that renaming will take about 4-5 days (Friday - Tuesday)
18:32:45 <SergeyLukjanov> we have integration tests, it'll help a lot
18:33:00 <tmckay> I think once we have the 5 candidates back, we can vote very quickly.  I think 24-36 hours ought to be enough.  Too quick?
18:33:27 <SergeyLukjanov> tmckay, I mean that process of renaming repos, and s/savanna/xxx/ code
18:33:27 <tmckay> no integration tests for docs, though.  ;-)
18:33:42 <SergeyLukjanov> tmckay, for docs it'll be just replace
18:33:49 <tmckay> SergeyLukjanov, yes, I meant that the quicker we vote, the quicker we can be done with the move
18:34:01 <SergeyLukjanov> tmckay, exactly
18:34:07 <SergeyLukjanov> so, I'd like to raise the following question
18:34:17 <SergeyLukjanov> how to change the final name?
18:34:22 <aignatov> SergeyLukjanov: is there ETA for the lawyers results?
18:34:41 <SergeyLukjanov> aignatov, they said we need a week, it was last friday
18:35:06 <SergeyLukjanov> we'll not wait for the next meeting anyway, so, I'd like to discuss provess today
18:35:09 <SergeyLukjanov> process*
18:35:26 <tmckay> oh man, we even have to change the swift://container.savanna/ pattern, which technically means a databasea migration script
18:35:29 <SergeyLukjanov> the only exception if we'll have a huge disagreement on final name
18:35:56 <SergeyLukjanov> tmckay, it could be done after the main renaming
18:36:13 <aignatov> tmckay: yes, and this has to be tested carefully
18:36:22 <SergeyLukjanov> neutron is still contains some quantum refs in code :)
18:36:26 <tmckay> heh
18:36:39 <SergeyLukjanov> it'll be very difficult, but it's possible
18:36:41 <aignatov> also we should replace all images and link to the images
18:37:02 <SergeyLukjanov> aignatov, yup
18:37:05 <dmitryme> I think 'grep -i savanna' will find 99% of what we need to rename
18:37:15 <tmckay> I wonder if we can extend pep8 with a "no savanna" rule
18:37:27 <tmckay> to bar it at the gate
18:37:28 <SergeyLukjanov> tmckay, good idea :)
18:37:41 <dmitryme> tmckay: I don't think it is needed, it is a one time change
18:38:02 <tmckay> dmitryme, someone might forget :)  Like still writing 2013
18:38:02 <SergeyLukjanov> let's presume that we'll have N=0...5 options for the new name, do we need to vote for them one more time? (we already have a sorted list)
18:38:28 <dmitryme> SergeyLukjanov: I think yes
18:38:33 <tmckay> I think I would vote again.  But a quick one
18:38:35 <alazarev> tmckay: and savanna-db:// and many other cases we don't remember right now
18:38:44 <tmckay> ack
18:39:23 <SergeyLukjanov> I've created an etherpad http://etherpad.openstack.org/p/savanna-renaming-process for sharing ideas about what should be renamed in savanna
18:39:32 <tmckay> stackadoop-db:// would have been great
18:40:50 <alazarev> SergeyLukjanov: I think vote is good, current list is not relevant since voters needed to sort 10+ options and a lot of votes are with places 1,2,3,26,26,26,...
18:41:13 <tmckay> agree with alazarev
18:41:34 <aignatov> +1
18:41:35 <SergeyLukjanov> btw I'm agree with too, just like to see your thoughts
18:42:05 <alazarev> should we replace everything savanna related before I?
18:42:23 <SergeyLukjanov> alazarev, it'll be the best case
18:42:45 <SergeyLukjanov> alazarev, I think that there not so many places where it'll be difficult to do
18:42:59 <tmckay> ooo, SergeyLukjanov, what about summit names?
18:43:17 <SergeyLukjanov> tmckay, talks titles?
18:43:20 <tmckay> We have a project with a new name, but summit slots with the old one
18:43:23 <tmckay> Yes
18:43:29 <tmckay> Can those be changed?
18:43:34 <SergeyLukjanov> sure
18:43:46 <SergeyLukjanov> I'll ask folks to update them when we'll know the new name
18:44:54 <SergeyLukjanov> re migrations - probably we'll just merge our migrations to only one "icehouse" migration
18:45:04 <SergeyLukjanov> should be discussed
18:45:43 <SergeyLukjanov> how much time should we have for voting for the final name?
18:46:19 <SergeyLukjanov> tmckay, alazarev , aignatov ErikB
18:46:21 <tmckay> 1-2 business days
18:46:28 <SergeyLukjanov> ++
18:46:35 <themistymay> +1
18:46:40 <dmitryme> +
18:46:42 <alazarev> +1 on 2 days
18:46:48 <crobertsrh> 2 should be plenty.  +1
18:46:56 <aignatov> and 1-2 weekends xD
18:47:03 <SergeyLukjanov> the best case is to have new name selected till the next weekend
18:47:22 <ErikB> +1
18:47:46 <aignatov> +! for me as well
18:47:51 <aignatov> +1
18:48:39 <SergeyLukjanov> than we'll be able to finish renaming till the March 18
18:48:56 <SergeyLukjanov> and have one month before the Icehouse
18:49:14 <SergeyLukjanov> that could be postponed in worst case too
18:50:59 <SergeyLukjanov> I'll try to find neutron's check list
18:51:06 <SergeyLukjanov> IIRC they had one
18:51:37 <SergeyLukjanov> #agreed setup final voting for 2 business days
18:52:00 <SergeyLukjanov> I hope we'll not have any disagreements on new name
18:52:02 <SergeyLukjanov> heh
18:52:39 <SergeyLukjanov> many of external folks mentioned that gravity is quite overloaded :(
18:53:04 <SergeyLukjanov> but I still think that it's ok if lawyers ok with it
18:53:05 <SergeyLukjanov> #topic Open discussion
18:53:06 <dmitryme> Sergey: But OpenStack Gravity is not
18:53:14 <SergeyLukjanov> 7 mins left
18:53:27 <SergeyLukjanov> dmitryme, sure, that's why I'm still +1 gravity
18:54:00 <aignatov> +1 for gravity as well
18:54:11 <themistymay> gravity well :P
18:54:15 <tmckay> not time to vote yet ;-)
18:54:20 <tosky> quick question (hi, I'm a RH QE, still learning here): I've seen the email about "Savanna graduation status", is Icehouse the target for being out of incubation?
18:54:31 <aignatov> crobertsrh: how is your results of the curling tournament?
18:54:32 <tmckay> hi tosky
18:54:49 <aignatov> will you play on the next olympics 2018? ;)
18:54:51 <crobertsrh> aignatov:  We won our last 4 games to finish in 5th place, just missing the medal round.
18:55:15 <SergeyLukjanov> tosky, yup, we'd like to be integrated in J
18:55:16 <crobertsrh> Olympics is unlikely, but I do know both our men's and women's Olympic curling teams...even played against them before.
18:55:34 <aignatov> really? you won?
18:55:42 <dmitryme> crobertsrh: ah, too bad you've missed the medal round
18:55:43 <tosky> SergeyLukjanov: ehm, so Icehouse or Juno?
18:55:51 <SergeyLukjanov> tosky, heh bad wording
18:56:08 <crobertsrh> I have beaten one of our olympians....not playing with her usual team though.
18:56:33 <SergeyLukjanov> tosky, we'd like to graduate from the incubation in March to be integrated project starting from J (inlusively)
18:57:15 <tosky> SergeyLukjanov: thanks, so for Icehouse the project will be in a kind of limbo out of incubation but not fully integrated yet?
18:57:22 * tosky does not know the workflow
18:57:33 <aignatov> crobertsrh: but will you plan to play in the next tournaments? will it in the next year or earlier?
18:57:47 <SergeyLukjanov> tosky, sounds like that
18:58:07 <tosky> oki, thanks again
18:58:09 <crobertsrh> I am actually going to take a bit of a break from competitive curling (2nd baby is on the way).  I will still play, but just at smaller tournaments.
18:58:21 <SergeyLukjanov> tosky, if we' graduate in March than we'll be part of integrated Juno release
18:58:38 <SergeyLukjanov> 1 min left
18:59:27 <SergeyLukjanov> thank you all!
18:59:31 <SergeyLukjanov> #endmeeting