18:03:11 <SergeyLukjanov> #startmeeting savanna
18:03:12 <openstack> Meeting started Thu Feb 20 18:03:11 2014 UTC and is due to finish in 60 minutes.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:03:12 <jspeidel> here
18:03:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:03:15 <openstack> The meeting name has been set to 'savanna'
18:03:19 <SergeyLukjanov> hey folks
18:03:28 <alazarev> o/
18:03:31 <SergeyLukjanov> let's wait for several more mins
18:04:00 <dmitryme> I am here too
18:04:32 <tmckay> I'm here
18:04:37 <NikitaKonovalov> Hi, everyone
18:04:43 <aignatov> o/
18:05:55 <SergeyLukjanov> ruhe, mattf
18:06:13 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/Meetings/SavannaAgenda
18:06:22 <SergeyLukjanov> #topic News / updates
18:06:31 <tmckay> SergeyLukjanov, mattf asked me to give his regrets, he may not make it
18:06:33 <SergeyLukjanov> let's start from the short news/updates section
18:06:45 <SergeyLukjanov> tmckay, ok, thx for info
18:07:00 <SergeyLukjanov> folsk, please, your updates
18:07:13 <SergeyLukjanov> #info Savanna and it's client are now gated together
18:07:36 <SergeyLukjanov> #info We have now simple CLI tests in Tempest that are gated for Savanna and client
18:07:50 <aignatov> this week I've updated savanna resource for heat and some bug fixes also
18:07:54 <tmckay> EDP is stable, nothing more for icehouse accept bugs, maybe some doc updates, and I have a mapreduce streaming example to add to savanna-extra
18:07:57 <SergeyLukjanov> I'll send an email to ML with explanation of what does it mean and how it works
18:07:58 <aignatov> nothing specific
18:08:01 <bob_nettleton> I've uploaded Patch #4 for the HDP work in savanna-image-elements, and awaiting reviews/feedback.
18:08:03 <aignatov> from me
18:08:12 <SergeyLukjanov> #info client docs moved to client
18:08:39 <sreshetnyak> i worked on hadoop 2
18:09:04 <SergeyLukjanov> #info we're going to support Hadoop 2 in all plugins for Icehouse
18:09:09 <SergeyLukjanov> that's awesome IMO
18:09:10 <alazarev> I've changed plugin SPI, this will allow EDP to work without assumptions
18:09:26 <jspeidel> HDP 2.0 support was merged
18:09:31 <ruhe> hi!
18:09:35 <SergeyLukjanov> #info HDP 2.0 support was merged
18:09:36 <alazarev> and returned to IDH 3.0.2, it is nearly done
18:09:56 <SergeyLukjanov> alazarev, will it install ephemeral Hadoop 3 ? :)
18:10:27 <ErikB> Working on a minor doc update.
18:10:36 <aignatov> we need to closer look from all of us to Hadoop 2 related patches and integration of it with all savanna ecosystem
18:10:49 <SergeyLukjanov> ErikB, great, I like doc updates ;)
18:11:40 <alazarev> SergeyLukjanov: Intel believes that hadoop 2 with patches from Intel is great enough to be called 3.0
18:11:40 <NikitaKonovalov> wsme models are still in wip, since I was busy with another project
18:11:58 <SergeyLukjanov> ylobankov, any CI news?
18:12:09 <SergeyLukjanov> :(
18:12:58 <aignatov> It seems Yaroslav is not here, he updated tests with cinder checks
18:13:05 <alazarev> aignatov: agree, a lot of common code
18:13:16 <SergeyLukjanov> themistymay, is working on final stage of removing obsolete swift-internals from our repos
18:13:29 <aignatov> and he is working on tempest tests afair
18:13:55 <SergeyLukjanov> aignatov, yup, he already pushed 2 commits to tempest for review
18:13:58 <themistymay> I am giving it my best shot, still learning
18:13:59 <SergeyLukjanov> with API tests
18:14:04 <ruhe> Yaroslav is always working on something great and useful
18:14:19 <SergeyLukjanov> and I'm working on finalizing my scenarios basics
18:14:33 <aignatov> ruhe: yes, exactly! :)
18:14:38 <SergeyLukjanov> ruhe, agreed ;)
18:14:46 <SergeyLukjanov> any other news/updates?
18:15:26 <SergeyLukjanov> ok, let's move on
18:15:34 <SergeyLukjanov> #topic icehouse-3
18:15:38 <SergeyLukjanov> #link https://launchpad.net/savanna/+milestone/icehouse-3
18:15:46 <aignatov> looks good
18:15:56 <SergeyLukjanov> #info code freeze - Mar 4
18:16:18 <SergeyLukjanov> yup, overall status is ok
18:16:20 <themistymay> good to know
18:16:35 <ruhe> SergeyLukjanov: i'd like to reserve 2 minutes to speak about Savanna docs
18:16:41 <SergeyLukjanov> additionally, Mar 4 is FeatureFreeze and StringFreeze
18:16:47 <SergeyLukjanov> ruhe, ok
18:16:55 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/FeatureFreeze
18:17:00 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/StringFreeze
18:17:27 <SergeyLukjanov> so, looks like we're going to write some FFEs to land all Hadoop 2 related commits
18:17:52 <SergeyLukjanov> maybe not, anyway, it looks like we're on track
18:17:59 <jspeidel> FFE?
18:18:07 <SergeyLukjanov> feature freeze exception
18:18:12 <jspeidel> ah, thx
18:18:35 <SergeyLukjanov> master will open only for bug fixes and commits covered by FFEs till the first rc1
18:18:55 <SergeyLukjanov> it'll be ~ Mar 27
18:19:13 <SergeyLukjanov> and then Icehouse dev will be moved to the milestone-proposal branch
18:19:20 <SergeyLukjanov> and master will be open for Juni dev
18:19:23 <SergeyLukjanov> Juno*
18:19:35 <SergeyLukjanov> April 17 is Icehouse release
18:20:35 <SergeyLukjanov> ok, let's move on
18:20:55 <SergeyLukjanov> heh, I've already covered the next topic "After i3"
18:21:05 <SergeyLukjanov> #topic Project naming collision
18:21:14 <SergeyLukjanov> it's the main topic for us now :)
18:21:21 <SergeyLukjanov> so, we have voting results
18:21:28 <SergeyLukjanov> let me find the link
18:21:40 <SergeyLukjanov> #link http://civs.cs.cornell.edu/cgi-bin/results.pl?num_winners=10&id=E_5dd4f18fde38ce8e&algorithm=beatpath
18:22:02 <tmckay> stackadoop, please, I was kidding.  Don't vote for it. :-D
18:22:16 <SergeyLukjanov> I've contacted foundation and they are ready to verify 5 options
18:22:30 <SergeyLukjanov> so, probably we should discuss some and filter them out
18:22:34 <SergeyLukjanov> tmckay, agreed ;)
18:22:53 <dmitryme> Sergey: can we set up another voting and pick 5 best?
18:23:10 <aignatov> I'm ok to send current top5 to the lawyers
18:23:15 <dmitryme> it can be a very short voting, if it is needed
18:23:25 <SergeyLukjanov> #startvote Remove 'stackadoop' from candidates for new Savanna name? yes, no, abstain
18:23:27 <openstack> Begin voting on: Remove 'stackadoop' from candidates for new Savanna name? Valid vote options are yes, no, abstain.
18:23:28 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
18:23:38 <SergeyLukjanov> dmitryme, we already have it - http://civs.cs.cornell.edu/cgi-bin/results.pl?num_winners=5&id=E_5dd4f18fde38ce8e&algorithm=beatpath
18:23:53 <aignatov> #vote yes
18:23:55 <themistymay> #vote yes
18:23:55 <SergeyLukjanov> #vote yes
18:23:57 <ruhe> #vote yes
18:23:59 <jspeidel> #vote yes
18:24:00 <sreshetnyak> #vote yes
18:24:20 <NikitaKonovalov> #vote yes
18:24:27 <dmitryme> ok, ok
18:24:38 <bob_nettleton> #vote yes
18:24:39 <alazarev> #vote yes
18:24:40 <dmitryme> #vote yes
18:24:42 <aignatov> tmckay: says: "Noooooo! I was kidding that I was kidding" :)
18:24:46 <tmckay> #vote yes
18:24:50 <tmckay> hehe
18:24:54 <themistymay> haha!
18:25:05 <dmitryme> lol :-)
18:25:39 <SergeyLukjanov> #endvote
18:25:40 <openstack> Voted on "Remove 'stackadoop' from candidates for new Savanna name?" Results are
18:25:42 <openstack> yes (11): bob_nettleton, aignatov, ruhe, dmitryme, jspeidel, NikitaKonovalov, tmckay, themistymay, SergeyLukjanov, alazarev, sreshetnyak
18:25:48 <SergeyLukjanov> awesome results!!
18:26:03 <SergeyLukjanov> ok
18:27:07 <SergeyLukjanov> personally, I don't like Caravan :(
18:27:17 <tmckay> but it sounds like "savanna"
18:27:29 <aignatov> tmckay: agree
18:27:38 <SergeyLukjanov> oh
18:27:41 <dmitryme> Sergey: me too
18:27:49 <SergeyLukjanov> probably I have some problems with years!
18:27:59 <themistymay> it does?
18:28:05 <alazarev> it looks current top5 beats 6+ places with a big gap
18:28:11 <tmckay> "internal rhyme"
18:28:14 <SergeyLukjanov> I don't understand how savanna and caravan could sounds same
18:28:39 <tmckay> SergeyLukjanov, themistymay, common vowel and consonant sounds
18:28:47 <tmckay> a, v, a, n
18:28:53 <aignatov> it sounds the same in both languages and sounds as you hear it
18:28:59 <alazarev> so, we are safe to submit current top5 to lawyers
18:29:05 <themistymay> tmckay, sold
18:29:11 <SergeyLukjanov> alazarev, yup, that's it
18:29:13 <tmckay> :)
18:29:56 <SergeyLukjanov> #startvote Send top 5 options to foundation for verification (Gravity, Sahara, Quazar, Stellar, Caravan)? yes, no, abstain, please_send_savanna_just_to_try
18:29:56 <openstack> Begin voting on: Send top 5 options to foundation for verification (Gravity, Sahara, Quazar, Stellar, Caravan)? Valid vote options are yes, no, abstain, please_send_savanna_just_to_try.
18:29:57 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
18:30:09 <tmckay> #vote yes
18:30:11 <ruhe> #vote yes
18:30:15 <SergeyLukjanov> #vote yes
18:30:16 <alazarev> #vote yes
18:30:19 <sreshetnyak> #vote yes
18:30:20 <themistymay> #vote yes
18:30:21 <aignatov> #vote yes
18:30:22 <NikitaKonovalov> #vote yes
18:30:26 <dmitryme> #vote yes
18:30:35 <jspeidel> #vote yes
18:30:36 <ErikB> #vote yes
18:30:43 <bob_nettleton> #vote yes
18:30:56 <aignatov> #vote please_send_savanna_just_to_try
18:31:00 <aignatov> xD
18:31:19 <tmckay> shravannnahhh
18:31:29 <tmckay> should be diffrerent enough
18:31:42 <SergeyLukjanov> heh, the funny thing is that all of the 5 options have potential trademark issues
18:31:45 <SergeyLukjanov> (facepalm)
18:31:46 <themistymay> tmckay, vote yes
18:32:16 <dmitryme> tmckay: are you going to advert "shravannnahhh" verbally?
18:32:19 <aignatov> SergeyLukjanov: ok, let's name it Stackadoop
18:32:31 <tmckay> SergeyLukjanov, well, if all 5 are rejected for TM then we can cycle back to 6+, true?
18:32:42 <SergeyLukjanov> aignatov, just google for Stackadoos
18:32:52 <tmckay> dmitryme, I don't know how :-D
18:32:53 <SergeyLukjanov> tmckay, sure
18:32:57 <alazarev> tmckay: where you were before? shavanna could be an answer :)
18:33:06 <tmckay> lol
18:33:10 <SergeyLukjanov> tmckay, my option, Fusor have no trademark issues :)
18:33:16 <tmckay> I was too busy thinking of stackadoop
18:33:16 <SergeyLukjanov> #endvote
18:33:17 <openstack> Voted on "Send top 5 options to foundation for verification (Gravity, Sahara, Quazar, Stellar, Caravan)?" Results are
18:33:17 <dmitryme> tmckay: I think that is my point :-)
18:33:18 <openstack> yes (11): bob_nettleton, ruhe, dmitryme, jspeidel, NikitaKonovalov, tmckay, themistymay, ErikB, SergeyLukjanov, alazarev, sreshetnyak
18:33:19 <openstack> please_send_savanna_just_to_try (1): aignatov
18:33:38 <SergeyLukjanov> great
18:33:51 <SergeyLukjanov> so, when we'll have a list of verified names
18:34:06 <SergeyLukjanov> and if len will be >-2
18:34:08 <SergeyLukjanov> >=2
18:34:30 <SergeyLukjanov> should we vote for them again?
18:34:42 <tmckay> yes
18:34:45 <dmitryme> yes
18:34:48 <aignatov> yes
18:35:03 <aignatov> lets vote for it
18:35:05 <alazarev> SergeyLukjanov: I think so, ranging of 10+ variants is not relevant
18:36:10 <SergeyLukjanov> #startvote Should we have a final voting to choose new name from the list of verified options? yes, no, abstain, just_quasar
18:36:11 <openstack> Begin voting on: Should we have a final voting to choose new name from the list of verified options? Valid vote options are yes, no, abstain, just_quasar.
18:36:12 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
18:36:38 <SergeyLukjanov> #vote yes
18:36:44 <ErikB> #vote yes
18:36:45 <sreshetnyak> #vote yes
18:36:52 <jspeidel> #vote yes
18:36:54 <bob_nettleton> #vote yes
18:36:55 <aignatov> SergeyLukjanov: it was a joke from about votes for votes ;)
18:36:55 <NikitaKonovalov> #vote yes
18:37:03 <aignatov> #vote yes
18:37:04 <themistymay> #vote yes
18:37:14 <tmckay> #vote yes
18:37:23 <SergeyLukjanov> aignatov, I'm very sad about renaming, so, hope that jokes will help us
18:37:49 <tmckay> we can still keep our irc channel, as a remembrance
18:37:54 <aignatov> btw, Stackadoos are the funny toys! :)
18:38:05 <alazarev> #vote yes
18:38:50 <ruhe> #vote yes
18:39:08 <dmitryme> #vote yes
18:39:24 <SergeyLukjanov> tmckay, oh, my *********, we should rename even channels....
18:39:27 <SergeyLukjanov> ;(
18:39:52 <tmckay> "the project formerly known as savanna"
18:40:07 <SergeyLukjanov> yup
18:40:10 <SergeyLukjanov> ex. Savanna
18:40:17 <SergeyLukjanov> now Stellar
18:40:18 <SergeyLukjanov> heh:)
18:40:36 <alazarev> upgrade :)
18:40:51 <SergeyLukjanov> I mean the following meaning from dict:  informal exceptionally good; outstanding: his restaurant has received stellar ratings in the guides.
18:41:09 <SergeyLukjanov> #endvote
18:41:09 <openstack> Voted on "Should we have a final voting to choose new name from the list of verified options?" Results are
18:41:10 <openstack> yes (11): bob_nettleton, aignatov, NikitaKonovalov, dmitryme, jspeidel, ruhe, themistymay, ErikB, SergeyLukjanov, alazarev, sreshetnyak
18:41:47 <SergeyLukjanov> should we discuss anything else about renaming?
18:43:36 <SergeyLukjanov> looks like nope
18:43:40 <SergeyLukjanov> ok, let's move on
18:44:00 <SergeyLukjanov> mattf is offline, so, let's postpone api
18:44:03 <jspeidel> haven't been able to link up with him yet.  We are going to talk sometime this afternoon
18:44:11 <jspeidel> *oops*
18:44:17 <jspeidel> sorry wrong window
18:44:21 <SergeyLukjanov> no action items and roadmap updates
18:44:50 <SergeyLukjanov> #topic docs (ruhe, 2 mins)
18:44:54 <SergeyLukjanov> ruhe, please
18:44:58 <ruhe> yes
18:45:15 <ruhe> i skimmed through savanna docs and figured out some of them are out of date
18:45:26 <ErikB> yes, me too
18:45:31 <ruhe> here is a list of things i think we need to update:
18:45:32 <ruhe> * development environment
18:45:32 <ruhe> * how to add a new migration script
18:45:32 <ruhe> * devstack guide
18:45:32 <ruhe> * mention Tempest tests for Savanna
18:45:52 <ErikB> I did not see anything for how to use the DiskBuilder scripts, did I miss it?
18:45:54 <ruhe> should i file a blueprint (like we did it before release 0.3) ?
18:46:00 <SergeyLukjanov> I'm taking tempest tests, we'll do it with Yaroslav
18:46:12 <SergeyLukjanov> ruhe, yup, please
18:46:19 <ruhe> ok, will do
18:46:25 <SergeyLukjanov> ruhe, it was quite useful
18:46:28 <SergeyLukjanov> ruhe, thx
18:46:33 <aignatov> ErikB: we have only few words about DIB in docs
18:46:39 <ruhe> we will use work items to track all the docs we need to update
18:46:50 <aignatov> but Savanna DIB itself contains descriptive README
18:47:02 <ruhe> ErikB: i'll post a link later, so you'll be able to add items you think are missing
18:47:14 <SergeyLukjanov> aignatov, probably, we should move them to docs for consistency or add link to the README
18:47:18 <ErikB> ruhe: thanks
18:47:34 <SergeyLukjanov> #action ruhe to create a bp for tracking doc updates
18:48:08 <SergeyLukjanov> ruhe, anything else?
18:48:12 <alazarev> SergeyLukjanov: in this case we should describe DIB for all plugins
18:48:14 <aignatov> but having README in the repo is looks better since it has scripting instructions
18:48:34 <aignatov> maybe we need to duplicate docs for dib elements?
18:48:43 <ruhe> aignatov: we can always have a link to savanan docs in the README file
18:50:35 <SergeyLukjanov> #topic Open discussion
18:51:06 <aignatov> ruhe: ok, I don't mind
18:51:27 <SergeyLukjanov> anything to discuss?
18:51:53 <aignatov> returning to previous topic, probably we can make docs cleanup day
18:52:33 <alazarev> jspeidel: could you review plugin SPI changes? They interfere with HDP plugin
18:52:41 <aignatov> when all savanna members will check the docs on actuality
18:53:03 <SergeyLukjanov> aignatov, nice idea
18:53:12 <ruhe> i support this idea
18:53:37 <SergeyLukjanov> aignatov, I think it should be after the i3
18:53:45 <aignatov> SergeyLukjanov: agree
18:53:56 <themistymay> i3?
18:53:59 <jspeidel> @alazarev ok
18:54:25 <aignatov> themistymay: icehouse-3 - intermediate release of openstack
18:54:39 <themistymay> aignatov, got it!
18:54:46 <aignatov> did you see icehouse street in the HK? ;)
18:54:50 <alazarev> jspeidel: thx
18:55:02 <themistymay> yep... got a good giggle out of it
18:55:18 <themistymay> (i may even have a picture of it actually)
18:55:41 <jspeidel> @alazarev, is there a CR for this, I didn't see it?
18:56:08 <aignatov> themistymay: I just asked, personally I didn't see this street xD
18:56:45 <themistymay> aignatov, oh man it was totally there... i'll hunt for the picture, i swear i took a pic
18:56:50 <themistymay> :P
18:57:02 <alazarev> jspeidel: https://review.openstack.org/#/c/73713/ and https://review.openstack.org/#/c/73729/
18:57:06 <jspeidel> thx
18:58:04 <aignatov> themistymay: share a link when you'll find it
18:58:08 <aignatov> :)
18:58:22 <themistymay> aignatov, oh you know it
18:59:15 <SergeyLukjanov> 1 min keft
18:59:18 <SergeyLukjanov> left.
18:59:36 <SergeyLukjanov> thank you all!
18:59:38 <SergeyLukjanov> #endmeeting