18:06:28 <aignatov> #startmeeting savanna
18:06:29 <openstack> Meeting started Thu Jan 16 18:06:28 2014 UTC and is due to finish in 60 minutes.  The chair is aignatov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:06:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:06:33 <openstack> The meeting name has been set to 'savanna'
18:06:50 <aignatov> #topic Agenda
18:07:03 <aignatov> #link https://wiki.openstack.org/wiki/Meetings/SavannaAgenda
18:07:18 <aignatov> #topic Action items from the last meeting
18:07:45 <aignatov> ok, I see from the previous aid were on Sergey
18:07:56 <aignatov> lets mov them as new AIs :)
18:08:27 <aignatov> btw, he was on PTLs webinar today and gave talk about savanna to the community
18:08:40 <aignatov> #action SergeyLukjanov to check that all blueprints created and ping guys to make them if not
18:08:50 <aignatov> #action SergeyLukjanov add links to the blueprints to roadmap
18:09:00 <aignatov> #topic News / updates
18:09:04 <aignatov> guys please
18:09:37 <mattf> so the cli is coming along. i took a break to look at the rest api itself.
18:09:46 <mattf> i posed many comments to the wiki and mailing list.
18:09:50 <mattf> thanks aignatov for feedback so far
18:10:09 <jmaron> my EDP on neutron private networks patch update is hung up while we rebuild our in-house neutron env.  Apologies for the delay
18:10:12 <mattf> i'd like feedback from jmaron jspeidel too before drafting the v2 api
18:10:23 <jmaron> will do
18:10:28 <jspeidel> mattf - sure thing
18:10:29 <mattf> jmaron, you too? i'm trying to do neutron atm too!
18:10:34 <ErikB> On the hortonworks side, we're working a few things around providing HDP2 support and adding native support in Ambari for Blueprints which we will eventually leverage in Savanna HDP plugin
18:10:41 <aignatov> mattf, you did bread job and some useful ideas - move jobs and job_executions to jobs and job_templates is very good!
18:10:50 <aignatov> bread -> great :)
18:11:05 <mattf> that rename is the least of it!
18:11:22 <aignatov> ErikB: nice to hear that!
18:11:23 <mattf> it looks like the api doc will need to be updated too, it wasn't always consistent w/ the code
18:11:58 <aignatov> btw, who has not undated bps you are working on, please do this :)
18:11:59 <jspeidel> mattf, if you know of specifics please file bugs
18:12:22 <mattf> jspeidel, ack
18:12:39 <jmaron> just so I'm certain I'm reviewing the correct doc/wiki - what's the link?
18:12:39 <aignatov> mattf, api should be updated, right! the last update was EDP section
18:12:52 <mattf> aignatov, there was a topic for the meeting that i mentioned to sergey and have since forgotten. he send you any notes?
18:13:50 <aignatov> mattf, sorry, but i didn't hear these notes
18:14:16 <aignatov> maybe we can discuss it on the General discussion section
18:14:21 <mattf> aignatov, fyi, there was an AI on me about oslo sync. i looked into it and decided to skip until after the release.
18:15:16 <aignatov> mattf, agree, please make action tag and title in this meeting :)
18:16:10 <aignatov> update from me: i'm finishing work on entegration savanna with heat provisioning feature, the latests bug fixes on the review
18:16:16 <alazarev> from my side: IDH is partially merged, several parts are still on review
18:16:17 <aignatov> action on me
18:16:21 * mattf found the general topic: if we should both w/ --name in the cli (we have --id and the api works primarily w/ ids)
18:16:52 <aignatov> #action create doc about features included into savanna's heat engine
18:17:12 <alazarev> Sergey Reshetnyak is working on adding IDH to CI
18:17:25 <aignatov> matte, +1, it should be added
18:17:30 <jspeidel> mattf, I like being able to use the name in the cli
18:17:49 <mattf> let's wait til general discussion
18:17:54 <jspeidel> mattf, avoids unnecessary query to get the id using the name
18:18:04 <aignatov> any other updates?
18:18:05 <alazarev> mattf: +1 on names
18:18:26 <aignatov> crobertsrh, any updates? :)
18:18:52 <crobertsrh> Got the review up for Oozie Java Actions in the UI.
18:19:01 <crobertsrh> Next up looks like HDFS data sources
18:19:10 <aignatov> crobertsrh: great!
18:19:15 <aignatov> lets move on
18:19:17 <aignatov> #topic Roadmap update/cleanup
18:19:37 <aignatov> action above is still on the Sergey
18:19:54 <aignatov> #topic General discussion
18:20:20 <mattf> should have --name (in addition to --id) for cli commands, i.e. cluster-show --name cluster0 (instead of --id 28ee3cff-9f43-4c03-91e2-06467e15a6d7). if we should then we either have to implement in the client library or in the service api.
18:20:21 <alazarev> small update from Intel side: their "dedicated" engineer is working on urgent project, going to start working on savanna in a week or two
18:20:51 <mattf> btw, that's should we have, just c&p from irc logs
18:20:59 <jmaron> mattf, just so I'm certain I'm reviewing the correct doc/wiki - what's the link?
18:21:11 <aignatov> mattf, afaik, openstack approach is to use both ids and names
18:21:36 <mattf> jmaron, https://blueprints.launchpad.net/savanna/+spec/v2-api and the email on openstack-dev
18:21:57 <jmaron> thx
18:22:12 <aignatov> #link https://blueprints.launchpad.net/savanna/+spec/v2-api
18:22:14 <mattf> i like names too. sounds like we have some consensus there.
18:22:34 <aignatov> maybe let's vote?
18:22:48 <jspeidel> mattf, +1 for names
18:22:57 <mattf> the issue is the rest api does not allow for lookup by name. so either we add that to the rest api, or we add the functionality to the python api. the python api would have to list + search + query.
18:22:58 <alazarev> aignatov: who is against?
18:23:08 <mattf> alazarev, lol, nice approach
18:23:28 <jspeidel> mattf, rest api should also support
18:23:52 <jmaron> jspeidel +1
18:24:00 <mattf> anyone know if it is common or not to have the name->id logic in the client or the api?
18:24:02 <alazarev> mattf: +1 on having names in rest too
18:24:05 <aignatov> it's just to be documented :) ok, we are all think the same about new rest
18:25:14 <aignatov> ErikB: will you continue working on edp over private networks and base support?
18:25:19 <aignatov> *hbase
18:25:25 <mattf> silence me no knows if it's more common to impl in api or in client?
18:25:55 <jspeidel> mattf, rest api should only have a single primary id per resource but should allow queries by name also
18:26:12 <jspeidel> mattf, I assume that id is the primary key for the resource
18:26:29 <aignatov> mattf, I think it should be in the api side
18:26:30 <ErikB> aignatov, yes this work will continue, we still need to do some more functional testing
18:27:12 <mattf> i'll take an AI to look into adding names, and hopefully integrate it into the v2 api spec.
18:27:38 <mattf> so far the vocal folks say +1 name and +1 add to api (not just to client)
18:28:12 <aignatov> mattf, I think it's too much stuff in the single blueprint. Maybe we should divide it into some small bps?
18:28:45 <mattf> aignatov, i'd like to keep it all in one place for now
18:28:54 <mattf> we can break it up later when some impl starts
18:29:10 <aignatov> ok, sounds reasonable
18:31:37 <aignatov> oh, one more update, Yaroslav updated bp to make HDP working over Heat, jspeidel and jmaron, please take a look on it ;)
18:32:04 <aignatov> #link https://review.openstack.org/#/c/65911/
18:32:39 <jmaron> aignatov:  ok
18:33:01 <aignatov> than we will enable gate job for that as voting
18:33:06 <jspeidel> aignatov, how is this related to #link https://review.openstack.org/#/c/65981/
18:33:08 <jspeidel> ?
18:33:54 <aignatov> jspeidel: sorry, the proper, I mean the https://review.openstack.org/#/c/65981/
18:34:21 <jspeidel> aignatov,ok.  I have already been involved in reviewing this
18:34:52 <aignatov> and my first link is about enabling hdp integration tests working over heat
18:35:19 <jspeidel> aignatov *nods*
18:35:56 <aignatov> :)
18:36:14 <aignatov> guys, do we have anything else to discuss?
18:36:20 <mattf> nothing from me
18:36:32 <jspeidel> not me either
18:36:37 <alazarev> not from me
18:36:37 <jspeidel> oh
18:37:09 <jspeidel> where are we in regards to hbase discussions with community?
18:37:45 <mattf> afaik that still lives w/ sergey
18:37:56 <mattf> i missed the update webcast today, maybe it was covered there
18:38:11 <jspeidel> would be nice to get an updated status on this
18:38:15 <mattf> actually, did anyone attend? can you give us a quick summary?
18:38:41 <aignatov> jspeidel: I only know that you can continue working on your patch, please talk with Sergey directly about that :)
18:39:04 <jspeidel> aignatov, ok.  Will ping Sergey
18:39:23 <aignatov> matff, as I know alazarev was there
18:39:42 <aignatov> I was moving to home from work at that time :)
18:40:21 <alazarev> just updates from savanna and trove
18:40:43 <aignatov> how many people were there?
18:40:53 <alazarev> mattf: are you interested in something particular?
18:41:10 <mattf> just general summary. i'll just go get the recording. thanks.
18:41:46 <ErikB> BTW - is there a page that describes the icehouse-3 milestone?
18:42:24 <aignatov> ErikB: there is no actual page in wiki
18:42:36 <aignatov> but this can help you
18:42:41 <aignatov> #link https://launchpad.net/savanna/+milestone/icehouse-3
18:43:07 <ErikB> aignatiov, thanks!
18:43:30 <aignatov> all unfinished bugs and bp in icehouse-2 will be moved to icehouse-3 as well
18:44:17 <aignatov> icehouse-2 release date is on Jan 23
18:44:23 <aignatov> useful link
18:44:34 <aignatov> #link https://wiki.openstack.org/wiki/Icehouse_Release_Schedule
18:45:07 <aignatov> ok, I think we can finish this meeting
18:45:34 <aignatov> thanks who's joined, have a nice day!
18:45:44 <aignatov> #endmeeting