18:07:38 <SergeyLukjanov> #startmeeting savanna
18:07:39 <openstack> Meeting started Thu Oct 31 18:07:38 2013 UTC and is due to finish in 60 minutes.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:07:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:07:43 <openstack> The meeting name has been set to 'savanna'
18:07:55 <SergeyLukjanov> #topic Agenda
18:08:03 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/Meetings/SavannaAgenda#Agenda_for_October.2C_31
18:08:20 <SergeyLukjanov> #topic Action items from the last meeting
18:09:34 <SergeyLukjanov> hm
18:10:00 <SergeyLukjanov> let's discuss here design summit proposals that wasn't accepted
18:10:47 <SergeyLukjanov> any updates?
18:11:04 <aignatov> I've just sent the letter about retrospective results
18:11:11 <aignatov> #link https://wiki.openstack.org/wiki/Savanna/Release_0.3_Retrospective
18:11:31 <crobertsrh> I've started a pad for post 0.3 dashboard enhancements.
18:11:35 <crobertsrh> #link https://etherpad.openstack.org/p/EDP_dashboard_post_0.3
18:11:53 <aignatov> if someone wants to add more thoughts please edit this page about retro
18:13:21 <SergeyLukjanov> Trevor's requirements doc is on review
18:13:31 <mattf> SergeyLukjanov, update from me re drafting actions, still tbd. i should have some initial goals out to collaborators today.
18:13:51 <SergeyLukjanov> mattf, ok, great
18:14:57 <SergeyLukjanov> ok, let's move on
18:15:11 <SergeyLukjanov> #topic Design summit update
18:15:29 <SergeyLukjanov> #link http://icehousedesignsummit.sched.org/overview/type/savanna
18:15:50 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/Summit/Icehouse/Etherpads#Savanna
18:16:00 <SergeyLukjanov> any questions about the design summit?
18:16:44 <SergeyLukjanov> ok
18:17:06 <SergeyLukjanov> #topic News / updates
18:17:09 <SergeyLukjanov> folks, please
18:17:53 <SergeyLukjanov> update from me - we start working on moving integration tests to CI
18:18:00 <SergeyLukjanov> I mean jenkins.o.o
18:18:06 <mattf> savanna got a lot of play during strata & hadoop world this week. i did an unconference session and discussed it quite a bit. there's a good amount of interest. there was also the rax + hwx preso and plans.
18:18:34 <ruhe> i'd like to hear more about rax + hwx
18:18:42 <ruhe> in regards to savanna
18:18:57 <SergeyLukjanov> mattf, interesting, could you, please, share some minutes and slides from strata for savanna-related stuff?
18:19:13 <mattf> me too actually. it was in the last slot yesterday. i had to leave 5 min into it. i just got to talk to rnirmal et al before it.
18:19:30 <mattf> i'm going to find the video and see if there were questions as they went through the presentation.
18:20:16 <mattf> SergeyLukjanov, i'll pull some notes together after summit and share points of interest
18:20:27 <SergeyLukjanov> mattf, thank you
18:21:14 <SergeyLukjanov> #info Reminder: The Nov 7 meeting is canceled. We’ll resume meetings on Nov 14.
18:21:57 <SergeyLukjanov> anything else?
18:22:15 <mattf> what are the next steps for the retrospective?
18:23:07 <aignatov> hmm, good question, page is done, need to think how to turn ideas for improvements into the real life :)
18:23:27 <mattf> definitely
18:23:40 <aignatov> most thoughts were about review process
18:23:40 <SergeyLukjanov> yep :)
18:23:49 <jspeidel> question - the patch that provides oozie support in hdp plugin was just merged.  For EDP, how does savanna controller know where oozie is running to execute jobs?
18:24:29 <SergeyLukjanov> I think that we can discuss retrospective at the next team meeting
18:24:55 <mattf> aignatov, the way we've run them, folks rank the items, we pick 1 or 2 and create a plan to address for the next release
18:25:47 <aignatov> jspeidel, edp controller knows about running uzi by looking at cluster info
18:26:11 <aignatov> afaik your pathc includes ooze url to cluster info
18:26:49 <jspeidel> aignatov, are you looking for specific node process names?
18:26:57 <jspeidel> in cluster info?
18:26:58 <aignatov> mattf, good idea
18:27:41 <aignatov> jspiedel, yes, we are looking for http://host:11000/oozie in cluster info
18:27:54 <aignatov> after that edp goes to ooze through rest
18:28:08 <jspeidel> ok
18:28:30 <SergeyLukjanov> I think that there are no updates in "Roadmap cleanup / update"
18:28:44 <SergeyLukjanov> and we're already in "General discussion"
18:29:43 <SergeyLukjanov> #topic General discussion
18:30:25 <Guest70023> jspeidel, client = o.OozieClient(cluster['info']['JobFlow']['Oozie'] + "/oozie")
18:30:42 <aignatov> mattf, you wanna run the votes to rank the items in retro?
18:30:55 <nprivalova> guest is me :)
18:31:08 <aignatov> nprivalova, thx, I meant the same exactly :)
18:31:28 <ruhe> aignatov, i don't think we need votes
18:31:31 <mattf> aignatov, i'd rather not. i'm short on time atm.
18:31:34 <ruhe> all the items are important
18:32:11 <mattf> aignatov, you could just try to pull out 3-4 themes, send them out a day or two before the next meeting, then we discuss which we should do at the next meeting
18:32:38 <SergeyLukjanov> ruhe, agreed
18:32:51 <mattf> i see 3 themes right off -- reviews, collaboration and process/housekeeping
18:32:55 <SergeyLukjanov> in fact there are 3-4 major themes at all
18:32:59 <aignatov> mattf, agreed, will do
18:33:24 <aignatov> SergeyLukjanov, please add AI on me
18:34:07 <SergeyLukjanov> #action aignatov to start retrospective discussion
18:34:13 <mattf> it also looks like few people responded to the poll
18:34:18 <aignatov> btw, only 5 contributors are answered , I waited for more answers;)
18:34:31 <ruhe> i'd let PTL to decide and convert retrospective results into action items
18:35:06 <aignatov> rune, we need just to start discussions about items in retro
18:35:26 <aignatov> rune -> ruhe, sorry
18:35:28 <mattf> i wish i had thought of it myself - the comment on 100x line commits is really insightful
18:35:47 <mattf> there was a thread on os-dev about patch set sizes recently too
18:36:27 <mattf> proper review of some of the reviews we have in process are a good day+ of work
18:36:32 <SergeyLukjanov> yeah, big CRs are very painful to review
18:37:07 <mattf> i'm about to launch the discussion on that one, but i'll hold off til our next meeting
18:37:15 * mattf zips lips
18:37:33 <SergeyLukjanov> in addition we can discuss it at summit
18:37:44 * mattf nods
18:37:50 <jspeidel> agreed
18:38:03 <alazarev> usually it is possible to split big commit into several smaller. May be we need some guidance?
18:38:14 <mattf> +10
18:38:41 <SergeyLukjanov> I think that there could not be the common guidance for splitting code
18:38:43 <mattf> that guidance can come from well defined purpose of change etc
18:38:46 * mattf rezips
18:39:18 <ruhe> hmm
18:39:31 <ruhe> that should be already covered somewhere on openstack wiki
18:40:12 <aignatov> the main problem of big patches I saw sometime on the review, that the certain patch contains not only certain fix but some unrelated code impovements
18:40:17 <SergeyLukjanov> yeah, there are some recommendations to not create large CRs
18:41:54 <mattf> there's also an issue w/ the number of iterations on reviews. not that 1 is a desirable number, but >12 raises a flag for me
18:42:04 <mattf> especially when only 4 people are reviewing
18:42:14 <mattf> but...we should discuss later
18:42:21 <alazarev> with the official doc, reviewers could request to split big commit into smallers
18:42:24 <SergeyLukjanov> at most it relates to CR size
18:42:32 <jspeidel> yes, will be good do discuss in person
18:43:06 <nprivalova> btw, recently in mail I saw the statement 'if you send cr you should review someone's code'
18:43:30 <mattf> ^^ is something we should facilitate imho
18:43:36 <SergeyLukjanov> agreed
18:43:43 <mattf> it's something a strong community supports
18:44:12 <SergeyLukjanov> btw http://russellbryant.net/openstack-stats/savanna-reviewers-30.txt looks not very good
18:44:48 <ruhe> for alazarev it looks very good :)
18:44:49 <mattf> we should kick off this discussion next week
18:45:15 <aignatov> after next week, mattf
18:45:26 <SergeyLukjanov> and next week (on summit) too
18:45:29 <mattf> time is compressed for me atm
18:45:32 <alazarev> review is a good way to get inside the project :)
18:45:47 <aignatov> alazarev, +2
18:47:13 <SergeyLukjanov> are there anything more to discuss?
18:47:52 <mattf> nothing from me
18:48:13 <ruhe> jspeidel, could you shed some light on hwx + rax? is it savanna spinning up HDP clusters?
18:49:06 <jspeidel> ruhe, I really don't have any info at the moment.  I will try to have some answers for next week
18:49:24 <ruhe> ok, thanks
18:49:28 <jspeidel> yep
18:50:24 <SergeyLukjanov> looks like that's all for today
18:50:27 <SergeyLukjanov> thank you all
18:50:39 <SergeyLukjanov> #info JFYI you can always use openstack-dev@lists.openstack.org mailing lists and #savanna irc channel to find us and ask your questions
18:50:42 <SergeyLukjanov> #endmeeting