18:05:22 <SergeyLukjanov> #startmeeting savanna
18:05:23 <openstack> Meeting started Thu Oct 24 18:05:22 2013 UTC and is due to finish in 60 minutes.  The chair is SergeyLukjanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:05:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:05:26 <openstack> The meeting name has been set to 'savanna'
18:05:38 <SergeyLukjanov> #topic Agenda
18:05:39 <SergeyLukjanov> #link https://wiki.openstack.org/wiki/Meetings/SavannaAgenda
18:06:03 <SergeyLukjanov> nothing specific except design track schedule draft
18:06:13 <SergeyLukjanov> #topic Action items from the last meeting
18:06:21 <SergeyLukjanov> #link http://eavesdrop.openstack.org/meetings/savanna/2013/savanna.2013-10-17-18.07.html
18:06:22 <SergeyLukjanov> nope
18:06:31 <SergeyLukjanov> #agenda Design summit update
18:06:39 <SergeyLukjanov> #topic Design summit update
18:07:00 <SergeyLukjanov> here is a draft schedule for design track
18:07:01 <SergeyLukjanov> http://icehousedesignsummit.sched.org/type/savanna
18:07:03 <SergeyLukjanov> #link http://icehousedesignsummit.sched.org/type/savanna
18:07:33 <SergeyLukjanov> in addition I would like to say that I hope to cover refused topics too but in offline manier
18:07:48 <SergeyLukjanov> manner*
18:08:12 <SergeyLukjanov> any questions?
18:08:14 <SergeyLukjanov> suggestions?
18:08:35 <crobertsrh> Looks pretty reasonable to me.
18:08:39 <ErikB> that sounds reasonable
18:10:44 <SergeyLukjanov> topics to discuss offline
18:10:45 <aignatov_> I see you merged allmost all proposed topics to only four, that's good decision :)
18:10:46 <SergeyLukjanov> http://summit.openstack.org/cfp/details/216
18:10:55 <SergeyLukjanov> http://summit.openstack.org/cfp/details/215
18:11:02 <SergeyLukjanov> http://summit.openstack.org/cfp/details/214
18:11:07 <SergeyLukjanov> http://summit.openstack.org/cfp/details/155
18:11:13 <SergeyLukjanov> http://summit.openstack.org/cfp/details/150
18:12:25 <SergeyLukjanov> any volunteers to collect retrospective and feedback?
18:13:23 <aignatov_> ok, I'll do it
18:13:42 <SergeyLukjanov> great, thx
18:14:00 <aignatov_> put action item on me to collect feedback
18:14:16 <SergeyLukjanov> #action aignatov_ to perform retrospective for all Savanna contributors and collect/aggregate feedback
18:14:45 <SergeyLukjanov> the next important thing is http://summit.openstack.org/cfp/details/216
18:14:46 <aignatov_> I'll send all involved participants mails for feedback and then collect answeres
18:15:01 <SergeyLukjanov> aignatov_, ok, sounds reasonable
18:15:16 <ruhe> I confirm, aignatov is master of retrospectives
18:15:31 <SergeyLukjanov> agreed :)
18:15:35 <aignatov_> hehe, ruhe
18:16:18 <SergeyLukjanov> anyone would like to prepare plugins-related policy initial draft?
18:17:31 <dmitryme> SergeyLukjanov, could you clarify?
18:18:06 <ruhe> HW guys went through all the stages of plugin creation. would be great if they describe this process and requirements
18:18:09 <SergeyLukjanov> searching for example
18:18:36 <SergeyLukjanov> yeah, the main goal is to describe deadlines and requirements
18:18:39 <ErikB> I think we can help, but not sure what's meant by policy exactly. Is it related to: http://summit.openstack.org/cfp/details/216
18:18:43 <mattf> you know i'm game for writing a draft
18:18:56 <SergeyLukjanov> Cinder guys have the same doc
18:19:26 <aignatov_> can you post a link on cinder's page?
18:19:40 <SergeyLukjanov> ErikB, yep, maybe policy isn't the best wording
18:19:44 <mattf> ErikB, it's about how we should handle plugins as they show up, making sure we have stable software that's easy to use and a strong community
18:20:13 <ErikB> mattf, ok
18:20:17 <mattf> policy is an ok word. maybe ErikB and i should tag team a draft.
18:20:23 <aignatov_> is it something related plugin spi as well?
18:20:36 <mattf> aignatov_, i would expect so
18:21:14 <SergeyLukjanov> ok, so, I'll add action item for mattf and ErikB
18:21:46 <SergeyLukjanov> #action mattf, ErikB to prepare initial draft for "plugins policy" http://summit.openstack.org/cfp/details/216
18:21:57 <aignatov_> ok, so we just need to extend that page or create something new?
18:22:29 <SergeyLukjanov> aignatov_, create a new one with deadlines for applying plugins and etc.
18:22:37 <SergeyLukjanov> can't find the cinder's page
18:22:58 <aignatov_> ok, no prob, I will find it later
18:23:55 <SergeyLukjanov> and one more time link to the design track session - http://icehousedesignsummit.sched.org/type/savanna
18:24:01 <SergeyLukjanov> sessions*
18:25:31 <SergeyLukjanov> the next item is http://summit.openstack.org/cfp/details/214
18:25:37 <SergeyLukjanov> "What are our supported guests?"
18:26:21 <SergeyLukjanov> IMO we should clarify supported guests and create support matrix for features in case of some are OS-depended
18:26:38 <SergeyLukjanov> mattf, could we use RHEL now?
18:26:52 <ErikB> I would think that this would be plugin specific.
18:27:03 <SergeyLukjanov> ErikB, absolutely
18:27:18 <SergeyLukjanov> but we have some common requirements, for example, cloud-init
18:27:32 <ErikB> right
18:27:35 <SergeyLukjanov> it should be documented too
18:27:54 <aignatov_> do we need to describe requirements from EDP as well there?
18:28:16 <dmitryme> I think yes, maybe in a separate section
18:28:30 <SergeyLukjanov> looks like it'll be better to write an additional doc for it
18:28:38 <aignatov_> or is it related to previous proposal of "plugins policy"?
18:28:44 <SergeyLukjanov> to make it easier for plugin writers to understand requirements
18:28:55 <SergeyLukjanov> aignatov_, it's the third doc ;)
18:29:04 <aignatov_> ok
18:29:11 <SergeyLukjanov> mattf, are you around?
18:29:56 <SergeyLukjanov> any volunteers for "What are our supported guests?"
18:30:09 <mattf> SergeyLukjanov, high level interrupt here, back in a bit
18:30:21 <SergeyLukjanov> ok
18:30:32 <SergeyLukjanov> any volunteers for "EDP requirements"?
18:30:41 <SergeyLukjanov> aignatov_, tmckay?
18:31:11 <aignatov_> I can, but not sure if I'll do it for the next meeting
18:31:30 <dmitryme> I can compose a doc for supported guests
18:31:41 <dmitryme> * but not for EDP
18:31:56 <tmckay> here
18:31:57 <ruhe> what about swift/cluster/ceph requirements?
18:32:03 <aignatov_> I meant EDP section, Dmitry
18:32:17 <dmitryme> or at least I will need to ask aignatov or tmckay for detail
18:32:21 <ruhe> *gluster
18:32:54 <SergeyLukjanov> tmckay, could you please write a doc about EDP requirements?
18:33:05 <dmitryme> ruhe: am, they don't seem to be related to guests, or are they?
18:33:10 <aignatov_> what do you mean about requirements for FSs?
18:33:21 <tmckay> SergeyLukjanov, what kind of requirements?
18:33:31 <SergeyLukjanov> I mean which processes and services should be installed/configured to support EDP?
18:33:37 <SergeyLukjanov> EDP*
18:33:50 <tmckay> okay, sure
18:34:03 <SergeyLukjanov> dmitryme, great, thx, I'll add action item for you and mattf to clarify RHEL support
18:34:05 <SergeyLukjanov> tmckay, thx
18:34:51 <mattf> back
18:34:55 <ruhe> plugins have to support swift. we need to outline this requirement. what is expected from plugin
18:35:09 <SergeyLukjanov> #action dmitryme to write "What are our supported guests?" (http://summit.openstack.org/cfp/details/214)
18:35:33 <ruhe> eventually we will add ceph and gluster support
18:35:40 <SergeyLukjanov> mattf, could you, please, help dmitryme to clarify RHEL guest support
18:35:44 <mattf> SergeyLukjanov, supported guests - what guest images do we provide to the community in a release (ubuntu & fedora atm) and what is needed if someone wanted to also do debian/centos/rhel/other, which has tie in to plugin requirements on images.
18:36:12 <aignatov_> ceph support: http://ceph.com/docs/next/cephfs/hadoop/
18:36:18 <SergeyLukjanov> mattf, agreed
18:36:27 <SergeyLukjanov> #undo
18:36:28 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x3653310>
18:36:39 <SergeyLukjanov> #action dmitryme and mattf to write "What are our supported guests?" (http://summit.openstack.org/cfp/details/214)
18:36:55 <SergeyLukjanov> #action tmckay to write a doc about EDP requirements
18:37:03 * mattf gets a phone call and apparently collects a bunch of actions, yay
18:37:16 <SergeyLukjanov> okay, looks like all main topics are covered now
18:37:31 <SergeyLukjanov> the last interesting one "Let's coordinate our performance evaluations"
18:37:34 <jmaron1> mattf:  I understand it's a long plane ride ;)
18:38:04 <mattf> argh
18:38:08 * mattf raises hand
18:38:15 <mattf> o/
18:38:29 <SergeyLukjanov> mattf :)
18:38:49 <mattf> sounds to me like at least 3 groups of people are working on some aspect of performance & savanna
18:39:11 <mattf> from the service interfaces itself and scale, to ability to provision, to performance of running clusters
18:39:23 <mattf> i'd like us to do some coordination on ^^
18:39:38 <mattf> i'll throw my name in the hat to help organize
18:40:33 <ErikB> sure, we have *some* information that we can share, depending on what we are looking for...
18:41:35 <mattf> that's also something we should work out. some of the data is relevant for specific product offerings, some is relevant to the community. we should figure out how to handle that.
18:41:40 <akuznetsov> mattf we starting investigate Savanna performance  on large scale
18:41:56 <SergeyLukjanov> #action mattf to collect info about savanna performance testing and try to coordinate our efforts
18:42:14 <mattf> oh, i'd like that action to include other folks who are doing perf eval atm
18:42:29 <mattf> i'll coordinate, but i need folks who i'm coordinating with
18:42:52 <ErikB> me
18:42:58 <mattf> +1
18:43:31 <mattf> akuznetsov, you?
18:43:45 <akuznetsov> mattf yes
18:43:50 <mattf> +1
18:43:56 <mattf> anyone else?
18:44:10 <jmaron1> I imagine that beyond just perf data, there may be some perf recommendations as part of the effort (e.g. approach to spawning a large cluster)?
18:44:51 <mattf> that's a good thought. maybe good params for config to how to use cinder or swift...
18:45:00 <mattf> there are a bunch of possible recommendations the group could make
18:45:09 <mattf> possibilities abound!
18:45:13 <jmaron1> :)
18:45:18 <mattf> SergeyLukjanov, will you add ErikB and akuznetsov to the action w/ me?
18:45:25 <akuznetsov> I think we can add Savanna benchmark to Rally project
18:45:36 <SergeyLukjanov> mattf, sure
18:45:44 <SergeyLukjanov> #undo
18:45:45 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x3653990>
18:45:52 <mattf> akuznetsov, nice idea
18:45:56 <SergeyLukjanov> #action mattf ErikB akuznetsov to collect info about savanna performance testing and try to coordinate our efforts
18:46:08 <mattf> danke
18:47:16 <SergeyLukjanov> ok, let's move on
18:47:36 <SergeyLukjanov> #topic News / updates
18:47:39 <SergeyLukjanov> folks, please
18:48:06 <SergeyLukjanov> any updates or news?
18:49:13 <ErikB> Nothing much this week. Working on a few major merges by the team (Quantum support and additional component support)
18:49:15 <crobertsrh> I've been mostly fixing small bugs and poking around the interface finding targets for improvement.
18:50:02 <mattf> i've been revving the RDO packages to make sure they run smoothly
18:50:24 <SergeyLukjanov> crobertsrh, do you want add smth UI-related to design track?
18:50:28 <mattf> ...and discovering some fun things along the way, such as os_auth_host needs to be accessible from w/i instances
18:50:36 <SergeyLukjanov> or discuss offline
18:50:44 <jmaron1> thanks to reviewers for quantum support reviews.  you've been keeping me busy ;)
18:50:52 <crobertsrh> Offline is probably fine.
18:51:15 <mattf> jmaron1, is that getting close? i've been waiting for it to slow down a bit before reading through completely
18:51:57 <jmaron1> it is.  trying to do some more clever caching of HTTP sessions and some code cleanup
18:52:17 <mattf> great
18:53:13 <SergeyLukjanov> any other news/updates?
18:53:43 <SergeyLukjanov> btw stable/0.3 is open now for backporting some stuff that we would like to land into the 0.3.1 release
18:54:00 <SergeyLukjanov> ok, let's move on
18:54:02 <SergeyLukjanov> #topic General discussion
18:54:38 <SergeyLukjanov> any things to discuss?
18:55:19 <mattf> nothing here
18:55:46 <SergeyLukjanov> ok
18:55:56 <SergeyLukjanov> 1 more min and I'll end the meeting
18:56:24 <SergeyLukjanov> btw I'll cancel Nov 7 meetin
18:56:31 <SergeyLukjanov> due to the OpenStack summit
18:56:40 <mattf> +1
18:56:56 <SergeyLukjanov> it'll be at 2am in HKG :)
18:57:29 <SergeyLukjanov> 15 hours ahead from CA
18:58:52 <SergeyLukjanov> ok, looks like that's all for today
18:58:59 <SergeyLukjanov> thank you guys
18:59:01 <SergeyLukjanov> #info JFYI you can always use openstack-dev@lists.openstack.org mailing lists and #savanna irc channel to find us and ask your questions
18:59:04 <SergeyLukjanov> #endmeeting